Titre

Vous êtes ici: Titre

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique
+32 9 252 66 28

www.buildsoft.eu
support@buildsoft.eu
Diamonds 2025
version 25.1
Copyright © 2025 BuildSoft


Disclaimer

Vous êtes ici: Disclaimer

© BuildSoft, version 25.1

Toute représentation ou reproduction, intégrale ou partielle, par quelque procédé que ce soit et à quelque fin que ce soit, est strictement interdite sans autorisation préalable écrite de BuildSoft.

A l’achat du programme Diamonds, l’acheteur acquiert une licence d’utilisation. L’utilisateur ne peut en aucun cas céder partiellement ou totalement cette licence à un tiers sans autorisation écrite préalable de l’éditeur.

L’éditeur n’est en aucun cas responsable des fautes éventuelles que le programme et/ou le présent manuel devraient encore comporter, et décline toute responsabilité pour tout dommage susceptible de découler de l'utilisation abusive ou non du programme Diamonds et/ou du présent manuel.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique
+32 9 252 66 28


Introduction

En quoi consiste le présent manuel ?

Connaissances préalables

Aperçu des raccourcis clavier dans Diamonds (shortcuts)

Convention relative aux axes des barres

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


En quoi consiste le présent manuel ?

Avec cette première partie du manuel de référence, nous souhaitons apporter une réponse à toutes les questions susceptibles de se poser lors de l'utilisation du programme Diamonds. Nous nous intéressons en particulier aux méthodes de calcul utilisées et aux grands principes théoriques. Pour une interprétation correcte et complète des résultats, il est en effet recommandé d'avoir une bonne connaissance des méthodes de calcul utilisées et des hypothèses afférentes. Diamonds est avant tout un outil de calcul ; la bonne compréhension et interprétation des résultats de calcul est dès lors essentielle pour une utilisation efficace du programme. Le présent manuel de référence sera donc également très utile à l'utilisateur expérimenté.

Malgré tout le soin apporté à l'élaboration de ce manuel, vous trouverez peut-être que certaines fonctions sont expliquées de manière incomplète ou confuse. Nous apprécierions que vous nous fassiez part de vos remarques.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Connaissances préalables

Avant de poursuivre, vous devez être familiarisé avec les commandes élémentaires de votre système d'exploitation MS Windows ainsi qu'avec l'utilisation des fenêtres et des icônes, les fonctions de sélection et de copier-couper-coller et l'utilisation de la souris. Aperçu sommaire:

Icône

Représentation graphique d'un programme ou d'une partie de programme.

Cliquer avec la souris

Pointer un élément donné ou une zone donnée à l'écran et cliquer 1 fois avec le bouton de la souris.

Sélection

Cliquer 1 fois sur une icône ou un élément. Vous pouvez également sélectionner plusieurs éléments au moyen d'un cadre : cliquez dans le coin supérieur gauche du rectangle qui doit englober la sélection souhaitée – maintenez le bouton de la souris enfoncé et faites glisser vers le coin inférieur droit ; lâchez ensuite le bouton de la souris.

Vous pouvez élargir une sélection en suivant la procédure ci-dessus tout en maintenant la touche majuscule enfoncée.

Double-cliquer

Cliquer 2 fois brièvement avec la souris. Cette fonction est utilisée pour démarrer un programme ou une partie de programme.

Copier-coller

Sélectionner un élément et le copier à un autre endroit dans le programme via le menu Edition.

Glisser

Faire glisser un élément donné en le sélectionnant et en déplaçant la souris tout en maintenant le bouton de la souris enfoncé.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Aperçu des raccourcis clavier dans Diamonds

Un certain nombre de raccourcis clavier permettent de travailler plus rapidement et plus efficacement avec Diamonds. Ci-dessous figure une liste des raccourcis disponibles pour les fonctions les plus fréquentes:

SHIFT

  • Sélectionner plusieurs éléments
  • Aide pour tracer des lignes orthogonales

CTRL

Sélectionner tous les éléments d’un même type

ALT

  • Sélectionner les éléments d’un même groupe
  • Sélectionner les bords avec la plaque
ALT + S | Sauvegarder comme

SUPR / DEL

Supprimer des éléments ou des charges

ENTER

Tracer une nouvelle ligne
ESPACE | Désactiver le curseur intelligent

ESC

Désactiver la fonction de dessin

Fermer les dialogues [image], [image], [image], [image], [image], [image],

CTRL + A

Sélectionner tous les éléments

CTRL + C

  • Copier les données des tableaux [image], [image], [image],
  • Copier la fenêtre modèle

CTRL + N

Nouveau fichier

CTRL + O

Ouvrir un fichier

CTRL + P

Imprimer fenêtre

CTRL + Q

Fermer Diamonds

CTRL + R

Activer/ déactiver la règle

CTRL + S

Sauvegarder le fichier

CTRL + W

Ferme le fichier, mais pas Diamonds

CTRL + Z

Annuler (Undo)

CTRL + cliquez sur un point

Sélectionner tous les points

SHIFT + CTRL + Z

Refaire (Redo)

SHIFT + CTRL + DEL

Supprimer la dalle / le voile

à l’exception des conditions aux appuis

F1

Ouvrir l’aide en ligne de Diamonds

F2

Calculer les armatures

F3

Effectuer la vérification à la norme acier et bois

F8

Exporter vers BIM Expert

F9

Effectuer l’analyse élastique

F10

Agrandir

F11

Réduire

F12

Montrer tout

SCROLL (roulette souris)

Glisser (Pan)

SHIFT + SCROLL

Effectuer une rotation (3D orbit)

Dans la configuration géométrique:

A ou a L ou l | Dessiner une nouvelle ligne [image] .
C ou c | Ouvre la fenêtre pour libellé et commentaire [image] .
D ou d | Ouvre la fenêtre pour diviser une ligne [image] .
E ou e | Ouvre la fenêtre pour extruder [image] .
I ou i | Ouvre la fenêtre pour intersection des lignes [image] .
M ou m | Ouvre la fenêtre au miroir [image] .
P ou p | Ouvre la fenêtre pour projection [image] .
R ou r | Ouvre la fenêtre pour pivoter [image] .
T ou t | Ouvre la fenêtre pour déplacer / copier [image] .

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Convention relative aux axes des barres

Tout élément barre est doté d’un système d’axes locaux orienté comme les doigts de la main droite x’y’z’. Dans ce repère, l’axe x’ correspond à l’axe principal de la barre alors que les axes y’ et z’ correspondent aux deux axes perpendiculaires déterminant un plan de section de la barre.

L’orientation de l’axe x’ dépend des coordonnées globales des deux extrémités de la barre. L’axe x’ est toujours orienté du l’extrémité avec la plus petite coordonnée x vers l’extrémité avec la plus grande coordonnée x. Lorsque les deux extrémités ont la même coordonnée x, c’est le point avec la plus petite coordonnée y qui sera considérée comme origine. Dans le cas d’une barre parallèle à l’axe global Z, l’axe x’ est orienté du point avec la plus petite coordonnée z vers celui avec la plus grande coordonnée z. En d’autres termes, cette barre aura la même orientation que l’axe global Z. L’axe local y’ est toujours situé dans un plan horizontal et forme un angle de 90° avec l’axe x’. L’axe y’ d’une barre verticale est toujours parallèle à l’axe global Z.

Étant donné que le repère est orienté tels les doigts de la main droite,

On peut toujours déduire l’orientation de l’axe local z’ à partir de celles des axes x’ et y’.

Lorsque vous attribuez une section à une barre, les conventions suivantes sont d’application pour les axes et les sections:

  • D’un point de vue général:
    • y’ axe parallèle aux ailes du profilé
    • z’ axe perpendiculaire aux ailes du profilé
  • Pour les cornières (profiles en L) :
    • y’ axe parallèle à la branche la plus courte
    • z’ axe perpendiculaire à la branche la plus courte

Dans la plupart des cas, les axes locaux y’ et z’ correspondent respectivement aux axes d’inertie fort (u) et faible (v) de la section.

Lorsque ce n’est pas le cas, la notation suivante est adoptée :

  • u axe fort d’inertie (lorsque celui-ci ne coïncide pas avec l’axe y’)
  • v axe faible d’inertie (lorsque celui-ci ne coïncide pas avec l’axe z’)

Les efforts normaux seront toujours accompagnés d’un indice faisant explicitement référence à un des axes précités. Les moments (Mx, My et Mz) seront quant à eux indicé de l’axe autour duquel ils s’appliquent.

L’indice des efforts tranchants (Vy et Vz) indiquera la direction dans laquelle s’applique la force.

Remarque: La majorité des règles et prescriptions des Eurocodes (et en particulier de l’Eurocode 3 – Partie règles générales) ont attrait aux axes d’inertie des sections des profilés. Même si dans la plupart des cas les formules sont exprimées en fonction de y’ et de z’, pour les profils dont les axes locaux ne coïncident pas avec les axes d’inertie principaux (par exemple dans le cas de cornières) ces mêmes formules peuvent être exprimées en fonction de u et v, à l’exception des profils à froid, pour lesquels les expressions sont toujours exprimées par rapport au axes y’ et z’.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L’environnement de travail Diamonds

La feuille de travail Diamonds comprend:

  • une fenêtre modèle dans laquelle le modèle de calcul et les résultats correspondants sont affichés.
  • une barre d'outils au dessus de la fenêtre modèle incluant les icônes suivantes:

Pour ouvrir et enregistrer des projets de calcul, imprimer une fenêtre modèle et gérer des notes de calcul

Pour annuler (undo) ou rétablir (redo) une opération

Pour cacher partiellement le modèle et pour configurer et reproduire la trame

Pour définir des types

Pour effectuer les différentes analyses et l'optimisation

Pour le dimensionnement des assemblages en acier

Pour gérer les fenêtres modèles

Pour définir les configurations

Pour déterminer la vue du plan de dessin, choisir l’échelle et la position du dessin, ou encore mesurer une distance entre deux points

Pour la présentation des données et résultats sous forme de tableau et la saisie des résultats détaillés
  • une palette d'icônes qui vous donne accès à l'ensemble des fonctions de modélisation et de calcul de Diamonds. Nous distinguons trois palettes:
    • Palette pour l'élaboration de la géométrie
    • Palette pour la définition des charges
    • Palette pour la reproduction des résultats

En fonction de la configuration sélectionnée, une ou plusieurs palettes s'affichent à l'écran.

  • une barre d'outils à la droite de la fenêtre modèle comprenant une série de fonctions pour la création et la gestion des plans de dessin ou étages, pour la sélection du mode de représentation, pour la définition de la grandeur de la police, des symboles, des charges et des résultats ainsi que pour la définition des groupes.

Nous traitons tout d'abord dans ce chapitre les principes généraux du mode de travail avec Diamonds. Nous étudierons ensuite de manière plus approfondie les fonctions de la barre d'outils et de la palette d'icônes.

Principes généraux

Sélection d'éléments

Sélection à l'aide de la souris

Sélection via le menu

Utilisation des touches CTRL et ALT

Sélection d'éléments supplémentaires

Le curseur intelligent

La barre d'outils

Gestion de projets

Ouvrir un nouveau projet

Sauvegarder un projet

Ouvrir un projet

Utiliser des fichiers templates

Imprimer la fenêtre modèle et gérer des notes de calcul

Imprimer la fenêtre modèle

Copier et coller la fenêtre modèle

Gérer des notes de calcul

Annuler et rétablir une opération

Masquer partiellement

La trame

Types de design

Fonctions d’analyse

Orientation du modèle

Plan de dessin

Zoom et déplacement

Mesurage

Gestion des fenêtres modèles

Paramètres de configuration

Qu’est-ce qu’une configuration?

Définition ou modification d’une configuration

Tableau de données et résultats

Tableau ‘Données’

Tableau ‘Résultats’

Tableau ‘Vérification d'équilibre’

Tableau ‘Information modale’

Fenêtre ‘Réponse Modale’

Résultats détaillés sur une section

Les contraintes

Résultats thermiques

Résultats détaillés

Les assemblages

Log in et notifications

La palette d’icônes

La palette 'Géométrie'

Le pointeur de sélection

Label et commentaire

Tracer des points

Tracer des lignes

Effacer des points, des lignes et des plans

Tracer des éléments structurels

Chercher des dalles ou plaques

Diviser des lignes

Extruder

Formes paramétrées

Structures paramétrées

Déplacer et copier

Pivoter

Projection

Miroiter

Intersection

Vérification du modèle

Redimensionner de la géométrie

Modifier les propriétés communes à plusieurs éléments

Propriétés des barres

Propriétés des dalles et plaques

Caractéristiques des semelles

Choix d’une section dans la bibliothèque des profilés

Excentricité des barres

Rotation de sections

Attribuer des points d'appui

Conditions limites pour les extrémités des barres et les tirants

Lignes articulées

Choix de matériau

Liens rigides

Paramètres de flambement et de déversement

Protection incendie

Modification de lignes et de nœuds

Copier et coller des points d'appui et des sections

La palette 'Charges'

Cas de charges

Combinaisons de charges

Combinaisons dans le temps

Les charges

Supprimer ou modifier des charges

Copier et coller des charges

La palette 'Résultats'

Affichage des déformations

Affichage des efforts internes dans les poutres et les poteaux

Affichage des efforts internes dans les dalles et les plaques

Affichage des réactions dans les points d'appui

Affichage des contraintes élastiques dans les poutres et les poteaux

Affichage des contraintes élastiques dans les dalles et les plaques

Affichage des résultats de l'armature

Affichage de la largeur de fissuration

Affichage des résultats thermiques

Résultats le long d’un ligne de coupe

La palette de création et de gestion des plans de dessin ou des étages

Gestion des étages

Niveau du sol

Un plan de dessin

La palette de sélection du mode d'affichage

La palette pour (dé-)grouper des éléments barres

Qu’est-ce qu’un groupe?

Comment créer un groupe?

Que faire avec un groupe?

Pour flambement

Physiques

Pour des charges

Pour des sections

La palette de définition de la grandeur des lettres, des symboles, des charges et des résultats

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Principes généraux

Sélection d'éléments

Sélection à l'aide de la souris

Sélection via le menu

Général

Barres les plus chargées

Surfaces les plus chargées

Utilisation des touches CTRL et ALT

Sélection d'éléments supplémentaires

Le curseur intelligent

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sélection d'éléments

Diamonds fonctionne toujours selon le principe que vous effectuez d'abord une sélection et que vous appliquez ensuite une fonction à cette sélection. Cette méthode de travail est typique des programmes Windows bien conçus. Elle offre de nombreux avantages, comme, par exemple, un meilleur contrôle visuel des éléments que l'on modifie et la possibilité d'appliquer plusieurs fonctions sur un seul et même groupe de sélection, ce qui est synonyme de gain de temps. Diamonds propose plusieurs méthodes de sélection. Nous les exposons dans les paragraphes qui suivent.

Diamonds indique le nombre d’éléments sélectionnés dans le pied de page côté droit. Vous pouvez voir s’afficher le nombre de points, de lignes (sans section), de barres (avec section) et de plaques sélectionnées.

Sélection à l'aide de la souris

Sélection via le menu

Général

Barres les plus chargées

Surfaces les plus chargées

Utilisation des touches CTRL et ALT

Sélection d'éléments supplémentaires

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sélection à l'aide de la souris

Vous pouvez sélectionner des éléments dans les différentes fenêtres au moyen de la souris.

Pour sélectionner un élément, cliquez avec le bouton gauche de la souris sur l'élément proprement dit.

Une autre possibilité consiste à sélectionner l'élément au moyen d'un cadre de sélection. Pour ce faire, procédez comme suit.

  • Cliquez avec le bouton gauche de la souris dans le coin gauche de l'extrémité gauche de l'élément à sélectionner.
  • Tout en maintenant le bouton enfoncé, faites glisser la souris vers le point inférieur droit de l'extrémité droite de l'élément à sélectionner.
  • Lors du déplacement de la souris, le cadre de sélection apparaît sous forme de rectangle en pointillés.
  • Lorsque le cadre de sélection englobe les éléments à sélectionner, relâchez le bouton de la souris et tous les éléments à l'intérieur du cadre sont sélectionnés.

Si vous tirez le cadre de sélection de façon analogue de droite à gauche, tous les éléments, outre ceux compris dans le cadre, qui sont partiellement inclus dans le cadre sont, eux aussi, sélectionnés. Si vous cliquez avec la souris dans une zone ne comprenant aucun élément, tous les éléments sélectionnés sont désélectionnés.

Il est également possible de sélectionner des éléments avec les mêmes propriétés via le bouton droit de la souris. Un exemple:

  • La ligne de support sélectionnée dans le modèle ci-dessous a une ressort de 300 000kN/m/m.
  • Pour sélectionner toutes les lignes de support avec les mêmes conditions de support, procédez comme suit :
    • Sélectionnez l'élément source de la propriété. Dans ce cas donc la ligne d'assistance correspondante.
      Mais vous pouvez également appliquer le même principe aux points ou aux surfaces.
    • Cliquez avec le bouton droit de la souris dans la zone de dessin. Allez dans le menu Sélectionner identique (Bar) et choisissez la propriété souhaitée. Dans ce cas Appui.
    • Résultat : Diamonds sélectionnera toutes les lignes qui ont la même condition de support que l'élément source.

Remarques: Vous pouvez sélectionner en fonction des propriétés suivantes

  • Pour les points : support, semelle, étiquette
  • Pour les barres : support, conditions aux limites, assemblage, section, matériau, excentricité, orientation, matériau de revêtement anti-feu, étiquette.
  • Pour les surfaces : support, conditions aux limites, section, matériau, étiquette

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sélection via le menu

Général

Barres les plus chargées

Surfaces les plus chargées

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Général

Vous pouvez également recourir aux options de menu pour sélectionner des points, des barres ou des plans sur la base de critères définis. Ces critères peuvent porter sur

  • les propriétés géométriques (éléments verticaux, horizontaux ou inclinés)
  • ou sur les caractéristiques de section (section de profil, par ex.)
  • ou sur la base du matériau.
  • ou sur la base du numéro de point, de barre ou de plaque
  • ou en fonction de la présence/ absence des appuis
  • ou sur les membres dans une connexion
  • ou sur le degré de chargement d'une barre (voir la section suivante)

Vous trouverez ci-dessous un exemple de sélection en fonction de la section de profil appliquée.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Barres les plus chargées

Un autre critère de sélection consiste à retrouver les ‘Éléments les plus chargée…’. Dans ce menu, vous pouvez:

  • Créer et enregistrer des ensembles de critères de sélection pour les barres.

  • Sélectionner des barres au moyen d’un ensemble de critères de sélection dans le menu.

Il va de soi que ce critère n’est disponible qu’à partir du moment où une analyse élastique a été effectuée sur le modèle.

Créer un nouvel critère de sélection.

  • Aller à Sélection > Barres les plus chargées > Paramètres de sélection.

  • Entrer un nom au critère de sélection.
  • Choisir le résultat de la barre à filtrer : déformation, effort, contrainte, armature ou vérification.
  • Sélectionner une combinaison de critères ; un enveloppe ELU/ ELS ou la combinaison actuellement sélectionnée la fenêtre de résultats.
  • Décider si vous souhaitez vérifier les résultats sur la barre entière ou seulement à ses extrémités.
  • Vous pouvez définir une ou plusieurs valeurs minimales et maximales :
    • Soit sur un certain nombre d’éléments
    • Soit sur une valeur
    • Soit sur un pourcentage de la valeur minimale ou maximale calculée sur l’ensemble du modèle.
  • Cliquer sur [image].
Modification d’un critère de sélection existant
  • Aller à Sélection > Barres les plus chargées > Paramètres de sélection.
  • Choisissez le critère de sélection dans la liste.
  • Modifiez le type de résultat, la combinaison et les critères de valeur minimale/ maximale.
  • Cliquez sur [image].
Supprimer un critère de sélection
  • Aller à Sélection > Barres les plus chargées > Paramètres de sélection.

  • Choisissez le critère de sélection dans la liste.

    Remarque: la dernière item de la liste ne peut pas être supprimée. Il doit toujours y avoir un seul critère de sélection.

  • Cliquez sur [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Surfaces les plus chargées

A l'aide de ce menu, vous pouvez sélectionner les murs et plaques pour lesquels les armatures théoriques sont insuffisant ( = murs/ plaques contenant un crâne).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Utilisation des touches CTRL et ALT

Comme nous le verrons plus loin à la section Types de design, nous pouvons également attribuer un ‘Type’ à un élément (ex. poutre, poteau, mur, etc.). Si vous appuyez sur la touche ‘Ctrl’ au moment de la sélection et que vous sélectionnez un élément d'un type donné, tous les autres éléments de même type sont, eux aussi, automatiquement sélectionnés.

Diamonds permet également d’exploiter la notion de ‘groupe’ afin de tenir compte du fait que deux ou plusieurs éléments correspondent à une seule entité physique et constituent par exemple une seule poutre.

Pour sélectionner toutes les barres d’un même groupe, sélectionnez simplement une barre du groupe en maintenant la touche ‘ALT’ enfoncée.

La touche ‘ALT’ vous permet également de séléctionner les bords avec la plaque. Gardez la touche ‘ALT’ lorsque vous cliquez sur une plaque pour la sélectionner.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sélection d'éléments supplémentaires

Si vous appliquez la méthode de sélection précédente, vous remarquerez que les éléments précédemment sélectionnés ne le sont plus après la nouvelle sélection. Si vous souhaitez sélectionner des éléments supplémentaires, en d'autres termes maintenir la sélection existante et ajouter de nouveaux éléments à la sélection, maintenez la touche ‘Majuscule’ enfoncée lorsque vous effectuez la nouvelle sélection. Si la nouvelle sélection coche des éléments qui étaient déjà sélectionnés, ceux-ci sont alors désélectionnés (supprimés de la sélection).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Le curseur intelligent

Dans Diamonds, vous avez la possibilité d'utiliser un curseur intelligent. Ce curseur détecte, par exemple, votre présence à proximité du centre d'une barre. Le curseur intelligent est doté d'une fonction SAISIE qui permet de relier des points et des lignes.

Il est particulièrement utile pour dessiner une structure et pour sélectionner des éléments. Grâce aux petits symboles associés, vous voyez immédiatement quel élément Diamondsva sélectionner ou relier.

Les 2ème et 3ème fonctions du curseur intelligent ( [image]) sont désactivées dès que vous appuyez sur la barre d'ESPACE. Ce curseur est particulièrement pratique si vous voulez sélectionner des plaques.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La barre d'outils

Gestion de projets

Ouvrir un nouveau projet

Sauvegarder un projet

Ouvrir un projet

Utiliser des fichiers templates

Imprimer la fenêtre modèle et gérer des notes de calcul

Imprimer la fenêtre modèle

Copier et coller la fenêtre modèle

Gérer des notes de calcul

Annuler et rétablir une opération

Masquer partiellement

La trame

Types de design

Fonctions d’analyse

Orientation du modèle

Plan de dessin

Zoom et déplacement

Mesurage

Gestion des fenêtres modèles

Paramètres de configuration

Qu’est-ce qu’une configuration?

Définition ou modification d’une configuration

L’onglet ‘Général’

L’onglet ‘Géométrie’

L’onglet ‘Charges’

L’onglet ‘Maillage’

L’onglet ‘Résultats’

Tableau de données et résultats

Tableau ‘Données’

Tableau ‘Résultats’

Tableau ‘Vérification d'équilibre’

Tableau ‘Information modale’

Fenêtre ‘Réponse Modale’

Résultats détaillés sur une section

Les contraintes

Résultats thermiques

Résultats détaillés

Les assemblages

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Gestion de projets

Ouvrir un nouveau projet

Sauvegarder un projet

Ouvrir un projet

Utiliser des fichiers templates

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Ouvrir un nouveau projet

Pour ouvrir un nouveau projet, sélectionnez l'option de menu ‘Fichier’ – ‘Nouveau’ ou cliquez sur l'icône [image]. Si vous souhaitez ouvrir un nouveau projet alors qu'un autre projet est déjà ouvert, il est vivement conseillé de d'abord sauvegarder le résultat de votre travail dans votre projet ouvert.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sauvegarder un projet

Pour sauvegarder un projet, sélectionnez l'option de menu ‘Fichier’ – ‘Sauvegarder’ ou cliquez sur le bouton [image]. Vous pouvez également utiliser l'option de menu ‘Fichier’ – ‘Sauvegarder comme’.

La différence entre ‘Sauvegarder’ et ‘Sauvegarder comme’ est la suivante:

  • si vous avez déjà sauvegardé le projet au préalable, vous pouvez à nouveau l'enregistrer sous le même nom via la commande ‘Sauvegarder’. L'extension ‘.bsf’ de la version préalablement enregistrée est modifiée en ‘.bs!’.
  • si vous souhaitez sauvegarder le projet sous un autre nom, choisissez l'option ‘ Sauvegarder comme’.

Des projets de Diamonds sont toujours constitués de quatre fichiers avec le même nom, mais une extension différente:

  • *.bsf contient la géométrie et les charges. Ce fichier est en réalité le modèle. S'il existe un fichier qu'il ne faut pas supprimer, c'est celui-ci.
  • *.bs! copie du fichier *.bsf. Ce fichier est peut très précieux si le fichier *.bsf est endommagé.
  • *.bsr contient le maillage
  • *_bsr est un dossier contenant les résultats

Remarques :

  • Si vous voulez nous transmettre votre modèle de calcul, il suffit d'envoyer le fichier *.bsf. De plus, vous pouvez compresser ce fichier ( [image] sur le fichier *.bsf → 'Copier vers' → 'Dossier compressé') s'il est trop volumineux. Il est possible de compresseur la taille 95 fois.
  • Il est conseillé d'enregistrer régulièrement le projet pour prévenir toute perte de données à la suite d'une panne ou autre sinistre. Le programme Diamonds permet la sauvegarde automatique. La description de celle-ci fait l’objet d’une rubrique spécifique de ce manuel (voir Paramètres de sauvegarde des projets).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Ouvrir un projet

Dans le menu ‘Fichier’, sélectionnez l'instruction ‘Ouvrir...’ ou cliquez dans la barre d'icônes sur l'icône [image] pour ouvrir un projet existant dans Diamonds. Dans le menu ‘Fichier’, vous retrouvez aussi les derniers fichiers ouverts dans Diamonds.

Pour un fichier ‘backup’ (avec l'extension ‘.bs!’), sélectionnez d'abord le type exact de fichier dans le bas de la boîte de dialogue. Sélectionnez ensuite le fichier backup adéquat et cliquez sur ‘Ouvrir’.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Utiliser des fichiers templates

Un fichier template est un fichier qui sert comme modèle pour un nouveau projet. En ouvrant un fichier template, les paramètres préformatés sont chargés. Par exemple: vous pouvez créer un fichier template avec toutes les normes Eurocodes et les annexes nationales pour un certain pays. Les paramètres suivants (ne) peuvent (pas) être enregistrés dans un fichier template:

Paramètres qui sont enregistrés dans un fichier template

= paramètres dépendants du projet

Paramètres qui NE sont PAS enregistrés dans un fichier template

= paramètres dépendants de l’utilisateur

  • normes sélectionnées
  • (une partie de) la structure et les charges appliquées
  • La définition des groupes de charges et les coefficients de pondération
  • ajustements dans la gestion des étages
  • ajustements pour le niveau de sol
  • paramètres des trames
  • ajustements dans les fenêtres

  • orientation du système de coordonnées global

  • taille des polices, symboles, charges et résultats
  • paramètres de mise en page [image] et des rapports
  • paramètres du maillage [image] et de l’analyse [image], … sous la condition qu’une structure (aléatoire) a été calculée en utilisant ces paramètres. La structure (alétoire) peut (mais ne doit pas) être enlevée avant de créer le fichier template *.bst.
  • unités et décimales
  • langue
  • ajustements dans les configurations
  • méthode de calcul pour les longueurs de flambement. Par défault, Diamondsproposera toujours des "nœuds déplacables".

Comment créer un fichier template:

  1. Démarrez Diamonds ou (si Diamondsest déjà ouvert) créez un nouveau projet .
  2. Définissez les paramètres vers les valeurs souhaitées.
  3. Accédez au commande ‘Fichier > Enregistrer sous’. Choisissez BuildSoftTemplate file *.bst comme type de fichier. Le fichier template est maintenant créé.

Comment ouvrir un fichier template:

  1. Démarrez Diamonds.
  2. Accédez au commande ‘Fichier > Ouvrir’. Choisissez BuildSoftTemplate file *.bst comme type de fichier. Le fichier template peut maintenant être sélectionné et ouvert.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Imprimer la fenêtre modèle et gérer des notes de calcul

Imprimer la fenêtre modèle

Copier et coller la fenêtre modèle

Gérer des notes de calcul

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Imprimer la fenêtre modèle

Vous pouvez à tout moment imprimer le contenu de la fenêtre modèle. L'image de la fenêtre sera dans la mesure du possible mise à l'échelle du papier tout en conservant les proportions. Si une fenêtre est agrandie sur un détail, seul ce détail sera imprimé.

Pour imprimer le contenu de la fenêtre modèle, sélectionnez l'option de menu ‘Fichier’ – ‘Gestionnaire pour notes de calcul’, cliquez sur l'icône [image] de la barre d'outils ou utilisez la combinaison de touches ‘CTRL+P’.

La fenêtre ‘Print Setup’ (Configuration imprimante) de MS Windows apparaît alors à l'écran. Cette fenêtre peut varier en fonction de la version de MS Windows. Vous pouvez y sélectionner l'imprimante que vous souhaitez utiliser pour l'impression et y modifier les paramètres en cliquant sur le bouton ‘Propriétés...’.

Avant de passer à l'impression proprement dite, vous pouvez toujours vous assurer que le résultat répond bien à vos attentes en demandant un aperçu avant impression. Pour obtenir un aperçu avant impression de la fenêtre modèle, sélectionnez l'option de menu ‘Fichier’ – ‘Visualiser avant impression’ ou cliquez sur l'icône [image] de la barre d'outils.

Les deux premiers boutons [image] et [image] sont utilisés pour l'impression proprement dite et pour le réglage des options d'impression. Au moyen de la loupe [image], vous pouvez sélectionner un rectangle sur une page qui est alors agrandi autant que possible. Pour revenir à l'affichage initial, cliquez sur [image].

Les boutons ‘<’ et ‘>’ vous permettent de passer respectivement à la page précédente ou suivante. La page en cours ainsi que le nombre total de pages sont indiqués dans le coin inférieur gauche. Les boutons [image] et [image] vous permettent d'afficher simultanément 1 ou 2 pages dans l'aperçu.

Pour enfin refermer l'aperçu avant impression, il suffit de cliquer sur ‘Fermer’.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Copier et coller la fenêtre modèle

Souhaitez-vous copier toute la fenêtre à par exemple Paint ou Microsoft Word, alors sélectionnez l'option de menu ‘Edition’ – ‘Copier vue’. Un méthode plus rapide consiste à utiliser les raccourcis clavier ‘Ctrl+C’ (Copier) en ‘Ctrl+V’ (Coller).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Gérer des notes de calcul

En plus d’imprimer la fenêtre modèle, il est aussi possible de composer et d’imprimer des notes de calcul en cliquant sur l’icône [image] de la barre d'outils.

Vous trouverez de plus amples informations sur cette fonction à la section Gérer et imprimer les notes de calcul.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Annuler et rétablir une opération

Le bouton ‘Annuler’ [image] (Undo) permet d’annuler une mauvaise manipulation ou une opération non souhaitée. Si vous souhaitez annuler plusieurs opérations, il suffit de cliquer plusieurs fois sur le bouton. Vous pouvez annuler jusqu’à vingt manipulations successives. Ce nombre est configurable via le menu ‘Options – Préférences’, voir Paramètres de sauvegarde des projets.

La même chose vaut pour le bouton ‘Refaire’ [image] (Redo). Ce bouton n’est toutefois actif qu’à partir du moment où au moins une opération a été annulée.

Diamonds conserve toujours le modèle avant la dernière modification. Ces deux icônes permettent donc de respectivement annuler (Undo) la dernière opération et de la rétablir (Redo).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Masquer partiellement

Pour accroître la lisibilité et la convivialité, il est possible de masquer des parties d'une structure. Lorsque vous masquez des parties d’une structure, celles-ci apparaissent en grisé (atténuées). Les éléments en grisé ne peuvent être sélectionnés.

Pour masquer une partie d'une structure, sélectionnez tout d'abord cette partie. Cliquez ensuite sur le bouton [image] pour masquer la partie sélectionnée. Si vous souhaitez l’opération inverse, à savoir afficher la partie sélectionnée et masquer le reste de la structure, cliquez sur le bouton [image].

Pour afficher à nouveau la structure complète, cliquez sur l’icône [image].

Si vous souhaitez inverser les parties apparentes et masquées, sélectionnez l'ensemble de la structure (seules les parties visibles sont effectivement sélectionnées) ; cliquez ensuite successivement sur les boutons [image] et [image] pour afficher d’abord le tout et masquer ensuite les parties sélectionnées (apparaissent en grisé).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La trame

Pour faciliter le dessin, Diamonds vous donne la possibilité de définir une trame. Lorsqu’une trame est active, le curseur ‘englobe’ automatiquement les points de trame en cours de dessin. Pour configurer une trame

  • sélectionnez l’option de menu ‘Vue – Paramètres trame…’
  • ou cliquez directement sur le bouton [image] de la barre d’icônes
  • ou double cliquez dans la zone de dessin avec la touche gauche de la souris (tandis qu'aucun élément est sélectionné)

Vous avez le choix entre la trame générale et une trame variable.

Dans la moitié supérieure de la boîte de dialogue, définissez le pas de trame de la trame générale. Ce pas de trame peut être configuré de manière différente suivant les trois grands axes. Indiquez ensuite si vous souhaitez activer la trame standard ou la rendre visible. A noter que cette trame n’est affichée que dans les vues projetées, jamais en perspective.

Si vous optez pour une trame variable, utilisez la moitié inférieure de cette boîte de dialogue.

Pour réaliser une trame variable, cliquez sur le bouton [image]. La boîte de dialogue de création d’une trame variable s’affiche à l’écran.

Vous devez tout d’abord définir un nom et une couleur de trame. Vous devez ensuite indiquer le plan dans lequel la nouvelle trame se situe.

Vous pouvez procéder de deux manières:

  • Soit vous introduisez, dans ‘Origine’, ‘Point sur l'axe x’’ et ‘Point sur l'axe y’’ des coordonnées.
  • Mais vous pouvez aussi pointer ces coordonnées directement sur l'écran dans la géométrie modèle à l'aide de la souris. Pour ce faire, cliquez sur le bouton [image]. Commencez par cliquer sur un point pour l'origine. Ensuite, l'axe x’ s'affiche et suit votre curseur. Cliquez sur un second point pour déterminer la direction de l'axe x'. Une fois déterminé l'axe x’, vous pouvez procéder de la même manière pour déterminer l'axe y’, en cliquant à nouveau sur un point.

Dans les tableaux inférieurs, définissez les distances intermédiaires des axes selon les deux directions orthogonales. Vous pouvez à nouveau procéder de deux manières:

  • Si l'icône [image] est active, vous devez ajouter vous-même un point à la fois à l'aide du bouton [image]. Vous pouvez introduire manuellement les coordonnées de chaque nouveau point ou cliquer sur le point à l'aide du curseur dans la géométrie modèle.
  • Si vous cliquez une fois sur [image], l' icône se transforme en [image] et vous pouvez sélectionner simultanément plusieurs points dans la géométrie modèle, sans devoir commencer par les ajouter à l'aide du bouton [image]. A cet effet, maintenez la touche SHIFT enfoncée pendant que vous sélectionnez les points. Si vous sélectionnez une barre, les deux points seront repris dans la liste. Vous pouvez indiquer en même temps les deux directions (x’ et y’) en modifiant chaque [image] en [image], ou examiner une direction à la fois. Quand vous souhaitez mettre fin à la sélection, cliquez sur [image], afin que l'icône se transforme à nouveau en [image].

Vous pouvez supprimer des points de la liste en sélectionnant les points en question et en cliquant sur le bouton [image].

Pour afficher la numérotation des axes, n’oubliez pas de cocher la case ‘Avec numérotation’. Cela vaut également pour l’affichage des distances (lignes de mesure) entre les axes et le quadrillage.

Cliquez sur ‘OK’ pour enregistrer les paramètres de cette trame. Le nom de la trame apparaît alors immédiatement dans la fenêtre initiale.

Si la ligne est précédée du symbole [image], cette trame variable apparaît dans la fenêtre modèle. Si vous ne souhaitez plus afficher la trame, cliquez sur le bouton [image] pour masquer la trame. Indiquez par la suite si la trame doit être activée, en d’autres termes si le curseur doit ‘englober les points de trame en cours de dessin.

Vous pouvez définir autant de trames variables que souhaitées. Elles peuvent être toutes visibles et activées simultanément (la trame générale aussi). La trame générale est toujours représentée sous forme de points, les trames variables sous forme de lignes.

Si vous souhaitez modifier une trame variable, sélectionnez d’abord le nom de cette trame et cliquez sur le bouton [image]. Le bouton [image] vous permet d’effacer la trame sélectionnée de la liste.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Types de design

Pour garder une vue d'ensemble d'un projet, il peut être utile de classer les éléments suivant des types définis. Diamonds vous permet de définir vous-même des types et de les attribuer ensuite à des barres ou des plans déterminés. Il est ainsi possible de définir des types pour des poteaux, des fermes, des pannes, des contreventements, des dalles, des voiles, etc.

Les types présentent l’avantage de permettre la sélection en une seule opération de toutes les barres ou de tous les plans d’un type donné. Pour ce faire, il suffit simplement de sélectionner une barre ou un plan d’un type donné tout en maintenant la touche Ctrl enfoncée. De cette manière, vous pouvez sélectionner tous les éléments du même type que l’élément cliqué. Par la suite, vous pouvez, si besoin, cacher temporairement les éléments sélectionnés afin de pouvoir intervenir sur d’autres … Finalement, l’utilisation de la fonction ‘Types’ est également bien utile pour l’import / export de fichiers DXF.

Lorsque vous exportez un fichier DXF (cf. Exportation de fichiers DXF), une couche différente (calque) est générée pour chaque type d’élément. A l’inverse, lorsque vous importez un fichier DXF (cf. Importation de fichiers DXF), les différentes couches sont converties en ‘types d’éléments’ de façon à vous permettre par la suite de sélectionner facilement toutes les lignes ou barres ayant appartenu à un même calque dans le logiciel de CAO. Il vous est dès lors facile de leur attribuer par exemple une section spécifique.

Pour définir un ‘Type’, cliquez sur le bouton [image] de la barre d’icônes ou sélectionnez l’option de menu ‘Édition – Types’.

Vous pouvez à tout moment définir un ‘Type’ ou en modifier les propriétés. Pour attribuer un ‘Type’ à un ou plusieurs éléments, il faut bien entendu préalablement sélectionner ceux-ci. Pour peu qu’un ‘Type’ avait déjà été attribué, celui-ci apparaîtra en surbrillance jaune claire.

Dans cette fenêtre de dialogue figure une liste de tous les ‘Types’ ayant déjà été définis dans Diamonds, qu’ils soient actuellement utilisés ou non.

  • Chaque projet comprend un certain nombre de ‘Types’ standards : poutres, colonnes, dalles, voiles, ... Ceux-ci sont d’ailleurs automatiquement attribués aux différents éléments de construction de votre structure au fur et à mesure que vous la modélisez. Des barres sans section sont du type 'Pas de type spécifique'.

    Vous pouvez bien entendu vous limiter à l’usage de ces ‘Types’ prédéfinis mais vous pouvez également les compléter avec vos propres ‘Types’ en utilisant le bouton [image]. En bas de liste apparaît une ligne vierge dans laquelle vous pouvez définir la visibilité, le nom et la couleur de votre nouveau ‘Type’.

    Si vous cliquez sur [image], cette fenêtre restera ouverte pendant que vous continuerez à travailler. Si vous cliquez sur [image], les modifications seront mises en œuvre et vous fermerez la fenêtre.

    Vous pouvez bien entendu également à tout moment supprimer vos ‘Types’ personnalisés (donc pas les ‘types’ prédéfinis) avec [image].

  • Chaque ‘Type’ est précédé d’un œil ( [image]) pouvant être inactif ( [image]).

    Seuls les types précédés d’un œil actif seront visibles dans l’environnement de modélisation. Selon les paramètres de configuration choisis, les autres types apparaîtront en gris clair transparent ou seront carrément invisibles (cf. Définition ou modification d’une configuration).

    Vous pouvez rendre tous les types visibles ou invisibles en une seule opération en cliquant sur l’œil de la barre des titres.

  • De plus, afin d’augmenter la lisibilité de votre modèle, vous pouvez attribuer à chaque ‘Type’ une couleur d’affichage et une couleur de sélection spécifiques. De ce fait, tous les éléments étant du même ‘Type’ apparaîtront en une seule et même couleur, qu’ils soient sélectionnées (seconde couleur) ou pas (première couleur).

  • Indiquer que vous voulez sauvegarder les ‘Types’ avec l’icône [image]. Si l’option est activée ( [image]) pour un certain ‘Type’, il sera disponible pour tous les fichiers existants ou nouveaux. Si l’option est désactivée ( [image]) pour un certain ‘Type’ et ce ‘Type’ contient des éléments, il ne sera disponible que pour le fichier actuel. Si ce ‘Type’ ne contient pas des éléments, il disparaîtra après la fermeture du fichier.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Fonctions d’analyse

Cette barre d’outils vous permet de démarrer les différentes analyses. Les méthodes de calcul sont exposées plus loin dans ce manuel. Nous les énumérons dans le tableau ci-dessous:

Création du maillage

Exécution de l’analyse élastique globale
Calcul de l'analyse modale

Calcul des longueurs de flambement

Exécution de l’analyse thermique

Calcul de l’armature

Attribution des armatures pratiques

Calculer la déformation fissurée

Calculer la déformation fissurée dans le temps

Vérification acier et bois
Calculer la déformation de l'inox

Optimiser les profilés en acier

Optimiser l'épaisseur des peintures ignifuges

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Orientation du modèle

Le modèle peut être reproduit à tout moment en vue perspective ou en vue projetée.

Vue du dessus | Vue de face | Vue arrière
Vue côté gauche | Vue côté droit | Vue 3D

La vue sélectionnée s’applique à toutes les configurations dans la même fenêtre. En d’autres termes, en passant d'un écran de configuration à l'autre (‘Géométrie’, ‘Charges’ et ‘Résultats’), le modèle est toujours présenté sous la même vue (perspective).

Pour modifier la présentation, procédez d’une des trois manières suivantes:

  • cliquez sur l’icône [image] dans la barre d'icônes
  • sélectionnez dans le menu l’option ‘Vue – Vue’
  • cliquez sur le bouton [image] dans le coin inférieur de la fenêtre modèle.

Si vous optez pour une vue perspective, vous pouvez déterminer la position au moyen des barres de défilement en bas et à droite de la fenêtre modèle. Dans le cas de la vue perspective, vous avez en outre le choix entre une véritable perspective ou une perspective parallèle (axonométrie). Ouvrez la boîte de dialogue ci-dessous via l’option de menu ‘Vue – Perspective...’.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Plan de dessin

Si vous optez pour une vue projetée (vue 2D), vous activez une surface parallèle au système d’axes général, en passant par le point avec coordonnées (X,Y,Z). Vous pouvez définir ces coordonnées via l’icône [image] dans la barre d’icônes. Vous trouverez de plus amples informations sur cette fonction à la section La palette de création et de gestion des plans de dessin ou des étages.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Zoom et déplacement

Pour accroître la lisibilité et la convivialité, Diamonds propose les fonctions de zoom avant (agrandissement de l’image) et de zoom arrière (réduction de l’image). Elles sont respectivement représentées par les icônes [image] et [image] dans la barre d’outils. Pour faire un zoom avant, cliquez d’abord sur l’icône [image] (maintenez la touche enfoncée), et tirez ensuite un cadre de sélection dans la fenêtre modèle. La partie du dessin incluse dans le cadre de sélection est à présent agrandie dans la fenêtre. Pour réduire le dessin, cliquez sur l’icône [image]. Notez toutefois qu’aucun cadre de sélection ne peut être réalisé dans le cas d’une vue perspective. Dans ce cas, le zoom s’effectue toujours vers le point central de la fenêtre modèle.

Une autre fonction intéressante consiste dans le déplacement de l’image; elle est également appelée fonction de recadrage. Vous pouvez déplacer l’ensemble du dessin dans la fenêtre au moyen de la souris. Activez la fonction de recadrage en cliquant sur l’icône [image]. Si vous cliquez avec le bouton gauche de la souris dans la fenêtre modèle et maintenez le bouton enfoncé tout en déplaçant la souris, le dessin se déplacera avec la souris dans la fenêtre.

Pour agrandir le plus possible le dessin dans la fenêtre active tandis que tous les éléments visibles sont inclus dans la fenêtre, cliquez sur le bouton [image].

Ces fonctions peuvent également être activées par le biais du menu ‘Écran’ en sélectionnant l’une des quatre premières commandes de ce menu ou en utilisant les touches raccourcis suivantes:

  • F10: Agrandir
  • F11: Réduire
  • F12: Montrer tout

Il existe finalement une méthode encore plus rapide et plus directe pour effectuer un zoom (avant ou arrière) ou un glissement du modèle. Il vous suffit d’utiliser la roulette de votre souris.

  • Si vous tourner votre roulette (bouton de défilement) vers le haut, Diamonds effectue un gros plan du dessin (le dessin est agrandi).
  • Si par contre vous tourner celle-ci vers le bas, Diamonds élargit la vue générale du dessin (le dessin devient plus petit).
  • Si vous déplacez votre souris en maintenant la roulette enfoncée, le dessin suivra le mouvement de votre souris.

Si vous utilisez la fonction ‘Zoom’ en temps réel, le point fixe dépendra de la position de votre souris sur votre dessin.

Outre la fonction ‘Glisser’ (pan), la roulette de votre souris permet également de faire pivoter votre modèle afin de l’observer dans la position et sous l’angle souhaités. Il suffit de maintenir simultanément la touche ‘Maj’ et la roulette de votre souris enfoncées avant de mouvoir votre souris sur le dessin. Un mouvement horizontal (vers la gauche ou vers la droite) fait pivoter le modèle autour d’un axe vertical tandis qu’un mouvement vertical (vers le bas ou vers le haut) fait pivoter le modèle autour d’un axe horizontal.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Mesurage

La fonction ‘Mesurer’, également accessible par l’icône représentant une petite latte [image] permet de mesurer une distance entre deux points. Cliquez sur l’icône pour activer la fonction et tracez un trait entre deux points. Vous pouvez lire en bas de l’écran, les coordonnées du point de départ, les déplacements en x, y et z ainsi que la distance entre les deux points.

Pour désactiver, cliquez sur le bouton ‘ESC’ de votre clavier ou répliquez sur le bouton [image]. La fonction ‘Mesurer est disponible dans toutes les configurations.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Gestion des fenêtres modèles

Une fenêtre modèle est la partie de la feuille de travail dans laquelle sont présentés le modèle de calcul et les résultats correspondants.

Les opérations que vous pouvez effectuer dans une fenêtre dépendent de la configuration réalisée. La notion de ‘configuration’ est expliquée en détail au paragraphe Paramètres de configuration. Il importe de savoir qu’une configuration n’est pas liée à une fenêtre déterminée. En d’autres termes, vous pouvez appliquer plusieurs configurations dans une seule et même fenêtre et une même configuration peut être utilisée dans plusieurs fenêtres.

L’utilisateur peut dès lors se limiter à l'application d'une seule fenêtre ou peut opter pour l'utilisation de plusieurs fenêtres. Plusieurs fenêtres peuvent s’avérer utiles si vous souhaitez présenter le modèle de calcul simultanément dans plusieurs configurations. La feuille de travail peut donc se composer de deux fenêtres modèles, l’une pour la saisie ou la reproduction de la géométrie, l’autre pour la présentation des résultats. A noter qu'une perspective différente peut être appliquée pour les deux fenêtres.

Les fenêtres définies dans le programme Diamonds sont accessibles via le menu déroulant [image] de cette barre d’outils. Vous pouvez utiliser ce menu pour passer rapidement d’une fenêtre modèle à l’autre.

Vous pouvez à tout moment rajouter une nouvelle fenêtre à cette liste via l’icône [image]. Si vous souhaitez modifier le nom d’une fenêtre existante, cliquez sur l’icône [image] et spécifiez ensuite le nouveau nom:

L’icône [image] vous permet d’afficher plusieurs fenêtres en cascade à l’écran. Toutes les fenêtres apparaissent alors décalées les unes par rapport aux autres.

Enfin, vous avez à tout moment la possibilité de supprimer des fenêtres modèles de la liste. Sélectionnez pour ce faire la fenêtre que vous souhaitez supprimer et cliquez sur l’icône [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres de configuration

Qu’est-ce qu’une configuration?

Définition ou modification d’une configuration

L’onglet ‘Général’

L’onglet ‘Géométrie’

L’onglet ‘Charges’

L’onglet ‘Maillage’

L’onglet ‘Résultats’

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Qu’est-ce qu’une configuration?

La définition de la structure, l’application des charges et la reproduction et l’interprétation des résultats s’effectuent toujours dans un environnement adéquat. Nous désignons ce type d’environnement par le terme ‘configuration’. Chaque configuration est pourvue d’une palette avec boutons qui prennent en charge l’une des trois fonctions susmentionnées. A noter qu’une configuration peut comporter plusieurs fonctions. Il est dès lors parfaitement possible d’inclure la géométrie et les charges dans une même fenêtre de configuration.

Une configuration englobe enfin tous les paramètres liés à la reproduction du modèle, des charges et des résultats, donc du maillage.

Choisissez une configuration en sélectionnant ‘Vue’ dans le menu contextuel de la barre d’outils.

L’utilisateur peut définir autant de configurations qu’il le souhaite. Il est également possible de s’écarter à tout moment d’une configuration existante. Vous trouverez plus loin dans ce manuel plus de détails sur la façon dont une telle configuration est réalisée ou modifiée.

Diamonds propose en standard quatre configurations, ou environnements, qui prennent chacune en charge une seule opération spécifique. Étant donné l’importance de cette configuration, un nom est attribué à chacune d’entre elles. Pour faciliter, d’autre part, le passage d’une configuration à l’autre, la barre d’icônes du menu comprend un bouton pour chacune d’elles.

Configuration ‘Géométrie’ – pour l’élaboration de la géométrie du modèle

Configuration ‘Charges’ – pour l’application des charges au modèle

Configuration ‘Maillage’ – pour visualiser et vérifier le maillage

Configuration ‘Résultats’ – pour la reproduction des résultats du calcul

A noter que lors de la sélection d’une autre configuration, vous restez actif dans la même fenêtre. Le choix d’une configuration est, en d’autres termes, indépendant de la fenêtre sélectionnée.

L’utilisateur est en mesure de modifier les paramètres relatifs à la reproduction de ces quatre écrans de configuration. Plusieurs fonctions peuvent être également attribuées à chacune de ces configurations. Il est toutefois impossible de désactiver la fonction pour laquelle elle a été conçue. En d’autres termes, à la fenêtre de configuration ‘Charges’, il n’est par exemple pas possible de supprimer la palette de charges.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définition ou modification d’une configuration

Pour créer une nouvelle configuration ou adapter une configuration existante

  • cliquez dans le menu ‘Montrer’ sur l’option ‘Configuration fenêtre’
  • ou sur l’icône [image] de la barre d’icônes
  • ou cliquez dans la zone de dessin une fois avec la touche droite de la souris (tandis qu'aucun élément est sélectionné)

Le nom de la configuration active s’affiche dans le menu déroulant, en bas à gauche. Tous les paramètres présents dans cette boîte de dialogue se rapportent à cette configuration. Sélectionnez une autre configuration existante dans le menu déroulant. A noter que le nom de la configuration apparaît une deuxième fois à la ligne suivante. Tant qu’aucune modification n’est apportée, vous ne pouvez modifier ce nom.

Dès qu’un paramètre est modifié, vous créez en principe un nouvel environnement. Le nom de la configuration active disparaît et un nouveau nom ‘Configuration utilisateur’ s’affiche. Le champ à côté de ‘Nom configuration’ se met alors en surbrillance. Les possibilités suivantes s'offrent à vous:

  • vous pouvez directement cliquer sur le bouton ‘OK’. Une configuration temporaire portant le nom ‘Configuration utilisateur’ est créée. Cette configuration est maintenue aussi longtemps que vous ne sélectionnez pas d’autre environnement.
  • vous pouvez choisir un nouveau nom pour cette configuration et créer un nouvel environnement.
  • vous pouvez également conserver la configuration en cours et remplacer les anciens paramètres par les nouveaux.

Si vous optez pour la variante 2 ou 3, vous devez encore cliquer sur le bouton [image]. Cette nouvelle configuration ou configuration modifiée devient immédiatement la configuration active. Dans le cas où vous adaptez un environnement existant, vous êtes invité à confirmer.

Pour supprimer un environnement existant, sélectionnez la configuration concernée et cliquez ensuite sur le bouton [image]. Par mesure de sécurité, un message vous demande si la configuration doit bien être supprimée. Cliquez sur ‘Non’ si vous souhaitez malgré tout conserver la configuration. A noter que vous ne pouvez utiliser cette fonction que pour un environnement que vous avez vous-même défini. En d’autres termes, il n'est pas possible de supprimer l'une des trois configurations par défaut.

Examinons en détail la façon dont une configuration est élaborée et les paramètres devant être définis.

En fonction de la structure de la configuration, cette boîte de dialogue comprend trois, quatre ou cinq onglets.

Les onglets ‘Général’, ‘Géométrie’ et ‘Maillage’ sont indépendants de la fonction choisie. Il s’agit ici d’une série de paramètres pouvant être réglés pour la définition de la structure, pour l’application des charges ainsi que pour la reproduction et l’interprétation des résultats.

Les onglets ‘Charges’ et ‘Résultats’ n’apparaissent que si la configuration autorise que des charges puissent être appliquées ou des résultats reproduits.

L’onglet ‘Général’

L’onglet ‘Géométrie’

L’onglet ‘Charges’

L’onglet ‘Maillage’

L’onglet ‘Résultats’

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L’onglet ‘Général’

A l’onglet ‘Général’, indiquez d’abord la fonction que doit remplir la configuration. Ce n’est que lorsqu’une fonction donnée est cochée que la palette correspondante s’affichera à l’écran de configuration. En sélectionnant ‘Charges’ et ‘Résultats’, vous affichez également deux onglets en option.

Après avoir déterminé la fonction de la configuration, vous devez indiquer l’opération qui reçoit la priorité. Il va de soi que cette option n’a de sens que si la configuration doit remplir plusieurs fonctions. Dans une configuration où la géométrie et les charges peuvent être, par exemple, toutes deux définies, un double-clic sur une case ou un bouton donnera lieu, en fonction de la priorité cochée, à une boîte de dialogue différente.

Vous devez ensuite indiquer le type de représentation que vous souhaitez. Chaque fois que vous appelez la configuration voulue en cours d’élaboration de modèle ou d’analyse des résultats, le modèle se présentera selon le type de représentation choisi.

Modèle filigrane

Modèle plan transparent

Modèle plan non transparent

Modèle solide en noir et blanc

Modèle solide en couleur
Modèle solide en couleur avec bords en noir

A noter que la feuille de travail Diamonds comprend également du côté droit une barre d’outils ‘Représentation’. Elle vous permet de rapidement changer de présentation en cours de modélisation. N’oubliez pas que cette barre d’outils fonctionne de manière autonome. Toute modification de celle-ci ne sera dès lors pas conservée comme paramètre de configuration.

Pour chaque configuration, vous pouvez en outre déterminer si le repère d’axes global et les appuis doivent être représentés. De plus, vous pouvez indiquez si vous souhaitez dessiner les parties cachées en grisé ou pas du tout.

La couleur du fond d’écran est le dernier paramètre de la liste des paramètres généraux. Vous avez le choix entre un fond d’écran blanc ou noir.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L’onglet ‘Géométrie’

L’onglet ‘Géométrie’ comprend tous les paramètres de visualisation. Vous définissez ici en particulier les données qui doivent être affichées pour les éléments structurels.

Dans le cas des points, il est possible de les représenter sous forme de petits carrés. Vous pouvez également afficher les numéros de point.

Pour les barres, vous pouvez afficher l'axe de calcul, la numérotation, les noms des profils, leur longueur, leur orientation, les axes locaux, la rigidité des extrémités, le matériau et les lignes de bord de l’ensemble de la section. De plus vous pouvez afficher les longueurs de flambement, les distances entre les support au déversement et les supports au déversement.

Pour les plaques, vous devez tout d’abord définir le degré de transparence en cas d’utilisation d’un modèle plan transparent.

Vous pouvez ensuite demander d’afficher les numéros de plaques, l’épaisseur, la surface, les repères d’axes locaux pour les efforts internes et l'armature, la rigidité des extrémités, le matériau, la représentation volumétrique, l’armature pratique et le sens portant des dalles orthotropes.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L’onglet ‘Charges’

Un onglet supplémentaire apparaît dans les configurations et permet de définir des charges. Il est uniquement possible de dessiner des charges si l’option ‘Charges’ de l’onglet ‘Général’ est cochée.

Vous pouvez définir à cet onglet la taille des différents types de charges dessinés. La valeur par défaut est de 20 pixels.

Indiquez également la couleur dans laquelle vous souhaitez dessiner les charges. Une charge active est une charge définie dans un groupe de charges actives. Les charges inactives, en revanche, sont les charges non incluses dans le calcul. Vous pouvez indiquer si un type de charge doit être pris en compte ou non dans la boîte de dialogue où sont définis les coefficients de charge et les facteurs de combinaison.

Quand la case à cocher 'Afficher le vecteur résultant') est décochée, les composantes des charges s’affichent séparément. Quand elle est cochée, le vecteur résultant s’affiche.

Quand la case à cocher 'Afficher la masse' est cochée et que vous avez défini un groupe de charges dynamiques ou sismiques, la masse prise en compte pendant l’analyse du modèle s’affiche dans ce groupe de charges.

Quand la case à cocher 'Afficher le poids propre' est cochée et que vous avez défini un groupe de charges dynamiques ou sismiques, la masse prise en compte pendant l’analyse du modèle s’affiche dans ce groupe de charges.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L’onglet ‘Maillage’

Vous enregistrez à l’onglet ‘Maillage’ tous les paramètres relatifs à la présentation du maillage.

Déterminez tout d’abord si les nœuds, les lignes et les bords libres du maillage doivent être affichés. Pour chacun d’entre eux, il est possible d’attribuer une couleur propre. Vous pouvez ensuite demander d’afficher un numéro pour les nœuds, les lignes et les triangles de maillage.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L’onglet ‘Résultats’

Un onglet supplémentaire ‘Résultats’ apparaît dans les configurations pour lesquelles les résultats du calcul peuvent être (aussi) demandés. La demande des résultats n’est possible que si l’option ‘Résultats’ de l’onglet ‘Général’ est cochée.

Cette fenêtre reprend l’ensemble des paramètres relatifs à la façon dont les résultats sont présentés.

Nous distinguons 3 sous-onglets:

  • Un premier permettant de définir les paramètres de représentation des barres, dalles et réactions et permettant d’indiquer les informations que vous voulez voir apparaître sur les graphiques.
  • Un second sous-onglet permet de paramétrer l’échelle par défaut des résultats alors qu’un troisième permet de définir des échelles spécifiques pour certains types de résultats.
  • Ce troisième sous-onglet n’est disponible qu’à partir du moment où vous avez coché sous le second sous-onglet que vous souhaitez utiliser des échelles spécifiques.

Sous-onglet ‘Représentation’

Il convient tout d’abord de définir l’écart maximal des graphiques par rapport à l’élément non déformé. Un autre paramètre est prévu pour les résultats d’une barre et pour les résultats d’une dalle ou d’une plaque. Pour les efforts de réaction aussi, un paramètre détermine la grandeur de la réaction maximale. A noter que les forces et les moments peuvent être traités indépendamment. En plus, vous pouvez choisir de visualiser les réactions en couleur ou en noir.

Vous pouvez en outre également cocher que les résultats sur barres soient affichés avec les valeurs. Ici, vous pouvez choisir de soit ne visualiser que les valeurs maximales soit visualiser aussi les valeurs dans les extrémités des barres. Pour la représentation des résultats des dalles et des plaques, vous avez le choix entre:

  • un modèle couleur 3D, éventuellement avec iso-lignes
  • une présentation avec iso-lignes

Dans les deux cas, les graphiques sont dessinés en dégradé de couleurs.

Pour les éléments en béton armé, vous pouvez choisir de tenir compte des armatures minimum et/ ou des armatures pratiques pour la représentation des armatures. Pour des résultats détaillés, il est également possible de représenter les armatures sur trame. Définissez pour ce faire les dimensions de la trame dans l’axe x’ et z’ (voir aussi Résultats détaillés).

Sous-onglet ‘Échelle standard’

A chaque type de résultat correspond une représentation graphique avec une échelle spécifique. Dans le sous-onglet ‘Échelle standard’ vous pouvez préciser l’échelle que vous souhaitez utiliser systématiquement. Par défaut, Diamonds 2010 construit l’échelle standard de manière telle que les valeurs extrêmes correspondent au maximum des valeurs absolues des valeurs les plus positives ou les plus négatives des déformations ou efforts internes. C’est donc la même valeur qui apparaît comme borne supérieure et inférieure de l’échelle des valeurs. Ceci a pour avantage qu’une très large palette de couleurs soit toujours disponible, mais pour désavantage que certains résultats n’en utilisent qu’une très faible partie. C’est une des raisons pour lesquelles nous vous offrons la possibilité de configurer vos propres échelles selon les résultats observés.

Comme l’illustre la figure précédente vous pouvez …

  • soit opter pour une échelle avec des plages positives et négatives
  • soit choisir une échelle aux valeurs absolues.

De plus, pour chacune de ces possibilités, vous pouvez intervenir librement sur les valeurs extrêmes de la palette de couleurs. Dans le premier cas, cela implique quatre possibilités, dans le second cas, seulement deux. Les diagrammes et échelles affichés s’adaptent automatiquement à l’échelle que vous avez sélectionnée. Vous pouvez dès lors effectuer un certain nombre de tests de façon à obtenir l’échelle qui vous satisfait le mieux.

Même après que vous ayez défini une échelle standard, Diamonds vous permet toujours d’imposer des échelles différentes et spécifiques pour l’affichage de certains résultats. Pour ce faire, il vous suffit de cocher l’option ‘Exceptions par rapport à l’échelle standard’ en bas à gauche. Dès que vous cochez cette option, le troisième sous-onglet ‘Echelle manuelle’ devient accessible.

Le fait de pouvoir activer et désactiver cette option à partir du second sous-onglet a pour avantage de pouvoir décider à tout moment d’afficher à nouveau tous les résultats conformément à l’échelle standard.

Sous-onglet ‘Echelle manuelle’

Nous venons de décrire comment définir une échelle standard à partir du second sous-onglet et de l’appliquer par défaut à l’ensemble des résultats. Pour certains résultats il peut parfois être intéressant d’utiliser une échelle différente : soit vous souhaitez utiliser un autre type d’échelle, soit vous souhaitez personnaliser les bornes supérieure et inférieure. Cette dernière option peut par exemple être utile lorsque vous souhaitez mettre en évidence les valeurs limites minimum et/ou maximum. Tous les résultats dépassant la limite supérieure ou inférieure apparaissent alors dans la même couleur.

En haut de la page attachée à ce sous-onglet se trouvent un certain nombre de boutons correspondant à des familles de résultats. Pour chacune de ces familles de résultats, vous avez un menu déroulant dans lequel vous pouvez indiquer le résultat spécifique que vous souhaitez observer.

Si pour un de ces résultats spécifiques, vous souhaitez définir une échelle plus appropriée, commencez par sélectionner ce résultat. Indiquez ensuite l’échelle que vous souhaitez utiliser lors de la représentation graphique de celui-ci. A gauche de l’échelle des couleurs, vous pouvez en outre décocher les deux champs numériques de façon à pouvoir imposer vos propres bornes supérieure et inférieure.

Vous pouvez par exemple choisir de représenter les armatures supérieures selon l’axe x’ en bleu foncé chaque fois que la quantité théorique d’armatures requises est inférieure à la quantité d’armatures pratiques (524mm²/m).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tableau de données et résultats

L'ensemble des données et des résultats du projet peuvent être demandés sous la forme de tableau. Les données de projet incluent tant les données géométriques que l’ensemble des charges.

Tableau ‘Données’

Tableau ‘Résultats’

Tableau ‘Vérification d'équilibre’

Tableau ‘Information modale’

Fenêtre ‘Réponse Modale’

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tableau ‘Données’

Le contenu de ce tableau [image] peut varier d’une configuration à l’autre. En principe, seules sont affichées les données correspondant aux paramètres de la configuration active. En d’autres termes, les données géométriques ne seront pas affichées dans le cas d’une configuration de charges; de même, un tableau ne comprendra aucune donnée de charges si la configuration active ne prévoit que le dessin du modèle. En revanche, dans le cas de l’écran de configuration ‘Résultats’, les données géométriques et les données de charges sont reprises.

Compte tenu de ce qui précède, la fenêtre ‘Données’ comporte un maximum de six tableaux. Il va de soi que si pour une catégorie, aucune donnée n’est disponible, elle n’apparaîtra pas dans la liste. Le tableau comprend d’autre part uniquement les informations sur les parties apparentes de la structure. Si vous souhaitez afficher des données sur un seul élément ou sur quelques éléments donnés, sélectionnez d’abord ces éléments et cliquez ensuite sur l’icône [image].

Les charges sont toujours données par groupe de charge. Affichez les charges pour un autre groupe de charge au moyen du menu déroulant qui s'affiche dans le coin supérieur gauche de cette boîte de dialogue.

En utilisant la liste déroulante avec les configurations, vous pouvez facilement changer entre les tableaux de données différents.

Déterminez via le bouton [image] les informations que vous souhaitez inclure dans le tableau. La boîte de dialogue suivante s’affiche:

A chaque caractéristique correspond une colonne. Pour supprimer une caractéristique donnée du tableau, il suffit de décocher la case correspondante.

Vous pouvez inclure ces données dans une note de calcul mais vous pouvez aussi directement les imprimer au moyen du bouton [image] dans le bas de la boîte de dialogue. Vous pouvez éventuellement d’abord cliquer sur le bouton [image] pour obtenir un aperçu avant impression. Si vous souhaitez convertir ces données en un fichier RTF, cliquez sur le bouton [image]. RTF est l’abréviation de ‘Rich Text Format’ et constitue un format de fichier qui peut être lu et modifié par la plupart des traitements de texte (MS Word, par ex.).

A noter enfin que vous pouvez modifier dans cette fenêtre les coordonnées et les limites des nœuds. Vous pouvez également adapter l’importance des charges sur les nœuds, sur les barres et sur les plaques. Pour ce faire, sélectionnez la cellule dans laquelle vous souhaitez apporter une modification et cliquez sur le bouton gauche de la souris. Notez la nouvelle valeur dans la cellule, que vous pouvez à présent éditer, et cliquez sur le bouton [image] pour appliquer la ou les modifications au modèle en cours.

Utilisez le bouton [image] pour copier le contenu de ce tableau.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tableau ‘Résultats’

La fenêtre ‘Résultats’ comprend sous forme de tableau les résultats du calcul [image].

Le contenu de ce tableau dépend des éléments sélectionnés, du résultat choisi, du groupe de charge ou de la combinaison sélectionnée et des options choisies avec [image].

  • Les résultats peuvent être demandés pour chaque groupe et combinaison de charges, donc pour les valeurs enveloppantes des combinaisons de charges au niveau des états-limites ultimes et des états-limites de service. Pour afficher les résultats d’une autre combinaison, ouvrez le menu déroulant dans le coin supérieur gauche de la boîte de dialogue.

  • Le bouton [image] vous permet de rendre certaines colonnes du tableau visibles/invisibles et vous permet d'indiquer quels résultats vous souhaitez voir.

    • L'étiquette d'un élément et les coordonnées du maillage peuvent être ajoutées au tableau sous forme de colonne supplémentaire. L'option Réaction moyenne pour lignes d'apuis prend en charge les résultats dans une ligne supplémentaire du tableau.

    • Pour les barres, vous pouvez spécifier la position dans laquelle vous souhaitez voir les résultats : valeurs extrêmes, tous les nœuds du maillage, les valeurs d'extrémité de la barre ou au point commun.

      Supposons cette structure:

      Valeurs extrêmes Tous les nœuds de maillage

      Seules les valeurs minimales et maximales des barres sélectionnées sont affichées dans le tableau.

      Cette option n'est pas compatible avec l'affichage des coordonnées du maillage.

      Les valeurs appartenant à chaque nœud de maillage des barres sélectionnées sont affichées dans le tableau.
      Valeurs finales des barres

      Point commun
      Seulement les valeurs aux extrémités des barres sélectionnées sont affichées dans le tableau.

      Seulement les valeurs du point commun des barres sélectionnées sont affichées dans le tableau.

      Il n'est possible de demander ce résultat que pour des barres n'ayant qu'un seul point commun.

Vous pouvez inclure ces résultats dans un rapport de calcul [image], les imprimer directement [image] ou convertir les données en RTF [image]. Dans les deux derniers cas, nous vous conseillons de demander un aperçu avant impression en utilisant [image].

Utilisez le bouton [image] pour copier le contenu du tableau. Avec la liste déroulante [image], vous pouvez indiquer si vous souhaitez :

  • copier uniquement les résultats de la combinaison en cours
  • copier les résultats de toutes les combinaisons
  • copier les résultats de toutes les combinaisons de l'ensemble en cours
    Si par exemple vous regardez les résultats de l'ELU FC 4 et que vous choisissez cette option, tous les résultats de l'ELU seront copiés.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tableau ‘Vérification d'équilibre’

Le bouton [image] dans la barre d'icônes héberge le contrôle d'équilibre et le facteur de flambement global:

  • Ce contrôle d'équilibre comporte, pour chaque combinaison de contraintes, un récapitulatif de la contrainte verticale/horizontale qui agit et des efforts de réaction qui en résultent.
  • Le facteur de flambement global est le facteur par lequel il faut multiplier la contrainte pour provoquer un flambement global.
    • Si le facteur de flambement global est inférieur à '1', la contrainte sera supérieure à la contrainte de flambement critique et la structure – dans son ensemble – va céder. Ces combinaisons sont affichées en rouge.
    • Si le facteur de flambement global est '<10', la structure est 'sway' et un calcul au 2 ordre est nécessaire.
    • Si le facteur de flambement global est '≥10' ou '-', la structure est 'non-sway' et un calcul au 1 ordre suffit.
    • Si aucune convergence a été trouvé un '*' est affiché. Parce que nous ne pouvons pas tirer des conclusions, ces combinaisons sont aussi affichées en rouge.

Notes:

  • Le facteur de flambement global [image] est disponible uniquement après un calcul du second ordre.
  • Le flambement global n'est pas lié à une norme et ne doit pas être confondu avec le contrôle de flambement d'un seul élément.
  • Le facteur de flambement global [image] est affiché en bas de la fenêtre.
  • Utilisez le bouton [image] pour copier le contenu de ce tableau.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tableau ‘Information modale’

Le bouton [image] vous permet d'invoquer un tableau des informations modales:

Vous y trouverez les paramètres suivants:

  • la fréquence ω [rad/s]
  • la fréquence f [Hz]
  • la période T [s]
  • la masse modale M
  • la rigidité modale K
  • l'atténuation modale D
  • l'atténuation critique Dc
  • le taux d'amortissement ξ [%]
  • la masse modale effective suivant l'axe global X
  • la masse modale effective suivant l'axe global Y
  • la masse modale effective suivant l'axe global Z

Utilisez le bouton [image] pour copier le contenu de ce tableau.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Fenêtre ‘Réponse Modale’

Au moyen du bouton [image], vous pouvez voir la réponse à la charge dynamique.

  • Dans le premier menu déroulant, sélectionnez le groupe de charges dynamiques pour lequel vous souhaitez examiner la réponse.
  • Si le groupe de charges dynamiques contient des sous-groupes de charges, vous pouvez sélectionner le sous-groupe de charges souhaité dans le deuxième menu déroulant.
  • Dans le troisième menu déroulant, choisissez le mode propre pour lequel la réponse doit être représentée. Vous pouvez aussi représenter la réponse pour tous les modes propres dans une seule et même figure.
  • Si vous cochez l'option 'Echelle globale', l'amplitude de chaque mode propre sera mise à l'échelle séparément par rapport à l'amplitude maximale. Si vous décochez cette option, la réponse sera simplement représentée de la manière la plus grande possible sur la fenêtre. Exemple:
Réponse de tous les modes propres ensemble. L'amplitude du mode propre vert est très petite par rapport au mode propre rouge. | Réponse du mode propre vert | Réponse du mode propre vert

Cette fenêtre vous aide à

  • déterminer quel mode réagit plus ou moins à la charge.
  • estimer si une correction quasi statique se justifie ou non. Si la fréquence propre du mode est beaucoup plus grande que la fréquence de la charge imposée, le mode réagira de manière quasi statique à la charge. En d'autres termes, l'amplitude de la réponse a la forme de la charge imposée.

Le temps sur lequel vous voyez la réponse est égal à la période que vous avez introduite en regard [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Résultats détaillés sur une section

Une vue détaillée des contraintes dans la section peut être obtenu:

  • Soit par double-cliquer une barre ayant visible les résultats correspondants.
  • Soit par sélectionner une barre et par cliquer [image] dans la barre d’icônes, ayant visible les résultats correspondants.

Les contraintes

Résultats thermiques

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Les contraintes

Vous allez voir la fenêtre suivante:

  • Choisissez à gauche en haut pour quel groupe ou combinaison de charges vous souhaitez montrer les contraintes.
  • Déplacez la position de l’ascenseur horizontale pour voir les contraintes dans la section à une certaine position de la barre. En cliquant cette distance, vous pouvez introduire une valeur à choix. Pressez u pour commencer une animation des contraintes au long de la barre. Utilisez n pour arrêter l’animation. Avec les boutons Ê et - vous accélérez ou ralentissez l’animation.

  • Résultats avec échelle

    • Dans la zone au milieu, la section sélectionnée est représentée graphiquement avec ses axes principaux d'inertie. Quand une section est double symétrique, ces axes seront coïncident avec les axes locaux.

    • Sur les axes principaux, vous voyez des points rouges. Ce sont les points pour lesquels les résultats de contrainte (N+My et N+Mz) sont représentés dans la fenêtre des résultats globaux de Diamonds. La position de ces points est déterminée comme l'intersection des axes principaux avec le rectangle qui enveloppe la section (EN : bounding box).

      Lorsque vous approchez ces points rouges avec le curseur, Diamonds va se caler à eux.

    • Bougez la souris sur la section pour voir les contraintes à une certaine position. Introduisez les coordonnées ‘x’ et ‘y’ pour montrer les contraintes dans un point à choix. Les contraintes dans cette fenêtre sont basées sur N+My+Mz
    • Compression est négative, traction est positive.
  • Avec le bouton [image] vous faites une capture d’écran des contraintes dans la section.
  • Avec le bouton [image] vous faites une visualisation avant impression d’écran des contraintes dans la section

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Résultats thermiques

Vous allez voir la fenêtre suivante:

  • Déplacez la position de l’ascenseur horizontale pour voir la température après x minutes. Pressez u pour commencer une animation des contraintes au long de la barre. Utilisez n pour arrêter l’animation. Avec les boutons Ê et - vous accélérez ou ralentissez l’animation.
  • Bougez la souris sur la section pour voir la température à une certaine position. Introduisez les coordonnées ‘x’ et ‘y’ pour montrer la température dans un point de votre choix.
  • A droite en haut, vous voyez la variation de la température dans le temps.
  • A droite en bas, vous voyez la gradient de température et la changement globale de température qui résultent dans les mêmes déformations thermiques que l’effet de l’incendie calculé à un moment donné. Ceci est particulièrement intéressant lorsque vous souhaitez modéliser la charge de feu comme un cas de charge thermique.
  • Avec le bouton [image] vous faites une visualisation avant impression d’écran des contraintes dans la section.
  • Avec le bouton [image] vous faites une capture d’écran des contraintes dans la section.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Résultats détaillés

A l’issue de l’analyse, vous pouvez demander des résultats détaillés pour chaque plaque sous forme de graphique. Sélectionnez pour ce faire la plaque et cliquez ensuite sur l’icône [image] de la barre d’icônes.

Pour des barres - Général

Dans le cas des barres, les graphiques des différentes grandeurs sont dessinés les uns en dessous des autres pour un bouton donné. Sélectionnez dans le coin supérieur gauche le groupe de charges ou la combinaison de charges pour lequel vous souhaitez obtenir des résultats détaillés. Indiquez ensuite les grandeurs pour lesquelles un graphique doit être affiché. Par défaut, les résultats détaillés sont reproduits en fonction des paramètres actifs de la palette ‘Résultats’.

Vous trouverez au dessus des graphiques une esquisse de la barre avec indication des numéros de nœuds et de la longueur de la barre.

Diamonds vous permet d'introduire une distance dans la case de défilement. La case de défilement se déplace ensuite vers ce point distant. Vous pouvez ainsi afficher immédiatement les résultats à l'endroit voulu.

Vous pouvez afficher ou masquer les combinaisons déterminantes (combinaison minimum et maximum) en utilisant les boutons [image] et [image]. En utilisant la liste déroulante, vous pouvez facilement changer entre les configurations. Avec [image] vous pouvez adapter les configurations.

Les remarques suivantes s’appliquent à chaque graphique:

  • Les valeurs dans les points de maillage sont déduites du calcul des éléments finis. Les valeurs intermédiaires sont déterminées par interpolation linéaire.
  • Vous pouvez demander les grandeurs à un point au choix de la barre au moyen du curseur de la barre de défilement horizontal. La valeur x (abscisse) de ce point apparaît juste en dessous de la barre de défilement. Une ligne verticale suit le déplacement du curseur au niveau de cette barre. Vous trouverez à gauche de cette ligne, à hauteur de chaque graphique, la valeur de la grandeur à ce point discret. Pour les valeurs enveloppantes, la valeur minimale et la valeur maximale sont indiquées.
  • A la droite de chaque graphique, les valeurs extrêmes sont notées avec le signe positif et négatif, ainsi que les unités.

Soulignons encore que pour les barres, il est possible de demander un close-up de plusieurs éléments sélectionnés à condition que ces barres soient dans le prolongement l’une de l’autre.

Pour des barres - Déformation relative

Des flèches relatives peuvent être indiquées pour des barres (comportant une section) ou des lignes de coupes dans une plaque :

  • Sélectionnez une ou plusieurs barres ou lignes de coupes (les éléments doivent être alignés et cliquez sur [image].
  • Sélectionnez le résultat de la flèche [image].
  • Cochez la case [image] .

La flèche relative est calculée en utilisant la distance entre les points rouges, affichées sur la ligne de déformation totale.

  • Affichez les points de maillage à l'aide de la case [image]. Plusieurs points noirs apparaissent sur la ligne de déviation totale
  • Des supports existants ou à des points fixes reconnus automatiquement (par exemple un mur ou une colonne) deviennent des points rouges par défaut.
  • Les points rouges peuvent être transformés en points noirs (non fixes), en cliquant dessus et vice versa.

Sous la flèche totale, vous voyez la déformation linéaire et relative.

  • La déformation linéaire est la corde qui relie les déformations au niveau des points rouges fixes.
  • La déformation relative est égale à la déformation totale moins la déformation linéaire.

Comme la longueur de portée (= la longueur entre les points rouges) est connue par Diamonds , la déformation relative par rapport à la longueur de portée L/xxx est également affichée.

Remarques:

  • Pour les barres, δy les flèches indiquées dans la fenêtre de résultat globale correspondent aux δz' résultats locaux dans la fenêtre détaillée.

    Pour les lignes de coupure, δy les flèches indiquées dans la fenêtre de résultat globale correspondent aux δy résultats globaux dans la fenêtre détaillée.

  • Dans le cas des flèches par rapport à l’axe Y local δy', Diamonds les scinde en conséquence.
  • L’option [image] affiche les rotations angulaires, pour les barres uniquement.
  • Un aperçu avant impression et l’impression peuvent être obtenus avec [image] et [image]. Les flèches relatives ne peuvent pas être incluses dans les rapports généraux.

Pour des surfaces - Général

Pour les dalles ou les plaques, le résultat actif peut être affiché dans la fenêtre des résultats détaillés. Vous trouverez du côté gauche tous les boutons de la palette ‘Résultats’ qui s’appliquent aux plaques. Seuls les boutons pour lesquels des résultats sont disponibles peuvent être enfoncés. Outre le choix d’une grandeur donnée, vous devez encore sélectionner le groupe ou la combinaison de charges dans le menu contextuel. Par défaut, les résultats détaillés sont représentés en fonction des paramètres actifs de la palette ‘Résultats’. En utilisant la liste déroulante, vous pouvez facilement changer entre les configurations. Avec [image] vous pouvez adapter les configurations.

A noter que vous pouvez demander un close-up de plusieurs éléments sélectionnés à condition qu’ils soient dans le même plan. A l’aide de la roulette de votre souris il est possible de agrandir ou de mouvoir le dessin.

Dès l’instant où vous déplacez la souris vers un point dans le périmètre de la plaque, les valeurs des résultats de la même famille de la grandeur sélectionnée s’affichent dans le bas.

Dans le cas des valeurs enveloppantes, les valeurs minimale et maximale s’affichent.

Pour les préslabs, les plaques portant dans une ou deux directions, l’optimum hoptet l’épaisseur minimale de la plaque hmin sont également indiquées.

  • hopt est calculé en utilisant une déformation de l'acier de 10‰ et une déformation de compression dans le béton de 3,5‰
  • hminest calculé en utilisant une déformation de l'acier correspondant au point où l'acier vient d'atteindre la limite d'élasticité et une déformation en compression dans le béton de 3,5‰

Pour les armatures dans des plaques, vous obtenez 3 résultats possibles:

  • Ainf,UGT (or Asup,UGT): l’armature nécessaire pour satisfaire ELU
  • Ainf,TOT (or Asup,TOT): l’armature nécessaire pour satisfaire ELU et ELS
  • Ainf (or Asup): dans le cas où Ainf,UGT= Ainf,TOT (or Asup,UGT=Asup,TOT)

En plus, vous y retrouvez les coordonnées relatives du point dont les résultats sont donnés. L’origine du repère d’axes relative se situe toujours en bas à gauche des dalles sélectionnées.

Afin de voir les résultats demandés à cet endroit immédiatement, vous introduisez des coordonnées pour x et y. Diamonds vous permet d'introduire une distance dans les cases de défilement. Les cases de défilement se déplacent ensuite vers ce point distant. Vous pouvez ainsi afficher immédiatement les résultats à l'endroit voulu.

En outre, Diamonds saisit dans la fenêtre de détail des points situés dans la plaque, si bien que vous pouvez afficher rapidement les résultats. Pour cela, sélectionnez la plaque et le(s) point(s) souhaité(s) et cliquez ensuite sur [image]. Le(s) point(s) sélectionné(s) est(sont) repris dans les résultats détaillés.

Nous insistons sur le fait que tous les résultats, y compris les déformées et les réactions (tant pour les poutres que pour les dalles), sont toujours données par rapport aux repères locaux.

Ceux-ci peuvent dès lors différer des résultats illustrés dans votre configuration ‘Résultats’ (Les résultats y sont toujours représentés en fonction des repères globaux), surtout dans le cas d’éléments inclinés.

Tant pour les barres que pour les plaques, vous pouvez imprimer le close-up du graphique via le bouton [image] dans le bas de la boîte de dialogue. Vous pouvez éventuellement faire pivoter la représentation de la plaque de 90° en cliquant sur le bouton [image]. Vous pouvez afficher ou masquer les combinaisons déterminantes (combinaison minimum et maximum) en utilisant les boutons [image] et [image].

Nous attirons enfin votre attention sur l’application pratique suivante. Dans le cas où les résultats relatifs à l’armature sont reproduits sous forme de trame (voir Définition ou modification d’une configuration), vous obtenez la représentation suivante:

Cela concerne en particulier la représentation de la sous-armature. Un treillis de base ‘B 6-100’ est sélectionné, ce qui correspond à une armature pratique de 283mm²/m dans les deux directions. Pour la représentation sous forme de trame, Diamonds indique l’armature requise (en mm²) qui doit être placée sur une distance égale au pas de trame. Pour les deux directions, la section maximale est reproduite en rouge. La première valeur correspond à l’armature déjà présente (donc l’armature pratique), la deuxième valeur indique l’armature manquante.

Tous les lieux où des armatures supplémentaires sont nécessaires (deuxième valeur > 0) sont affichés en bleu.

La taille de la trame appliquée ici équivaut à 1 mètre. Nous pouvons donc conclure que le treillis de base est suffisant dans l’axe z’ local de la plaque mais que dans l’axe x’, une armature supplémentaire est requise. Il est possible d’atteindre une plus grande précision si un pas de trame inférieur est appliqué.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Les assemblages

BuildSoft dispose d’un logiciel, PowerConnect, avec lequel on peut dimensionner la plupart des assemblages métalliques. Voici l’explication des icônes. Elles seront expliquées plus détaillé dans le paragraphe Assemblages.

Dimensionner les assemblages avec PowerConnect

Ouvrir la bibliothèque des assemblages

Vérifier les assemblages

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Log in et notifications

Si vous travaillez avec des bibliothèques centrales (Bibliothèques locales ou centrales ) ou lorsque vous souhaitez échanger des fichiers sur le réseau, le log in est nécessaire pour vous identifier auprès des autres utilisateurs. Si vous n'utilisez pas ces fonctions, le log in n'est pas importante.

Le log in est définie par un administrateur (voir Guide d'installation).

Vous pouvez vous déconnecter en cliquant sur la flèche située à côté de votre nom d'utilisateur et en sélectionnant ‘Se déconnecter’.

Lorsque des ajustements sont apportés aux bibliothèques centrales, vous recevrez une notification chez [image].

Aussi, lorsque vous avez reçu un modèle de BIM Expert, vous recevrez une notification chez [image] (voir Importation de fichiers BIM Expert).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette d’icônes

Chaque configuration est munie d'au moins une palette d'icônes. Une palette d'icônes contient un ensemble de boutons qui vous aident à effectuer l'une des opérations suivantes:

  • définir la géométrie et les conditions préalables
  • créer les charges
  • vérifier les résultats détaillés à l'aide de graphiques

Nous parlerons respectivement de palettes 'Géométrie', 'Charges' et 'Résultats'. Nous en parcourrons toutes les fonctionnalités ci-après.

La palette 'Géométrie'

Le pointeur de sélection

Label et commentaire

Tracer des points

Tracer des lignes

Effacer des points, des lignes et des plans

Tracer des éléments structurels

Chercher des dalles ou plaques

Diviser des lignes

Extruder

Formes paramétrées

Structures paramétrées

Déplacer et copier

Pivoter

Projection

Miroiter

Intersection

Vérification du modèle

Redimensionner de la géométrie

Modifier les propriétés communes à plusieurs éléments

Propriétés des barres

Dimensions

Propriétés des sections de barres

Matériaux, enrobages (béton) et mode de fabrication (Fe) des barres

Axes locaux des barres

Propriétés des dalles et plaques

Propriétés des sections de dalles

Matrice de rigidité

Matériaux et enrobages des dalles

Axes locaux des dalles

Caractéristiques des semelles

Choix d’une section dans la bibliothèque des profilés

Excentricité des barres

Excentricité d’une poutre par rapport à une dalle

Excentricité entre différentes barres

Modèle physique

Rotation de sections

Attribuer des points d'appui

Points d'appui et lignes d'appui

Support surfacique

Conditions limites pour les extrémités des barres et les tirants

Tirants

Rigidités de rotation et de translation aux extrémités des barres

Définir un diagramme de rigidité

Jarrets

Lignes articulées

Choix de matériau

Liens rigides

Paramètres de flambement et de déversement

La longueur de flambement d’une barre individuelle

Longueur de torsion latérale ou de déversement d’une barre

Paramètres pour la vérification au déversement

Protection incendie

Modification de lignes et de nœuds

Copier et coller des points d'appui et des sections

La palette 'Charges'

Cas de charges

Choix de la norme

Choix de la classe de service

Définir ou supprimer des cas de charges

Définir des incompatibilités

Définir des groupes de charges liés

Définir des sous-groupes de charges

Combinaisons de charges

Combinaisons dans le temps

Les charges

Redimensionner les charges

Charges ponctuelles sur nœuds

Moments sur nœuds

Charges ponctuelles sur barres

Moments sur barres

Charges linéaires uniformément réparties et charges trapézoïdales

Torsion répartie

Charge surfacique

Générateur de charges surfaciques sur barres

Charge de température

Générateur de vent

Générateur de neige

Charge sismique

Charge dynamique

Charge mobile

Courbes de feu

Supprimer ou modifier des charges

Copier et coller des charges

Bouton droite souris

Translation

La palette 'Résultats'

Affichage des déformations

Affichage des efforts internes dans les poutres et les poteaux

Affichage des efforts internes dans les dalles et les plaques

Affichage des réactions dans les points d'appui

Affichage des contraintes élastiques dans les poutres et les poteaux

Affichage des contraintes élastiques dans les dalles et les plaques

Affichage des résultats de l'armature

Affichage de la largeur de fissuration

Affichage des résultats thermiques

Résultats le long d’un ligne de coupe

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette 'Géométrie'

Le pointeur de sélection

Label et commentaire

Tracer des points

Tracer des lignes

Effacer des points, des lignes et des plans

Tracer des éléments structurels

Chercher des dalles ou plaques

Diviser des lignes

Extruder

Formes paramétrées

Structures paramétrées

Déplacer et copier

Pivoter

Projection

Miroiter

Intersection

Vérification du modèle

Redimensionner de la géométrie

Modifier les propriétés communes à plusieurs éléments

Propriétés des barres

Dimensions

Propriétés des sections de barres

Onglet 'Général'

Onglet 'Elastique'

Onglet 'Plastique'

Onglet 'Effective'

Onglet 'Dimensionnement'

Matériaux, enrobages (béton) et mode de fabrication (Fe) des barres

Axes locaux des barres

Propriétés des dalles et plaques

Propriétés des sections de dalles

Matrice de rigidité

Matériaux et enrobages des dalles

Axes locaux des dalles

Caractéristiques des semelles

Choix d’une section dans la bibliothèque des profilés

Excentricité des barres

Excentricité d’une poutre par rapport à une dalle

Excentricité entre différentes barres

Modèle physique

Rotation de sections

Attribuer des points d'appui

Points d'appui et lignes d'appui

Support surfacique

Conditions limites pour les extrémités des barres et les tirants

Tirants

Rigidités de rotation et de translation aux extrémités des barres

Définir un diagramme de rigidité

Jarrets

Lignes articulées

Choix de matériau

Liens rigides

Paramètres de flambement et de déversement

La longueur de flambement d’une barre individuelle

Longueur de torsion latérale ou de déversement d’une barre

Paramètres pour la vérification au déversement

Protection incendie

Modification de lignes et de nœuds

Copier et coller des points d'appui et des sections

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Le pointeur de sélection

Le bouton portant le pointeur de sélection [image] vous permet de mettre fin à la fonction actuelle (p. ex. pour dessiner des lignes ou des points). Le curseur reprend alors son aspect initial. Lorsque cette fonction est activée, vous pouvez sélectionner des éléments dans la fenêtre modèle à l'aide de la souris.

Remarque: Vous pouvez aussi désactiver la fonction actuelle à l’aide du bouton ESC de votre clavier.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Label et commentaire

L'icône [image] vous permet d’attribuer une étiquette et un commentaire aux points, lignes et surfaces.

L’étiquette peut être utilisée par exemple pour attribuer un numéro individuel aux éléments. Le commentaire permet en revanche d'indiquer des points d'intérêt.

Les propriétés ‘Étiquette’ et ‘Commentaire’ peuvent être toutes les deux affichées à l’écran ( [image] > onglet Géométrie), consultées et éditées dans le tableau Données [image] ou imprimées à l’aide du Gestionnaire pour notes de calcul [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tracer des points

Le bouton [image] vous permet d'activer le tracé de points. Les points figurant dans le modèle peuvent servir de points de construction (p.ex. le centre d'un cercle) ou de points auxquels peuvent être attribués des charges ou des points d'appui.

Il y a deux manières d'introduire un point. Soit vous tracez le point à l'aide de votre souris, soit vous définissez le point en introduisant ses coordonnées. Dans le premier cas, vous naviguez avec votre souris vers l'emplacement où vous voulez tracer le point après quoi vous cliquez une fois avec le bouton gauche de la souris. Vous pouvez vous baser, pour cela, sur les coordonnées qui s'affichent dans le bas de la barre d'informations et qui s'adaptent en fonction du mouvement de la souris. Bien entendu, dans ce cas, vous pouvez uniquement tracer des points dans une vue 2D. Dans le second cas, notez sur votre clavier les coordonnées du point dans le champ à remplir prévu à cette fin dans le bas de la fenêtre modèle, puis appuyez sur ENTER.

Les coordonnées sont séparées par un “;”. Selon la vue dans laquelle vous trouvez, vous noterez deux coordonnées (vue 2D) ou trois coordonnées (vue 3D).

Vous désactivez la fonction de dessin en enfonçant le bouton [image] ou en appuyant sur la touche ESC de votre clavier.

Remarque: outre les points de maillage, Diamonds vous permet aussi toujours de vous rattacher à des nœuds existants dans le modèle, même si ces derniers sont repris en mode caché. Ainsi, il est également possible, dans une vue du haut, de se rattacher à des nœuds situés dans les étages sous-adjacents.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tracer des lignes

Le bouton [image] vous permet d'activer le tracé de lignes. Ces lignes représentent les bords d'une plaque, ou bien une section pourra y être affectée par la suite.

Il y a deux manières de définir une ligne:

  • Soit vous dessinez le point de début et le point de fin de la ligne à l'aide de votre souris (en cliquant une fois sur le bouton gauche de la souris sur la position de début et la position de fin). Vous pouvez vous baser, pour cela, sur les coordonnées qui s'affichent dans le bas de la barre d'informations et qui s'adaptent en fonction du mouvement de la souris. Une fois que le point de fin de la ligne est défini, vous pouvez commencer une nouvelle ligne en indiquant directement un point suivant (le point de début de la nouvelle ligne est alors égal au point de fin de la ligne précédente) ou tracer deux nouveaux points après avoir appuyé sur le bouton droit de votre souris (si la ligne ne se rattache pas à la ligne précédente). Dans une vue 2D, vous pouvez tracer ainsi des lignes à n'importe quel endroit de la fenêtre modèle. Dans une vue 3D, vous pouvez uniquement tracer entre des lignes ou des nœuds existants.
  • Soit vous introduisez les coordonnées des deux points de fin dans le champ à remplir prévu dans le bas de la fenêtre modèle. Utilisez la touche Enter après avoir introduit les coordonnées de chacun des points. Une fois que les coordonnées du second point ont été introduites et confirmées (avec ENTER), vous pouvez désactiver la fonction de dessin avec ESC ou noter immédiatement les coordonnées du point de fin de la ligne suivante.

Les coordonnées d'un point sont séparées par un “;”. Selon la vue dans laquelle vous trouvez, vous noterez deux coordonnées (vue 2D) ou trois coordonnées (vue 3D). En plus de l'introduction de coordonnées absolues, il est également possible de définir avec “@” le point de fin d'une barre au moyen de coordonnées relatives.

Dans les deux cas, vous désactiverez la fonction de dessin à l'aide du bouton [image] ou en appuyant sur la touche ESC de votre clavier.

Remarque: voici encore quelques conseils pour le cas où vous tracez des lignes avec votre souris.

  • Outre les points de maillage, Diamonds vous permet aussi toujours de vous rattacher à des points existants dans le modèle, même si ces derniers sont repris en mode caché. Ainsi, il est également possible, dans une vue du haut, de se rattacher à des points situés dans les étages sous-jacents.
  • Vous tracerez très aisément des lignes orthogonales en tenant la touche SHIFT enfoncée pendant que vous naviguez.
  • Si vous souhaitez que les distances soient exprimées à côté du curseur de votre souris pendant que vous dessinez, sélectionnez la commande 'Options – Préférences …’ et cochez la case voulue dans l'onglet 'Tracer'. (voir également Paramètres de dessin ).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Effacer des points, des lignes et des plans

Vous pouvez supprimer à tout moment un élément structurel ou une partie de la construction. Dans tous les cas, vous devez sélectionner les éléments à supprimer. Ensuite, vous avez le choix:

  • soit vous cliquez sur l'icône [image] de la palette ‘Géométrie’,
  • soit vous utilisez la touche Effacer (DEL ou SUPRR) du clavier.

Les objets ou sections (semelles de fondation, poutres, plaques) attribués éventuellement aux points, lignes et plans seront effacés en même temps que ces derniers.

Notes:

  • Lorsque vous supprimez le bord d'une plaque, Diamonds vous demandera si la plaque adjacente doit aussi être supprimée.

    Sauf si une section a été affectée à ce bord. Ensuite, seule la section sera supprimée et la ligne et la plaque restera.

    Lorsque vous supprimez un bord de plaque faisant partie d'au moins deux plaques, Diamonds permet également la fusion des plaques.

    • Sélectionnez uniquement le(s) bord(s) des surfaces que vous souhaitez unir.

    • Cliquez sur [image] ou la touche SUPRR.

    • Une boîte de dialogue vous demande ce que vous voulez faire avec la sélection. Choisissez Merge.

    • Résultat:

  • Si vous voulez supprimer la section d'une barre isolée mais conserver la ligne à laquelle la section a été attribuée, utilisez la fonction [image] et modifiez la forme de la section tel que décrit au Propriétés des sections de barres.
  • Quand vous supprimez une plaque, les bords de la plaque seront eux aussi effacés, sauf si des poutres ont également été attribuées à ces lignes. Si vous souhaitez ne pas supprimer les bords de la plaque en même temps que cette dernière, veuillez utiliser la combinaison de touches CTRL+ SHIFT + DEL. De manière analogue, vous pouvez effacer la section de la plaque avec la fonction [image] (voir Propriétés des sections de dalles).
  • Si vous effacez une plaque entièrement incluse dans une autre plaque, cette dernière ne sera pas effacée mais sera modifiée en ouverture. Comme toutes les ouvertures sont automatiquement identifiées comme étant du même type (c.-à-d. ‘Ouverture’), vous pouvez facilement dissimuler celle-ci tel que décrit au Types de design. Cette méthode présente l'avantage que vous n'êtes plus gêné par ces ouvertures pendant que vous sélectionnez des éléments sous-jacents.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tracer des éléments structurels

Lors de l'application de structures hiérarchisées (donc en cas d'utilisation du gestionnaire 'niveau'), Diamonds dispose d'une méthode rapide pour tracer des poteaux, des poutres et des murs.

Un bouton de la palette 'Géométrie' correspond à chacun des éléments susmentionnés.

  • pour tracer des poteaux
  • pour tracer des poutres
  • pour tracer des murs
  • pour tracer des semelles

Le tracé de ces éléments structurels s'effectue de manière analogue à celui d'un point ou d'une ligne dans la fenêtre modèle, à cette différence près qu'une section est affectée immédiatement au point ou à la ligne. Il convient d'ajouter ce qui suit:

  • Les poutres tracées au droit des bords de plaques seront toujours positionnées de manière à ce que leur face supérieure coïncide avec la face supérieure de la plaque. Cela implique que la poutre et la plaque collaboreront a priori. Vous pouvez toutefois éliminer l'excentricité accordée au moyen du bouton [image] (cf. Choix d’une section dans la bibliothèque des profilés).Attention: cette règle ne s'applique pas aux poutres isolées. Dans ce cas, la fibre neutre coïncidera toujours avec le plan de projection horizontale actif (e = 0).
  • L’utilisateur positionne toujours la tête de colonne (poteau) et trace toujours l’arrête supérieure des voiles. Les éléments générés se situent toujours physiquement en dessous des points et lignes dessinées. Les hauteurs des éléments générés dépendent du niveau de l’étage directement situé sous l’étage actif. Notez que vous pouvez également modéliser des parois dont les arrêtes supérieures sont inclinées. Les arrêtes inférieures seront quant à elles impérativement horizontales.

Diamonds tient à jour une liste de toutes les sections déjà définies dans le projet pour tous les éléments structurels. Une fois enfoncé le bouton de tracé d'un poteau, d'une poutre ou d'un mur, vous pouvez sélectionner le profil souhaité dans le menu déroulant. Si aucun élément structurel n'a encore été défini, Diamonds définit pour vous un élément standard. Ensuite, les éléments qui ne font plus partie du projet de calcul seront supprimés automatiquement de la liste.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Chercher des dalles ou plaques

Avant de pouvoir attribuer des dalles ou plaques, il faut sélectionner un ensemble de lignes formant un contour fermé. Cliquez ensuite sur le bouton [image], après quoi Diamonds définit entre ces lignes une dalle ou plaque de béton de 20 cm d'épaisseur. Si plusieurs contours sont possibles, Diamonds attribuera une dalle ou plaque à chacun de ces contours. La seule condition est que toutes les lignes sélectionnées soient situées dans le même plan.

Remarque :Lorsque les lignes sélectionnées ne constituent pas un contour fermé, le logiciel entoure d’un cercle l’endroit où des lignes ne se rejoignent pas mais dont les extrémités sont relativement proches. Vous pouvez ainsi facilement détecter un certain nombre d’erreurs de modélisation et les corriger.

Dans le cas décrit, il vous suffit de fusionner les deux points pour pouvoir générer une dalle.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Diviser des lignes

Commencez par sélectionner les lignes que vous voulez diviser. Une fois les lignes sélectionnées, vous pouvez les diviser à l'aide du bouton [image]. La boîte de dialogue suivante s'affiche:

Par défaut, Diamonds va diviser la(les) ligne(s) en 2 parties égales. Vous pouvez diviser la/ les ligne(s) en plusieurs segments égaux en introduisant le nombre souhaité dans la case 'Nombre de parties'.

En décochant l'option 'Segments égaux', vous pouvez indiquer vous-même la longueur des parties pour chaque barre sélectionnée.

Notez bien que la longueur d'une partie sera toujours déterminée automatiquement, puisque qu'il faut conserver la longueur totale existante. Cette partie a un fond grisé, pour indiquer que cette longueur sera calculée sur base des autres longueurs que vous avez introduites (L3[m] = L[m] – L1[m] – L2[m]). Vous pouvez changer de place le fond grisé en cliquant dessus avec le bouton droit de la souris et en sélectionnant [image]. La longueur partielle 'fixe' se déplace vers une autre partie. Vous pouvez aussi cliquer sur une autre cellule avec le bouton droit de la souris et cliquer sur [image].

La longueur L1[m] commence toujours au point initial.

Si vous cochez l'option ‘Voir les points de terminaison de la barre’, le point initial et le point terminal seront affichés le tableau à l'aide de leur numéro de nœud.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Extruder

L'extrusion consiste à tracer une ligne dans une direction donnée depuis un point donné. Sélectionnez les points à partir desquels vous voulez extruder puis cliquez sur l'icône [image].

Dans la fenêtre de dialogue qui s'affiche, vous avez le choix entre:

  • Distance: Vous indiquez les coordonnées globales du vecteur sur lequel il faut extruder. Tous les points sont extrudés sur cette même distance.
  • Au plan: Tous les points sont prolongés jusqu'à un plan de référence. Le plan de référence est toujours un plan perpendiculaire à l'un des axes globaux.

On procède différemment, entre les options 'distance' et 'au plan', pour générer plusieurs colonnes en une fois:

Remarque: Vous pouvez aussi indiquer le vecteur d'extrusion ou le plan de référence (1 point) de manière graphique dans la configuration 'Géométrie (pendant que la fenêtre de dialogue reste ouverte).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Formes paramétrées

Diamonds vous permet de générer rapidement des arcs, des cercles, des ellipses et des angles droits. Commencez par sélectionner un ou plusieurs points puis cliquez sur le bouton [image].

  • Si vous sélectionnez un seul point, la boîte de dialogue de création d'un arc ou d'un cercle s'ouvre, avec pour centre le point sélectionné.

    Le cercle ou l'arc seront toujours tracés dans un plan parallèle au plan XZ, XY ou ZY. A côté de ce plan, notez également le rayon, l'angle de départ et l'angle de fin ainsi que le nombre de segments dans lequel l'arc ou le cercle seront divisés. Les angles positifs sont mesurés tel qu'indiqué sur l'illustration. Notez que les angles ou les cercles sont toujours abordés par des segments rectilignes.

  • Si vous sélectionnez deux points, on vous demande de choisir.

    Soit ces deux points sélectionnés constituent le centre de deux cercles ou deux arcs, tous parallèles au plan XZ, XY ou ZY. Vous ouvrez alors la même boîte de dialogue que ci-dessus.

    Diamonds construit soit un rectangle soit un parallélépipède, dont les deux points constituent les deux points opposés en diagonale.

    Soit les deux points forment la boîte englobante d'une ellipse, parallèle au plan XZ, XY ou ZY. Cette boîte de dialogue s'ouvre :

    L'ellipse est toujours dessinée dans un plan parallèle au plan XZ, XY ou ZY. Notez le nombre de segments de l'ellipse ci-dessous. Une ellipse est toujours approximée par des segments droits.
  • Quand trois points sont sélectionnés, vous devez également faire un choix.
    • Soit les trois points sélectionnés constituent le centre d'un cercle ou d'un arc, tous parallèles au plan XZ, XY ou ZY.
    • Soit Diamonds construit un cercle ou un arc passant par les trois points sélectionnés. Vous indiquez ensuite le nombre de segments de chaque partie de l'arc comprise entre deux points.

  • Si vous sélectionnez plus de 3 points, la boîte de dialogue s'ouvre à nouveau pour générer un arc ou un cercle dont les centres coïncideront avec les points sélectionnés.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Structures paramétrées

Diamonds comprend un assistant qui contient beaucoup de structures très courantes (un portique, un treillis, une poutre continue, etc.) pour lesquelles vous ne devez introduire qu'un nombre limité de paramètres pour générer l'ensemble de la structure.

Pour avoir accès à cet assistant, cliquez sur l'icône [image] .

Vous pouvez générer les structures suivantes:

Poutre continue

Portique

Treillis

Ferme

Ossature

Portique industriel
Silo

Cliquez sur la structure souhaitée, confirmez par 'OK' et complétez les paramètres demandés.

Les paramètres demandés sont en grande partie similaires pour toutes les structures.

  • Paramètres relatifs aux champs
  • Paramètres relatifs aux points d'appui
  • Paramètres relatifs au choix des profils
  • Point d'insertion

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Déplacer et copier

Pour déplacer une structure ou une partie de structure, ou la copier un certain nombre de fois, commencez par sélectionner les éléments sur lesquels vous souhaitez appliquer la translation puis cliquez sur le bouton [image].

Si vous voulez déplacer les éléments sélectionnés, N doit avoir la valeur 0. Indiquez ensuite les distances suivant le repère d'axes global, sur lesquelles la sélection doit être déplacée. Vous avez l’option de redimensionner les éléments physiques (voir Physiques).

Si vous voulez copier les éléments sélectionnés, indiquez d'abord combien de copies vous désirez (N),. Indiquez ensuite les distances suivant le repère d'axes global, sur lesquelles la sélection doit être copiée. Cette distance est répétée autant de fois qu'il y a de copies. Une option supplémentaire vous permet de relier chaque copie à la précédente:

  • soit en ajoutant une ligne entre le nœud initial et le nœud copié,
  • soit en ajoutant un plan entre la ligne initiale et la ligne copiée,

Remarque: Les valeurs du vecteur de translation peuvent également être introduits graphiquement en indiquant soi-même la distance à l’aide de la souris dans la ‘Configuration – Géométrie’ (en gardant néanmoins la fenêtre de dialogue ouverte).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Pivoter

La fonction 'pivoter' s'exécute à peu près de la même manière que la fonction 'déplacer et copier'. Après avoir sélectionné les éléments à faire pivoter, cliquez sur le bouton [image]. Dans la boîte de dialogue qui s'ouvre, vous devez indiquer le plan dans lequel la rotation doit s'effectuer (l'axe autour duquel la rotation a lieu est donc ici perpendiculaire), le nombre de copies pivotées que vous souhaitez, l'angle sur lequel il faut pivoter, et le point (indiqué par le numéro du point ou par les coordonnées globales) par lequel l'axe de rotation doit passer. Il est éventuellement possible, lors de chaque rotation, d'effectuer également un déplacement le long de l'axe de rotation.

Une option supplémentaire vous permet de relier les nœuds et les barres pivotés par des lignes ou des plans.

Vous avez l’option de redimensionner les éléments physiques (voir Physiques).

Les charges globales ayant déjà été définies et appliquées au niveau de la structure d’origine conservent leurs sens et direction conformément au repère d’axes globaux. Par contre, les charges ayant été définies localement seront bel et bien elles aussi miroitées.

Remarque: Le centre et l’angle de rotation peuvent également être introduits graphiquement à l’aide de la souris dans la ‘Configuration - Géométrie’ (en gardant néanmoins la fenêtre de dialogue ouverte). Concrètement, il suffit d’indiquer 3 points : le premier correspond au centre de rotation, les deux suivants définissent l’angle de α.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Projection

Afin de projeter une partie de la structure, vous sélectionnez les éléments concernés, et vous cliquez le bouton [image].

La position du plan de projection est établie à l'aide d'une seule coordonnées (X=0m dans la capture d'écran ci-dessus). Autrement dit: Diamonds va projeter maintenant tous les points sélectionnés perpendiculairement au plan X=0m.

Les options dans le bas de la fenêtre de projection s'expliquent comme suit:

  • 'Préserver la structure originale': La structure que vous projetez sera conservée.
  • 'Créer des lignes de connexion': Diamonds va tracer les lignes de liaison entre la structure d'origine et la structure projetée.
  • 'Créer des plaques de connexion': Diamonds va générer les plaques de liaison entre la structure d'origine et la structure projetée.

Non seulement il est possible de projeter dans un plan vertical ou horizontal, mais vous pouvez aussi projeter dans n'importe quel plan. Alors, il faut que vous introduisez les coordonnées de 3 points A, B et C pour spécifier ce plan.

Cette fonction est utile pour la correction des éléments qui ne sont pas bien d'aplomb.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Miroiter

Commencez par sélectionner la partie de la structure que vous souhaitez réfléchir puis cliquez sur le bouton [image]. Selon l'orientation, notez les coordonnées ou les numéros de nœud de 2 ou de 3 points formant une ligne ou un plan de symétrie.

Indiquez en outre, en bas à gauche, s'il faut conserver la figure d'origine.

Les charges globales ayant déjà été définies et appliquées au niveau de la structure d’origine conservent leurs sens et direction conformément au repère d’axes globaux. Par contre, les charges ayant été définies localement seront bel et bien elles aussi miroitées.

Remarque: Les coordonnées de deux points définissant un axe de symétrie ou de trois points définissant un plan de symétrie peuvent eux aussi être introduits graphiquement. Pour un axe de symétrie, il suffit de le dessiner à l’aide de la souris. Pour un plan, il suffit de cliquer 3 points qui le définissent. (En gardant néanmoins la fenêtre de dialogue ouverte).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Intersection

Les fonctions pour intersection des lignes sont disponibles via le bouton [image]. Vous avez le chois entre:

  • de faire se couper des lignes entre elles

    de faire se couper des lignes et un plan de référence.

  • de conserver le point d'intersection entre 2 lignes.

    Un appui ou la position d'une colonne est généralement indiquée par une croix dans un fichier DXF. Quand vous importez le fichier DXF dans Diamonds, il ne doit rester qu'un seul point qui indique la position de la colonne. C'est un jeu d'enfants grâce à cette fonction.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification du modèle

Les erreurs qui apparaissent dans le modèle de calcul suite à des imprécisions lors des manipulations de dessin dans la ‘Configuration – Géométrie’ ou à des erreurs importés en DXF à partir d’un modèle de CAO, peuvent toujours être réparées en utilisant le bouton [image], à condition qu’une tolérance suffisante ait été définie.

En particulier, cette fonction permet de

  • Fusionner des points trop proches (en fonction de la tolérance géométrique).

    Par exemple: les points A et B sont distants de 2cm. Or, la tolérance géométrique est fixée à 5cm. Dans ce cas, Diamonds va fusionner le point A avec le point B, ou le point B avec le point A.

  • Arrondir les coordonnées des points à la tolérance indiquée.

    Par exemple: lors de l'importation d'un fichier DXF, un point A a pour coordonnée x 2,15940041m. Si l'on définit une tolérance géométrique de 0,01m, la coordonnée x devient 2,16000000m. Si la tolérance géométrique est de 1,00m, la coordonnée x deviendra 2,00000000m.

  • Supprimer des plaques dont tous les points ne se trouvent pas dans le même plan.
  • …

Cette fonction ne pourra être appliquée que sur les parties sélectionnées et actives de la structure.

Remarque: avec une vérification du modèle, deux ou plusieurs points sont fusionnés. Une inspection approfondie de la géométrie et des charges est recommandée.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Redimensionner de la géométrie

Sélectionnez toute la structure et cliquez sur [image]. Entrez le facteur de redimensionnement et les coordonnées du point de référence. Vous pouvez également indiquer le point de référence à l'écran. Diamonds entrera alors automatiquement les coordonnées.

Notes:

  • La fonction d’échelle n’affecte pas les dimensions des sections transversales, seulement la longueur (pour les éléments de ligne) et les contours (pour les éléments de surface).
  • La fonction d’échelle n’affecte pas la valeur des charges appliquées. Si vous souhaitez également mettre à l’échelle les charges, utilisez le bouton [image] dans la configuration Charges [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Modifier les propriétés communes à plusieurs éléments

Vous êtes sans conteste régulièrement confronté à la nécessité ou le souhait de modifier une ou plusieurs propriétés simultanément pour un ensemble d’éléments. Lorsque les propriétés des éléments sélectionnés sont toutes identiques, cela ne pose aucun problème. Par contre, lorsque certaines propriétés diffèrent pour un certain nombre d’éléments de la sélection, certaines confusions peuvent survenir suite à la modification d’une ou plusieurs propriétés.

Considérons la situation suivante en guise d’exemple:

Imaginez que vous ayez modélisé un réservoir cylindrique à l’aide du générateur de formes de Diamonds. Le générateur de forme fixe par défaut l’orientation des facettes de façon à ce que l’axe local y’ (perpendiculaire à l’élément surfacique) soit toujours dirigé vers l’extérieur.

Par contre, l’orientation de l’axe local x’ de chaque facette sera toujours fonction de l’axe global X. Compte-tenu du fait que le repère d’axes locaux x’y’z’ est toujours orienté selon ‘les doigts de la main droite’, celui-ci sera inversé de 180° pour la moitié des éléments surfaciques générés par rapport à l’autre moitié. A partir de ce moment, toutes les propriétés ne sont plus communes pour l’ensemble des éléments surfaciques puisque au moins l’orientation diffère.

Pour modifier simultanément l’épaisseur de tous les éléments surfaciques, sélectionnez ceux-ci et ouvrez la fenêtre de dialogue relative aux propriétés des dalles.

Un nombre limité de propriétés sont alors directement modifiables par l’utilisateur. Les champs qui ne peuvent pas directement être modifiés sont grisés et accompagnés d’une icône représentant un cadenas [image]. Ce n’est qu’après avoir déverrouillé ce cadenas ( [image]) que vous pourrez effectivement modifier la valeur de la propriété.

Lorsque vous validerez votre choix par ‘OK’, vous affecterez la nouvelle valeur à l’ensemble de la sélection.

Les propriétés qui n’ont pas explicitement été libérées par l’utilisateur (et dont les champs demeurent dès lors grisées) ne seront nullement modifiées lors de la validation par ‘OK’.

Dans le cas de l’exemple décrit précédemment, la fenêtre de dialogue est la suivante:

L’icône illustrant un petit cadenas en bas à droite indique que l’orientation des axes locaux x’y’z’ n’est pas identique pour l’ensemble des éléments sélectionnés.

Si vous ne changez rien et laisser le cadenas verrouillé, vous pouvez modifier l’épaisseur des éléments, leurs enrobages et/ou le matériau utilisé sans changer l’orientation de leurs axes locaux.

Ce n’est que si vous déverrouillez le cadenas, précisez une (nouvelle) orientation commune et validez votre choix par ‘OK’ que vous affecterez une nouvelle orientation unique pour l’ensemble des éléments surfaciques sélectionnés.

Le principe que nous venons de décrire pour des éléments de parois avec des orientations différentes de leurs repères locaux, peut bien entendu être appliqué chaque fois qu’il est envisageable de modifier simultanément plusieurs caractéristiques ou propriétés de plusieurs éléments de même nature (dalles, poutres, …). Ce principe peut globalement être appliqué pour l’ensemble des icônes de la palette ‘Géométrie’.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Propriétés des barres

Diamonds vous permet de définir une section de 2 façons: sur base d'une forme type, en créant les dimensions, ou en sélectionnant un profil dans la bibliothèque des profils. Nous traiterons dans ce paragraphe de la première option. Après avoir sélectionné les lignes auxquelles vous voulez attribuer une section donnée, cliquez sur le bouton [image]. Pour consulter ou modifier les propriétés d’une poutre ou colonne existante, vous pouvez utiliser la même fonction. La fenêtre suivante apparaît à l’écran:

Nous classifions les propriétés des barres en 4 catégories, correspondant chacune à un sous-cadre de la fenêtre à l’écran (cf. 3 paragraphes suivants).

  • les dimensions
  • les propriétés des sections des barres (profils)
  • les matériaux et les valeurs caractéristiques (enrobages du béton, mode de fabrication de l’acier, direction des fibres du bois)
  • axes locaux de la barre

Dimensions

Propriétés des sections de barres

Onglet 'Général'

Onglet 'Elastique'

Onglet 'Plastique'

Onglet 'Effective'

Onglet 'Dimensionnement'

Matériaux, enrobages (béton) et mode de fabrication (Fe) des barres

Axes locaux des barres

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Dimensions

Le premier cadre se rapporte aux propriétés de la section de la barre, notamment son profil correspondant à sa forme et ses dimensions.

Le champ en haut à gauche permet d’attribuer un nom à chaque section de barre et d’ajouter ces noms au menu déroulant.

Si vous avez déjà prédéfini un certain nombre de profils et que vous voulez vous en servir pour attribuer les mêmes propriétés et dimensions à une ou plusieurs barres sélectionné(es), il vous suffit d’ouvrir le menu déroulant à l’aide du curseur (petite flèche dirigée vers le bas à droite du champ ‘nom’) et d’y sélectionner le profil dont vous voulez copier les propriétés. Dès que vous sélectionnez une section parmi la liste, ses propriétés et caractéristiques sont automatiquement complétées dans le tableau et réellement appliquées à la ou les barres sélectionné(es).

Remarque: Les autres propriétés des barres (le matériau et l’orientation locale de la barre) ne se rapportent pas directement aux sections de celles-ci. Ils ne sont dès lors pas associés à l’attribution d’une section à l’aide du menu déroulant. Vous devez paramétrer ces propriétés indépendamment des propriétés des sections de barres. D’autre part, les enrobages et le mode de fabrication de l’acier se rapporteront bien aux sections bien que ces propriétés ne puissent que définies après avoir sélectionner le matériau.

Notez qu'il est aussi possible de sélectionner de cette façon un profil d'acier dans la bibliothèque des profils.

Dans ce cas, cliquez sur le bouton [image], et la même boîte de dialogue s'ouvrira que si vous voulez attribuer directement un profil normalisé à la barre via le bouton [image] (voir Choix d’une section dans la bibliothèque des profilés). Ici aussi, toutes les propriétés de la section se remplissent automatiquement.

Choisissez ensuite, la forme de profil souhaitée à l'aide d'un menu déroulant. Les formes disponibles dans Diamonds sont représentées ci-dessous.

L'option ‘Valeurs liés à l’élément physique’ met les dimensions des sections 1 et 2 en rapport avec les points extrêmes du groupe physique, et non avec les différentes barres partielles. (voir Que faire avec un groupe ?).

Remarques:

  • En cas de section variable, Diamonds sélectionne automatiquement les caractéristiques; vous ne pouvez pas les modifier.
  • Les sections variables ne sont pas applicables à des profils autodéfinis (Section Utility) et à des profils formé à froid.

Si vous souhaitez définir une section qui ne figure pas dans la liste, vous pouvez la générer à l'aide de Section Utility (générateur de profils). Le générateur de profils est un outil (fourni en même temps que Diamonds) qui vous permet de définir n'importe quelles sections et/ou profils composés d'un ou plusieurs matériaux. Pour lancer Section Utility, sélectionnez l'option [image] tout en bas de la liste des formes types disponibles puis appuyez sur le bouton [image]. Vous pouvez ensuite définir toutes les formes de profils possibles à l'aide des fonctions de dessin dans Section Utility ou à l'aide de la fonction 'Importer un DXF' dans le générateur de profils. L'utilisation de ce module est décrite dans le manuel séparé de Section Utility. Il est intéressant de noter que la méthode ci-dessus peut également être activée depuis la boîte de dialogue où est définie la bibliothèque des profils (voir La bibliothèque des profilés). L'utilisateur a ainsi la possibilité d'ajouter aisément des profils qu'il a définis lui-même à sa bibliothèque des profils Diamonds.

Vous devrez indiquer plus ou moins de dimensions selon la forme du profil. Les dimensions demandées sont toujours présentées dans un dessin de principe de la section. Une fois toutes les dimensions introduites, la section effective peut être affichée avec indication des axes géométriques (y’ et z’). Dans le cas où les axes géométriques ne correspondent pas aux axes d'inertie principaux (alpha ≠ 0°), ces derniers (u et v) seront également tracés.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Propriétés des sections de barres

Au milieu de la boîte de dialogue, vous retrouvez toutes les caractéristiques élastiques et plastiques de la section définie ainsi que quelques autres caractéristiques qui seront nécessaires si vous voulez effectuer ultérieurement un contrôle normatif. Si vous avez une section définie sur base d'une forme type, toutes ces caractéristiques sont calculées automatiquement, pour autant que la case ‘Calculer automatiquement’ soit cochée. Si vous décochez cette case, vous pouvez affecter une valeur différente à chacune des caractéristiques de la section.

Nous distinguons 5 catégories possibles de caractéristiques qui sont exprimées chacune dans un onglet distinct. Certains onglets et/ou certaines caractéristiques peuvent ne pas être accessibles selon la section et/ ou le matériau attribué.

Nous allons maintenant passer en revue les différentes catégories:

Onglet 'Général'

Onglet 'Elastique'

Onglet 'Plastique'

Onglet 'Effective'

Onglet 'Dimensionnement'

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Général'

Cet onglet contient quelques caractéristiques générales de la section.

  • Vous y trouverez en particulier les coordonnées du centre de gravité (COG = “Center of gravity”) et du centre de cisaillement (SC = Shear center) par rapport à un repère d'axes dont l'origine se situe dans le point inférieur gauche de la section (ce repère d'axes se retrouve sur le croquis de la section quand vous sélectionnez 'Axes' en haut à droite).
  • Les paramètres [image] et [image] sont utilisés pour prendre la déformation de la force de cisaillement en compte. Les indices ‘u’ et 'v' réfèrent aux axes principaux d'inertie de la section.
    (Source de la méthode de calcul: R. Van Impe, Berekening van Bouwkundige Constructies I, §5.1.2).

En outre, le poids spécifique et la surface brute de la section seront toujours exprimés ici.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Elastique'

Vous trouverez dans cet onglet toutes les caractéristiques d'élasticité de la section. Les 2 premières colonnes concernent toutes les propriétés en rapport avec la flexion autour de l'axe y’ ou de l'axe z’ de la section. Si les axes locaux y’ et z’ ne correspondent pas aux axes principaux d'inertie (alpha ≠ 0°), les caractéristiques relatives à l'axe fort (u) ou à l'axe faible (v) s'afficheront également. La troisième colonne contient l'angle alpha et le produit d'inertie dérivé ainsi que quelques caractéristiques nécessaires pour évaluer la résistance en torsion.

Vous trouverez ci-dessous la signification des notations utilisées.

- | Sy, Sz | Moment statique de la section par rapport aux axes Y et Z
- | Iy', Iz' | Moment d’inertie de la section par rapport aux axes y’ et z’
- | iy',iz' | Rayon d’inertie ou rayon giratoire de la section dans les directions y et z
- | Iyz | Produit d’inertie de la section par rapport aux axes y’ et z’
- | Wel,y',t | Moment résistant élastique par rapport à la flexion autour de l’axe y’, au niveau de la fibre supérieure de la section
- | Wel,y',b | Moment résistant élastique par rapport à la flexion autour de l’axe y’, au niveau de la fibre inférieure de la section
- | Wel,z',l | Moment résistant élastique par rapport à la flexion autour de l’axe z’, au niveau de la fibre d’extrême gauche
- | Wel,z',r | Moment résistant élastique par rapport à la flexion autour de l’axe z’, au niveau de la fibre d’extrême droite
- | It | Constante de torsion
- | Iw | Inertie de gauchissement
- | Twm | Le module de torsion
- | alpha | Angle entre les axes d’inertie principaux et les axes locaux y’ et z’ de la section
- | Iu,Iv | Moment d’inertie de la section par rapport aux d’inertie principaux
- | Wel,u,t | Moment résistant élastique par rapport à la flexion autour de l’axe fort d’inertie u, au niveau de la fibre avec la plus grande coordonnée v
- | Wel,u,b | Moment résistant élastique par rapport à la flexion autour de l’axe fort d’inertie u, au niveau de la fibre avec la plus petite coordonnée v
- | Wel,v,t | Moment résistant élastique par rapport à la flexion autour de l’axe faible d’inertie v, au niveau de la fibre avec la plus grande coordonnée u
- | Wel,v,b | Moment résistant élastique par rapport à la flexion autour de l’axe faible d’inertie v, au niveau de la fibre avec la plus petite coordonnée u

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Plastique'

Cet onglet reprend toutes les caractéristiques nécessaires pour calculer le moment résistant plastique et la résistance plastique au cisaillement.

Vous trouverez ci-dessous la signification des notations utilisées.

- | Wpl,y | Moment résistant plastique par rapport à la flexion autour de l’axe y’
- | Wpl,z | Moment résistant plastique par rapport à la flexion autour de l’axe z’
- | Wpl,u | Moment résistant plastique par rapport à la flexion autour de l’axe fort d’inertie u
- | Wpl,v | Moment résistant plastique par rapport à la flexion autour de l’axe faible d’inertie v
- | Avz, Avy | Surface de cisaillement dans les directions z’ et y’

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Effective'

Cet onglet s'affiche uniquement quand il s'agit d'un profil en acier.

Vous noterez en particulier ici le déplacement du centre de gravité de la section réduite (si la section est soumise uniquement à une compression uniforme). Le déplacement eNy provoque un moment fléchissant supplémentaire autour de l'axe y’, tandis que l'excentricité eNz génère un moment fléchissant supplémentaire autour de l'axe z'. Le signe de cette excentricité est important, puisque le moment supplémentaire ne sera appliqué que s'il provoque un effet défavorable (et donc si ΔM a le même signe que MEd). Une excentricité positive signifie que la ligne neutre s'est déplacée suivant l'axe positif local de la section. Les excentricités eNy et eNz des profils doublement symétriques sont forcément toujours égales à zéro. En outre:

- | Aeff | est la surface effective de la section lorsque la section est mise en charge uniquement en compression
- | Weff,y | est le moment résistant effectif de la section en cas de flexion autour du seul axe local y'
- | Weff,z | est le moment résistant effectif de la section en cas de flexion autour du seul axe local z'

Pratiques :

  • Les propriétés utiles sont calculées automatiquement durant la vérification de l'acier pour les formes suivantes :
  • Pour les sections Joris Ide, MRP, Brausa et Sadef, les propriétés utiles sont chargées depuis la bibliothèque.
  • Pour les sections Section Utility , l’utilisateur doit saisir les propriétés utiles à l’aide du bouton ‘Classes Imposées’.
  • Pour toutes les autres sections, l’utilisateur doit saisir les propriétés utiles en remplaçant le paramètre Automatique par la bonne valeur. En cas de non-respect de cette consigne, un message d’erreur s’affiche durant la vérification de l'acier.

Remarques:

  • Si les axes locaux y’ et z’ ne correspondent pas aux axes principaux d'inertie, il faut remplacer les notations y’ et z’ par u et v.

  • Bien que vous puissiez définir ici un moment résistant effectif différent pour le haut et le bas (le côté gauche et le côté droit) de la section, ce sera toujours la plus petite valeur qui sera utilisée dans le contrôle normatif de l'acier.

    En présence d'un profilé asymétrique, dont les caractéristiques sont calculées automatiquement, vous retrouverez donc toujours la même valeur pour cette même raison.

    Concrètement, cette approche veut dire qu'il est possible d'obtenir un résultat conservateur si la section est soumise à une flexion composée (N+M).

  • Dans le cas des sections à dimensions variables, l'utilisateur doit saisir les propriétés utiles pour la section la plus grande et la section la plus petite.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Dimensionnement'

Ces caractéristiques sont spécifiques pour les sections en acier.

  • Les facteurs d'imperfection αy, αz et αLT, qui servent à déterminer respectivement la courbe de flambement et la courbe de déversement
  • L'épaisseur maximale tmax de la section de la plaque, qui sert à déterminer la limite de fluage.

  • La classe de section pour N, Myet Mz dans le cas où le profilé est soumis à un effort de compression (N), de flexion autour de son axe faible (My) ou de flexion autour de son axe fort (Mz).

    • En ce qui concerne les profils de la bibliothèque [image] et des profiles basés sur une forme type ( [image] > [image]), la classe de section sera calculée automatiquement au moment où l'on entame le contrôle normatif de l'acier.

    • Pour les sections Section Utility [image] , l’utilisateur doit saisir les classes à l’aide du bouton ‘Classes Imposées’.

      S'il s'agit d'une section de classe 4, les caractéristiques effectives de résistance doivent aussi être indiquées.

    • Vous pouvez imposer ici une classe de section différente pour N, Myet Mz séparément. Dans Diamonds, la classe de section est toujours déterminée sur base de N+My et N+Mz (la classe de section peut donc être différente selon la combinaison). Si la classe de section est imposée, on retiendra toujours la classe la plus défavorable pour les combinaisons d'effort normal et de moment fléchissant. Si seul N intervient dans une combinaison, on retiendra évidemment la classe correspondante

  • L'Eurocode 3 divise la vérification des sections en acier en deux parties :

    • EN 1993-1-1, pour les sections présentant une épaisseur t ≥ 3 mm
    • EN 1993-1-3, pour les sections formées à froid présentant une épaisseur de t <3 mm.
  • Si l’option ‘Utilisez la norme pour les sections formés à froid à paroi mince t < 3mm’ est cochée, alors il est nécessaire de spécifier les propriétés suivantes: Vz,Rd, Vy,Rd, Vz,Rd. Ces propriétés ont la même signification que dans les versions précédentes de Diamonds.
  • Enfin, vous pouvez cocher l'option permettant d'appliquer des règles de vérification supplémentaires pour les pannes (norme EN 1993-1-3, §10).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Matériaux, enrobages (béton) et mode de fabrication (acier) des barres

Dans le second sous-cadre vous pouvez indiquer le matériau souhaité. La liste du menu déroulant comprend tous les matériaux présents dans la bibliothèque des matériaux. Si le profil défini est une profilé standard figurant dans la bibliothèque des profils, l'acier standard qui sera indiqué par défaut.

Pour les sections en acier, il est possible d’indiquer le mode de fabrication (lamellé, soudé ou formé à froid). Celui-ci intervient parfois au niveau du contrôle normatif.

Pour les sections en béton armé, un bouton supplémentaire [image] s'affiche à l’écran. Ce bouton ouvre une nouvelle boîte de dialogue dans laquelle vous définissez l'enrobage brut de l'armature et les schémas d’armature.

  • Par enrobage brut de l'armature, il faut entendre la distance entre le centre de gravité de l'armature et le bord de la section de béton.
  • Vous pouvez définir un enrobage différent pour le côté supérieur, inférieur, gauche et droit de l'armature. On utilise ces enrobages pour calculer la hauteur utile de la section.
  • Quand vous vous préparez à déterminer les schémas d'armature dans des colonnes et des poutres en béton, vous avez trois options pour l'emplacement: 'tous les côtés', 'en haut et en bas' et 'côté gauche et côté droit'. Les figures ci-dessous illustrent où se situent exactement ces zones de d'armatures pour différentes formes de section transversale :

  • En ce qui concerne la répartition, vous avez aussi 4 options: 'optimalisée', 'identique', 'proportionnelle' et 'imposée'. La signification des 3 premiers est expliquée sur support.buildsoft.eu. Avec 'imposé' vous définissez les répartitions. Supérieur (z'>0), inférieur (z'<0), gauche (y'<0), droite (y'>0) font référence au système de coordonnées local de la barre.

Vous pouvez combiner chaque emplacement avec chaque répartition, bien que, dans certains cas, cela puisse entraîner des quantités moins économiques.

Pour les sections variables rectangulaires en bois, un bouton supplémentaire [image] s'affiche. Vous pouvez y indiquer l'angle entre le sens des fibres et l'axe longitudinal de la barre. Vous avez le choix entre:

Le sens des fibres du bois est parallèle à l'axe longitudinal de la barre.

Le sens des fibres du bois est parallèle à la fibre supérieure.

Le sens des fibres du bois est parallèle à la fibre inférieure.

Se basant sur le sens des fibres introduit, Diamonds va déterminer l'angle entre le sens des fibres et l'axe longitudinal. Cet angle est pris en compte dans le calcul de la résistance en flexion selon le §6.2.4 de EN1995-1-1.

Pour toutes les autres sections variables en bois, le sens des fibres est supposé parallèle à l'axe de la poutre.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Axes locaux des barres

Dans le dernier sous-cadre vous pouvez modifier l’orientation des sections.

L’axe local x’ est toujours situé dans le prolongement de la barre et ne peut de ce fait être modifié. Néanmoins, il vous est possible de faire pivoter la section autour de cet axe. Plus d'informations sur la convention des axes peut être trouvée au Convention relative aux axes des barres.

Les boutons [image] et [image] vous permettent d'échanger la section attribuée au nœud au début et celle attribuée au nœud final. Ces boutons ne s'affichent que pour les sections variables.

D’autre part, vous pouvez effectuer un miroir de la section, auquel cas votre repère local orienté comme les doigts de la main droite devient un repère orienté selon les doigts de la main gauche (ou vice-versa).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Propriétés des dalles et plaques

Vous pouvez ouvrir la fenêtre de dialogue relative aux caractéristiques et propriétés des dalles de deux façons distinctes:

  • soit vous double-cliquez sur la dalle dans la configuration ‘Géométrie’,
  • soit vous cliquez sur le bouton [image] après avoir sélectionné une ou plusieurs dalles.

Dans les deux cas, la fenêtre suivante apparaît à l’écran:

Nous classifions les propriétés des dalles en 3 catégories, correspondant chacune à un sous-cadre de la fenêtre à l’écran (cf. 3 paragraphes suivants).

  • les propriétés des sections des dalles
  • les propriétés des matériaux utilisés (valeurs caractéristiques, enrobages du béton, …)
  • axes locaux de la dalle

En bas de la boîte de dialogue, vous pouvez voir à quel étage l'élément sélectionné appartient. Cette affectation est importante si vous utilisez en même temps l’outil 'étages'. En effet, un élément qui appartient à un étage donné n’apparaitra à l'écran que si tout l'étage est visible. En outre, un élément ne peut être sélectionné en vue du dessus que si l'élément appartient à l'étage actif.

Avec les boutons [image] et [image] vous pouvez respectivement exporter et importer les propriétés de la plaque. De cette façon, vous pouvez facilement réutiliser des plaques auto-définies. N'oubliez pas que le matériau et les enrobages ne sont pas importés / exportés.

Propriétés des sections de dalles

Matrice de rigidité

Matériaux et enrobages des dalles

Axes locaux des dalles

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Propriétés des sections de dalles

Dans la partie supérieure de cette fenêtre de dialogue vous pouvez définir les propriétés des sections de dalles, c.-à-d. le profil ou le type de dalle ainsi que les différentes dimensions de celle-ci. Vous pouvez attribuez un nom à chaque dalle que vous définissez. Il suffit pour cela d’indiquer le nom dans le menu déroulant en haut de la fenêtre.

Si vous souhaitez attribuer à une dalle sélectionnée, les propriétés (section, épaisseur, orthotropie, etc.) d’une autre dalle définie précédemment, utilisez la petite flèche à droite du menu déroulant pour indiquer le nom de la dalle dont vous voulez récupérer les caractéristiques. Celles-ci sont alors automatiquement copiées dans les différents champs de propriétés.

Remarque: Les caractéristiques restantes, telles le matériau (ou le type de béton) les enrobages, l’orientation des axes locaux, etc. ne font pas partie des propriétés des sections de dalles. Elles ne sont donc pas copiées lorsqu’on récupère les caractéristiques d’une dalle pour les attribuer à une autre. Il vous faudra dès lors systématiquement les spécifier manuellement.

Dans Diamonds, vous avez le choix parmi plusieurs types. Chaque plaque définie à l'aide [image] est à priori isotrope et à cet effet, les propriétés sont identiques dans toutes les directions. Dalles orthotropes sont des dalles ayant un profil différent dans deux directions perpendiculaires, ce qui ont une rigidité différente dans ces deux directions. Vous pouvez toujours changer le type de plaque à l'aide de la déroulant. Vous avez le choix de entre:

Dalles isotropes – dalles qui possèdent les mêmes propriétés dans toutes les directions.

Planchers en prédalles – planchers composés de prédalles (portantes dans une seule direction) sur lesquelles est coulée une couche de béton isotrope.

Dalles portantes dans une seule direction – dalles sans la moindre rigidité dans le sens perpendiculaire au sens porteur.

Planchers à nervures avec nervures dans une seule direction – éléments de plancher munis de nervures dans le sens longitudinal.

Planchers à nervures croisées – éléments de plancher avec nervures dans le sens de la longueur et de la largeur.

Dalles creuses multicellulaires – planchers-dalles creux dont les évidements vont tous dans le même sens.

Planchers-dalles creux – planchers dont les évidements sont pratiqués suivant une trame rectangulaire.

Dalle alvéolée – une dalle portante dans un sens, avec une couche de béton optionnelle coulée sur place, portante dans deux sens
Diaphragme – une plaque sans rigidité à la flexion, uniquement capable de transférer des forces normales
Plaque arbitraire avec définition de la matrice de rigidité

Ouverture

En fonction du type sélectionné, vous devrez préciser un certain nombre de dimensions. Un dessin détaillé s'affiche toujours à droite pour illustrer les dimensions demandées ainsi que les autres paramètres nécessaires pour définir la matrice du système.

Dans le cas d’une dalle orthotrope, on peut distinguer les sens de portée principal et secondaire. Le sens principal de portée correspond toujours à l'axe local x' de la plaque. Dans le cas d’une dalle horizontale, cet axe local x’ est toujours par défaut parallèle à l’axe global X. Si vous êtes amenés à utiliser un autre sens de portée, vous devrez modifier le repère d'axes locaux en double-cliquant sur la plaque (voir aussi Axes locaux des dalles).

Dans le cas où aucune section ne doit être affectée à une surface sélectionnée, optez pour la dernière option [image]. Vous définissez ainsi un une ouverture au contour ou périmètre sélectionné.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Matrice de rigidité

Diamonds est un logiciel basé sur la méthode des éléments finis (MEF). Avec la MEF, la structure doit être subdivisée en éléments finis, qui seront ensuite reliés les uns aux autres de façon logique. Plusieurs exigences s'appliquent à ces liens, selon le type d'élément (poutre, colonne, plaque, paroi...). Dans tous les cas, il est nécessaire que les nœuds reliant les éléments se déplacent ensemble.

Cette méthode permet d'obtenir une approximation du comportement d'une structure complexe en résolvant une équation matricielle. L'équation matricielle exprime la relation entre les éléments de la structure. Dans le cas d'une analyse statique linéaire, l'équation matricielle s'écrit ainsi :

L'équation matricielle contient une matrice de rigidité [K], une matrice de déplacement des nœuds [U] et une matrice de charge des nœuds [Q].

La matrice de rigidité [K] conditionne le comportement des éléments (poutre, colonne, plaque, paroi...). Sans approfondir davantage la dérivation, on suppose que la matrice de rigidité [K] d'une dalle ou d'une plaque ressemble à celle ci-dessous :

Les facteurs de ‘L’ décrivent le comportement de membrane (= forces normales), les facteurs de ‘D’ décrivent le comportement à la flexion. Les facteurs de cisaillement ne sont pas mentionnés ici. Le tableau ci-dessous offre un aperçu de ces facteurs pour plusieurs types de plaques :

Pour des dalles portantes dans une direction, la rigidité à la torsion [image] est une fonction du rapport de la largeur à l'épaisseur des bandes à partir de laquelle la plaque est construite. Par conséquent, la rigidité à la torsion d'une plaque de support est exprimé dans une direction en pourcentage de la rigidité à la torsion t d'une plaque isotrope.

Le tableau ci-dessous calcule la rigidité à la torsion d'une plaque portante dans une direction [image] et le coefficient de torsiont pour différents rapports b/e.

Lorsque les plaques portantes dans une direction sont réalisées sous forme de bandes de 20 cm d'épaisseur et de 60 cm de largeur b/t=60/20=3, nous constatons qu'elles atteignent 80 % de la rigidité de torsion d'une dalle isotrope. Dans ce cas, vous devrez indiquer dans la fenêtre des propriétés de la plaque un coefficient de 80 % :

Plus d'information:

  • O.C.Zienkiewicz, The Finite Element Method, McGraw-Hill book Company, 1977
  • J. Blauwendraad, Plates and FEM, Surprices and pitfalls, ISBN 978-90-481-3595-0

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Matériaux et enrobages des dalles

Le champ suivant permet de sélectionner le matériau souhaité. La liste du menu déroulant comprend tous les matériaux présents dans la bibliothèque des matériaux.

Dans le cas d'une dalle ou d'une plaque en béton armé, vous devez également indiquer à Diamonds l'enrobage brut de l'armature supérieure et de l'armature inférieure dans les deux sens orthogonaux.

Par enrobage brut de l'armature, il faut entendre la distance entre le centre de gravité de l'armature et le bord supérieur ou inférieur de la section. Cliquez sur le bouton [image] pour ouvrir la boîte de dialogue.

Sens de portée principale (x’) | Sens de portée secondaire (z’)
 | ---

Observez que dans le cas de dalles orthotropes, il est parfois nécessaire de prendre un enrobage assez grand pour l'armature inférieure dans le sens z' (4) afin de pouvoir effectuer le calcul de celle-ci.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Axes locaux des dalles

Dans le dernier champ, vous pouvez définir le sens du repère d'axes local. Le repère d'axes local détermine le sens du treillis d'armature orthogonal. Par défaut, l'axe local x' sera toujours situé dans un plan parallèle au plan horizontal XZ. En outre, l'axe x' correspond au sens porteur principal de la plaque orthotrope. Vous pouvez donc modifier le sens de ces plaques à l'aide de ce paramètre. Ce paramètre peut également être important pour une plaque isotrope, puisque les résultats (et en particulier le sens des treillis d'armature orthogonaux) dépendront du repère d'axes local sélectionné.

C'est surtout pour l'introduction des charges et l'interprétation des résultats qu'il est parfois pratique d'orienter la normale (axe local y') de toutes les plaques et parois dans le même sens. Nous pensons ici, par exemple, à un bassin cylindrique. Dans ce cas, nous souhaiterons que l'orientation de la normale en chaque portion de paroi soit radiale vers l'extérieur. C’est pourquoi, une fonction permet de pivoter l'axe local y'de chaque plaque de 180°. L'axe x' garde ici son sens.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Caractéristiques des semelles

Diamonds offre la possibilité de définir rapidement des semelles de fondations sur base de leurs dimensions (voir Tracer des éléments structurels). Diamonds génère alors automatiquement des dalles isotropes de taille réduite sans que vous devez vous-même en tracer les contours. En plus vous pouvez les placer simultanément sous différentes colonnes ou appuis. N’oubliez pas de définir un sol sous vos semelles!

La fenêtre de dialogue relative aux semelles peut être ouverte de deux façons distinctes:

  • Soit vous double-cliquez sur la semelle et ensuite sur le bouton [image] de la fenêtre de dialogue qui s’ouvre.
  • Soit vous sélectionnez une ou plusieurs semelles avant de cliquer sur le bouton [image] de la palette ‘Géométrie’.

Dans les deux cas la fenêtre suivante apparaît à l’écran …

Dans la partie supérieure de la fenêtre vous indiquez les différentes dimensions de la semelle, à savoir sa longueur, sa largeur, son épaisseur et le nombre de divisions pour le maillage. Chaque division est divisée en 4 triangles.

10x10 | 5x5 | 5x8

Il est possible d’attribuer un nom à chaque semelle. Ce nom figure alors dans le menu déroulant en haut de la fenêtre. Ce menu permet également de réattribuer facilement les caractéristiques d’une semelle déjà définie à un autre élément. Les dimensions se complètent alors automatiquement.

Remarque: Le matériau, les enrobages et l’orientation du repère local ne font pas partie des caractéristiques de la section de la semelle. Ces valeurs ne peuvent dès lors être affectées d’une semelle à une autre.

Dans la partie centrale de la fenêtre vous indiquez la qualité du béton et les enrobages. Voir Matériaux et enrobages des dalles pour plus d'informations.

Dans la partie inférieure, vous déterminez l’orientation du repère local. Par défaut, l’axe local x’ est toujours parallèle à l’axe globale X.

Notez qu’il est possible de charger une semelle de façon excentrique lorsque la base de la colonne et le centre de gravité de la semelle ne coïncident pas.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Choix d’une section dans la bibliothèque des profilés

Diamonds est fourni avec une bibliothèque des profils reprenant des sections d'acier normalisées. Nous avons déjà vu au paragraphe précédent comment attribuer une section aux lignes sélectionnées. Mais il y a une manière plus directe d'attribuer des profils d'acier.

En effet, après avoir sélectionné les lignes souhaitées, il vous suffit de cliquer sur le bouton [image] dans la palette 'Géométrie'. La boîte de dialogue suivante s'affiche alors à l'écran:

Dans la première colonne, sélectionnez le groupe dans lequel vous désirez sélectionner un profil.

La seconde colonne affiche alors tous les profils qui font partie de ce groupe. Notez que seuls sont représentés les profils qui ont été cochés dans la bibliothèque des profils (voir La bibliothèque des profilés).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Excentricité des barres

Excentricité d’une poutre par rapport à une dalle

Excentricité entre différentes barres

Modèle physique

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Excentricité d’une poutre par rapport à une dalle

Lors de l'attribution de poutres à des bords de plaque (et donc PAS en cas d'application de l'icône [image]), on suppose toujours a priori un appui froid. Les axes des poutres coïncideront alors, dans le modèle, avec le plan médian de la plaque. L'excentricité entre la poutre et la plaque sera égale à zéro. Concrètement, cela veut dire que la rigidité de la plaque est localement augmentée de la rigidité de la poutre.

Souvent, dans la pratique, on fera collaborer la poutre et la plaque, par exemple en coulant les deux éléments en même temps, ou en prévoyant une armature de reprise entre la poutre et la plaque afin de pouvoir mobiliser des efforts de cisaillement. On réalise ainsi une plus grande rigidité de l'ensemble et on réduit les flèches de la plaque et de la poutre.

La rigidité de la section composée n'est pas facile à calculer étant donné qu'on ne connaît pas tout de suite la largeur collaborante de la plaque. Il faudrait pouvoir augmenter localement la rigidité de la plaque de la rigidité de la poutre en appliquant le théorème de Steiner. Mais on surestime alors la rigidité de la section composée étant donné que la rigidité est recalculée suivant le plan médian de la plaque. Une autre solution consiste à déplacer l'axe de la poutre et à relier la poutre et la plaque au moyen de plusieurs liens très rigides ou 'rigid link elements'. Ces liens ne possèdent pas de caractéristiques physiques spécifiques (comme une section ou une caractéristique matérielle) mais ils définissent une relation entre deux points reliés, la position respective de ces deux points restant supposée inchangée à tout moment. Vous trouverez de plus amples informations sur ces liens rigides à la section Liens rigides. En principe, cette méthode correspond davantage à la réalité, puisque les deux rigidités se combinent maintenant de manière correcte, compte tenu d'un déplacement de la ligne de gravité. Diamonds opte donc pour l'application de ce dernier principe lorsqu'une excentricité est attribuée à une poutre.

L'attribution d'une excentricité à une poutre s'effectue via l'icône [image].

Vous voyez dans la fenêtre ci-dessus que vous pouvez définir une excentricité différente suivant les deux axes locaux (y’ et z’) de la barre. Vous devrez donc adapter l'excentricité dans le sens y’ ou z’ selon l'orientation de la poutre/colonne. Les options suivantes sont possibles:

  • Soit vous alignez les poutres (colonnes) sur un des bords de la plaque (paroi). Cela se fera automatiquement, par exemple, si vous tracez les poutres avec la fonction ‘Tracer des poutres’ ( [image]). Mais il y a une condition: les poutres doivent être tracées à l'intérieur ou le long du pourtour d'une plaque. Si vous modifiez par la suite l'épaisseur de la plaque, l'excentricité de ces poutres se modifiera automatiquement.
  • Soit vous définissez vous-même une excentricité. L'excentricité est ici la distance entre les fibres neutres de la poutre ou de la plaque.

De plus, il est possible de définir une excentricité différente pour le point de début et le point de fin de la barre. Par exemple, il peut être souhaitable ou nécessaire d'imposer une excentricité différente pour des poutrelles de hauteur variable.

Vous pouvez lier l'excentricité à un élément physique (voir Que faire avec un groupe ?).

Supprimer toutes les excentricités avec [image].

Une poutre avec une excentricité sera établi comme suit:

La ligne de référence de la poutre, comme celle que vous aviez tracée, est tracée à bâtons rompus.. Le véritable axe (déplacé) de la poutre est tracé en trait plein et les liens rigides ajoutés entre les deux lignes sont tracés en trait interrompu. Vous remarquerez qu'il n'est pas possible de sélectionner séparément les différents éléments de cet objet (c.-à-d. les liens rigides, l'axe et la ligne de référence de la poutre).

Enfin, dans les deux derniers onglet vous pouvez encore décider comment définir la connexion entre la poutre (‘Connexion à la poutre’) et la plaque (‘Connexion à la dalle’), c.-à-d. quelles conditions limites il faut attribuer aux extrémités des liens rigides pour simuler un raccord correct. Selon la disposition de votre modèle, vous devez attribuer les conditions limites au début ou à la fin du lien rigide. Toutefois, il ne faut jamais attribuer les mêmes degrés de liberté aux deux extrémités, sans quoi le système risque de dégénérer en mécanisme.

Dans le cas où la poutre et la plaque collaborent à 100%, il ne faut pas découpler de degrés de liberté. Si vous éliminez le transfert de moments et d'efforts tranchants sur toute la longueur de la poutre, vous définissez en fait à nouveau un appui froid. Un petit test montre en effet clairement que les modèles suivants produisent des résultats identiques (My'):

Pas d'excentricité Il y a excentricité, mais avec des conditions limites adaptées

Remarque: Dans le cas où une excentricité est attribuée et qu'aucun degré de liberté n'est dissocié, contrairement à l'approche classique (cf. théorème de Steiner), non seulement des moments (qui seront fortement réduits dans certains cas) mais des forces normales non négligeables surviendront également dans la poutre. L'armature proposée pourra donc avoir l'air surprenante à première vue, puisque vous obtiendrez aussi une armature latérale. Mais si l'on y regarde de plus près, le résultat est logique, étant donné que la poutre sera principalement mise en charge en traction ou en compression. Une telle méthode exige donc une approche différente de l'armature !

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Excentricité entre différentes barres

Diamonds permet aussi de définir une excentricité entre les différentes barres. Alors, un lien rigide sera supposé dans chaque nœud commun. Les propriétés d'un lien rigide sont abordées à la section Liens rigides.

La situation suivante est un exemple de cas pratique où la fonction ci-dessus prouve tout à fait son utilité. Supposons un bâtiment industriel où il faut poser un certain nombre de pannes sur les fermes. Ces pannes sont supposées se prolonger sur les arbalétriers sans pour autant induire de moments de frottement dans ces derniers. En d'autres termes, au droit des appuis, elles transfèrent uniquement les forces de réaction verticales sur les arbalétriers.

Et bien, grâce à la fonction [image], vous pouvez attribuer très rapidement cette caractéristiques aux pannes:

Supprimez toutes les excentricités avec [image].

L'excentricité est sélectionnée ici de manière à ce que le bas des pannes coïncide avec le haut des arbalétriers. Un nœud rigide est maintenant prévu sur chaque nœud; il ne peut transférer aucun moment à son extrémité.

Il en résulte l'évolution suivante des moments pour les pannes. En réalité, ces pannes se comportent donc comme une poutrelle continue sur plusieurs points d'appui.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Modèle physique

Diamonds vous permet de définir les excentricités physiques (principalement pour la liaison BIM avec Tekla Structures).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Rotation de sections

Lorsque vous attribuez des sections à des lignes, ces dernières reçoivent en même temps une orientation standard. Vous pouvez modifier cette orientation pour les barres sélectionnées en cliquant sur le bouton [image].

Pour les profils asymétriques, il est en outre parfois nécessaire de créer une image-miroir de la section Le repère d'axes local à droite se modifie alors en un repère d'axes à gauche.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Attribuer des points d'appui

Diamonds a un cœur de calcul 3D, chaque bouton ayant six degrés de liberté: 3 translations et 3 rotations. Lors de l'attribution de points d'appui, vous pouvez limiter ou empêcher chacun de ces 6 degrés de liberté.

Nous distinguons 3 formes d'appuis : points d'appui, lignes d'appui et supports surfaciques. Un onglet correspond à chacun de ces 3 appuis dans la boîte de dialogue des points d'appui. Selon le type d'élément (point, ligne ou plaque) sélectionné, les onglets s'afficheront ou non.

L'affectation de relations avec le monde extérieur (au moyen de points d'appui) s'effectue toujours dans une configuration 'Géométrie'. Sélectionnez d'abord les éléments en question, puis cliquez sur le bouton [image] de la palette ‘Géométrie’ pour invoquer la boîte de dialogue des points d'appui.

Points d'appui et lignes d'appui

Support surfacique

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Points d'appui et lignes d'appui

Les onglets permettent de configurer les points et lignes d'appui sont très similaires. C'est pourquoi nous les présenterons ensemble.

Partie supérieure de la fenêtre

Les boutons situés en haut à gauche dans la fenêtre vous permettent de créer rapidement des points ou des lignes d'appui types.

En haut à droite, les degrés de liberté entravés sont représentés sous forme graphique [image]. L'orientation de cette figure change en fonction de l'orientation des axes globaux [image]. Si vous avez sélectionné plusieurs points, le point représenté dans la figure est celui qui porte le plus petit numéro.

Dans la partie centrale de cette fenêtre, les degrés de liberté correspondants sont enregistrés.

Partie centrale de la fenêtre

Dans cette partie, vous pouvez immédiatement bloquer vous-même les différents degrés de liberté. Le menu déroulant vous permet d'effectuer les opérations suivantes :

  • conserver le degré de liberté souhaité. Vous pouvez aussi cocher la case.
  • saisir une valeur pour un ressort de déplacement ou de rotation (selon que le degré de liberté concerne un déplacement ou une rotation).
  • saisir une fonction de point d'appui (voyez Définir un diagramme de rigidité).

Pour chaque ressort de translation, vous pouvez en outre indiquer qu'il ne peut reprendre aucune réaction négative (traction) ou positive (compression). Dans le sens vertical (déplacement suivant l'axe global y), ceci signifie, par exemple, que le déplacement ascendant ou descendant de la structure dans ce point ou cette ligne n'est pas empêché.

Partie inférieure de la fenêtre

Enfin, vous pouvez paramétrer l'orientation du point d'appui s'il s'avère que les degrés de liberté bloqués ne correspondent pas à la situation réelle, comme dans le cas d'une poutre inclinée dont l'extrémité peut librement bouger dans le prolongement de la poutre.

Concernant les points, vous pouvez indiquer les angles α et β :

  • l'angle α fera pivoter le point d'appui dans le plan YX. Un angle positif correspond à une distorsion en sens antihoraire.
  • l'angle β fera pivoter le point d'appui dans le plan XZ. Un angle positif correspond à une distorsion en sens horaire.

En revanche, les lignes sont définies par des axes locaux. Il est donc possible de faire pivoter simplement les lignes d'appui suivant les axes locaux de la barre. Pour obtenir la rotation d'une ligne d'appui, cochez l'option Appui défini selon l'orientation de la ligne. Ensuite, indiquez l'angle α auquel le point d'appui doit pivoter.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Support surfacique

Si l'élément sélectionné est un plan, il vous est demandé d'assigner un appui à ce plan.

Partie supérieure de la fenêtre

Dans la partie supérieure de cette fenêtre, les degrés de liberté bloqués sont représentés sous forme graphique. L'orientation de cette figure suit l'orientation des axes globaux .

Partie centrale de la fenêtre

Dans la partie centrale de cette fenêtre, vous indiquez les déplacements qui sont fixes.

Dans cette partie, vous pouvez immédiatement bloquer vous-même les différents degrés de liberté. Le menu déroulant vous permet d'effectuer les opérations suivantes:

  • conserver le degré de liberté souhaité. Vous pouvez aussi cocher la case.
  • saisir une valeur pour un ressort de déplacement ou de rotation (selon que le degré de liberté concerne un déplacement ou une rotation).
  • saisir une fonction de point d'appui (voyez Définir un diagramme de rigidité).
  • utiliser des couches de sol (même principe que précédemment).

Ici aussi, Diamonds offre la possibilité de définir des points d'appui non linéaire (seulement compression ou traction). Par exemple, vous pouvez indiquer qu'une dalle de fondation sur terre pleine ne peut reprendre aucune traction dans le sens y (un déplacement dans sens global positif y peut s'effectuer librement).

Partie inférieure de la fenêtre

Enfin, vous pouvez définir l'appui par rapport à l'orientation de la plaque.

Utilisation des couches de sol

En ce qui concerne les radiers, Diamonds prévoit une méthode itérative pour le calcul de la couche dans le sens global y. Cette méthode tient compte des caractéristiques réelles du sol et recherche de manière itérative un équilibre entre la déformation de la plaque et l'affaissement afin de déterminer ainsi la rigidité élastique correcte dont il faut tenir compte en chaque point de maillage. Cette méthode de calcul utilise deux lois fondamentales de la mécanique des sols: la loi de Boussinesq ou de Frölich pour le calcul des contraintes en un point donné à une profondeur donnée, et la loi de Therzaghi (ou équivalente) pour le calcul des tassements.

Malgré le caractère intensif de ces calculs, les résultats sont beaucoup plus exacts et sont plus proches de la réalité. Si vous souhaitez recourir à cette méthode, vous devez évidemment disposer du profil du sol. Si ce profil a déjà été défini antérieurement dans le projet, il suffit de l'indiquer dans le menu déroulant. Si ce profil n'existe pas encore, configurez les couches de sol au moyen de l'icône [image]. Une nouvelle boîte de dialogue s'ouvre.

Cette boîte de dialogue vous permet de consulter et/ ou modifier tous les profils de couches de sol déjà définis. Sélectionnez le nom du profil dans le menu déroulant pour consulter ses données.

Utilisez les boutons [image] et [image] pour configurer un nouveau profil de couches de sol ou le supprimer. Modifiez éventuellement le nom du profil dans le menu déroulant.

Pour chaque profil de couches de sol, il faut répondre aux questions suivantes:

  • Avec quel essai a-t-on obtenu les paramètres du sol? Nous supportons deux essais de sol:
Le pénétromètre statique | Ménard

Dans les deux cas, vous devez noter l'épaisseur de la couche ainsi que le poids spécifique de la couche à sec (γsec) et humide (γhumide). Dans le cas d'un essai CPT, définissez en outre

  • la constante de compressibilité C [-],
  • la constante de de remise en charge A [-],
  • le rapport de surconsolidation OCR [-],
  • le rapport de drainage CC [-]:

de la couche en question. Dans l'autre cas, vous disposez également du module pressiométrique (E) et du coefficient de la structure du sol (α).

  • Quel est le niveau de la nappe phréatique par rapport au sol naturel? En fait, de façon générale, un profil des couches de sol reprend toutes les couches de sol à partir du sol naturel, quel que soit le niveau de la dalle de fondation. Logiquement, vous noterez donc toujours ici un nombre positif. Si le niveau de la nappe phréatique se situe au-dessus du niveau de la dalle de fondation, vous devez aussi tenir compte des poussées ascendantes de l'eau qui agissent sur la dalle de fondation immergée. C'est pourquoi il est nécessaire de définir ces poussées ascendantes de l'eau dans un groupe de charges supplémentaires dans une configuration 'Charges'.

Indiquez ensuite les différentes couches de sol du profil, en commençant par la couche située juste en-dessous du sol naturel. Cliquez sur les boutons [image] et [image] pour ajouter une couche de sol ou la supprimer.

Lorsque vous travaillez avec des dalles de fondation à différents niveaux, vous devez aussi garder le même plan de référence pour définir les couches de sol. Lorsque plusieurs profils de couches de sol se trouvent dans un projet, définissez-les tous par rapport au même sol naturel. La définition du niveau-même du sol naturel, est faite dans la fenêtre de dimensionnement qui apparaît au lancement du calcul élastique (voir Calcul des radiers par équilibre itératif).

Toutes les couches de sol ainsi que leurs propriétés sont enregistrées sous forme de tableau. Vous pouvez adapter directement ces valeurs dans le tableau proprement dit.

La couche de sol de la dernière rangée du tableau est supposée se prolonger jusqu'à une profondeur infinie.

On dispose souvent des résultats d'un sondage dans un fichier sous forme de feuille de calcul. Vous pouvez ouvrir directement ce fichier sous format txt via le bouton [image]. Exemple:

La première ligne contient les titres des colonnes: épaisseur, C, A, OCR, CC, γsec and γhumide, avec les unités correspondantes entre parenthèses. Ci-dessous, toutes les couches de sol sont remplis, pour chaque couche de sol une nouvelle ligne est lancée. Les quatre colonnes sont séparés par des tabulations.

D’autre part, il est toujours possible d’exporter les couches de sol définies pour les rouvrir dans un autre projet via le bouton [image].

Pour plus d'informations sur la méthode de calcul proprement dite, on consultera le chapitre Calcul des radiers par équilibre itératif.

Signalons encore que la méthode de calcul itératif peut aussi s'appliquer au calcul du tassement des poutres de fondation. La couche se réduit alors à une ligne d'appui résiliente sous l'axe de la barre.

Enfin, notons que Diamonds est un logiciel à éléments finis, de telle sorte que les lignes d'appui et les couches résilientes sont toujours ramenées à des points d'appui discrets. Les intervalles entre les différents points d'appui dépendent de la densité du maillage. En principe, un point d'appui correspond à chaque point de maillage.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Conditions limites pour les extrémités des barres et les tirants

Un point nodal entre deux barres correspond, dans la pratique, à une connexion ou un mode de fixation dotés de caractéristiques bien déterminées. Les caractéristiques concernent dans une large mesure la manière dont les différents efforts tranchants à l'extrémité (aux extrémités) d'une barre sont transférés sur le reste de la structure, mais elles peuvent aussi concerner la question de savoir si le reste de la structure – en particulier les barres qui y aboutissent perpendiculairement – soutiendra latéralement la barre en question. Cette dernière caractéristique n'influence pas la répartition des contraintes, mais il faut absolument la connaître pour vérifier la stabilité au déversement d'une barre. De plus, les jarrets seront également abordés dans ce chapitre. Les jarrets interviendront dans le calcul des tensions, le contrôle normatif de l'acier et la répartition des forces.

Toutes ces conditions limites imposées aux extrémités des barres sont regroupées dans une seule boîte de dialogue, que vous ouvrirez à l'aide du bouton [image], par exemple.

Le haut et le bas du profil sont indiqués respectivement par les notations z' > 0 et z' < 0. Ces notations font référence au repère d'axes locaux de la barre sélectionnée. En outre, la première colonne renvoie au nœud de début de la barre tandis que la deuxième colonne se réfère au nœud de fin de la barre. Le nœud de début est le point qui possède la plus petite coordonnée x ou, si celle-ci est identique pour les deux points, le point qui possède la plus petite coordonnée y. Si la coordonnée x et la coordonnée y sont identiques, le point est indiqué comme nœud de début avec la plus petite coordonnée z. Etant donné que le critère ci-dessus sert également à déterminer l'orientation de la barre, vous pouvez aussi toujours déduire le nœud de début et le nœud de fin d'une barre du sens de l'axe local x'.

Tirants

Rigidités de rotation et de translation aux extrémités des barres

Définir un diagramme de rigidité

Jarrets

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tirants

Si vous sélectionnez un tirant, aucun moment n'est transféré aux extrémités de la barre. Le tirant proprement dit peut aussi ne se voir attribuer aucune charge susceptible de provoquer une flexion dans la barre. Le poids propre du tirant sera ramené à un effort ponctuel sur chacune des extrémités de la barre. A part les moments fléchissants, le tirant ne peut pas non plus reprendre d'efforts de compression. En d'autres termes, si le tirant se trouve mis en compression sous une combinaison donnée de charges, il sera retiré de la structure et l'on reprendra le calcul. En outre, étant donné qu'aucune superposition ne peut être appliquée, le temps de calcul peut rapidement s'élever à quelques minutes pour les modèles plus grands comportant de nombreux tirants.

Remarque:Un tirant tel que défini dans Diamonds présente un comportement linéaire. Comme le poids propre est éliminé, la ligne d'action de l'effort de traction se situe toujours dans le prolongement du tirant proprement dit. Le comportement non linéaire d'une corde ne peut donc pas être simulé de cette façon.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Rigidités de rotation et de translation aux extrémités des barres

Si vous ne sélectionnez pas un tirant, vous pouvez éliminer tout transfert d'effort aux extrémités de la barre en cochant "Libre" dans le menu déroulant correspondant. Si aucun transfert de moment n'est plus possible autour d'un axe donné, nous parlerons d'une charnière. Une glissière, par contre, empêche le transfert d'efforts longitudinaux (N) ou transversaux (V). Les indices x’, y’ et z’ renvoient aux axes locaux des barres.

Dans le cas de connexions semi-rigides, le transfert des efforts ne se fera que partiellement. De plus, la rigidité peut encore dépendre de l'importance et du sens de l'effort sollicitant. Diamonds prévoit une solution pour tous les cas possibles.

  • La rigidité est indépendante de l'importance et du signe de l'effort interne. Dans ce cas, il suffit de cliquer sur "Valeur" dans le menu déroulant et d'introduire la rigidité finie de rotation et/ou de translation.
  • La rigidité est constante mais elle est différente pour un effort positif et un effort négatif.
  • La rigidité varie en fonction de l'importance de l'effort.

Alors que, dans le premier cas, un calcul linéaire suffit, dans les autres cas, l'analyse globale sera réalisée de manière itérative.

La façon de définir une rigidité variable est expliquée au paragraphe suivant Définir un diagramme de rigidité).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définir un diagramme de rigidité

Un diagramme de rigidité vous montre la déformation angulaire ou le déplacement en fonction du moment appliqué (effort normal, effort de cisaillement ou effort tranchant). Diamonds vous permet de définir, pour chaque extrémité de barre et pour effort, une fonction différente qui établit la rigidité en fonction de l'importance et du sens de l'effort sollicitant.

Pour attribuer un diagramme de rigidité à une extrémité de barre:

  • Sélectionnez l'option "Fonction" en regard de l'effort concerné dans le menu déroulant.
  • Si vous aviez déjà défini auparavant un diagramme de rigidité dans le modèle et que vous l'aviez attribué à une extrémité de barre, vous pouvez effectuer ici une nouvelle sélection. Dans l'autre cas, utilisez le bouton [image] pour composer une nouvelle fonction.
  • Dans la boîte de dialogue qui s'affiche, cliquez sur le bouton [image].
  • Donnez un nom à la fonction.

  • Optez soit pour une rigidité constante mais dépendante du signe soit pour une rigidité variable en fonction de l'importance et du signe de l'effort.

    Dans le premier cas, vous pourrez décider, pour les deux signes, que le transfert s'effectuera pleinement, partiellement ou pas du tout. Le diagramme de rigidité suivant correspond, par exemple, à une situation où un effort normal négatif (compression) peut être transmis mais pas un effort positif (traction).

    Par exemple, cette condition limite peut être affectée à l'extrémité supérieure d'une colonne lorsque cette dernière ne peut produire qu'une réaction positive.

    Si vous disposez d'un diagramme de rigidité où la rigidité de rotation ou de translation varie en fonction de l'importance de l'effort sollicitant, recourez à la seconde option et définissez le nombre de points pour lequel vous connaissez la valeur de la déformation angulaire ou du déplacement.

    Vous trouvez ci-dessous, à titre d'exemple, un diagramme de rigidité possible pour une connexion arbitraire.

    un diagramme de rigidité possible pour une connexion arbitraire un diagramme de rigidité possible pour un pieu qui ne pas prendre du traction, et 100kN compression

    Il résulte de ce diagramme que la rigidité de rotation M/ϕ est constante aussi longtemps que le moment appliqué est inférieur à 45,4kNm. Une fois que ce moment est dépassé, la rigidité varie en fonction de M. Si le moment est supérieur à 68,2kNm, il se forme une charnière plastique, puisque un moment supplémentaire produira une déformation angulaire infiniment grande.

Notez bien que ce diagramme de rigidité se remplira automatiquement quand vous attribuerez une connexion instantanée à un nœud depuis PowerConnect (voir Attribuer les caractéristiques de l’assemblage à un nœud).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Jarrets

Enfin, la dernière option vous permet d'appliquer un jarret inférieur ou supérieur à chaque extrémité de barre. Un jarret est caractérisé par une longueur et une hauteur. La longueur est forcément égale pour le jarret supérieur et le jarret inférieur, mais leur hauteur peut néanmoins être différente.

En appliquant un jarret, vous augmenterez localement la résistance du profil. En particulier, les tensions calculées par Diamonds seront diminueront d'autant plus que la hauteur du profil diminuera. Le contrôle normatif de l'acier tiendra également compte de cette section variable. Le jarret a également une influence sur la répartition des moments car la rigidité variable est aussi reprise dans la matrice de rigidité globale.

En outre, le jarret sera recalculé automatiquement quand vous détaillerez par la suite le nœud entre les deux barres dans PowerConnect. Et inversement, ces dimensions seront remplies quand un jarret sera ajouté à la connexion dans PowerConnect.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Lignes articulées

Toutes les plaques sont a priori supposées continues. Vous pouvez éliminer la rigidité en flexion, en allongement et transversale entre les plaques en formant une ligne de charnière. Sélectionnez à cette fin une ou plusieurs plaques et cliquez sur l'icône [image].

  • Dans la partie supérieure, vous pouvez éliminer le transfert de moments le long de tous les bords à l'aide d'options spécifiques aux parois verticales.
  • La partie inférieure vous permet de définir vous-même les conditions limites sur des bords au choix.

Supprimer toutes les conditions avec [image].

La partie inférieure

Dans le cas où une seule plaque est indiquée, vous trouverez une représentation de la plaque dans le bas de cette fenêtre de dialogue.

Les bords auxquels une condition limite a déjà été affectée s'affichent en bleu. (bord de gauche sur l'illustration ci-dessus). Les bords sélectionnés s'affichent en rouge. (bord de droite sur l'illustration). Les bords sélectionnés auxquels une condition limite a déjà été affectée sont rouges à l'intérieur et bleus à l'extérieur (bord au milieu de l'illustration)

Le menu déroulant vous donne le choix entre affecter des conditions limites:

  • à tous les bords de l'élément plat sélectionné
  • uniquement aux bords sélectionnés de l'élément plat sélectionné.
    • Pour ce faire, sélectionnez avec la souris le bord dont vous voulez adapter la rigidité en rotation et/ ou translation. Notez bien que vous pouvez sélectionner plusieurs bords de plaque à la fois à l'aide de la touche SHIFT. Vous pouvez ainsi affecter les mêmes conditions limites à plusieurs bords à la fois.
    • Mais vous pouvez aussi sélectionner d'avance plusieurs bords au moment où vous sélectionnez l'élément plat.
  • à tous les bords horizontaux de l'élément plat sélectionné
  • à tous les bords verticaux de l'élément plat sélectionné. Cette option ne générera une sélection qu'en cas de parois (plaques) verticales.

Pour annuler une sélection, cliquez une fois en-dehors du périmètre de la plaque.

La partie supérieure

Si vous indiquez l'option 'Pas de transfert de moments le long de tous les bords', la plaque ne pourra pas transférer de moment hors le plan sur aucun bord.

Si vous indiquez l'option 'Pas de moment dans le plan', la plaque ne pourra pas transférer de moment dans le plan sur aucun bord.

Les options complémentaires 'pas d’effet d’arc' et 'au bord supérieur: pas de traction' n'ont de sens que pour les parois verticales (en particulier pour les murs de maçonnerie).

  • L'option 'au bord supérieur: pas de traction' garantit que la plaque posé sur ces murs de maçonnerie ne puisse pas tirer sur les murs vers le bord supérieur. Cependant, cela n'exclut pas la traction dans le mur lui-même!

    Cette option entraînera toujours un calcul itératif et le temps de calcul sera plus long.

  • L'option 'pas d’effet d’arc' prévoit aussi que le cisaillement soit éliminé le long du bord inférieur du mur. C'est particulièrement important quand une poutre se trouve sous ce mur. Du fait de l'élimination du cisaillement, le mur et la poutre ne collaborent en effet plus comme un ensemble résistant au cisaillement.

    Les modèles dont certains éléments comprennent cette option seront toujours calculés de manière itérative. Par conséquent, le principe de superposition n'est plus valable pour composer les résultats des combinaisons de charges et le temps de calcul sera donc plus long.

    N'oubliez pas que 'pas d'effet d'arc' ne se traduit pas par un comportement correct de la maçonnerie puisque on peut compter, en principe, sur une dispersion à 45°. Mais cette méthode aboutira toujours à un résultat sans danger, puisque un maximum de la charge est transmis aux éléments sous-jacents. Les modèles composés uniquement de murs de maçonnerie comprenant cette seule option ne seront pas calculés de manière itérative, ce qui procurera évidemment un gain de temps.

    Du fait que l'effort transversal n'est pas éliminé le long des bords, l'élément peut aussi transférer les charges horizontales éventuelles (p.ex. le vent) le long de ses bords.

Vue d'ensemble des icônes et de leur signification:

pas de moment hors le plan | pas de moment dans le plan | pas de traction sur le bord supérieur | pas d’effet d’arc
þ |  |  |
þ | þ |  |
þ |  |  |
þ |  |  | þ
þ |  | þ | þ
þ | þ | þ |
þ | þ |  | þ
þ | þ | þ | þ

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Choix de matériau

Diamonds est fourni avec une bibliothèque des matériaux. Le matériau est défini a priori lors de la définition de la section ou des propriétés des plaques. Il est toujours possible de consulter ou de modifier le matériau des barres sélectionnées à l'aide du bouton [image].

Dans la première colonne, vous pouvez sélectionner (en option) le groupe dans lequel vous souhaitez sélectionner un matériau. Ceci est un filtre.

La deuxième colonne présente ensuite tous les matériaux appartenant à ce groupe. Pour changer de matériau, sélectionnez le nouveau matériau souhaité dans la liste et cliquez sur « OK ».

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Liens rigides

Dans un modèle de calcul constructif, les éléments (barres et plaques) sont représentés schématiquement par des lignes et des plans auxquels sont assignées des caractéristiques constructives. Pour assurer le transfert des efforts entre éléments constructifs, il faut que ces éléments soient interconnectés. Dans la plupart des cas, le transfert des efforts se fera via des nœuds partagés entre éléments constructifs, mais si ces éléments présentent une grande excentricité les uns par rapport aux autres, il est recommandé de procéder autrement. Par ailleurs, les éléments constructifs excentriques n'ont plus de nœuds communs, mais sont interconnectés à l'aide de liens rigides placés entre des nœuds voisins. Les liens rigides ne possèdent pas de caractéristiques physiques spécifiques (comme une section ou une caractéristique matérielle) mais ils définissent une relation entre les deux points reliés, dont la position respective est supposée inchangée à tout moment.

Procédez comme suit pour définir des liens fixes:

  • tracez un segment de droite entre 2 points qui doivent être interconnectés par un lien rigide
  • sélectionnez le segment de droite (ou différents segments de droite) et attribuez des caractéristiques de lien rigide à l'aide de l'icône [image]. Notez bien que cette icône n'invoque pas de nouvelle boîte de dialogue puisque aucun paramètre supplémentaire n'est exigé pour définir la relation rigide. Il suffit, en d'autres termes, de cliquer 1 fois sur l'icône pour attribuer automatiquement les caractéristiques souhaitées aux segments de droite sélectionnés.

Si vous utilisez une représentation volumétrique pour les éléments (barres et plaques) tracés, tenez compte du fait que les liens rigides sont tracés sous forme de barres cylindriques. Cela n'implique en aucun cas que des propriétés de section et/ou de matériau sont attribuées à ces liens rigides – il s'agit d'une représentation purement symbolique pour visualiser clairement les liens rigides. Notez bien qu'un type propre est attribué automatiquement à ces liens, de sorte que vous pourrez les cacher facilement par la suite.

Pour supprimer des liens rigides, il suffit de supprimer le segment de droite correspondant. Pour remplacer ces liens par des éléments physiques (barres), il suffit d'attribuer les propriétés de section et de matériau nécessaires aux segments de ligne correspondants.

Comme nous l'avons dit plus haut, les liens rigides n'ont pas de caractéristiques physiques spécifiques, mais ils définissent une relation entre deux points reliés, dont la position respective est supposée inchangée à tout moment. Par conséquent, tous les efforts internes (moment fléchissant, moment de torsion, effort normal, effort tranchant) sont transmis d'un point à l'autre, compte tenu évidemment de l'excentricité entre les points reliés (en d'autres termes, de la longueur du lien rigide).

Cependant, il est possible de définir également des conditions limites déviantes aux extrémités des barres pour les liens rigides, tout comme c'est le cas pour les liens physiques (voir illustration ci-dessous). En particulier, il est possible, par exemple, d'éliminer le transfert de moments afin de limiter le transfert d'efforts d'un point à l'autre à l'effort normal et à l'effort tranchant. Les pannes continues posées au-dessus d'une série de fermes parallèles en sont un exemple typique, car les pannes transmettent uniquement un "effort de réaction" vertical à la structure d'appui. Vous trouverez de plus amples informations sur la modification des conditions limites aux extrémités des barres à la section Rigidités de rotation et de translation aux extrémités des barres.

Remarque:Dans l'exemple ci-dessus, les lignes axiales des arbalétriers et des pannes ont été dessinées de manière excentrique dès le début. Si, à un stade ultérieur, vous modifiez les dimensions des arbalétriers et/ou des pannes et que vous désirez en tenir compte dans le modèle de calcul, il y a lieu de déplacer plusieurs lignes axiales pour tenir compte de l'excentricité modifiée. Mais il est possible de ne pas le faire en utilisant des poutres excentriques à l'aide de l'icône [image]. Vous pouvez alors tracer des lignes axiales centrées pour les arbalétriers et les pannes, et des liens rigides sont automatiquement supposés au droit des nœuds communs lors de l'attribution de l'excentricité aux pannes. Vous trouverez de plus amples informations à la section Excentricité des barres.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres de flambement et de déversement

Lorsque vous voulez contrôler la stabilité d'un élément de construction, vous devez prendre en compte les longueurs de flambement et de déversement correctes.

  • Les longueurs de flambement sont importantes lorsqu'une barre est mise en charge en compression (colonne).
  • La longueur de déversement, par contre, est un paramètre qui intervient dans le calcul du moment théorique de flambement élastique et qui est, de ce fait, important pour les barres mises en contrainte en flexion suivant l'axe fort (résistant en flexion) du profilé.

Les longueurs de flambement et de déversement d'une ou de plusieurs barres peuvent être contrôlées ou modifiées dans la boîte de dialogue ci-dessous, que vous ouvrirez via le bouton [image] dans la palette ‘Géométrie’.

Les longueurs de flambement peuvent

  • soit être calculé par Diamonds (voir Calcul des longueurs de flambement)
  • soit imposé par l'utilisateur dans la fenêtre ci-dessus.

La longueur de déversement est calculée comme la longueur entre deux supports de déversement (voir Définition des renforts au déversement ). La longueur de la pointe d'une barre avec une extrémité libre est le double de la longueur de la barre.

L'option 'Effets 2e ordre via e2 + excentricité accidentelle: 20 mm' s'applique aux barres en béton. Plus d'informations sur buildsoftsupport.com.

La longueur de flambement d’une barre individuelle

Longueur de torsion latérale ou de déversement d’une barre

Paramètres pour la vérification au déversement

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La longueur de flambement d’une barre individuelle

Si au moment d’ouvrir la fenêtre de dialogue, vous avez déjà effectué le calcul des longueurs de flambement, vous retrouvez les valeurs calculées dans les champs supérieurs de la fenêtre de dialogue. Sinon, ce sont les longueurs réelles qui apparaissent dans ces cases. Deux valeurs sont prises en considération : une première pour le flambement autour de l’axe fort (y’ ou u) et une seconde pour le flambement autour de l’axe faible (z’ ou v).

Les longueurs de flambement sont définies en valeur absolue ou en pourcentage de la longueur effective de la barre ou du groupe de barre étudié. Votre choix s’effectue au sein d’un menu déroulant à droite du champ de définition de la longueur de flambement. La longueur de barre correspond à la longueur physique de celle-ci. La longueur d’un groupe de barre correspond à la somme des longueurs des barres constituant ce groupe.

Si vous ne souhaitez pas effectuer de vérification au flambement autour d’un des deux axes, il vous suffit de décocher la case correspondante.

Lors de la vérification normative apparaîtra alors un message approprié vous rappelant qu’il n’y a pas de risque de flambement autour d'un ou deux des axes principaux d'inertie.

EN 1992-1-1 § 5.1.4 établit que pour le béton, des effets de second ordre doivent être pris en compte :

  • Soit en effectuant une analyse complète de second ordre (F9 + analyse de second ordre)
  • Soit en utilisant une méthode simplifiée. Diamonds utilise la méthode de la courbure nominale (EN 1992-1-1 §5.8.8).

Ici vous pouvez ainsi activer ou désactiver facilement cette option pour plusieurs barres à la fois.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Longueur de torsion latérale ou de déversement d’une barre

Dans la seconde partie de la fenêtre de dialogue apparaissent les longueurs de déversement pour la barre sélectionnée. Par définition, il s’agit de la longueur pour laquelle la poutre ou l’élément n’est pas soutenu latéralement. Selon l’Eurocode, cette longueur est symbolisée par la lettre L.

En fonction du signe du moment fléchissant (My'), il s’agira soit de la semelle supérieure, soit de la semelle inférieure. C’est pourquoi Diamonds permet pour chaque profil de définir des renforts au déversement tant supérieurement (z’>0) qu’inférieurement (z’<0).

Le calcul automatique des longueurs de déversement ne peut être effectué que si vous avez préalablement défini les positions des renforts au déversement. Dans les cas où les éléments servant de renforts au déversement sont effectivement dessinés dans le modèle, la définition est relativement rapide. Par contre, lorsque ces barres ne font pas partie intégrante du modèle étudié, il faudrait normalement subdiviser chaque élément soumis à flexion en un certain nombre de sous-éléments. Cette opération est susceptible de prendre plus de temps. Pour éviter de devoir effectivement subdiviser ces barres, vous pouvez indiquer le nombre de supports au déversement présents.

Diamonds supposera a priori que plusieurs renforts au déversement ont été appliqués, de manière à ce que vous deviez effectuer le moins possible d'adaptations. Toutefois, vous pouvez toujours décider de placer des renforts au déversement supplémentaires ou bien de permettre quand même le déplacement latéral aux extrémités de barres où un renfort au déversement est supposé a priori. Vous pouvez modifier la définition d'un support au déversement aux extrémités de barres en cliquant avec le bouton droit de la souris sur le renfort au déversement concerné. Vous pouvez ensuite choisir dans une liste si le renfort au déversement sera automatique, fixe ou libre.

  • de suivre la règle générale ("Auto") citée à la section Renforts au déversement et calcul automatique des longueurs de déversement. Les renforts au déversement placés suivant cette règle ne s'afficheront pas dans la fenêtre modèle.
  • de supprimer un renfort au déversement placé a priori (“Libre”), exprimé dans la fenêtre modèle par le symbole [image].
  • de placer un renfort au déversement supplémentaire (“Fixe”), exprimé dans la fenêtre modèle par le symbole [image].

Vous pouvez ajouter des renforts intermédiaires au déversement en incrémentant le chiffre en regard du nombre de supports intermédiaires au déversement [image] ou en cliquant avec le bouton droit de la souris dans le champ concerné

En cochant l'option [image], vous disposez tous les renforts au déversement à égale distance les uns des autres. Si vous décochez cette option, vous pouvez adapter manuellement la longueur entre les renforts au déversement en cliquant une fois avec le bouton gauche de la souris sur la longueur que vous souhaitez adapter.

Si le bouton [image] est activé, introduisez des distances intermédiaires absolues. En cliquant une fois sur le bouton [image], vous le modifiez en [image]. Vous pouvez maintenant introduire des distances intermédiaires relatives au moyen d'un pourcentage.

Si par contre vous ne souhaitez pas effectuer de vérification au déversement, parce que, par exemple, la barre est soutenue latéralement sur la totalité de sa longueur, décochez la/les case(s) pour la face supérieure (z’>0) ou la face inférieure (z’<0). Lors de la vérification normative apparaîtra alors un message approprié vous rappelant qu’il n’y a pas de danger de torsion latérale suite à un phénomène de déversement.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres pour la vérification au déversement

Diamonds attribue des valeurs par défaut (en tenant compte de la sécurité bien entendu) à un certain nombre de paramètres. Néanmoins, l’utilisateur peut modifier celles-ci s’il le souhaite. Vous trouvez ces paramètres sous le deuxième onglet 'Paramètres de déversement avancés':

Il s’agit plus particulièrement des facteurs kz et kw ainsi que du coefficient C1. Ceux-ci interviennent tous dans le calcul de la valeur théorique du moment de déversement élastique (Mcr).

Les facteurs kz et kw escomptent l'effet de plusieurs types de conditions limites.

  • kz est égal à 0.5, 0.7 ou 1 lorsque le déversement latéral (rotation autour de l'axe faible (axe z’) du profil) est entravé respectivement au droit des deux points d'appui, d'un seul point d'appui ou d'aucun des points d'appui.
  • kw tient compte du fait que la gauchissement des sections est ou non empêchée au niveau des extrémités.
    • kw=0.5 si la gauchissement est empêchée aux deux extrémités.
    • kw=1, si les deux extrémités sont libres de se gauchir, mais que la rotation est empêchée autour de l'axe longitudinal. C'est cette valeur qui est recommandée, à moins que des dispositions spéciales soient prises.

A priori, les deux facteurs sont équivalents à 1, mais vous pouvez opter pour une condition limite plus favorable via les options du menu déroulant. En cas de doute, il vaut mieux laisser les deux valeurs à 1, ce qui correspond à:

  • résistance au déplacement latéral, liberté de pivoter dans le plan (kz)
  • blocage contre le pivotement autour de l'axe longitudinal, liberté de gauchissement (kw)

Le coefficient C1 tient compte de la forme du diagramme des contraintes. Diamonds est amène de le déterminer pour bon nombre de cas de figure. Dans le cas contraire, la valeur par défaut est égale à 1. Concrètement cela signifie que Mcr est alors calculé en supposant que le moment maximum s’applique sur la totalité de la longueur de l’élément. Si vous disposez d’un outil ou logiciel vous permettant de calculer rigoureusement la valeur de C1, vous pouvez ‘imposer’ cette valeur à l’aide du menu déroulant prévu à cet effet.

Compte-tenu du fait que la formule permettant de calculer Mcr ne peut en théorie être utilisée que pour des sections symétriques par rapport à leur axe faible, vous avez également la possibilité d’introduire manuellement la valeur théorique du moment de déversement élastique. Notez que vous ne pouvez fixer qu’un seul paramètre (soit vous imposez la valeur de C1 qui permettra de déterminer automatiquement Mcr à partir de l’expression générale, soit vous introduisez directement Mcr) et que les valeurs fixées seront utilisées pour toutes les combinaisons de charges (même si elles peuvent en théorie varier d’une combinaison à l’autre).

Enfin, vous devez spécifier la méthode pour déterminer les courbes de déversement. Vous avez le choix entre:

  • La méthode générale EN 1993-1-1 §6.3.2.2
  • La méthode équivalente EN 1993-1-1 §6.3.2.3.

Remarque : Le calcul de C1 dépendant de la position des renforts contre le déversement, ce coefficient ne peut être déterminé que si les longueurs de déversement sont calculées automatiquement. Lorsque la longueur de déversement est imposée manuellement par l’utilisateur, ce dernier doit également imposer la valeur C1. Par défaut, la valeur de C1 est fixée à 1.

Remarque: La méthode équivalente EN 1993-1-1 §6.3.2.3 de détermination des courbes de déversement n'est pas applicable sur tous les types de formes (p.ex., il l'est sur I, H, mais pas sur L, T, O,…). Si vous décidez de déterminer les courbes de déversement selon cette méthode, Diamonds le fera pour TOUS les profilés du modèle si possible. Si ce n'est pas possible, Diamonds déterminera les courbes de déversement selon la méthode générale.

  • Le choix des courbes de déversement influence non seulement le contrôle du déversement mais aussi le contrôle de l'interaction (également appelé “flambement + déversement” ou “force normale + moment”).
  • Par défaut, Diamonds calcule selon la méthode générale EN 1993-1-1 §6.3.2.2.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Protection incendie

Sélectionnez une barre et cliquez sur pour [image] définir la protection contre le feu. Vous pouvez choisir entre:

  • Une section non-protégée

  • Une section protégée suivant des cas standards populaires. Sélectionnez un en cliquant dessus:

  • Une section protégée pour laquelle vous allez définir la protection vous-même.

    • Cliquez sur [image]. Une fenêtre s’ouvre, ayant la possibilité de créer plusieurs cas (variations en protection) d’une même section dans l’Utilitaire de Sections.

    • Ajoutez un nouveau cas avec [image], supprimez-le avec [image] et utilisez [image] pour modifier une section dans l’Utilitaire de Sections.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Modification de lignes et de nœuds

Pour terminer, citons encore une fonctionnalité à laquelle ne correspond aucun bouton dans la palette 'Géométrie' mais qui relève bien d'une configuration 'Géométrie', à savoir la consultation d'informations sur les nœuds et les barres.

Si vous double-cliquez sur un bouton, l'écran affiche une boîte de dialogue dans laquelle vous pouvez modifier les coordonnées

Rappelez-vous que vous pouvez aussi modifier les coordonnées des nœuds dans la fenêtre ‘Données’ que vous invoquerez via l'icône [image] dans la barre d'icônes. On voit aussi dans le bas à quel étage le bouton sélectionné appartient. Cette affectation est importante si vous utilisez en même temps le concept 'étages'. En effet, un nœud qui appartient à un étage donné ne sera visible sur l'écran que si tout l'étage est apparent. En outre, un nœud ne peut être sélectionné en vue du dessus que si le nœud appartient à l'étage actif.

En double-cliquant sur une barre, vous pouvez en modifier la longueur, l'orientation et plusieurs propriétés de la section.

Dans le champ supérieur, vous voyez la barre telle que reprise dans la fenêtre modèle, avec indication des numéros des nœuds de fin.

La longueur, la pente et l'angle de projection horizontale entre la barre et l'axe global x sont adaptés de manière à ce que le point le plus près duquel on a double-cliqué reste fixe tandis que l'autre point de fin de la ligne se déplace. La longueur peut être créée soit comme une longueur réelle ou comme une longueur projetée sur le plan horizontal.

En-dessous, vous trouvez le nom du profil affecté à cette ligne. Le bouton [image] donne directement accès à la boîte de dialogue reprenant toutes les propriétés des sections (voir Propriétés des barres).

Vous pouvez ici consulter et éventuellement modifier le matériau, les enrobages (béton) et le mode de fabrication (Fe) des sections utilisées. D’autre part, vous pouvez modifier l’orientation de vos axes locaux de façon à faire pivoter la section autour de l’axe longitudinal de la barre. Les boutons [image] vous permettent d'échanger la section attribuée au nœud au début et celle attribuée au nœud final. Si vous souhaitez miroiter l’axe local y’ (axe fort) de la barre, il suffit de cliquer sur l’icône [image].

De manière similaire au cas des nœuds, on indique ici aussi à quel étage la barre sélectionnée appartient. Des règles identiques à celles discutées pour les nœuds et les plaques s'appliquent ici.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Copier et coller des points d'appui et des sections

Si vous désirez copier et coller les caractéristiques de section d'une semelle de fondation, d'une colonne, d'une poutre ou d'une plaque vers un autre élément, commencez par sélectionner l'objet dont vous voulez copier les caractéristiques et enfoncez ensuite le bouton droit de la souris. Dans le menu flottant qui s'affiche, sélectionnez l'option 'Copier les propriétés'.

Sélectionnez ensuite les éléments auxquels vous voulez attribuer ces caractéristiques et enfoncez à nouveau le bouton droit de la souris. Cette fois, sélectionnez l'option avec les propriétés à coller dans le menu flottant.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette 'Charges'

Chaque configuration 'Charges' est munie d'une palette 'Charges' du côté droit de la fenêtre modèle. Cette palette se compose comme suit:

  • Les trois rangées de boutons [image] servent à créer les charges proprement dites (charges ponctuelles, moments, charges réparties sur des nœuds, des barres et des surfaces).
  • En-dessous, vous pouvez sélectionner dans un menu déroulant le cas de charges que vous voulez traiter ou examiner dans une configuration 'Charges'. Selon le type de groupe de charges sélectionné pour , lors de la définition des charges, Diamonds ouvrira uniquement la liste qui contient des boutons pertinents par rapport au groupe de charges sélectionné. De cette façon, Diamonds n'est pas surchargé de boutons dont vous n'avez pas besoin.
  • Si vous voulez effacer à nouveau des charges, utilisez le bouton [image]. Toutes les charges qui se trouvent sur les éléments sélectionnés seront alors supprimées pour les autres groupes de charges actifs. Le bouton pour translater [image] des charges, c.à.d déplacer ou copier des charges, se trouve à coté du bouton [image].
  • Avec les deux boutons sous le menu déroulant 'Température' vous créez les charges de température pour les poutres et les plaques. Nous distinguons les charges de température globales et les gradients de température.
  • Avec les boutons sous le menu déroulant 'Vent' vous créez les charges de vent pour les poutres, les plaques et les groupes de poutres.
  • Avec les boutons sous le menu déroulant 'Neige' vous créez les charges de neige pour les poutres, les plaques et les groupes de poutres.
  • Avec le bouton sous le menu déroulant 'Sismique' vous créez une charge sismique.
  • Avec les boutons sous le menu déroulant 'Dynamique' vous créez une charge dynamique.
  • Avec les boutons sous le menu déroulant 'Mobile' vous créez une charge mobile.
  • Avec les boutons sous le menu déroulant 'Feu' vous créez une charge de feu.

Notez bien que les boutons du haut ne s'éclaireront qu'une fois un élément sélectionné dans la fenêtre modèle.

Le fonctionnement de tous ces boutons est décrit de manière circonstanciée dans les paragraphes suivants.

Cas de charges

Choix de la norme

Choix de la classe de service

Définir ou supprimer des cas de charges

Définir des incompatibilités

Définir des groupes de charges liés

Définir des sous-groupes de charges

Combinaisons de charges

Combinaisons dans le temps

Les charges

Redimensionner les charges

Charges ponctuelles sur nœuds

Moments sur nœuds

Charges ponctuelles sur barres

Moments sur barres

Charges linéaires uniformément réparties et charges trapézoïdales

Torsion répartie

Charge surfacique

Générateur de charges surfaciques sur barres

Charge de température

Charge de température sur barres

Charge de température sur barres

Générateur de vent

Norme de vent et données du terrain

Vent sur une ossature

Vent sur un plan

Vent sur un groupe de barres

Générateur de neige

Norme de neige et données du terrain

Neige sur une ossature

Neige sur un plan

Neige sur un groupe de barres

Charge sismique

Charge dynamique

Données généraux: période et synchronisation

Données de l'onde

Charge mobile

Bibliothèque des charges mobiles

Attribuer une charge mobile à un modèle

Aperçu des charges mobiles appliquées

Animation

Courbes de feu

Supprimer ou modifier des charges

Copier et coller des charges

Bouton droite souris

Translation

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Cas de charges

Pour définir les groupes de charges avec leurs coefficients de sécurité et leurs facteurs de combinaison, cliquez sur le bouton [image]. Ce dialogue vous offre une foule de possibilités pour définir rapidement et efficacement vos charges. Nous allons les analyser ci-après une à une.

Choix de la norme

Choix de la classe de service

Définir ou supprimer des cas de charges

Définir des incompatibilités

Définir des groupes de charges liés

Définir des sous-groupes de charges

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Choix de la norme

Avant tout, vous pouvez indiquer, à l'aide du menu déroulant en haut, quelle norme vous voulez utiliser. Ce choix est important car, d'une part, les coefficients de sécurité et les facteurs de charge peuvent être différents mais, d'autre part, la composition des combinaisons de charges peut également l'être pour chaque norme. Pour l'instant, il existe les normes suivantes:

  • EN 1990 (norme Européenne)
  • NEN 6702 (norme ancienne des Pays-Bas)
  • CTE (norme Espagnol)
  • ASCE 7-10 (LRFD) (norme Américain)
  • NEN 8700 (norme des Pays-Bas pour des rénovations et des aversions)
  • NSR-10 (norme Colombien)
  • SI 412 (norme Israélienne)
  • CM 66 (norme ancienne de la France)
  • SIA 260 (norme Suisse)

Étant donné qu'il est possible de dévier, au niveau national, des valeurs recommandées par l'Eurocode pour une série de coefficients (les "DAN"), vous pouvez sélectionner l'Annexe nationale correspondante en plus de EN 1990 (--). Une précision:

  • “BE” pour la Belgique
  • “DE” pour l'Allemagne
  • “FR” pour la France
  • “GB” pour la grande Bretagne
  • “LU” pour le Luxembourg
  • “NL” pour les Pays-Bas
  • “NO” pour le Luxembourg
  • “PL” pour la Pologne

En fonction de cette annexe, on vous demandera, en outre, sur base de quelle classe de conséquences ou de quelle durée de vie du projet, il faut déduire les facteurs de sécurité. Ces facteurs de sécurité sont liés à l'intérêt économique et/ ou social de l'ouvrage. Une classe de conséquence plus haute ou une durée de vie plus longue du projet entraîneront logiquement un facteur de sécurité plus élevé.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Choix de la classe de service

Si vous disposez d'une licence "Bois", vous pourrez aussi indiquer la classe de climat dans le haut. La classe de climat prend en compte le taux d'humidité et déterminera, conjointement avec la durée de contrainte qui peut être définie par groupe de charges, le facteur de modification kmod.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définir ou supprimer des cas de charges

Une fois que la norme est choisie, vous pouvez commencer à définir les différentes cas de charges.

Le nombre de cas de charges à définir n'est pas limité. A chaque cas de charges correspond une ligne du tableau.

  • Vous définirez un nouveau groupe de charges à la fin de ce tableau, en cliquant sur le bouton [image].
  • Pour créer un groupe de charges entre deux cas de charges existants, cliquez sur le bouton [image].
  • Le bouton [image] permet de supprimer de la liste un groupe de charges que vous aurez sélectionné.

Vous pouvez taper vous-même le nom de chaque cas de charges ou en sélectionner un dans le menu déroulant proposant une liste de cas de charges prévus par la norme. Si vous choisissez un cas de charges dans le menu déroulant, les coefficients de sécurité et les facteurs de combinaison se remplissent automatiquement conformément à la norme sélectionnée. Vous pouvez bien entendu toujours modifiés ces valeurs manuellement dans les champs prévus à cet effet.

Plus vous utilisez de cas de charges, plus il faudra préparer de combinaisons et plus le calcul prendra de temps. La case précédant le nom du cas de charges vous permet d'indiquer si vous voulez ou non intégrer ce cas de charges dans le calcul. Si la case est cochée [image], le cas sera intégré dans le calcul, sinon il ne le sera pas [image]. Si des charges créées dans un cas de charges ne doivent pas être prises en compte, elles sont atténuées (grisées) dans la configuration 'Charges'.

Parcourons les différentes facteurs et propriétés qu’on peut assigner à un cas de charge.

Les coefficients de sécurité γUGT-, γUGT+, γBGT- et γBGT+

Les deux premiers facteurs sont les coefficients de sécurité pour l'état-limite ultime: la première dans le cas où la charge a un effet défavorable, la seconde dans le cas où la charge a un effet favorable. En général, l'Eurocode prévoit que le coefficient le plus défavorable est égal à 1.35 pour les charges permanentes et que le plus favorable est égal à 1.00; pour les charges utiles, ces coefficients sont respectivement de 1.50 et 0.00. Les deux coefficients suivants sont les coefficients de sécurité correspondant à l'état-limite de service. En général, l'Eurocode prévoit que le coefficient le plus défavorable est égal à 1.00 pour les charges permanentes et que le plus favorable est également de 1.00; pour les charges utiles, ces coefficients sont respectivement de 1.00 et 0.00.

Les coefficients de combinaison ψ0, ψ1 et ψ2

  • ψ0 est le coefficient de combinaison avec lequel ce type de charge est appliqué lors du calcul en état-limite ultime (combinaison fondamentale) et dans les combinaisons rares en état-limite de service quand c'est une autre surcharge qui est la plus défavorable;
  • ψ1 est le coefficient de combinaison quand ce type de charge est appliqué lors du calcul dans la combinaison accidentelle dans l'état-limite ultime et dans la combinaison fréquente en état-limite de service quand cette surcharge est la plus défavorable;
  • ψ2 est le coefficient de combinaison avec lequel on applique ce type de charge lors du calcul dans la combinaison quasi-permanente en état-limite de service. Dans la combinaison accidentelle en état-limite ultime et dans la combinaison fréquente en état-limite de service, ce coefficient est appliqué quand c'est une autre surcharge qui est la plus défavorable.

Coefficient de corrélation φ

Les paramètres modales de la structure (modes propres et fréquences propres) sont calculés sur base de la répartition de la rigidité et des masses sur la structure.

  • La rigidité dépend seulement de la géométrie introduite de la structure.
  • Pour la répartition des masses, des masses sont relatées aux charges verticales (charges concentrées, réparties ou surfaciques) (0,981 kN → 100 kg) par le coefficient de corrélation φ (et encore multiplié par le facteur de combinaison ψ2 pour la norme EN 1990).

Pour l’EN 1990, Diamonds met le coefficient de corrélation égale à 1 pour tous les cas de charges, sauf pour les charges de température et les charges dynamiques pour lesquelles ce coefficient est mis égale à 0. Pour les normes qui n’ont pas de facteur de combinaison ψ2, le coefficient de corrélation est mis à 1 seulement pour le poids propre et les charges permanentes.

Le facteur de réduction ξ

Dans la colonne suivante, indiquez la valeur de ξ. Ce facteur de réduction intervient lorsque les combinaisons fondamentales sont générées conformément aux formules 6.10a et 6.10b. la formule 6.10b prévoit en effet une réduction des charges permanentes en fonction du facteur ξ et des facteurs de combinaisons prévues par les Documents d’Application Nationale (DAN). La valeur préconisée au niveau européen étant ξ = 0.85.

La combinaison pour la fissurabilité et le paramètre t0

Dans la colonne suivante, notez le moment (en jours) où les charges d'un groupe de charges donné seront appliquées après le coulage du béton. De même que le groupe de charges représentatif servant à déterminer la fissurabilité de la section, que vous indiquez via le menu déroulant à l'extrême droite, ces paramètres s'utilisent uniquement pour le calcul de la flèche fissurée dans le temps. Vous trouverez davantage d'informations sur ces colonnes dans le paragraphe Flèche fissurée dans le temps.

Le facteur modificatif kmod

Ce facteur tient compte du taux d'humidité (en fonction de la classe de climat que vous pouvez sélectionner dans le haut de la boîte de dialogue) et de la durée de la charge. Avec le facteur de matériau, kmod exerce une réduction sur les caractéristiques de résistance du bois. Le facteur de modification doit être défini différemment par groupe de charges. Le kmod utilisé en fin de compte dépend de la composition de la combinaison projetée. En particulier, le facteur de modification sera toujours fourni par le groupe de charges qui comprend les charges les plus passagères (donc celles pour lesquelles kmod est le plus élevé), à condition bien sûr que ce groupe de charges fasse partie de la combinaison envisagée. Nous noterons encore que cette colonne ne s'affiche que si votre licence permet le dimensionnement du bois.

'Charge' et 'Action'

Ces colonnes indiquent le caractère du groupe de charges. Ainsi, dans la fenêtre ci-dessus:

  • ‘Poids propre’ est une contrainte statique [image] normale [image].
  • ‘Charges permanentes’ est une contrainte statique [image] normale [image].
  • ‘Charge d'exploitation A’ est une contrainte statique [image] normale [image].
  • ‘Charge d'exploitation B’ est une contrainte dynamique [image] normale [image].
  • 'Neige (H<=1000m)’ est une contrainte statique [image] de neige [image].
  • ‘Vent’ est une contrainte statique [image] de vent [image].
  • ‘Température’ est une contrainte statique [image] de température [image].
  • ‘Sismicité’ est une contrainte sismique [image] dynamique [image].
  • ‘Ponts roulants’ est une contrainte statique [image] mobile [image].

Pour les ‘Charges d'exploitation’, vous avez le choix entre la charge statique ou dynamique . Vous basculerez entre les deux en cliquant sur l'icône dans la colonne 'Action'. Une charge sismique a évidement toujours un caractère dynamique.

Pour le vent, la neige, la température, la sismicité et des ponts roulants, le type est rempli automatiquement sans action de votre part.

Le type de charge (uniquement pour AISC)

Avec le type de charge, Diamonds sait alors quels facteurs de sécurité partiels il doit utiliser. Diamonds distingue les types de charges suivants:

  • Dead load [D]: poids propre et charges permanentes
  • Live load [L<]: charge d'exploitation ≤ 100 psf
  • Live load [L>]: charge d'exploitation > 100 psf
  • Roof live load [Lr]: charge d'exploitation sur le toit
  • Snow load [S]: neige
  • Wind load [W]: vent
  • Wind load [Wa]: vent pour état-limite de service (service)
  • Earth,groundwater, bulk materials à caractère permanent [H-]: Sol, l'eau souterraine, matériaux en vrac à caractère permanent
  • Earth, groundwater, bulk materials à caractère variable [H~]: Sol, l'eau souterraine, matériaux en vrac à caractère variable
  • Rain load [R]: pluie

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définir des incompatibilités

Diamonds vous offre la possibilité d'interdire la présence simultanée de plusieurs cas de charges, en configurant des 'groupes de charges incompatibles'. Lorsque des cas de charges sont indiqués comme incompatibles, Diamonds ne générera jamais lui-même de combinaisons dans lesquelles plusieurs de ces cas de charges se présenteront en même temps. Pour configurer ces incompatibilités, cliquez sur le bouton [image].

Pour rendre des cas de charges incompatibles avec un cas de charges donné, sélectionnez d'abord ce dernier dans le menu déroulant en haut de la boîte de dialogue et indiquez ensuite, en-dessous, les groupes de charges incompatibles.

Vous pouvez lever les incompatibilités avec le cas de charge sélectionné dans le menu déroulant en cliquant sur le bouton [image]. Par contre, si vous souhaitez supprimer toutes les incompatibilités, utilisez le bouton [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définir des groupes de charges liés

Diamonds vous offre la possibilité de lier plusieurs cas de charges qui ont toujours le même effet favorable ou défavorable, en configurant des 'groupes de charges liés'. Alors le nombre de combinaisons de charges sera réduite, car les combinaisons où un groupe de charge est favorable et l'autre lié au premier est défavorable seront éliminé par Diamonds.Un exemple peut être le 'Poids propre' et les 'charges permanentes'. Pour configurer ces liens, cliquez sur le bouton [image].

Pour rendre des cas de charges liés avec un cas de charges donné, sélectionnez d'abord ce dernier dans le menu déroulant en haut de la boîte de dialogue et indiquez ensuite, en-dessous, les groupes de charges liés.

Vous pouvez lever les liens avec le cas de charge sélectionné dans le menu déroulant en cliquant sur le bouton [image]. Par contre, si vous souhaitez supprimer toutes les liens, utilisez le bouton [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définir des sous-groupes de charges

Des sous-groupes de charges (“sub load cases”) peuvent être activée en cochant la case ‘Plusieurs cas de charge par groupe’.

Dans le tableau apparaissent trois colonnes supplémentaires. La colonne # vous permet de définir le nombre de sous-groupes (excepté le poids propre). Ensuite vous pouvez eux donner un nom et indiquer s’ils agissent ensemble ou pas. Diamonds distingue 2 scénarios différents

  • Plusieurs sous-groupes de charges permanentes

    Dans ce cas, il faut veillez à ce que la colonne TYPE soit en mode ‘toujours ensemble’ [image]. Toutes les charges de ce groupe sont alors supposées toujours être présentes et appliquées simultanément. Un exemple pratique de ce cas de figure est une charge permanente de plancher dont les composants (chape, isolant, finition, …) sont définies séparément. En utilisant les sous-groupes, vous maîtriser la façon dont la charge globale est définie et pouvez à tout moment intervenir et modifier un de ces composants.

  • Plusieurs sous-groupes de charges d’utilisation

    Dans ce cas, il faut veillez à ce que la colonne TYPE soit en mode ‘séparé’ [image]. Toutes les charges de ce groupe sont alors supposées ne jamais agir ensemble et sont d’emblée considérées comme étant incompatibles entre elles. Un exemple pratique de ce cas de figure sont les charges de vent provenant de différentes directions. Vous n’avez plus besoin, comme dans les versions précédentes de définir vous-même l’incompatibilité entre ces charges.

Pour supprimer des sous-groupes, il faut déduire le nombre (#) des groupes. Quand il n’y a qu’un seul sous-groupe, vous avez la possibilité de désactiver l’option ‘Plusieurs cas de charge par groupe’ ainsi que les trois colonnes seront cachées.

A l'aide de la touche CTRL, vous pouvez combiner des groupes de charges existants (auxquels des charges ont été attribuées) en une série de groupes de sous-charges. Pour ce faire, sélectionnez un premier groupe de charges et gardez la touche CTRL enfoncée tout en sélectionnant les autres groupes de charges. Une fois que vous avez sélectionné tous les groupes de charges à regrouper, cliquez en bas à gauche sur le bouton 'Combiner des groupes de charges'.

Notez que cette nouvelle fonctionnalité permet de limiter considérablement le nombre de groupes de charges. De plus, lors de la consultation des résultats, vous avez accès aux résultats globaux des groupes sans visualiser les résultats des sous-groupes, les courbes enveloppes étant automatiquement générées. Si vous souhaitez néanmoins consulter les résultats individuels des différents cas de charges (de vent par exemple), vous devez définir celles-ci comme cas de charges à part entière, et non pas comme des sous-cas de charges; sans oublier bien entendu de les rendre incompatibles entre elles.

Les sous-groupes de charges peuvent être dégroupés en sélectionnant le groupe de charges concerné et en cliquant sur le bouton [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Combinaisons de charges

Une fois que toutes les charges ont été créées dans les différents cas de charges, il vous reste encore à générer les combinaisons. La génération automatique des combinaisons de charges s'effectue sur la base des facteurs de sécurité et de combinaison affichés dans la boîte de dialogue servant à configurer les cas de charges. Pour générer automatiquement les combinaisons ou éventuellement les configurer vous-même, cliquez sur le bouton [image] de la palette 'Charges'.

Au départ, le tableau ne contient aucune combinaison. Cliquez sur le bouton [image] pour que Diamonds génère automatiquement les combinaisons.

En fonction de la norme, et éventuellement du document d’application nationale, qui a initialement été choisie dans le but de définir les coefficients de sécurité ainsi que les facteurs de combinaisons (voir Choix de la norme), vous devez ici préciser, dans le menu déroulant en haut à droite, sur base de quelle équation vous souhaitez générer les combinaisons fondamentales à l’ELU. Soit vous optez pour la solution classique mais conservative en sélectionnant la ligne ‘Eq. 6.10’, soit vous préférez utiliser les équations ‘Eq. 6.10a et 6.10b’. L’équation 6.10a prend également en compte une fraction ψ0 de la charge variable prédominante. L’équation 6.10b, quant à elle, réduit les charges permanentes d’un facteur ξ. Il va de soi que cette seconde option (‘Eq. 6.10a et 6.10b’) génère d’avantage de combinaisons mais mène très souvent à des réalisations plus économiques. Ces équations sont détaillées et abordées dans le manuel intitulé "Les Eurocodes dans Diamonds".

Pour les pays européens pour lesquels le document d’application nationale ne prévoit pas ces deux cas de figure, l’équation la plus appropriée est automatiquement appliquée.

Indiquez ensuite quelles combinaisons de charges doivent être préparées. Nous distinguons les combinaisons de charges classiques selon

  • l'état-limite ultime

    • ELU CF pour les combinaisons fondamentales
    • ELU CS pour les combinaisons sismiques
    • ELU IN pour les combinaisons incendie

  • les états-limites de service

    • ELS CR pour les combinaisons rares
    • ELS CF pour les combinaisons fréquentes
    • ELS QP pour les combinaisons quasi-permanentes

À l’aide du menu déroulant vous pouvez parcourir toutes les combinaisons par état-limite. De cette façon, vous gardez aperçu de toutes les combinaisons qui sont générés dans le projet. En utilisant le menu déroulant (en haut à gauche), vous pouvez afficher les combinaisons dans chaque état limite.

Si vous voulez créer vous-même votre propre combinaison, cliquez sur le bouton [image]. Au lieu de faire déterminer les coefficients de charge et les facteurs de combinaison par Diamonds, vous devez maintenant les indiquer vous-même.

Donnez dans cette fenêtre un nom à la nouvelle combinaison et indiquez le type de combinaison. Indiquez ensuite dans le tableau, pour chaque groupe de charges, le facteur Psi (ψ) ainsi que le facteur de charge (γ). Le facteur psi est le coefficient de combinaison pour le cas de charges en question. Le facteur γ est le facteur de sécurité à appliquer aux charges dans ce groupe de charges.

Pour supprimer une combinaison, sélectionnez-la dans la liste et cliquez ensuite sur le bouton [image]. Si vous désirez supprimer plusieurs combinaisons en une fois, utilisez la touche CTRL ou SHIFT du clavier pendant la sélection.

  • A l’aide de la touche CTRL vous sélectionnez deux combinaison dont Diamonds aussi sélectionnera les combinaisons intermédiaires.
  • A l’aide de la touche SHIFT vous pouvez les sélectionner une par une.

Les combinaisons sélectionnées sont marquées en bleu clair.

Sélectionnez avec SHIFT | Sélectionnez avec CTRL

Si vous voulez modifier une combinaison donnée, sélectionnez-la dans la liste et cliquez sur le bouton [image]. A ce moment s'ouvre la même boîte de dialogue que ci-dessus. Si vous générez automatiquement des combinaisons, celles-ci s'ajoutent aux combinaisons existantes. C'est pourquoi il est utile, dans de nombreux cas, de commencer par cliquer sur le bouton [image].

Enfin, nous mentionnons que l'aide du bouton [image], il est possible d'enregistrer un certain ensemble de combinaisons pour utilisation dans un autre projet. Pour ouvrir ensemble précédemment enregistré, cliquez sur le bouton [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Combinaisons dans le temps

Pour limiter les dommages causés aux murs de séparation, on impose généralement une limitation à la flèche supplémentaire. Dans cette situation, on est intéressé non seulement par la flèche maximale totale, mais aussi par la flèche à des moments spécifiques.

Pour générer les combinaisons des charges dans le temps, cliquez sur l'icône [image]. Soit vous faites générer automatiquement les combinaisons au moyen du bouton [image], soit vous créez manuellement les combinaisons à l'aide du bouton [image]. Dans le premier cas, toutes les combinaisons s'afficheront immédiatement dans le tableau, avec les facteurs correspondants.

Dans la première colonne, vous trouvez le nom de la combinaison. La flèche juste avant l'application d'une nouvelle charge est caractérisée par un signe moins. Une composition affectée d'un signe plus indique la flèche juste après l'application de la charge. Indiquez le moment des charges dans la fenêtre de définition des cas de charges.

Ensuite, les coefficients Ci et Cc(t)sont exprimés par combinaison, pour chaque groupe de charges. Le premier coefficient correspond à la partie de la flèche immédiate. Il va de soi que Ci sera toujours égal à 1 pour la charge permanente. Pour les autres charges, Ci peut être égal soit à ψ2 (la partie quasi-permanente de la charge variable), soit à 1. Le second coefficient Cc(t)représente la partie de la déformation qui survient par fluage du béton. Ce coefficient varie de 0, au moment où la charge est appliquée, à 1 à l'infini dans le cas d'une charge permanente et à ψ2 à l'infini dans le cas d'une charge variable.

Tant le nom de la combinaison que tous les facteurs peuvent être modifiés à tout moment dans la moitié inférieure de la fenêtre. En effet, les champs sont éditables si on sélectionne une colonne ad hoc. Le nouveau nom ou les nouveaux coefficients sont adaptés immédiatement dans le tableau.

Appliquez cette méthode pour définir une nouvelle combinaison. Pour supprimer une combinaison, sélectionnez-la dans la liste et cliquez ensuite sur le bouton [image]. Si vous souhaitez supprimer toutes les combinaisons, utilisez le bouton [image].

Sachez toutefois que le grand intérêt de la méthode est de pouvoir déterminer une différence de déformation d’un instant donné à un autre. C’est précisément cette différence qui doit être contrôlée lors du dimensionnement des dalles, plus que la déformée totale. Pour déterminer une différence de déformation entre deux moments indiqués dans le tableau de gauche, cliquez d’abord sur le bouton [image] et sélectionnez ensuite les deux lignes appropriées. Tout de suite, Diamonds générera en bas de la liste une combinaison de temps correspondant à la différence entre les deux.

Pour plus d'informations sur la méthode utilisée, voir Flèche fissurée dans le temps.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Les charges

Avant d'exposer les différents types de charges, nous commencerons par apprendre comment supprimer ou modifier des charges. Si vous désirez supprimer toutes les charges sur une ou plusieurs barres ou et/ou sur un ou plusieurs nœuds dans le cas de charge actif, sélectionnez d'abord les barres et les nœuds puis cliquez sur le bouton [image]. Par contre, si vous ne souhaitez pas supprimer toutes les charges, mais quelques-unes seulement, sur une barre ou un nœud donnés, double-cliquez sur la barre ou le nœud en question. Une liste de toutes les charges de l'élément double-cliqué dans le cas de charge considéré s'affiche alors. Vous pouvez modifier les valeurs dans cette liste (voir aussi Tableau ‘Données’)

Redimensionner les charges

Charges ponctuelles sur nœuds

Moments sur nœuds

Charges ponctuelles sur barres

Moments sur barres

Charges linéaires uniformément réparties et charges trapézoïdales

Torsion répartie

Charge surfacique

Générateur de charges surfaciques sur barres

Charge de température

Charge de température sur barres

Charge de température sur barres

Générateur de vent

Norme de vent et données du terrain

Vent sur une ossature

Vent sur un plan

Vent sur un groupe de barres

Générateur de neige

Norme de neige et données du terrain

Neige sur une ossature

Neige sur un plan

Neige sur un groupe de barres

Charge sismique

Charge dynamique

Données généraux: période et synchronisation

Données de l'onde

Charge mobile

Bibliothèque des charges mobiles

Attribuer une charge mobile à un modèle

Aperçu des charges mobiles appliquées

Animation

Courbes de feu

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Redimensionner les charges

Pour multiplier les charges avec un certain facteur:

  • Sélectionnez les éléments sur lesquels vous souhaitez redimensionner les charges.
  • Cliquer sur [image].
  • Indiquez quelles charges (point, ligne et / ou surface) doivent être adaptées.
  • Entrez le facteur.
  • Indiquez si vous souhaitez adapter seulement le groupe de charges actuel ou tous les groupes de charges.
  • Appuyez sur 'OK'.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charges ponctuelles sur nœuds

Commencez par sélectionner les nœuds dans la fenêtre modèle puis cliquez sur le bouton [image] pour faire apparaître la boîte de dialogue suivante:

Dans le premier feuillet vous pouvez indiquer les trois composantes de la charge ponctuelle suivant le repère d'axes global. Notez que la représentation de ces composantes pivote avec ce repère d'axes. L'application de couleurs rend la direction de la charge visible. Chaque couleur renvoie à un axe du repère d'axes global repris en bas à droite de la fenêtre modèle. Les petites flèches des charges ponctuelles indiquent le sens (positif) de la charge. Cette manière très visuelle de créer des charges simplifie très fort leur introduction.

Diamonds prévoit la possibilité d'introduire des charges concentrées suivant un angle. Pour ce faire, passez au second onglet 'Angle'.

Cet onglet vous permet de positionner la force concentrée en lui faisant former un angle avec le plan XZ α et un angle avec l'axe X β. En outre, vous avez le choix entre un repère d'axes global ou local. Dans le bas, vous introduirez la valeur et la position de la charge ponctuelle sur la barre.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Moments sur nœuds

Une fois que vous avez sélectionné les nœuds, cliquez sur l'icône [image].

Dans cette fenêtre, vous pouvez indiquer les trois composantes du moment suivant le repère d'axes global. Tout comme pour les charges ponctuelles, les dessins des nœuds pivotent avec le repère d'axes global. L'affichage en couleur montre autour de quel axe le moment est appliqué. La direction des petites flèches indique toujours le sens positif de la charge.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charges ponctuelles sur barres

Pour introduire une charge ponctuelle sur une ou plusieurs barres sélectionnées, cliquez sur l’icône [image].

Dans le premier feuillet vous pouvez indiquer les trois composantes de la charge ponctuelle suivant le repère d'axes global (première colonne avec icônes) ou locale (deuxième colonne avec icônes). Notez que la représentation de ces composantes globales pivote avec ce repère d'axes. L'application de couleurs rend la direction de la charge visible. Chaque couleur renvoie à un axe du repère d'axes global repris en bas à droite de la fenêtre modèle. Les petites flèches des charges ponctuelles indiquent le sens (positif) de la charge. Cette manière très visuelle de créer des charges simplifie très fort leur introduction.

En outre, le champs au-dessous permette de préciser la distance d’application de ces charges par rapport aux extrémités de la barre sur laquelle elles sont appliquées. Par défaut, l’origine de la barre correspond à l’extrémité avec la plus petite coordonnée ‘x’. Lorsque les deux extrémités ont la même coordonnée ‘x’, c’est le point avec la plus petite coordonnée ‘y’ qui sera choisi comme origine. Lorsque les coordonnées ‘x’ et ‘y’ sont identiques, c’est le plus petit ‘z’ qui déterminera l’origine.

Compte-tenu du fait que les mêmes critères s’appliquent pour fixer l’orientation de la barre, l’origine et l’extrémité d’une barre peuvent également être déduites de l’orientation des axes locaux de celle-ci.

Si le bouton [image] est actif, introduisez une distance absolue. Quand vous cliquez une fois sur le bouton [image], l'icône se transforme en [image]. Vous pouvez maintenant introduire une distance relative à l'aide d'un pourcentage. 0% correspond au début de la barre, 25% à L/4 depuis le point initial, 50% à L/2 depuis le point initial (= le milieu de la ligne), etc.

Diamonds prévoit la possibilité d'introduire des charges concentrées suivant un angle. Pour ce faire, passez au second onglet 'Angle'.

Cet onglet vous permet de positionner la force concentrée en lui faisant former un angle avec le plan XZ α et un angle avec l'axe X β. En outre, vous avez le choix entre un repère d'axes global ou local. Dans le bas, vous introduirez la valeur et la position de la charge ponctuelle sur la barre. Vous pouvez à nouveau choisir d'introduire la ‘Distance par rapport au début’ de manière absolue [image] ou relative [image].

Enfin, vous pouvez spécifier si la charge devrait être liée à un élément physique (voir Pour des charges).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Moments sur barres

Pour introduire un couple sur une ou plusieurs barres sélectionnées suivant les axes globaux, cliquez sur l’icône [image].

Ces charges peuvent être appliquées soit suivant le repère d'axes global de la structure (trois premières icônes), soit suivant le repère d'axes local de la barre (trois dernières icônes). Les axes globaux sont indépendants de la barre proprement dite et donc également de sa direction; les axes locaux sont pour ainsi dire attachés à la barre et changent en cas de modification de la position de la barre.

L'application de couleurs rend la direction de la charge globale visible. Chaque couleur renvoie à un axe du repère d'axes global repris en bas à droite de la fenêtre modèle. Les petites flèches indiquent le sens (positif) de la charge.

La direction souhaitée une fois indiquée, vous pouvez préciser les valeurs de début et de fin pour la charge répartie. Si le bouton [image] est actif, introduisez une distance absolue. Quand vous cliquez une fois sur le bouton [image], l'icône se transforme en [image]. Vous pouvez maintenant introduire une distance relative à l'aide d'un pourcentage. 0% correspond au début de la barre, 25% à L/4 depuis le point initial, 50% à L/2 depuis le point initial (= le milieu de la ligne), etc.

En outre, le champs au-dessous permette de préciser la distance d’application de ces charges par rapport aux extrémités de la barre sur laquelle elles sont appliquées. Par défaut, l’origine de la barre correspond à l’extrémité avec la plus petite coordonnée ‘x’. Lorsque les deux extrémités ont la même coordonnée ‘x’, c’est le point avec la plus petite coordonnée ‘y’ qui sera choisi comme origine. Lorsque les coordonnées ‘x’ et ‘y’ sont identiques, c’est le plus petit ‘z’ qui déterminera l’origine.

Enfin, vous pouvez spécifier si la charge devrait être liée à un élément physique (voir Pour des charges).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charges linéaires uniformément réparties et charges trapézoïdales

Pour appliquer des charges uniformément réparties ou trapézoïdales sur une ou plusieurs barres sélectionnées, cliquez sur l'icône [image].

Ces charges peuvent être appliquées soit suivant le repère d'axes global de la structure (trois premières icônes), soit suivant le repère d'axes local de la barre (trois dernières icônes). Les axes globaux sont indépendants de la barre proprement dite et donc également de sa direction; les axes locaux sont pour ainsi dire attachés à la barre et changent en cas de modification de la position de la barre. L'application de couleurs rend la direction de la charge globale visible. Chaque couleur renvoie à un axe du repère d'axes global repris en bas à droite de la fenêtre modèle. Les petites flèches indiquent le sens (positif) de la charge.

Pour des charges globales, vous devez indiquer si la valeur est une valeur réelle par mètre de longueur de barre ( [image]) ou une valeur projetée par mètre de longueur horizontale ( [image]). Si vous sélectionnez la seconde option, la valeur par mètre de longueur de barre sera inversement proportionnelle à l'inclinaison de la barre.

Précisez les valeurs de début et de fin pour la charge répartie. Si le bouton [image] est actif, introduisez une distance absolue. Quand vous cliquez une fois sur le bouton [image], l'icône se transforme en [image]. Vous pouvez maintenant introduire une distance relative à l'aide d'un pourcentage. 0% correspond au début de la barre, 25% à L/4 depuis le point initial, 50% à L/2 depuis le point initial (= le milieu de la ligne), etc.

Si vous modifiez la valeur du premier champ, la même valeur apparaît automatiquement dans le second et vous obtenez alors une charge uniformément répartie. Si vous modifiez également la valeur du second champ, la valeur du premier champ reste inchangée et vous obtenez alors une charge trapézoïdale.

En outre, deux autres champs permettent de préciser les distances d’application de ces charges par rapport aux extrémités de la barre sur laquelle elles sont appliquées. Par défaut, l’origine de la barre correspond à l’extrémité avec la plus petite coordonnée ‘x’. Lorsque les deux extrémités ont la même coordonnée ‘x’, c’est le point avec la plus petite coordonnée ‘y’ qui sera choisi comme origine. Lorsque les coordonnées ‘x’ et ‘y’ sont identiques, c’est le plus petit ‘z’ qui déterminera l’origine. Compte-tenu du fait que les mêmes critères s’appliquent pour fixer l’orientation de la barre, l’origine et l’extrémité d’une barre peuvent également être déduites de l’orientation des axes locaux de celle-ci.

Enfin, vous pouvez spécifier si la charge devrait être liée à un élément physique (voir Pour des charges).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Torsion répartie

Pour appliquer une torsion répartie sur une ou plusieurs barres sélectionnées, cliquez sur l'icône [image].

Une telle charge sera toujours définie localement.

Dans cette fenêtre vous pouvez préciser les valeurs de début et de fin de la charge de torsion. Si vous modifiez la valeur du premier champ, la même valeur apparaît automatiquement dans le second et vous obtenez alors une charge uniformément répartie. Si vous modifiez également la valeur du second champ, la valeur du premier champ reste inchangée et vous obtenez alors une charge trapézoïdale.

En outre, deux autres champs permettent de préciser les distances d’application de ces charges par rapport aux extrémités de la barre sur laquelle elles sont appliquées. Si le bouton [image] est actif, introduisez une distance absolue. Quand vous cliquez une fois sur le bouton [image], l'icône se transforme en [image]. Vous pouvez maintenant introduire une distance relative à l'aide d'un pourcentage. 0% correspond au début de la barre, 25% à L/4 depuis le point initial, 50% à L/2 depuis le point initial (= le milieu de la ligne), etc. Par défaut, l’origine de la barre correspond à l’extrémité avec la plus petite coordonnée ‘x’. Lorsque les deux extrémités ont la même coordonnée ‘x’, c’est le point avec la plus petite coordonnée ‘y’ qui sera choisi comme origine. Lorsque les coordonnées ‘x’ et ‘y’ sont identiques, c’est le plus petit ‘z’ qui déterminera l’origine.

Enfin, vous pouvez spécifier si la charge devrait être liée à un élément physique (voir Pour des charges).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charge surfacique

Pour appliquer une charge surfacique sur une ou plusieurs plaques, cliquez sur l'icône [image].

Une charge surfacique peut être appliquée soit suivant le repère d'axes global de la structure (trois premières icônes), soit suivant le repère d'axes local de la surface (dernière icône). Dans le dernier cas, il s'agit toujours d'une charge perpendiculaire à la plaque sélectionnée.

L'application de couleurs rend la direction de la charge globale visible. Chaque couleur renvoie à un axe du repère d'axes global repris en bas à droite de la fenêtre modèle. Les petites flèches indiquent le sens (positif) de la charge.

Si vous optez pour une charge surfacique suivant le repère d'axes global, vous devez également indiquer si la valeur créée est une valeur par m² de surface ( [image]) ou par m² de surface horizontale (projetée) ( [image]).

Outre la direction, vous devez également indiquer la grandeur de la charge répartie. Nous distinguons 3 scénarios:

  • Dans le cas d’une charge uniformément répartie, il suffit d’indiquer une valeur unique.
  • Si vous souhaitez appliquer une charge variant linéairement en fonction de la profondeur, il faut indiquer la valeur de la charge pour deux niveaux précis. Cette possibilité est particulièrement intéressante pour définir des pressions d’eau ou de sol. Si vous appliquez simultanément ce type de charges sur différentes surfaces, n’oubliez pas d’orienter préalablement tous les axes locaux de façon cohérente (tous vers l’intérieur ou tous vers l’extérieur).

  • Finalement, pour les charges surfaciques non uniformes, la valeur de la charge doit être définie pour trois points indépendants. En plus de la surface, sélectionnez trois points distincts appartenant à la surface. Les coordonnées de ces trois points sont créées automatiquement dans les champs de données. Cela représente souvent un grand gain de temps. Sinon, Diamonds remplit les coordonnées des 3 vecteurs unitaires.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Générateur de charges surfaciques sur barres

Le générateur de charges surfaciques est un module de calcul qui permet de traduire une charge surfacique en une charge répartie sur les barres de support.

Dans la configuration 'Charges', sélectionnez toutes les barres qui doivent supporter la charge et cliquez sur le bouton [image] dans la palette correspondante. Notez bien que la fonction est disponible dès le moment où deux barres sont sélectionnées et que celles-ci se situent dans le même plan.

A l'aide de la figure du haut, vous pouvez vérifier si le transfert de charge a été interprété correctement. En particulier, Diamonds recherche toutes les surfaces à définir possibles qui se situent entre les barres sélectionnées et sur lesquelles la charge surfacique est supposée agir. Si les barres sélectionnées ne forment pas une surface fermée, le programme imposera lui-même des limites qui s'afficheront en rouge. On présume que seules les barres sélectionnées, qui sont tracées en gras dans la figure, supporteront la charge.

Dans la partie suivante de la boîte de dialogue, définissez l'importance et la direction de la charge surfacique. Avant tout, vous avez le choix d'appliquer la charge soit perpendiculairement au plan (des barres sélectionnées) soit suivant un des axes globaux. L'application de couleurs permet de visualiser la direction de la charge globale. Chaque couleur renvoie à un axe du repère d'axes global repris en bas à droite de la fenêtre modèle. Les petites flèches indiquent le sens (positif) de la charge. Si vous optez pour une charge surfacique suivant le repère d'axes global, vous devez également indiquer si la valeur introduite est une valeur par m² de surface ( [image]) ou par m² de surface horizontale (projetée) (

Dans la partie inférieure de la fenêtre, nous définissons enfin quelques paramètres en rapport avec la manière dont la charge uniformément répartie est convertie en charge au niveau des barres. La procédure est expliquée brièvement ci-après.

Les surfaces fictives seront partagées en plusieurs triangles, un processus que nous appelons triangulation et dont la finesse peut être déterminée par l'utilisateur à l'aide d'une barre de défilement. Le nombre de triangles et, par conséquent, la finesse de la triangulation augmente au fur et à mesure que vous déplacez la barre de défilement vers la gauche. Il va de soi qu'un maillage plus fin produira une plus grande précision, mais qu'il exigera un temps de calcul plus long. Si vous le souhaitez, vous pouvez visualiser la triangulation en cochant la case correspondante.

Ensuite, on détermine le centre de gravité de chacun des éléments ainsi que la charge P sur ces triangles.

Si nous divisons ensuite les barres environnantes (vers lesquelles la charge sera déviée) en plusieurs petites barres dont les nœuds sont numérotés de 1 à j, et que nous calculons la distance di entre chacun de ces points et le centre de gravité d'un triangle, il est possible de calculer, pour chaque point de la barre, quelle partie (Fi) de la charge P sera déviée vers ce point spécifique à l'aide de la formule suivante.

Il en découle que la majeure partie de la charge est déviée vers les points qui se trouvent le plus près du triangle considéré.

Une fois que cette procédure a été appliquée pour tous les triangles, on peut évaluer la charge totale pour chaque point. La dernière étape consiste à convertir les charges sur les points discrets en une charge répartie sur la barre. Plus précisément, chaque barre est fractionnée en plusieurs tronçons pour lesquels la charge est supposée constante. C'est à l'utilisateur de l'introduire. La valeur 1 correspond à une charge constante pour toute la barre.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charge de température

Diamonds vous permet de tenir compte de contraintes supplémentaires dues à l'empêchement de la dilatation ou du retrait d'éléments soumis à une variation de température. Cette dilatation ou ce retrait thermiques sont calculés à l'aide du coefficient de dilatation thermique. Ce coefficient dépend du matériau et est sauvegardé dans la bibliothèque de matériaux (voir La bibliothèque des matériaux).

Dans le cas d'une variation globale de la température, l'ensemble de la section subit un réchauffement (+) ou un refroidissement (-) régulier. Les gradients de température par contre, provoquent un réchauffement ou un refroidissement irrégulier, et donnent de ce fait lieu à des moments supplémentaires si la section ne peut pas pivoter librement.

Charge de température sur barres

Charge de température sur barres

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sur des barres

Pour attribuer une variation ou un gradient de température à une ou plusieurs barres sélectionnées, cliquez sur l'icône [image] dans la palette 'Charges':

  • : à la suite d'une variation globale de la température (N)
  • : la suite d'un gradient de température suivant l'axe local z' (My')
  • : à la suite d'un gradient de température suivant l'axe local y' (Mz')

Les efforts entre parenthèses désignent les efforts internes qui se créeront si la déformation est empêchée.

Une modification globale de la température est caractérisée par deux petites flèches dans le prolongement de la poutre. Si les flèches sont pointées l'une vers l'autre ( → ← ), il s'agit d'une baisse de température (la poutre va se contracter). Si les flèches sont pointées dans des directions opposées ( ← →), il s'agit d'une hausse de température (la poutre va se dilater).

Un gradient de température est indiqué par deux petites flèches perpendiculaires (↓↓ ou ↑↑) à l'axe local de la barre suivant lequel le gradient est appliqué. Diamonds interprète un gradient de température de +50°C, p.ex., comme suit: une face de la poutre se réchauffe de 25°C, l'autre face refroidit de 25°C.

La flèche pointe toujours dans la direction du côté chaud.

Visitez notre site Web de support pour des exemples:http://buildsoftsupport.com/knowledge-base/how-to-define-a-temperature-load/

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sur des surfaces

Pour affecter une modification globale de la température ou un gradient de température à une ou plusieurs plaques, cliquez sur l'icône [image]:

  • : à la suite d'une variation globale de la température
  • : à la suite d'un gradient de température suivant l'axe local y'

Le principe est le même que pour les barres. Une modification de la température globale est représentée par le symbole ( [image] ou [image] ) dans le plan de la plaque, respectivement pour une hausse et une baisse de la température. Un gradient de température est caractérisé par une flèche perpendiculaire au plan (↓ ou ↑ ).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Générateur de vent

Le générateur de vent est applicable pour des ossatures, des planes et des groupes de barres. La méthode est analogue pour tous:

  • définir le niveau du sol naturel (Niveau du sol)
  • définir les paramètres de vent généraux [image] (Norme de vent et données du terrain)
  • sélectionner ensuite les éléments et appliquez-y le vent:
    • pour des barres [image] (voir Vent sur une ossature)
    • pour des planes [image] (voir Vent sur des surfaces)
    • pour des groupes de barres [image] (voir Vent sur un groupe de barres)

Remarques:

  • La génération de vent n'a pas de sens si vous n'avez pas réglé le niveau du sol naturel!
  • Les charges de vent sont toujours mises sur le groupe physique (Comment créer un groupe physique?). Si vous définissez correctement les groupes physiques, vous pourrez modifier les longueurs des barres partielles internes sans devoir redéfinir les charges de vent.
  • Nous insistons sur le fait que le générateur de vent intégré dans Diamondsa été conçu pour des bâtiments. Il ne convient nullement pour des panneaux publicitaires, des ponts, etc.

Norme de vent et données du terrain

Vent sur une ossature

Vent sur un plan

Vent sur un groupe de barres

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Norme de vent et données du terrain

Sélectionnez la générateur de vent et les paramètres du terrain en regard de [image] .

Norme

Commencez par sélectionner la norme et l'annexe nationale suivant laquelle vous aimeriez générer le vent:

  • EN 1991-1-4 + annexes nationales (norme Européenne)
  • ENV 1991-2-4 (norme ancienne Européenne)
  • SE-AE (norme Espagnol)
  • NEN 6702 (norme ancienne des Pays-Bas)
  • ASCE 7-10 (norme Américain)
  • NSR-10 (norme Colombien)
  • SI 414 (norme Israélienne)
  • SIA 261 (norme Suisse)

L'explication ci-dessous s'applique à la norme EN 1991-1-4.

Paramètres de structure

Dans la partie supérieure de cette fenêtre, indiquez si vous souhaitez prendre en compte le manque de corrélation (=cohérence) entre le vent sur les façades. Dans ce cas, le vent sur les façades est majoré d'un facteur 0,85. En Belgique, en Luxembourg et en France, ce choix n'est pas autorisé, mais il l'est aux Pays-Bas. Notez encore le coefficient structurel CsCd. Ce coefficient tient compte des effets dus à la non-simultanéité de la poussée extrême sur toute la surface (Cs) ainsi que du risque de vibrations dû à la turbulence (Cd).

Facteur de saison, facteur de direction et facteur de probabilité

Notez ici le facteur de direction du vent cdir et le facteur de saison cseason qui seront multipliés par la vitesse de vent de référence de base vb,0. Ces facteurs ont été déterminés au niveau national, mais ils peuvent être assimilés à 1,0 dans la plupart des cas.

Le facteur de probabilité cprob prend en compte la durée de vie de conception. Un facteur de probabilité cprob=1 équivaut à une durée de vie de conception de 50 ans. Si vous indiquez une autre durée de vie de conception dans la fenêtre réservée aux groupes de charges, Diamonds déterminera le facteur de probabilité cprob selon EN 1991-1-4 §4.2 Remarque 4.

Vitesse de vent

Enfin, vous pouvez soit noter immédiatement la pression de vent de référence qb qui sert de base pour le calcul des pressions de vent sur une surface, soit définir explicitement tous les paramètres qui interviennent dans le calcul de cette pression de vent du référence.

Soit vous introduisez manuellement la vitesse de vent de référence de base vb,0, soit vous faites calculer cette valeur par Diamonds en sélectionnant le pays concerné dans le menu déroulant. Lorsqu'il s'avère qu'on distingue plusieurs zones de vent pour un pays donné, une carte s'affiche, sur laquelle vous pouvez indiquer la zone souhaitée. Notez enfin encore la densité de l'air (=1,25kg/m³), et la pression de vent de référence peut être calculée sur base des paramètres ci-dessus.

Type de terrain

Les autres paramètres de cette boîte de dialogue concernent le calcul du coefficient d'exposition ce(z). Commencez tout d'abord par déterminer la catégorie de terrain (de 0 à IV), en cliquant sur le bouton [image].

Pente

Si, en outre, le bâtiment se situe sur une pente, il est possible d'en tenir compte au moyen du coefficient orographique co(z). Soit vous introduisez vous-même le pourcentage d'inclinaison et le facteur s, soit vous les faites calculer par Diamonds.

Si le bâtiment se trouve à proximité d'un plateau, c'est la première option qui s'applique. Si le bâtiment se trouve sur une colline, c'est la seconde option qui prévaut. Toutes les dimensions peuvent être introduites correctement à l'aide d'un dessin détaillé.

Remarques:

  • Les paramètres du terrain peuvent être consultés dans la gestion des rapports (voir L'onglet 'Charges').
  • La modification de la norme ou des paramètres du terrain fait disparaître les charges de vent générées précédemment!

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vent sur une ossature

Sélectionnez l'ossature (ou portique) sur laquelle vous désirez générer du vent, et le bouton [image] ou [image] s'activera. Notez bien que l'ossature sélectionnée doit se situer dans un plan 2D.

Cliquez sur le bouton [image] pour le vent sur une ossature. L'écran ci-dessous s'affiche alors (selon EN 1991-1-4):

  • Un premier cadre vous donne le dessin de la structure avec, encadré en rouge, les points d’extrémités considérés. Par défaut, Diamonds va rechercher le point libre le plus en bas à gauche et le point le plus en bas à droite comme point respectivement de début et de fin. Toutefois, si un appui a été défini en un point, ce point sera prioritaire au niveau recherche des extrémités du contour défini.

    L’exemple visuel ci-dessous permet de mieux comprendre :

    Dans le premier cas, aucun appui n’a été défini alors que dans le second cas, des appuis ont été définis en bas des deux poteaux. Toutefois, le point de départ, c'est-à-dire celui numéroté ‘1’ peut être modifié manuellement en cliquant avec le bouton gauche sur une extrémité possible (avec un petit carré blanc). De même, le deuxième extrémité peut être modifiée de la même manière mais en utilisant le bouton droit de la souris. Toutefois, il faut respecter le fait que le point ‘1’ est toujours à gauche du point ‘2’.

    Dans le cadre 'Géométrie', notez la profondeur totale de la construction ainsi que la position de l'ossature sélectionnée par rapport à la façade principale (FRONT) et la distance jusqu'à l'ossature précédente et l'ossature suivante. La figure de droite vous montre en plan terrier la position de cette ossature par rapport à l'avant et à l'arrière du bâtiment. L'ossature précédente et l'ossature suivante sont également représentées (en pointillé). Le repère d'axes en haut à gauche définit clairement l'orientation du bâtiment. La charge de vent qui pèse sur le portique sélectionné tient donc compte des distances entre les portiques successifs ainsi que de leur distance par rapport à la façade frontale. De la sorte, on calcule aussi correctement le coefficient de pression extérieure cpe qui varie en fonction de la profondeur de la construction.

    Sélectionnez l'option [image] si vous voulez générer le vent sur une toiture isolée (voir Vent sur une toiture isolée).

  • Dans les 4 onglets indiquez quelles charges de vent doivent être générées et dans quel cas ces charges doivent être classées. Notez bien que Diamonds vous permet de générer en une seule fois 24 charges de vent différentes.

    • Il distingue les 4 directions:
      • vent de gauche à droite
      • vent de droite à gauche
      • vent d'avant en arrière
      • vent d'arrière en avant

    • Deuxièmement, la norme fait une différence entre du vent ascendant (sous-pression) et du vent descendant (surpression) avec des coefficients de pression externe cpe adaptés. Nous avons obtenu 12 cas:

      • vent de gauche à droite nous avons 4 cas
      • vent de droite à gauche nous avons 4 cas
      • vent d'avant en arrière nous avons 2 cas
      • vent d'arrière en avant nous avons 2 cas
    • Enfin, vous pouvez spécifier d'un coefficient de pression interne alternatif cpi pour tous les cas de vent. ça va doubler le nombre de cas de vent, donc 24 cas.

  • Bien que le générateur de vent de Diamonds ne puisse être appliqué que sur un portique 2D, le générateur a un caractère 3D. En particulier, lorsqu'on envisagera une direction de vent déterminée, la pression ou l'aspiration exercées sur les surfaces parallèlement à cette direction du vent seront également prises en compte. Par exemple, si le vent souffle de gauche à droite (et donc parallèlement au portique), une force d'aspiration s'exercera aussi sur les deux façades frontales. Par ailleurs, si une charge de vent est exercée sur la façade frontale, il y a lieu d'envisager également les forces de pression et d'aspiration exercées sur les autres portiques. Cela vaut donc la peine d'envisager tous les cas de charge, quelle que soit la position du portique en question.

    Un portique situé au bord de la construction subira non seulement une charge de vent dans le plan mais aussi une pression ou une aspiration depuis le plan. Comme, bien souvent, toutes les barres de la façade frontale ne seront pas prévues pour reprendre le vent, vous pouvez désélectionner les barres qui ne reprendront pas de vent dans un deuxième onglet.

Le coefficient de pression interne

Si Diamonds détermine les coefficients de pression externe cpe de manière tout à fait automatique, le coefficient de pression interne dépend, pour sa part, de la taille et de la répartition des ouvertures et doit, de ce fait, être défini par l'utilisateur.

La boîte de dialogue suivante s'affiche quand vous cliquez sur le bouton [image]:

Dans le cas d'une construction à parois verticales, cpi est calculé en fonction des ouvertures permanentes et temporaires dans le bâtiment. Vous trouvez dans le bas les limites dans lesquelles se situe cpi par direction du vent. L'utilisateur doit indiquer avec quel cpi on peut poursuivre les calculs ou il peut, s'il le souhaite, noter lui-même une valeur dans le champ prévu à cet effet.

Remarque: dans les cas où il n'est pas possible de déterminer la répartition et la taille des ouvertures, on peut prendre la plus défavorable des deux valeurs suivantes pour cpi: +0,2 et -0,3. Il possible de sélectionner ces valeurs directement du menu déroulant de la fenêtre principale du vent.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vent sur des surfaces

Sélectionnez les surfaces sur lesquelles vous souhaitez générer du vent. Notez bien que les surfaces sélectionnées ne doivent pas se trouver dans le même plan. Cliquez sur le bouton [image]. Vous pouvez ensuite générer jusqu'à 4 cas de vent à la fois.

  • Sélectionnez le groupe de charges dans lequel Diamonds doit placer le vent.
  • Introduisez les coefficients de pression interne cpi et externe cpe. La pression interne wi, la pression externe we et la pression nette de vent wn sont calculées automatiquement.

Assurez-vous que le repère d'axes locaux des surfaces soit orienté dans le même sens: soit tous les axes locaux y' sont orientés vers l'extérieur, soit tous les axes locaux y' sont orientés vers l'intérieur.

MAL

le repère d'axes locaux des surfaces ne soit pas orienté dans le même sens

BIEN le repère d'axes locaux soit orienté vers l'extérieur | BIEN le repère d'axes locaux soit orienté vers l'intérieur

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vent sur un groupe de barres

Sélectionnez le groupe de barres sur lequel vous désirez générer du vent, et le bouton [image] ou [image] s'activera. Cliquez sur le bouton [image] pour le vent sur un groupe de barres. L'écran ci-dessous s'affiche. La moitié supérieure de cette fenêtre fonctionne de la même manière que le générateur de charge surfacique sur les barres (voir Générateur de charges surfaciques sur barres). Dans la moitié inférieure de cette fenêtre vous sélectionnez le groupe de charges dans lequel Diamonds doit placer le vent.

Introduisez ensuite les coefficients de pression interne cpi et externe cpe. La pression interne wi, la pression externe we et la pression nette de vent wn sont calculées automatiquement.

Les barres sélectionnées doivent être situées dans le même plan.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Générateur de neige

Le générateur de neige est applicable pour des ossatures, des planes et des groupes de barres. La méthode est analogue pour tous:

  • définir les paramètres de vent généraux [image] ( Norme de neige et données du terrain)
  • sélectionner ensuite les éléments et appliquez-y le vent:
    • pour des barres [image] (voir Neige sur une ossature )
    • pour des planes [image] (voir Neige sur des surfaces)
    • pour des groupes de barres [image] (voir Neige sur un groupe de barres)

Remarques:

  • Les charges de neige sont toujours mises sur le groupe physique (Comment créer un groupe physique?). Si vous définissez correctement les groupes physiques, vous pourrez modifier les longueurs des barres partielles internes sans devoir redéfinir les charges de neige.

Norme de neige et données du terrain

Neige sur une ossature

Neige sur un plan

Neige sur un groupe de barres

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Norme de neige et données du terrain

Sélectionnez la norme de neige et les paramètres du terrain avec [image] .

Norme

Commencez par sélectionner la norme et l'annexe nationale suivant laquelle vous aimeriez générer la neige:

  • EN 1991-1-3 + annexes nationales (norme Européenne)
  • ENV 1991-2-3 (norme ancienne Européenne)
  • SE-AE (norme Espagnol)
  • NEN 6702 (norme ancienne des Pays-Bas)
  • SI 412 (norme Israélienne)
  • SIA 261 (norme Suisse)

L'explication ci-dessous s'applique à la norme EN 1991-1-3.

Paramètres du terrain

Indiquez ensuite la région pour laquelle vous souhaitez générer la neige. La valeur caractéristique de la charge de neige sk sur le sol, dépend de la situation géographique et de l'altitude par rapport au niveau de la mer. L'Eurocode prévoit une carte et le tableau correspondant d'où l'on peut déduire la valeur caractéristique de la charge de neige pour les différents Etats membres de l'Union européenne (voir Annexe C dans EN 1991-1-3). Vous avez l'opportunité de prendre en compte la durée de vie de conception. Ce choix est autorisé en Belgique, en Luxembourg, et aux Pays-Bas mais il ne l'est pas en France.

Coefficient d'exposition et coefficient thermique

Le coefficient d'exposition Ce permet de tenir compte des effets d'érosion du vent. Le coefficient thermique Ct tient compte de l'effet de déperdition thermique par le toit. En Belgique, en Luxembourg et aux Pays-Bas, le coefficient d'exposition Ce est égal à 1. En Belgique, en Luxembourg, en France et aux Pays-Bas le coefficient thermique Ct est égal à 1.

Débordement de la neige aux bords

Pour les zones situées à une altitude supérieure à 800m au-dessus du niveau de la mer, il y a lieu de tenir compte de la neige en surplomb. Cela se traduit par une charge verticale supplémentaire sur la rive de toiture. Vous décidez vous-même si vous voulez prendre cette charge supplémentaire en compte en cochant ou non la case correspondante.

Remarques:

  • Les paramètres du terrain peuvent être consultés dans la gestion des rapports (voir L'onglet 'Charges').
  • La modification de la norme ou des paramètres du terrain fait disparaître les charges de neige générées précédemment!

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Neige sur une ossature

Sélectionnez l'ossature (ou portique) sur laquelle vous désirez générer de la neige, et le bouton [image] ou [image] s'activera. Notez bien que l'ossature sélectionnée doit se situer dans un plan 2D. Cliquez sur le bouton [image] pour la neige sur une ossature.

L'écran ci-dessous s'affiche alors:

Diamonds recherche automatiquement le périmètre du portique sélectionné, qui s'affiche en gras. Sur base de ce contour, le logiciel calcule la charge de neige sur toutes les barres horizontales et les barres obliques éventuelles.

  • Tout d'abord, définissez la largeur de la surface enneigée (perpendiculairement au plan du portique) qui doit effectivement être reprise par le portique. Pour un portique central, il s'agit donc de la distance intermédiaire, tandis que, pour un portique situé en bordure, cette distance est égale à la moitié.
  • Enfin, indiquez dans la partie inférieure quelles charges de neige doivent être générées et dans quel groupe de charges elles doivent être classées. La norme distingue des situations de charge en fonction de la forme du toit. Diamonds considère ensuite la situation de la forme du toit qui correspond le mieux au contour réel du toit. Les facteurs de forme corrects sont également pris en compte pour les toits attenants à des ouvrages plus hauts, tel que prescrit dans la norme.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Neige sur des surfaces

Sélectionnez les surfaces sur lesquelles vous souhaitez générer de la neige. Notez bien que les surfaces sélectionnées ne doivent pas se trouver dans le même plan. Cliquez sur le bouton [image] .

Après:

  • sélectionnez le groupe de charges dans lequel Diamonds doit placer la neige.
  • remplissez le coefficient de forme μi.

Assurez-vous que le repère d'axes locaux des surfaces soit orienté dans le même sens: soit tous les axes locaux y' sont orientés vers l'extérieur, soit tous les axes locaux y' sont orientés vers l'intérieur (voir Vent sur des surfaces).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Neige sur un groupe de barres

Sélectionnez l'ossature (ou portique) sur laquelle vous désirez générer de la neige, et le bouton [image] ou [image] s'activera. Cliquez sur le bouton [image] pour la neige sur un groupe de barres. L'écran ci-dessous s'affiche.

La moitié supérieure de cette fenêtre fonctionne de la même manière que le générateur de charge surfacique sur les barres (voir Générateur de charges surfaciques sur barres). Dans la moitié inférieure de cette fenêtre

  • vous sélectionnez le groupe de charges dans lequel Diamonds doit placer la neige
  • vous remplissez le coefficient de forme μi.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charge sismique

Quand vous avez créé un cas de charge sismique, vous pouvez définir le spectre sismique via [image] . L'écran suivant s'affiche:

Indiquez d'abord selon quelle norme vous souhaitez définir le spectre sismique. Vous avez le choix entre:

  • EN 1998-1:2004 + annexes nationales (EU)
  • ASCE 7-10 (USA)
  • INPRES-CIRSOC (ARG)
  • NSR-10 (norme Colombien)
  • NCH 433 (CHL)
  • NCSE-02 (norme Espagnol)
  • SI 413 (norme Israélienne)
  • NPR 9998 (norme des Pays-Bas)

(Dans la figure ci-dessus, nous avons opté pour EN 1998-1:2004.)

Un spectre sismique se compose de:

  • Un spectre horizontal dans la direction u
  • Un spectre horizontal dans la direction v
  • Et éventuellement un spectre vertical dans la direction w

L'accélération de réponse en fonction de la période modale est reprise pour chaque spectre (direction u, v et w) dans le graphique.

  • Introduisez ensuite l'angle entre la direction du spectre et le repère d'axes global. La figure vous montre comment le spectre pivote alors par rapport au repère d'axes global.

    Si l'angle est de 0°, les directions u et v correspondent respectivement avec la direction globale X et Z.

  • Indiquez alors si vous désirez tenir compte de l'élément vertical ou non.
  • Lorsque les modes propres sont indépendants les uns des autres, la réponse totale peut se calculer avec la somme des carrés. Si les modes propres sont interdépendants, il faudra recourir à la méthode Complete Quadric Combination (méthode CQC).
  • En cochant l'option 'Appliquer correction quasi statique', le manque de masse modale effective est compensé (voir plus loin dans cette rubrique).
  • Sélectionnez le type de spectre et type de sol. Vous avez le choix entre un type de spectre I et un type II. Pour le type de sol, vous avez le choix entre des types de A à E.
  • Sélectionnez aussi la catégorie d'importance du bâtiment. Vous avez le choix entre les classes de I à IV. Selon la catégorie d'importance sélectionnée, Diamonds va remplir pour vous le facteur d'importance γI. Si vous optez pour la catégorie d'importance ‘--‘, vous pourrez introduire une valeur pour le facteur d'importance γI proprement dit.
  • Introduisez ensuite les facteurs de comportement qu,qv,qw (par direction),
  • L'accélération du sol
  • Le facteur de déplacement

Vous pouvez sauvegarder un spectre défini dans un fichier TXT externe au moyen du bouton [image] en bas de cette fenêtre. Vous pouvez introduire en mémoire un spectre préexistant (au format TXT) via [image]. Le spectre chargé en Diamonds, devrait être un spectre relative avec des valeurs entre 0 et 1 sur les deux axes. Vous redimensionner le spectre avec l'accélération de référence et la période de référence.

Remarques:

  • L'action sismique est supposée agir sur tous les points d'appui en même temps.
  • Vous pouvez supprimer une action sismique en cliquant sur [image] .

  • Si vous avez une masse modale effective insuffisante (< 90%) pour une ou plusieurs directions, vous pouvez:

    • Soit reprendre le calcul avec plus de modes propres.
    • Soit cocher l'option 'Appliquer correction quasi-statique'. A ce moment, toutes les résultats pour les directions pertinentes avec une masse modale < 90% seront divisé par la massa obtenu. Par exemple: 40% => division par 0,4.
  • Une action sismique est représentée par le symbole [image]. Ce symbole est toujours repris dans le plan XZ. Avec ce symbole suit aussi l'information:
    • La masse totale prise en compte pendant l'analyse modale. La masse totale comprend:

      • Pour Eurocode: les composantes verticales des charges dans le groupe de charges x Ψ2 x φ-factor

        Les facteurs Ψ2 et φ sont définis dans la fenêtre des groupes de charges [image].

      • Pour CTE: les composantes verticales des charges dans le groupe de charges x φ-factor
    • un certain nombre de points
      • un point noir: le centre de gravité de la masse totale
      • un point bleu: le centre de gravité de la masse propre
      • un point rouge: le centre de gravité de la masse ajoutée
    • Vous pouvez montrer la distribution de la masse propre et la masse ajoutée par crocher les options 'Montrer masse' et 'Montrer poids propre' chez la configuration 'Charges'.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charge dynamique linéaire

Pour définir les fonctions dynamiques, vous devez donner le caractère dynamique au groupe de charges, et le configurer dans le tableau des groupes de charges, voir Cas de charges.

Le groupe de charges dynamique peut contenir plusieurs sous-groupes de charges, qui agissent ensemble [image] ou indépendamment [image] les uns des autres.

L'introduction de la contrainte dynamique comporte trois éléments, à savoir la définition de

  • périodicité, synchronisation, période du groupe de charges (principal) [image] (voir Données généraux: période et synchronisation)

  • charge (statique) pour le groupe de charges ou chacun des sous-groupes de charges

    Définissez la contrainte maximale pour le groupe de charges ou chacun des sous-groupes de charges, sous la forme d'une charge concentrée, d'une charge linéaire, d'une charge superficielle, ... (voir Les charges)

  • propagation de l'onde, amplitude, phase,… du (sous-)groupe de charges [image] (voir Données de l'onde)

Données généraux: période et synchronisation

Données de l'onde

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Données généraux: période et synchronisation

Dans la fenêtre [image], vous indiquez:

Les (sous-)groupes

  • si tous les (sous-)groupes de charges sont périodiques (l'onde se répète dans le temps) ou non (= onde apériodique):

    Périodique Apériodique

  • s'ils agissent de manière synchrone ou asynchrone.

S'il n'y a pas de (sous-)groupes de charges, seule la périodicité est d'application. Dans le cas de charges partielles, la synchronisation est également d'application. Cette option ne se justifie que si les charges partielles agissent toujours ensemble . Si les charges partielles agissent indépendamment les unes des autres, cette option n'a aucun effet. Dans le cas où les charges partielles agissent ensemble et sont définies comme 'asynchrones', Diamonds va rechercher lui-même la situation la plus défavorable (en l'occurrence la période) entre les ondes. Si vous optez pour une action 'synchrone' des charges partielles, vous devez absolument connaître la période entre les ondes et cette dernière doit rester constante. Si la période entre les ondes des charges partielles est inconnue ou ne reste pas constante, il vaut mieux opter pour 'asynchrone'.

La période

Indiquez ensuite la période de l'onde. Dans le cas de sous-groupes de charges, vous devez sélectionner la période maximale de toutes les charges partielles. Vous pouvez introduire la période de 2 manières:

  • Comme valeur absolue de la période (s) ou de la pulsation (rad/s).

    Quand vous complétez l'une des deux valeurs, l'autre est calculée automatiquement.

  • Relativement par rapport à une période propre sélectionnée.

    Le facteur de période vous permet d'encore multiplier la période propre sélectionnée par une valeur au choix. De la sorte, vous pouvez examiner l'effet d'une contrainte dont la période correspond étroitement (ou est égale) à la période propre. Pour ce faire, vous pouvez vous attendre à une résonance de la structure, compte tenu évidemment de l'atténuation.

Avancé

  • Le '# points', soit le nombre de nœuds dans lesquels les déplacements dus à la contrainte sont déterminés par mode propre (= la résolution des équations de mouvement). 100 points est une bonne hypothèse.
  • Plus la fréquence propre de ces modes augmente, et plus la période du mode propre raccourcit. Afin d'avoir ici aussi un nombre suffisant de points pour que l'intégration soit suffisamment précise, vous pouvez indiquer un nombre minimum de points en regard de 'Min. Points/onde'. 15 points est une bonne hypothèse.
  • Le ‘# points d'évaluation’, soit le nombre de nœuds dans lesquels la réponse est déterminée par superposition. Choisir le ‘# points d'évaluation’ égal au ‘# points’ est l'hypothèse la plus précise, mais c'est elle qui nécessite le plus long temps de calcul. Vous pouvez sélectionner le ‘# points d'évaluation’ inférieur au ‘# points’; l'erreur que vous commettrez est négligeable. Il ne se justifie pas de sélectionner le '# points d'évaluation' supérieur au '# points'.
  • Si la somme des masses modales effectives s'avère trop petite pour une ou plusieurs directions, vous pouvez faire deux choses:
    • Vous exécutez à nouveau l'analyse modale mais vous demandez davantage de modes propres.
    • Ou vous recourez à la correction quasi statique.

Vous trouvez à droite de la boîte de dialogue une liste de toutes les ondes définies dans le(s) (sous-)groupe(s) de charges. Au départ, quand aucune onde n'a encore été définie, le graphique est vide. Si vous revenez plus tard dans cette fenêtre, vous verrez l'interaction des ondes définies. Le sous-groupe de charges actif à ce moment se dessine en gras.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Données de l'onde

Dans la fenêtre [image], vous déterminerez pour le groupe de charges ou chacun des sous-groupes de charges:

  • Propagation de l'onde
    • Sinus (ou harmonique)
    • Bloc (ou impulsion)
    • Dent de scie (ou triangle)
    • Aléatoire
  • Facteur d'amplitude: c'est la valeur maximale de l'onde, c.-à-d. le facteur par lequel la contrainte statique sera multipliée. L'amplitude doit toujours se situer entre -1 et 1.
  • Amplitude 2 (uniquement si bloc ou dent de scie): C'est la valeur descendante maximale de l'onde.
  • N° période: cette option vous indique combien de fois le cycle doit se dérouler sur 1 période.
  • Phase (uniquement en cas d'harmonique): vous définissez ainsi un glissement de phase
  • Départ: c'est le point de départ relatif de l'onde par rapport à la période (moment de départ = départ * période). Cette valeur se situe toujours entre 0 et 1. Si la valeur se situe sur 0, l'onde démarre au début de la période. Avec une valeur > 0, l'onde démarre plus tard et il y a donc une partie où l'amplitude est de 0 (la partie 'morte').
  • Pas (uniquement pour bloc ou dent de scie): c'est le point où l'onde traverse l'axe horizontal, en d'autres termes, le point où elle change de signe, le point zéro de l'onde.
  • Fin: c'est le point final relatif de l'onde par rapport à la période (moment de fin = fin * période). Si la valeur se situe sur 1, l'onde se termine à la fin de la période. Avec une valeur < 1, l'onde s'arrête plus tôt que la période et il y a donc une partie où l'amplitude est de 0 (la partie 'morte').

Enfin, vous indiquerez si vous souhaitez adapter l'onde à la contrainte (statique) introduite ou en tant qu'accélération des points d'appui. Pour cette dernière option, indiquez la valeur de l'accélération et la direction avec des angles α et β.

Du côté droit, vous trouvez la propagation de l'onde et un détail sur 1 période. Dans le détail, vous avez la possibilité d'afficher l'onde dans le domaine temporel (classique) ou dans le domaine de fréquence. Il est possible, au moyen d'une transformation de Fourier, de définir chaque onde aléatoire (= l'onde rouge dans la figure ci-dessous) comme une somme de fonctions harmoniques (sinus et cosinus) (= les ondes bleue, verte et violette dans la figure ci-dessous). La décomposition peut être représentée dans le domaine de fréquence. On peut y voir quelles fréquences apparaissent le plus dans l'onde, et à quelle amplitude. Les fréquences qui ont la plus grande amplitude seront les plus déterminantes et pourront même être critiques, notamment si elles correspondent à la fréquence propre de la structure.

Onde aléatoire

Diamonds permet de définir une onde à propagation aléatoire. Si vous sélectionnez cette option, vous devez indiquer un certain nombre de points d'interpolation. Vous pouvez utiliser à cet effet les outils intégrés ou coller une propagation extraite d'un tableau externe.

  • supprime un point
  • interpolation ‘fluide’ entre les points. Les points sont reliés entre eux par une spline cubique.
  • interpolation linéaire entre les points. Les points sont reliés entre eux par des lignes droites.
  • insère un point, avant le point actuel et à mi-chemin du point précédent.
  • insère un point, après le point actuel et à mi-chemin du point suivant.

  • colle un tableau externe depuis le presse-papiers. Dans un tableau externe (par exemple en MS Excel), vous devez prévoir 2 colonnes: une première colonne avec la propagation temps/période et une seconde colonne avec l'amplitude. Sélectionnez ces colonnes contenant des valeurs, copiez-les (par exemple via CTRL+C) dans le presse-papiers et collez les valeurs dans Diamonds à l'aide du bouton [image] .

Outre des opérations dans le tableau, vous pouvez aussi cliquer sur les points d'interpolation dans le graphique de détail de l'onde et les déplacer à votre guise.

Si vous importez un modèle Diamonds comprenant des contraintes sismiques et dynamiques dans PowerFrame, il faut redéfinir les charges sismiques et dynamiques. Il en va de même pour l'importation d'un modèle PowerFrame dans Diamonds.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Charge mobile

Pour définir une charge mobile, procédez comme suit:

  • Prévoyez les éléments (lignes ou barres) dans la géométrie sur lesquels la charge mobile agira.
  • Définissez un groupe de charge Charges mobiles (voir).
  • Ajoutez une charge mobile dans la bibliothèque (voir )
  • Assignez la charge mobile aux barres (voir ).

Nous utilisons l'exemple ci-dessus pour illustrer la fonctionnalité: sur un parcours en L avec deux voies, un train peut se déplacer en ayant les propriétés suivantes:

Bibliothèque des charges mobiles

Attribuer une charge mobile à un modèle

Aperçu des charges mobiles appliquées

Animation

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Bibliothèque des charges mobiles

Plusieurs parcours et plusieurs charges mobiles peuvent exister dans un même projet. Plusieurs charges mobiles peuvent agir sur un même parcours et une charge mobile peut revenir dans plusieurs projets.

Pour avoir un historique global complet, les charges mobiles sont enregistrées dans la bibliothèque. Cliquez sur [image] pour ouvrir la bibliothèque.

Une charge mobile peut être précédée des icônes [image] ou [image] .

  • L'icône [image] indique que la charge mobile se trouve en permanence dans la bibliothèque et qu'elle est donc disponible dans tous les projets.
  • L'icône [image] indique que la charge mobile est présente provisoirement dans la bibliothèque et qu'elle est donc disponible uniquement dans le projet en cours.

Le bouton nouveau vous permet de définir une nouvelle charge mobile. Voici les paramètres/ options de la fenêtre :

  • Nom : le nom de la charge mobile dans la bibliothèque.
  • Longueur : la longueur totale du train.
  • Nombre de charges : le nombre de points sur lesquels agit la charge.

  • Références concernant les charges :

    • Suivant les axes locaux
    • Suivant les axes globaux

  • Tableau : le nombre de lignes dans le tableau correspond au nombre de charges.

    • Vous pouvez indiquer la position des charges par rapport au train de 2 manières :

      • d1 est la distance depuis la fin.
      • d2 est la distance depuis le début.

      Si vous indiquez la distance d1, Diamonds calculera automatiquement la distance d2 comme étant la longueur du train diminuée de d1 et inversement si vous indiquez la distance d2.

    • Ensuite, vous pouvez assigner à chaque charge la valeur des forces et des moments.
  • Les boutons [image] et [image] vous permettent d'importer ou d'exporter une charge mobile.
  • L'exemple ci-dessus montre la fenêtre après l'application de tous ces paramètres.
  • Le bouton [image] vous permet de modifier la charge mobile sélectionnée.
  • Le bouton [image] vous permet d'enregistrer de manière permanente une charge mobile provisoire dans la bibliothèque. L'icône pour les charges mobiles [image] deviendra [image] .
  • Le bouton [image] vous permet d'enregistrer une charge mobile permanente en tant que charge mobile provisoire dans la bibliothèque. L'icône pour les charges mobiles [image] deviendra [image]. Diamondssupprimera automatiquement les charges mobiles provisoires qui ne sont pas assignées à un parcours.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Attribuer une charge mobile à un modèle

Sélectionnez les lignes auxquelles vous voulez appliquer la charge mobile. C'est ce que nous appelons « parcours ». Notez que vous pouvez sélectionner plusieurs parcours. Ensuite, cliquez sur [image] .

  • Sélectionnez la charge mobile dans la liste déroulante contenant toutes les charges disponibles dans la bibliothèque. Le bouton vous permet d'ouvrir la bibliothèque contenant les charges mobiles pour éventuellement modifier de nouveau la charge.
  • Ensuite, indiquez si vous souhaitez appliquer la charge de voie de roulement au groupe de lignes ou aux lignes individuelles. Diamonds essaiera toujours de créer le groupe des plus longues lignes ininterrompues.

  • Enfin, vous devez indiquer les positions où le train démarre et s'arrête sur le parcours.

    • Dans la première colonne, Ltot représente la longueur du parcours sélectionné. Si la charge mobile est plus longue que le parcours sélectionné, la distance Ltot s'affichera en rouge.
    • Puisque différentes distances sont représentées, il est possible que plusieurs parcours soient sélectionnés.
    • La deuxième colonne et la dernière colonne comportent des listes déroulantes. Ces listes vous permettent de sélectionner respectivement le point de début et le point de fin.
    • Dans la troisième colonne et l'avant-dernière colonne, vous indiquez depuis quel endroit et jusqu'à quel endroit la charge mobile peut se déplacer sur le parcours.
    • Au centre, Arrêts vous permet d'indiquer les numéros des nœuds où la charge de voie de roulement doit être synchronisée.

  • Après avoir cliqué sur OK, vous obtenez une représentation graphique de la charge mobile.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Aperçu des charges mobiles appliquées

Vous pouvez obtenir un aperçu de toutes les charges mobiles appliquées avec le bouton [image].

  • Le champ 'Nombre de positions vous' permet d'indiquer le nombre de positions sur lesquelles Diamonds doit placer et calculer la charge mobile. Le nombre de positions est limité à un nombre minimum en fonction du nombre d'arrêts.

    Le résultat est un résultat enveloppe toutes ces positions.

  • Le tableau en dessous récapitule les propriétés du parcours et de la charge mobile.
  • Le bouton 'SUPP' vous permet de supprimer une charge mobile du parcours concerné. Vous pouvez aussi sélectionner le parcours concerné dans la fenêtre de modèle et en cliquant sur [image].
  • Si vous avez supprimé involontairement une charge, vous pouvez replacer la charge mobile sur le parcours à l'aide du bouton [image] .

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Animation

Cliquez sur le bouton [image] pour démarrer/arrêter une animation de la charge mobile.

Dans un « arrêt », on peut voir clairement, par exemple, que « le train » passe sur les deux parcours en même temps.

Aucun arrêt utilisé | Arrêts utilisés

Remarque :

  • Pour calculer les charges mobiles, la licence « Charges mobiles » est requise.
  • Lors de l'importation d'un modèle Diamonds avec des charges mobiles dans PowerFrame, il est recommandé de définir de nouveau ces charges. Ceci s'applique aussi en cas d'importation d'un modèle PowerFrame dans Diamonds.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Courbes de feu

Quand vous avez créé un cas de charge incendie, vous pouvez définir le courbe de feu [image]. L'écran suivant s'affiche:

De la liste à gauche en haut, vous pouvez choisir entre un nombre de courbes de feu prédéfinis (voir EN 1991-1-2 §3.2), c’est à dire:

  • La courbe de feu standard ISO 834
  • La courbe de feu externe
  • La courbe de feu hydro-carbone

  • Il est également possible de définir sa propre courbe de feu:

    • Cliquez sur le bouton [image] . Une fenêtre de dialogue apparaîtra:

    • Nommez la courbe de feu.

    • Définissez la fonction par faire glisser les points rouges vers leur position correcte.

      • supprime un point
      • interpolation ‘fluide’ entre les points. Les points sont reliés entre eux par une spline cubique.
      • interpolation linéaire entre les points. Les points sont reliés entre eux par des lignes droites.
      • insère un point, avant le point actuel et à mi-chemin du point précédent.
      • insère un point, après le point actuel et à mi-chemin du point suivant.

      • colle un tableau externe depuis le presse-papiers. Dans un tableau externe (par exemple en MS Excel), vous devez prévoir 2 colonnes: une première colonne avec la propagation temps/période et une seconde colonne avec l'amplitude. Sélectionnez ces colonnes contenant des valeurs, copiez-les (par exemple via CTRL+C) dans le presse-papiers et collez les valeurs dans Diamonds à l'aide du bouton [image] .

    • Avec les bouton [image] et [image] , il est possible d’importer ou d’exporter une courbe de feu.

  • Cliquez sur [image] pour supprimer la courbe de feu définie par l'utilisateur.

  • Cliquez sur [image] pour modifier la courbe de feu définie par l'utilisateur.

Entrez la résistance au feu requise [min].

Cliquez sur [image] pour supprimer la courbe de feu des barres sélectionnées.

Remarques:

  • Une courbe de feu attaché à une barre sans section ou matériau n’a pas de sens.
  • Une courbe de feu est uniquement possible pour des éléments barres, pas pour les plaques.
  • Une courbe de feu et la résistance au feu [min] sont liés aux barres, pas au projet. Alors, un seul projet peut contenir plusieurs barres avec différentes courbes de feu et différentes exigences de résistance au feu.
  • Le calcul de résistance au feu demande une licence du module ‘Analyse résistance au feu’.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Supprimer ou modifier des charges

Si vous souhaitez supprimer toutes les charges appliquées sur une ou plusieurs dalles et/ou barres et/ou sur un ou plusieurs nœuds, sélectionnez-les et cliquez sur le bouton [image].

Attention ! Vous ne supprimez ainsi que les charges appartenant à la famille de charges active dans le menu déroulant de la palette d’icones (par exemple charges permanentes).

Si par contre, vous ne souhaitez supprimer que certaines charges appliquées sur une ou plusieurs dalles, barres ou nœuds, ou si vous souhaitez en modifier les valeurs, vous devez double-cliquez sur la dalle, la barre ou le nœud concerné. Une fenêtre de dialogue s’ouvre alors affichant une liste de toutes les charges appliquées sur l’élément sur lequel vous venez de double-cliquer.

Attention ! Ne figurent dans cette liste, que les charges appartenant à la famille de charges active dans le menu déroulant de la palette d’icones (par exemple charges permanentes).

Pour supprimer une charge figurant dans cette liste, sélectionnez-la et cliquez ensuite sur le bouton [image] en haut à gauche de la fenêtre de dialogue.

Attention, ce bouton n’est disponible qu’à partir du moment où il y a au moins deux charges différentes de définies au sein d’un même groupe de charges. L’explication et l’utilité des autres boutons sont décrites plus loin dans ce manuel.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Copier et coller des charges

Bouton droite souris

Translation

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Bouton droite souris

Si vous souhaitez copier la charge attribuée à un nœud, une barre ou un plan vers un autre élément (pas pour des surfaces!)/ dans un autre groupe de charges:

  • Sélectionnez d'abord l'objet sur lequel se trouve la charge à copier.
  • Enfoncez ensuite le bouton droit de la souris. Dans le menu flottant qui s'affiche, sélectionnez l'option
    • 'Copier charges'
    • ou 'Copier groupe de charges complet'
  • Choisissez ensuite le groupe de charges vers lequel vous voulez copier la charge et sélectionnez les éléments sur lesquels cette charge doit agir.
  • Enfoncez ensuite le bouton droit de la souris et sélectionnez cette fois l'option 'Coller charges' dans le menu flottant.

Vous pouvez aussi sélectionner plusieurs nœuds, barres ou surfaces, avec l'intention de copier les charges sur la même sélection, mais dans un groupe de charge différente. Copiez les charges de multiples nœuds, barres ou surfaces avec l'intention de copier les charges sur une autre sélection (si oui ou non dans le même groupe de charge), n'est pas possible avec cette fonction. C'est parce que alors Diamondsdevrait vérifier si la nouvelle sélection a la même géométrie que l'ancienne sélection (= un processus chronophage). Pour les points et les bars vous pouvez éventuellement utiliser la fonction 'Translation' (voir Translation des charges).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Translation des charges

Pour déplacer des charges ou une partie de charges, ou la copier un certain nombre de fois, commencez par sélectionner les éléments ayant les charges sur lesquels vous souhaitez appliquer la translation puis cliquez sur le bouton [image].

Indiquez d'abord combien de copies vous désirez (N). Si vous voulez simplement déplacer les charges des éléments sélectionnés, N doit avoir la valeur 0. Indiquez ensuite les distances suivant le repère d'axes global, sur lesquelles la sélection des charges doit être déplacée ou copiée. Cette distance est répétée autant de fois qu'il y a de copies.

Remarque:

  • Les valeurs du vecteur de translation peuvent également être introduits graphiquement en indiquant soi-même la distance à l’aide de la souris dans la ‘Configuration – Charges’ (en gardant néanmoins la fenêtre de dialogue ouverte).

  • Seulement des charges sur des points et des lignes peuvent être déplacé/ copié.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette 'Résultats'

Chaque configuration 'Résultats' est munie d'une palette 'Résultats' du côté droit de la fenêtre modèle. Grâce à cette palette, il est possible d'exprimer graphiquement tous les résultats du calcul dans la fenêtre modèle. Évidemment, on ne disposera d'un résultat détaillé que si l'analyse correspondante a été effectuée. Le mode d'affichage des résultats dépend donc de la configuration définie. Pour la définition de ces paramètres, on consultera le Définition ou modification d’une configuration.

Examinons maintenant comment se compose la palette :

Dans le haut de la palette se trouvent plusieurs boutons qui représentent chacun une série de résultats détaillés. Pour qu'un résultat soit exprimé dans la fenêtre modèle, il faut qu'un de ces boutons soit enfoncé. On distingue les 'groupes de résultats' suivants:

Pour exprimer les déformations

Pour exprimer les efforts internes dans les poutres

Pour exprimer les efforts internes dans les dalles et les plaques

Pour exprimer les réactions

Pour exprimer les contraintes élastiques dans les poutres

Pour exprimer les contraintes élastiques dans les dalles et les plaques

Pour exprimer l'armature longitudinale et l'armature d'effort tranchant

Pour exprimer les résultats de la vérification acier et bois

Pour exprimer la largeur des fissures
Pour exprimer la température en fonction du temps

Une fois qu'un des boutons ci-dessus est enfoncé, vous pouvez visualiser les résultats détaillés correspondants au moyen du menu déroulant situé en-dessous. On peut ainsi visualiser pas mal de résultats de manière structurée, sans que la palette 'Résultats' soit surchargée de nombreux boutons. Les différents symboles seront discutés succinctement ci-après.

Indiquez ensuite de quelle combinaison de charges vous souhaitez examiner les résultats. Dans un premier menu déroulant, sélectionnez le type de combinaison de charges (groupe de charges individuel, ELU CF, ELU CS, ELS CR, ELS CF ou ELS QP), puis indiquez quel groupe de charges spécifique ou quelle combinaison projetée il faut visualiser. Dans le cas d'une combinaison de charges, vous avez le choix entre une combinaison de charges individuelle (désignée par un numéro) ou l'enveloppante. Dans les cas où le résultat propose une enveloppante, il se peut qu'il faille encore indiquer, pour certains résultats, s'il faut afficher les résultats minimaux (min) ou maximaux (max).

Remarque:Si vous avez défini des groupes de charges composés de sous-groupes de charges du type de service (voir Définir des sous-groupes de charges), un résultat enveloppant s'affichera automatiquement pour ce groupe de charges ainsi que pour toutes les combinaisons dans lesquelles ce groupe de charges apparaît, sur base des sous-résultats pour les différents sous-groupes de charges. Si vous désirez quand même avoir accès aux résultats relatifs aux différents sous-groupes de charges, il faudra définir ces derniers comme des groupes de charges et non comme des sous-groupes de charges.

Affichage des déformations

Affichage des efforts internes dans les poutres et les poteaux

Affichage des efforts internes dans les dalles et les plaques

Affichage des réactions dans les points d'appui

Affichage des contraintes élastiques dans les poutres et les poteaux

Affichage des contraintes élastiques dans les dalles et les plaques

Affichage des résultats de l'armature

Affichage de la largeur de fissuration

Affichage des résultats thermiques

Résultats le long d’un ligne de coupe

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des déformations

Pour visualiser les résultats des déformations, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant.

Représentation du déplacement dans le sens de l'axe x global

Représentation du déplacement dans le sens de l'axe y global

Représentation du déplacement dans le sens de l'axe z global

Représentation de la déformation globale de la structure

Représentation de la rotation des angles autour de l'axe x global

Représentation de la rotation des angles autour de l'axe y global

Représentation de la rotation des angles autour de l'axe z global
Représentation de la première forme de flambement

Dans l'affichage de la déformation globale, vous voyez comment la structure se déforme vraiment dans une vue 3D. Bien sûr, l'échelle de l'écart exagérera l'écart par rapport à la géométrie de la structure proprement dite. Attention: cet affichage 3D n'est pas possible dans le cas de valeurs enveloppantes. L'affichage 3D de tous les états de déformation possibles produit en effet une nuée d'enveloppantes qui ne peut plus être représentée par une ou deux lignes.

Les trois icônes [image], [image], [image] ne s'appliquent non plus qu'aux barres. Cette déformation des angles ne peut pas être consultée pour les dalles et les plaques.

Dans beaucoup de cas, il se peut qu'on souhaite connaître la déformation selon le repère d'axes local. Dans ce cas, il est conseillé de visualiser un résultat détaillé de la barre en question (voir Résultats détaillés).

Lors d'une analyse de 2ème ordre, le coefficient de flambement global αcr est calculé. Un flambement global se produit si αcr<1. Vous pouvez désormais afficher le premier mode de flambement global au moyen de l'icône [image]. Dans l'exemple ci-dessous, on constate un déplacement net depuis le plan du treillis en raison d'un appui insuffisant dans cette direction.

Remarque :

  • Les déplacements sont atténués de sorte qu'un coefficient de flambement global αcr=1 équivaut à une déformation de 1m. Une déformation supérieure à 1 m correspond à un coefficient de flambement global αcr<1.
  • Pour calculer le coefficient de flambement global αcr, il vous faut une licence "calcul 2nd ordre ossatures".

Après avoir effectué une analyse modale, vous pouvez examiner, par fréquences propres, les modes propres et les résultats correspondants. Pour ce faire, passez à la fenêtre des résultats et sélectionnez, par exemple, le déplacement de 'Modes dynamiques'. Vous pouvez visualiser la fréquence propre souhaitée dans le menu déroulant du bas. Vous pouvez lancer une animation de cette fréquence propre au moyen des boutons [image] :

  • : play
  • : pause
  • : accélérer
  • : ralentir
  • : animer à la vitesse de la fréquence propre.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des efforts internes dans les poutres et les poteaux

Pour visualiser les résultats des efforts internes dans les poutres ou les poteaux, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant.

Représentation des efforts normaux dans les barres.

Représentation de l'effort tranchant suivant l'axe local z' du profil (à la suite de la flexion autour de l'axe y').

Représentation de l'effort tranchant suivant l'axe local y' du profil (à la suite de la flexion autour de l'axe z').

Représentation des moments fléchissants autour de l'axe local y'.

Représentation des moments fléchissants autour de l'axe local z'.

Représentation des moments de torsion (autour de l'axe local x).

Les efforts tranchants et les moments fléchissants sont donc toujours représentés suivant les axes locaux des barres. Pour les profils doublement symétriques, les axes locaux y' et z' correspondent respectivement à l'axe fort et à l'axe faible.

En outre, les conventions graphiques suivantes sont adoptées.

  • Un effort normal négatif correspond à un effort en compression, un effort positif à un effort en traction.
  • Un moment fléchissant est positif si la face supérieure (côté droite) du profil est soumises à une traction. Donc, les moments seront toujours représentés sur la face du profil où intervient une traction.

  • Le signe de l'effort tranchant dépend de la variation du moment correspondant. Un effort tranchant positif correspond à une courbe de moment ascendante, un effort tranchant négatif correspond à une courbe de moment descendante.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des efforts internes dans les dalles et les plaques

Pour visualiser les résultats des efforts internes dans les plaques et les disques, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant.

Représentation de l'effort tranchant dans le plan perpendiculaire à l'axe x'.

Représentation de l'effort tranchant dans le plan perpendiculaire à l'axe z'.

Représentation des moments fléchissants autour de l'axe z'.

Représentation des moments fléchissants autour de l'axe x'.

Représentation des moments de torsion.

Représentation du premier moment principal.

Représentation du deuxième moment principal.

Représentation des directions des moments principaux.

Représentation des efforts normaux parallèlement à l'axe x'.

Représentation des efforts normaux parallèlement à l'axe z'.

Représentation des efforts de glissement dans le plan.

Représentation du premier effort normal principal.

Représentation du deuxième effort normal principal.

Représentation des directions des efforts normaux principaux.

Les efforts internes sont toujours représentés suivant les axes locaux de la dalle ou de la plaque.

Représentation des efforts internes dans une dalle | Représentation des efforts internes dans une plaque

En outre, tous les résultats sont exprimés par unité de longueur.

Les moments principaux M1 et M2 et les efforts normaux principaux N1 et N2 sont calculés à l'aide du cercle de Mohr respectivement à partir des moments (Mxx, Mzz et Mxz) et des efforts normaux (Nxx, Nzz et Nxz) sur deux petits plans perpendiculaires. Aux moments principaux et aux efforts normaux principaux correspondent aussi toujours des directions principales qui sont exprimées au moyen de petites flèches proportionnelles à la taille des moments principaux et des efforts normaux principaux. Aucun moment de torsion (Mxz) ni aucun effort de glissement (Nxz) n'agit sur les petits plans parallèles aux directions principales.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des réactions dans les points d'appui

Pour visualiser les résultats des efforts de réaction, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant.

Représentation des efforts de réaction dans les points d'appui dans le sens X global.

Représentation des efforts de réaction dans les points d'appui dans le sens Y global.

Représentation des efforts de réaction dans les points d'appui dans le sens Z global.

Représentation des efforts de réaction dans les points d'appui dans le sens X, Y et Z global.

Représentation de la réaction répartie dans les lignes d'appui dans le sens X global.

Représentation de la réaction répartie dans les lignes d'appui dans le sens Y global.

Représentation des efforts de réaction répartie dans les lignes d'appui dans le sens Z global.

Représentation des efforts de réaction répartie dans les lignes d'appui dans le sens X, Y et Z global.

Représentation des efforts de réaction dans la couche résiliente dans le sens X global.

Représentation des efforts de réaction (du sol) dans la couche résiliente dans le sens Y global

Représentation des efforts de réaction dans la couche résiliente dans le sens Z global.

Représentation des moments de réaction dans les points d'appui autour de l'axe X global.

Représentation des moments de réaction dans les points d'appui autour de l'axe Y global.

Représentation des moments de réaction dans les points d'appui autour de l'axe Z global.

Représentation des moments de réaction dans les points d'appui autour de l'axe X, Y et Z global.

Représentation des moments de réaction répartie dans les lignes d'appui autour de l'axe X global.

Représentation des moments de réaction répartie dans les lignes d'appui autour de l'axe Y global.

Représentation des moments de réaction répartie dans les lignes d'appui autour de l'axe z global.

N’oubliez pas que dans les configurations ‘Résultats’, les réactions aux appuis sont toujours représentées en fonction des repères globaux alors que les résultats détaillés des réactions au niveau d’une ligne de coupe ou d’une dalle sont localement représentés. (cf. Résultats détaillés).

En ce qui concerne les lignes d'appui, vous pouvez également visualiser la valeur totale ainsi que la valeur moyenne d'une réaction. Pour cela, sélectionnez d'abord la réaction souhaitée dans le menu déroulant et double-cliquez ensuite sur la barre pour que la boîte de dialogue suivante s'affiche.

Vous obtenez la réaction moyenne en divisant la réaction totale exercée par la ligne d'appui sélectionnée par sa longueur. La réaction totale est égale à la somme des réactions des différents points d'appui au droit des différents points de maillage. La réaction des points d'appui en un point qui appartient à deux lignes d'appui ne sera reprise que pour moitié lors de l'évaluation de la réaction totale (produite par une seule ligne d'appui).

Si vous désirez consulter les résultats pour cette ligne sous forme de tableau, Diamonds affichera la valeur totale pour la combinaison exprimée.

Missing file

Si vous sélectionnez plusieurs lignes, le tableau des résultats effectuera la sommation:

  • Sur chaque réaction linéaire séparément
  • Sur toutes les réactions linéaires sélectionnées

Les efforts de réaction répartie produits par les lignes d'appui sont exprimés en kN/m ou équivalent. Les efforts de réaction exercés par une couche sont exprimés en N/mm² ou équivalent.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des contraintes élastiques dans les poutres et les poteaux

Pour visualiser les résultats des contraintes élastiques dans les poutres ou les poteaux, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant.

Représentation des contraintes de compression résultant de N et Mu

Représentation des contraintes de traction résultant de N et Mu

Représentation des contraintes de compression résultant de N et Mv

Représentation des contraintes de traction résultant de N et Mv

Ces contraintes correspondent aux contraintes qui se produisent dans la projection perpendiculaire des fibres extrêmes sur les axes principaux du profil. Par exemple pour une forme rectangulaire et un profilé en Z, ce qui équivaut aux points suivants:

Elles sont toujours dessinées sur le côté du profil où elles surviennent. Le dessin de la contrainte ne trahit donc pas s'il s'agit d'une contraintes de traction ou de compression. Une contrainte positive est une contraintes qui survient dans la fibre supérieure ou gauche du profil (donc dans la fibre extrême ayant une ordonnée positive u ou v.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des contraintes élastiques dans les dalles et les plaques

Pour visualiser les résultats des contraintes élastiques dans les dalles ou les plaques, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant.

Représentation des contraintes dans le sens x' dans la fibre supérieure.

Représentation des contraintes dans le sens z' dans la fibre supérieure.

Représentation des contraintes effectives dans la fibre supérieure.

Représentation des contraintes dans le sens x' dans la fibre inférieure.

Représentation des contraintes dans le sens z' dans la fibre inférieure.

Représentation des contraintes effectives dans la fibre inférieure.

Représentation de la première contrainte normale principale dans la fibre supérieure de la plaque.

Représentation de la deuxième contrainte normale principale dans la fibre supérieure de la plaque.

Représentation des directions des contraintes normales principales dans la fibre supérieure de la plaque.

Représentation de la première contrainte normale principale dans la fibre inférieure de la plaque.

Représentation de la deuxième contrainte normale principale dans la fibre inférieure de la plaque.

Représentation des directions des contraintes normales principales dans la fibre inférieure de la plaque.

Le mode d'affichage des contraintes dans les dalles et les plaques n'est pas identique à celui des contraintes dans les poutres et les poteaux. On adopte donc une autre convention graphique. Pour les dalles, on admet qu'une contrainte en compression est représentée par une valeur négative et une contrainte en traction par une valeur positive. Par contre, les contraintes effectives sont toujours positives. Elles sont calculées à l'aide du critère de plasticité de Huber-Hencky-von-Mises:

Il est admis dans tous les cas que [image]. En principe, la formule précédente doit être appliquée pour tous les points. Dans Diamonds, les contraintes effectives ne sont calculées que pour la fibre supérieure et la fibre inférieure. Elles sont toutefois surestimées, puisqu'il est toujours admis que [image], [image] et [image] où Axz = min (Ax, Az).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des résultats de l'armature

Pour visualiser les résultats du calcul d'armature, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant. Ces résultats ne sont disponibles qu'une fois effectué le calcul d'armature.

Dans des poutres et des colonnes

  • : Représentation de l'armature longitudinale parallèlement à l'axe local y', dans la plupart des cas, donc, l'armature inférieure et l'armature supérieure

  • : Représentation de l'armature longitudinale parallèlement à l'axe local z', dans la plupart des cas, donc, l'armature latérale

  • : Représentation de l'armature transversale parallèlement à l'axe local z', dans la plupart des cas, donc, la section des pattes verticales des étriers par unité de longueur de la poutre

  • :Représentation de l'armature transversale parallèlement à l'axe local y', dans la plupart des cas, donc, la section des pattes horizontales des étriers par unité de longueur de la poutre

Dans des plaques et des voiles
Général |
Représentation de l'armature supérieure parallèlement à l'axe local x' | Représentation de l'armature supérieure parallèlement à l'axe local z'
Représentation de l'armature inférieure parallèlement à l'axe local x' | Représentation de l'armature inférieure parallèlement à l'axe local z'

Représentation de l’armature de poinçonnement

Remarques:

  • Si vous avez ajusté l'orientation du système de coordonnées local (qu'il s'agisse d'une poutre, d'un poteau, d'un mur ou d'une dalle), assurez-vous d'afficher le système de coordonnées local afin de ne pas vous tromper de direction!

    Diamonds ne montre aucun résultat de renforcement «double». Vous devez tenir compte de la somme de tous les résultats de l'armature lors de la création d'un plan d'armature. Par exemple: Diamonds affiche les résultats suivants dans une colonne armée symétriquement:

    Ay Az
    >

    Dans la section transversale en bas, vous placerez au moins 298 mm² de chaque côté. Au total, cela donne 4 fois 298 mm² = 1192 mm². PAS 298 mm² divisé par 4!

  • Dans les poutres, l'armature longitudinale et l'armature d'étriers renferment également l'armature supplémentaire nécessaire pour résister au frottement. Dans le cas des dalles et des plaques également, les moments de frottement ou les efforts de glissement seront repris par l'armature longitudinale.
  • Pour les semelles Diamonds va automatiquement vérifier le poinçonnement, pour les dalles en général c’est à vous de réaliser une vérification de poinçonnement comme décrit dans Calcul des armatures de poinçonnement.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage de la largeur de fissuration

Pour visualiser les résultats du calcul de la largeur de fissuration, cliquez tout d'abord sur le bouton [image] puis sélectionnez le résultat partiel souhaité dans le menu déroulant. Ces résultats ne sont disponibles qu'une fois effectué le calcul de la flèche fissurée..

Représentation de la largeur de fissuration dans les poutres résultant de la flexion autour de l'axe local y'.

Représentation de la largeur de fissuration dans les poutres résultant de la flexion autour de l'axe local z'.

Représentation de la largeur de fissuration dans la face supérieure des dalles.

Représentation de la largeur de fissuration dans la face inférieure des dalles.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Affichage des résultats thermiques

Les résultats du calcul thermique sont disponible dans la configuration ‘Résultats’ en cliquant l’icône [image].

La liste déroulante à gauche vous permet de visualiser la température en fonction du temps pour tous les éléments dans le modèle. Diamonds indique la température maximale et la température minimale (si applicable).

Double-cliquer sur une barre afin de visualiser les résultats thermiques détaillés d’une section (voir Résultats thermiques)

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Résultats le long d’un ligne de coupe

Sous les boutons pour les résultats se trouvent encore plusieurs boutons qui permettent d'exprimer les résultats des calculs de dalles et de plaques suivant des lignes de coupe.

Une fois que les lignes de coupe sont tracées, nous voulons évidemment encore faire connaître les résultats suivant ces lignes. Utilisez pour cela les deux derniers boutons de la palette afin de changer rapidement de mode d'affichage.

Mode d'affichage selon un modèle de couleurs continu

Mode d'affichage selon les lignes de coupe

Vous pouvez consulter les résultats détaillés [image] à ces lignes de coupe comme si vous le faisiez pour des poutres.

En double-cliquant la ligne de coupe, vous pouvez également consulter les valeurs totale et moyenne pour la ligne de coupe.

Pour demander les valeurs totales et moyennes de plusieurs lignes de coupe, sélectionnez les lignes de coupe pertinentes et ouvrez le tableau des résultats [image].

Ajouter une ligne de coupe

Pour ajouter une ligne de coupe :

  • Cliquer sur [image].
  • Dessinez une ligne comme vous le feriez dans la configuration "Géométrie" (voir Tracer des lignes). Une ligne de coupe est toujours rose.
  • Terminer la fonction de dessin avec [image] ou ESC.
Modifier ligne de coupure
  • Sélectionnez la ligne de coupe et cliquez une fois avec la touche droite de votre souris

  • Du menu flottant, vous choisissez "Modifier ligne de coupure"

  • Vous pouvez modifier la longueur de la ligne de coupe. Par défaut, le point de départ (A) est tenu – à voir au carré autour du point A. B sera donc changer de position. Préféreriez-vous maintenir le bouton B, cliquez sur le bouton ‘Echange le point début’. Vous pouvez également ajuster l'angle avec l’axe X' et/ ou avec le plan XZ .

Translater ligne de coupure
  • Sélectionnez la ligne de coupe et cliquez une fois avec la touche droite de votre souris

  • Du menu flottant, vous choisissez "Modifier ligne de coupure"

  • Avec cette fonction connue permet de déplacer la ligne de coupe, dans la circonférence de la plaque à laquelle la ligne de coupe correspondant.

Diviser une ligne de coupe
  • Sélectionnez la ligne de coupe et cliquez une fois sur le bouton droit de la souris.

  • Dans le menu flottant qui apparaît, choisissez "Diviser la ligne de coupe".

  • Vous pouvez maintenant diviser la ligne de coupe comme vous le feriez pour une ligne régulière.
Supprimer une ligne de coupe
  • Les lignes de coupe sélectionnées peuvent toujours être supprimées via le bouton [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette de création et de gestion des plans de dessin ou des étages

Avec cette palette vous pouvez :

  • créer, modifier, supprimer, masquer & afficher les niveaux (voir Gestion des étages);
  • modifier la position du niveau du sol (voir Niveau du sol);
  • et modifiez la position du plan de dessin (voir Plan de dessin);

Chacun de ces sujets est abordé ci-dessous.

Gestion des étages

Niveau du sol

Un plan de dessin

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Gestion des étages

Dans le cas de structures composées de plusieurs niveaux, il peut être particulièrement intéressant de subdiviser le modèle en plusieurs étages, chacun d’eux étant composés de tous les éléments situés entre deux niveaux successifs. Notez que Diamonds considère systématiquement que les dalles horizontales appartiennent au même étage que les éléments qui les soutiennent (voiles, poutres, colonnes, …). Il en résulte qu’un étage comprend physiquement les dalles de plafond mais que les dalles de planchers appartiennent à l’étage sous-jacent.

Recourir à la définition d’étages offre un certain nombre d’avantages, notamment en matière de possibilités de visualisation :

  • Le modèle peut être construit couche par couche en vue en plan. Les boutons [image] et [image] permettent alors de dessiner et de modéliser des colonnes et des voiles (voir Tracer des éléments structurels).
  • En vue en plan, il est facile de passer d’une coupe horizontale à une autre (Ces coupes correspondent en réalité aux plans de chaque étage.).
  • Il est possible de masquer des étages entiers.

Vous activez un étage en sélectionnant son nom dans le menu déroulant. A ce moment, vous ne pourrez sélectionner, dans un plan de dessin horizontal, que les éléments qui appartiennent à cet étage. Les objets qui appartiennent aux autres étages sont atténués dans ce mode d'affichage.

Sous ce menu déroulant s'affiche le niveau et la hauteur de l'étage actif. Le niveau d'un étage donné est mesuré par rapport au plan global XZ.

Pour ajouter un nouvel étage ou modifier un étage existant, appuyez sur le bouton [image]. La boîte de dialogue suivante s'affiche:

Vous trouvez ici une liste des étages définis dans le projet. Vous pouvez y ajouter de nouveaux étages, y copier des étages existants ou en supprimer des étages.

L'étage actif est précédé d'un petit crayon coloré. Cet étage correspond toujours à l'étage indiqué dans le menu déroulant. Vous activerez un autre étage en pointant le petit crayon [image] correspondant dans la première colonne.

En outre, vous pouvez accroître la lisibilité et la convivialité en masquant certains étages du bâtiment.

Les symboles de la deuxième colonne fonctionnent comme des interrupteurs (ON/ OFF) et permettent les fonctionnalités suivantes :

  • rendre l'étage visible;
  • représenter l’étage de façon grisée et transparente ou masquer complètement l'étage (en fonction de votre paramètres de configuration, voir Définition ou modification d’une configuration).

Notez que l’étage actif ne peut jamais être en mode caché.

D’autre part, cette boîte de dialogue indique également le nom, le niveau (relativement au sol) et la hauteur de chaque étage. Pour modifier l'une de ces données, il suffit de cliquer sur le champ approprié. Sachez que le niveau de l’étage est automatiquement recalculé lorsque vous choisissez d’adapter sa hauteur et vice-versa. Dans le cas de l’étage inférieur (fondations), vous ne pouvez introduire que le niveau, la hauteur étant d’office égale à zéro.

  • Pour créer un nouvel étage, utilisez le bouton [image]. Dès que vous cliquez sur celui-ci, Diamonds ajoute un étage en partie haute de votre modèle. Par défaut la hauteur du nouvel étage vaut 2m70. Dans la fenêtre de dialogue qui apparaît, vous pouvez préciser le nom du nouvel étage, modifier sa hauteur et indiquer à l’aide d’un menu déroulant au dessus de quel étage vous souhaitez insérer le nouvel étage. Il est également possible de créer un étage en sous-sol, sous la fondation actuelle. Pour valider, cliquer sur ‘OK’.

  • Pour scinder un étage, cliquer sur le bouton [image]. Dans le menu déroulant, indiquez l’étage concerné et précisez à quel niveau (relativement au sol) vous souhaitez le scinder. Un nouvel étage est alors créé au niveau du plan de coupe que vous venez d’indiquer. Validez par ‘OK’.

  • Pour copier un étage, cliquez sur le bouton [image]. Dans la boîte de dialogue qui s'affiche, sélectionnez d'abord l'étage à copier. Puis, précisez le nombre de copies souhaitées et terminez par indiquer l'étage au-dessus duquel cet/ ces étage(s) doivent être insérés.

    Notez que vous ne pouvez copier un étage qu’au-dessus d’un étage préexistant. Il n’est pas permis de copier un étage sous le niveau du sol (ou des fondations). Outre la possibilité de définir de nouveaux étages, vous pouvez également en supprimer.

  • Pour ce faire, cliquez sur le bouton [image], l’étage sélectionné disparaît alors de la liste des étages.

  • Pour terminer, il est également possible de déplacer (translater) des étages ou de copier les données d’un étage à un autre, simplement en glissant l’étage à l’aide de la souris comme l’indique la figure ci-dessous.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Niveau du sol

Le bouton [image] vous permet d'indiquer le niveau du sol par rapport à l'origine du repère d'axes global. Diamonds sait ainsi:

  • lors du calcul des couches de sol: combien de terre vous allez déblayer.
  • lors de la génération de vent: à combien de mètres au-dessus du niveau du sol naturel se trouve l'élément en question.

En cliquant sur l'icône [image] , vous pouvez choisir de représenter ou non le sol naturel dans le modèle:

Remarques:

  • Le calcul de sol et la génération de vent n'ont aucun sens si vous n'avez pas défini le niveau du sol!
  • Ne vous trompez pas: lors de la génération de la charge de neige, vous devez introduire la hauteur du sol par rapport au niveau de la mer.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Un plan de dessin

A l'exception de la vue perspective, vous dessinez toujours dans un plan de dessin parallèle au plan global XY, XZ ou YZ. La position de ce plan dans le repère d'axes global est déterminée dans la boîte de dialogue suivante:

Vous invoquez cette fenêtre au moyen du bouton [image]. Si vous choisissez une vue du dessus, vous dessinerez dans le plan affecté de l'équation 'Y = ...'. De manière analogue, vous dessinez dans le plan de dessin affecté de l'équation ‘Z = ...’ ou ‘X = ...’ lorsque vous activez une vue de face ou arrière, ou une vue de côté. En outre, la coordonnée Y du plan de dessin horizontal sera toujours égale au niveau de l'étage actif.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette de sélection du mode d'affichage

Nous appelons mode d'affichage la manière dont le modèle est représenté. Le modèle peut ainsi être représenté de manières très différentes: d'un rendu en modèle filigrane à une illustration en couleur. La barre d'outils du côté droit de la fenêtre modèle offre à l'utilisateur le choix entre les modes d'affichage suivants:

Modèle filigrane
 | Un modèle filigrane est une reproduction simplifiée dans laquelle seuls sont illustrés les lignes axiales et les contours respectifs des éléments de barres et des éléments plats.
Modèle de plans transparent
 | Dans un modèle de plans, les contours mais aussi les dalles et les plaques sont représentés à plat. Mais le modèle reste transparent.
Modèle de plans non transparent
 | Ce rendu diffère du précédent en ce que les objets sous-jacents ne sont plus visualisés.
Modèle solide en noir/blanc
 | Un modèle solide représente la géométrie réelle des profils et des éléments de dalles et de plaques. Les contours des volumes sont illustrés en noir.
Modèle solide en couleur
 | Par rapport au rendu précédent, les objets sont maintenant illustrés en couleur.
Modèle solide en couleur + lignes de bords
 | Les objets sont maintenant illustrés en couleur avec les lignes de bords.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette pour (dé-)grouper des éléments barres

Qu’est-ce qu’un groupe?

Comment créer un groupe?

Que faire avec un groupe?

Pour flambement

Physiques

Pour des charges

Pour des sections

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Qu’est-ce qu’un groupe?

On appelle ‘barre’, tout élément linéaire reliant un ‘nœud’ (= point correspondant à une extrémité de barre) à un autre, sans nœud intermédiaire. Il en découle que chaque fois qu’on relie une barre à un point, autre qu’une extrémité, d’une autre barre préexistante; un ‘nouveau nœud’ est créé à la jonction des deux barres. La barre initiale est alors instantanément remplacée par deux ‘nouvelles barres’ (Ci-après, nous appellerons celles-ci ‘sous-barres’).

Pour certains calculs, il s’avère néanmoins indispensable de pouvoir considérer plusieurs ‘sous-barres’, comme un seul élément physique.

Un groupe se compose de différentes barres situées dans le prolongement les unes des autres et qui se comportent comme si elles étaient une seule barre continue.

Les groupes peuvent être définis à différents niveaux:

  • Pour flambement (voyez Pour flambement)
  • Physique (voyez Physiques)
  • Pour des charges (voyez Pour des charges)
  • Pour des sections (voyez Pour des sections)

Les barres groupées en 'flambement', 'charges', 'physique' ou 'sections' ne doivent pas nécessairement être identiques.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Comment créer un groupe physique?

Pour créer un groupe physique, suivez les étapes suivantes:

  • Sélectionnez les barres en question
  • Sélectionnez 'Flamebement', 'Physique', 'Charges' ou 'Sections' dans la fenêtre 'Groupes'.
  • Cliquez sur

Pour supprimer un groupe physique, procédez de manière analogue mais sélectionnez le bouton [image].

A chaque définition de groupe correspond également un mode d’affichage spécifique. Les barres groupées sont systématiquement dessinées de manière continue alors que les barres dégroupées apparaissent de façon discontinue (au niveau de leurs extrémités).

Ce mode de visualisation permet de vérifier ou retrouver très rapidement les barres groupées. D’autant plus que vous pouvez toujours combiner ce mode de visualisation avec les modes de représentation classiques (filaire, transparent, semi-transparent, …).

Pour abandonner l’affichage des groupes, il vous suffit de repositionner le menu déroulant sur l’option ‘Aucun’. La possibilité de grouper ou dégrouper effectivement des barres n’est alors également plus active. Observez que rien ne vous oblige à quitter ce mode pour poursuivre votre modélisation et que ce mode reste actif même si vous quittez la configuration ‘Géométrie’.

Pour peu que le mode ‘Groupe’ soit resté actif, il est également possible de sélectionner simultanément toutes les barres appartenant à un même groupe. Pour ce faire, il suffit de cliquer un seul des sous-éléments en maintenant la touche ALT enfoncée (voir Utilisation des touches CTRL et ALT).

Remarques:

  • Par défaut, les barres dessinées dans le prolongement les unes des autres sont dégroupées. En cas de besoin, c’est à l’utilisateur de faire le nécessaire pour qu’elles soient groupées.
  • Lorsqu’une barre existante est subdivisée, les sous-éléments restent automatiquement groupés.
  • Lorsque vous sélectionnez plusieurs barres, Diamonds va composer tous les groupes physiques possibles. Concrètement, cela veut dire que vous pouvez, par exemple, sélectionner toutes les colonnes dans un modèle. Diamonds groupera les barres qui se situent dans le prolongement les unes des autres.
  • Les opérations de translations, rotations, miroir, copie, … n’influencent en rien les groupes existants.
  • Les définitions de groupes sont également maintenues lorsque le modèle géométrique subit des modifications. Ainsi le fait de faire aboutir une nouvelle barre sur un ensemble groupé de barres ne dégroupera pas ces dernières.
  • Néanmoins, Diamonds groupera automatiquement (et sans prévenir l’utilisateur) les barres situées dans le prolongement les unes des autres à condition qu’aucune autre barre soit reliée à leur point de jonction. Ceci afin d’éviter des erreurs lors du calcul des longueurs de flambement.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Que faire avec un groupe ?

Du fait que Diamonds considère un groupe physique comme une barre continue, les sections, les excentricités et les charges variables se prolongeront sur les barres partielles et ne recommenceront pas pour chaque barre partielle:

Si vous désirez qu'une section ou une charge variable soit attribuée en tenant compte des groupes physiques définis, vous devez cocher l'option 'Valeurs (et distances) associées à l'élément physique' dans la boîte de dialogue correspondante.

Pour flambement

Physiques

Pour des charges

Pour des sections

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Pour flambement

Nous pensons par exemple au calcul de la longueur de flambement hors du plan de l’arrête supérieure d’une poutre en treillis qui, entre ses appuis aux extrémités, n’est pas soutenue latéralement.

  • Vous n’obtiendrez un résultat correct et exploitable (de longueur de flambement hors du plan) que si vous considérez toutes les barres constituant cette arrête supérieure comme un seul élément physique. Sinon, vous risquez d’obtenir et de prendre en compte des longueurs de flambement différentes pour chacune de celles-ci.

    Pour ce faire, Diamonds dispose d’une fonction ‘grouper’ qui permet de regrouper plusieurs barres en un seul élément physique.

  • Pour le calcul des longueurs de flambement dans le plan des barres constituant l’arrête supérieure d’une poutre en treillis, il faudra par contre prendre en compte les longueurs de flambement des différents éléments sans les regrouper en un seul élément physique.

Remarque: Lorsque, dans l’exemple ci-dessus, on parle de longueur de flambement ‘dans’ le plan, celle-ci ne correspond pas forcément à la longueur de flambement autour de l’axe fort du profilé. De même, lorsqu’on parle de longueur de flambement ‘hors’ du plan, celle-ci ne correspond pas forcément à la longueur de flambement autour de l’axe faible du profilé. Il faut toujours tenir compte de l’orientation des axes locaux.

Les groupes ainsi définis sont également pris en compte lors de la vérification des normes acier. Certaines normes nécessitent en effet des informations relatives aux barres adjacentes pour vérifier la stabilité des éléments, notamment au niveau de la détermination des coefficients prenant en compte la répartition des moments.

D’un point de vu pratique, trois types de groupes peuvent être définis :

  • Flambement y’ (u) : Ce premier type de groupe sert à l’évaluation du flambement suite à la présence d’un moment autour de l’axe fort des profilés. Dans la plupart des cas, c’est la longueur de flambement autour de l’axe local y’ qui est prise en compte. Néanmoins, pour les profilés dont les axes principaux d’inertie ne correspondent pas aux axes locaux y’ et z’, il faut considérer la longueur de flambement autour de l’axe principal d’inertie le plus fort. Cette même notion de groupe sert également pour déterminer les facteurs de moment Cmy intervenant dans la vérification des normes acier.
  • Flambement z’ (v) : Ce second type de groupe sert à l’évaluation du flambement suite à la présence d’un moment autour de l’axe faible des profilés. Dans la plupart des cas, c’est la longueur de flambement autour de l’axe local z’ qui est prise en compte. Néanmoins, pour les profilés dont les axes principaux d’inertie ne correspondent pas aux axes locaux y’ et z’, il faut considérer la longueur de flambement autour de l’axe principal d’inertie le plus faible. Cette même notion de groupe sert également pour déterminer les facteurs de moment Cmy intervenant dans la vérification des normes acier.

Attention ! Vous ne pouvez grouper qu’un ensemble de barres alignées et continues. Le fait de pouvoir définir des groupes différents en fonction du but recherché permet d’effectuer le calcul des longueurs de flambement et les contrôles normatifs de façon très détaillée et poussée.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Physiques

Du fait que Diamonds considère un groupe comme une barre continue les excentricités et les translations se prolongeront sur les barres partielles et ne recommenceront pas pour chaque barre partielle:

  • Excentricité

    groupe DÉFINI PAS de groupe

  • Translation du sommet de 1 m vers le haut

    Modifier la taille d'un groupe physique

    NE PAS modifier la taille d'un groupe physique

  • Rotation à 10° de la colonne de droite

    Modifier la taille d'un groupe physique

    NE PAS modifier la taille d'un groupe physique

Si vous désirez qu'une excentricité ou translation soit attribuée en tenant compte des groupes physiques définis, vous devez cocher l'option 'Valeurs (et distances) associées à l'élément' dans la boîte de dialogue correspondante.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Pour des charges

Du fait que Diamonds considère un groupe comme une barre continue les charges se prolongeront sur les barres partielles et ne recommenceront pas pour chaque barre partielle:

groupe DÉFINI | PAS de groupe

Si vous désirez qu'une charge variable soit attribuée en tenant compte des groupes définis, vous devez cocher l'option 'Valeurs (et distances) associées à l'élément' dans la boîte de dialogue correspondante.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Pour des sections

Du fait que Diamonds considère un groupe comme une barre continue, les sections se prolongeront sur les barres partielles et ne recommenceront pas pour chaque barre partielle:

groupe DÉFINI | PAS de groupe

Si vous désirez qu'une section soit attribuée en tenant compte des groupes définis, vous devez cocher l'option 'Valeurs (et distances) associées à l'élément' dans la boîte de dialogue correspondante.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La palette de définition de la grandeur des lettres, des symboles, des charges et des résultats

Cette palette vous permet de modifier facilement sur l'écran la taille des lettres, des symboles, des charges et des résultats. Ces caractéristiques sont, en principe, intrinsèques au projet, puisqu'elles dépendent de la taille du modèle. Elles seront donc sauvegardées avec le projet. Alors que la taille des lettres et des symboles est déterminée clairement dans cette palette, il faut interpréter la taille d'affichage définie pour les charges et les résultats comme un multiplicateur appliqué aux réglages de base tel qu'établi dans la configuration des fenêtres via l'icône [image] .

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Bibliothèques

Bibliothèques locales ou centrales

La bibliothèque des matériaux

Les propriétés élastiques

Les propriétés thermiques

Les propriétés élastiques

La bibliothèque des profilés

La bibliothèque des treillis

Opérations avec les bibliothèques

Ajouter un nouvel objet

Supprimer un objet

Changer les paramètres du filtre

Importer une bibliothèque

Exporter une bibliothèque

Mettre à jour une bibliothèque

Réinitialiser une bibliothèque aux paramètres par défaut

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Bibliothèques locales ou centrales

Les bibliothèques peuvent être stockées localement sur votre ordinateur ou sur n'importe quel ordinateur du réseau. Si les bibliothèques sont stockées sur n'importe quel ordinateur du réseau, nous appelons ces bibliothèques centrale. Un administrateur gère les bibliothèques centrales, les utilisateurs obtiennent des mises à jour automatiques lorsque des modifications sont apportées.

Pour configurer le système des bibliothèques centrales, reportez-vous au Guide d'installation.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La bibliothèque des matériaux

Diamonds est livré en version de base avec un bibliothèque de tous les matériaux courants.

Vous pouvez à tout moment adapter ou compléter cette bibliothèque en sélectionnant l'option 'Édition – Bibliothèque matériaux…'. La boîte de dialogue suivante s'affiche:

  • Au milieu, vous trouvez une liste de tous les matériaux définis

    • Les matériaux précédés par l'icône [image] sont des matériaux standard. Il est impossible de modifier les propriétés des matériaux standard. Vous pouvez copier des matériaux standard avec [image]. Ce faisant, vous pouvez facilement en modifier un paramètre.
    • Les matériaux précédés par [image] sont des matériaux définis par l'utilisateur.
    • Si un matériau est utilisé dans le modèle en cours, le bouton [image] s'illumine lorsque ce matériau est sélectionné.
    • Si vous souhaitez qu'un matériau défini par l'utilisateur soit disponible pendant toute votre session de Diamonds (jusqu'à la fermeture du logiciel), cliquez sur le bouton [image] .
    • Utilisez le bouton [image] pour ajouter un matériau défini par l'utilisateur à la bibliothèque.
    • Cliquez sur [image] ou avec le bouton droit de votre souris pour définir le matériau sélectionné comme matériau par défaut en tant qu’acier, bois ou béton (un seul matériau possible pour chaque type).

  • À droite, vous trouvez les propriétés correspondantes. Les propriétés des matériaux sont réparties dans trois onglets:

    • Les propriétés élastiques
    • Les propriétés thermiques
    • Les propriétés avancées

  • Les boutons à gauches vous permettent d'ajuster le contenu de la bibliothèque

    • Enregistrez toutes les modifications avec [image].
    • Vous pouvez classer les matériaux par ordre alphabétique en cliquant sur les boutons [image] et [image]. Si vous préférez voir apparaître les matériaux dans un ordre différent, vous pouvez les reclasser dans l’ordre que vous souhaitez, simplement en les glissant à l’aide de la souris comme l’indique la figure ci-dessous.
    • Pour ajouter un nouveau matériau, cliquez sur [image] (Ajouter un nouvel profil/ matériau ).
    • Pour supprimer le matériau sélectionné, cliquez sur [image] (Supprimer un élément).
    • Cliquez sur [image] pour copier le matériau sélectionné.
    • Cliquez sur [image] pour afficher le nombre de matériaux.

  • Utilisez le filtre pour déterminer les matériaux qui doivent être visibles dans la boîte de dialogue 'matériaux' [image]. Le critère utilisé est 'OU'. Les matériaux utilisées (matériaux assignées aux barres du modèle) seront toujours visibles dans la liste, quels que soient les paramètres du filtre.

  • Les boutons à droite en bas, vous permettent d'importer ou exporter la bibliothèque.

    • Exportez le contenu de la bibliothèque actuelle avec [image] (Exporter une bibliothèque). Seuls les éléments visibles avec les paramètres de filtre à ce moment seront exportés. Donc, utilisez le filtre à bon escient. Ce n'est pas le but d'exporter tout!
    • Importez une bibliothèque extérieure avec [image] (Importer une bibliothèque).

Les propriétés élastiques

Les propriétés thermiques

Les propriétés élastiques

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Les propriétés élastiques

Les propriétés élastiques sont utilisés pour l’analyse structurelle. Les propriétés élastiques sont les suivants:

En haut à droite, vous trouvez

  • le nom de l'élément sélectionné
  • Indiquez ensuite à quel type le matériau appartient. Si vous sélectionnez le type acier, béton ou bois, il faut aussi mentionner les propriétés de résistance afin qu'il soit possible de réaliser un contrôle normatif supplémentaire. Pour tous les autres matériaux, Diamonds effectue uniquement une analyse élastique de la structure et vous obtenez les résultats des efforts internes et des contraintes (élastiques), mais il n'y a pas de contrôle normatif spécifique supplémentaire.

  • le module d'élasticité de Young E, le coefficient de Poisson ν, le module de glissement G

    En présence d'un matériau élastique, il y a un lien certain entre les trois premières propriétés. De ce fait, vous pouvez faire calculer automatiquement le module de glissement à l'aide du bouton [image] une fois que E et ν sont déterminés.

  • le coefficient de dilatation thermique α
  • la densité ρ du matériau

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Les propriétés thermiques

les propriétés thermiques sont utilisés pour l’analyse résistance au feu. Les propriétés thermiques sont les suivants:

  • La capacité thermique
  • La conductivité thermique
  • L’émissivité

La capacité thermique et la conductivité thermique sont dépendent de la température. Cette relation est connue (et y compris) pour tous les matériaux ‘BuildSoft’ dans la bibliothèque standard (reconnaissables par l'icône BuildSoft en face). Pour les bétons, ces deux propriétés dépendent également de la composition de béton.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Les propriétés avancées

Si le matériau est du type acier, béton ou bois, une nouvelle boîte de dialogue s'ouvre via l'onglet 'Avancé' les propriétés de résistance du matériau sélectionné y sont indiquées.

Dans la barre de titre, vous voyez le nom du type d'acier pour lequel vous examinez les propriétés du matériau.

Vous y trouvez, en haut, une liste de toutes les normes implémentées dans Diamonds. Comme les propriétés de résistance peuvent varier d'une norme à l'autre, vous devez en principe remplir cette fenêtre pour chaque norme.

Dans le premier menu déroulant, sélectionnez la norme pour laquelle vous voulez examiner les propriétés du matériau.

Dans la deuxième liste déroulante, sélectionnez l'annexe nationale correspondante (aucune annexe nationale n'est disponible pour le bois).

Si la case de gauche est cochée, cela veut dire que la norme en question avec annexe nationale est différente de la norme nationale sans annexe nationale:

  • Pour les matériaux standard, vous ne pouvez pas cocher ou décocher la case.
  • Pour les matériaux définis par vous-même, vous pouvez cocher la case si vous souhaitez que, pour une norme donnée avec annexe nationale, les propriétés du matériau s'écartent de cette norme sans annexe nationale.

Si le matériau sélectionné est du type 'béton', vous y définirez les propriétés de résistance du béton ainsi que de l'acier d'armature. Pour un matériau du type 'acier' et 'bois', toutes les propriétés sont regroupées en une seule page.

Les propriétés de résistance du béton, de l'acier et du bois font l'objet d'une analyse détaillée respectivement aux paragraphes Paramètres pour le bois, Paramètres pour le béton et l'armature et Paramètres pour l’acier.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La bibliothèque des profilés

Diamonds est livré en version standard avec une bibliothèque contenant tous les profils d'acier courants. Vous ouvrez cette bibliothèque au moyen de l'option de menu 'Edition – Bibliothèque section…’.

  • Au milieu, vous trouvez une liste de tous les profils.

    • Les profils précédés par [image] sont des profils standard. Il est impossible de modifier les propriétés des profils standard. Vous pouvez copier des profils standard avec [image]. Ce faisant, vous pouvez facilement en modifier un paramètre.
    • Les profils précédés par [image] sont des profils définis par l'utilisateur (user defined).
    • Si une section est utilisée dans le modèle en cours, le bouton [image] s'illumine lorsque cette section est sélectionnée.
    • Si vous souhaitez qu'une section définie par l'utilisateur soit disponible pendant toute votre session dans Diamonds (jusqu'à la fermeture du logiciel), cliquez sur le bouton [image].
    • Utilisez le bouton pour ajouter une section définie par l'utilisateur à la bibliothèque [image].

  • À droite, vous trouvez les propriétés correspondantes. Les propriétés sont réparties dans deux onglets :

    • Les propriétés géométrique
    • Les propriétés avancées

  • Les boutons à gauches vous permettent d'ajuster le contenu de la bibliothèque.

    • Enregistrez toutes les modifications avec [image].
    • Vous pouvez classer les profils par ordre alphabétique en cliquant sur les boutons [image] et [image]. Si vous préférez voir apparaître les profils dans un ordre différent, vous pouvez les reclasser dans l’ordre que vous souhaitez, simplement en les glissant à l’aide de la souris comme l’indique la figure ci-dessous.
    • Cliquez sur [image] pour ajouter un nouveau profil (Ajouter un nouvel profil/ matériau )
    • Cliquez sur [image] pour supprimer le profil sélectionné (Supprimer un élément)
    • Cliquez sur [image] pour copier le profil sélectionné. Ensuite, vous pouvez le changer.
    • Cliquez sur [image] pour afficher le nombre de profils.

  • Utilisez le filtre pour déterminer les sections qui doivent être visibles dans la boîte de dialogue 'Sections' [image] (Changer les paramètres du filtre).

  • Les boutons à droite en bas, vous permettent d'importer ou exporter la bibliothèque.

    • Exportez le contenu de la bibliothèque actuelle avec [image] (Exporter une bibliothèque). Seuls les éléments visibles avec les paramètres de filtre à ce moment seront exportés. Donc, utilisez le filtre à bon escient. Ce n'est pas le but d'exporter tout!
    • Importez une bibliothèque extérieure avec [image] (Importer une bibliothèque).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La bibliothèque des treillis

Diamonds contient aussi une bibliothèque avec des treillis d'armature. Cette bibliothèque peut s'utiliser pour l'application d'une armature pratique à des dalles ou des plaques. Sélectionnez l'option de menu 'Edition – Bibliothèque treillis…' pour ouvrir cette bibliothèque.

Vous y trouvez, à gauche une liste de treillis d'armature déjà définis. Sélectionnez un treillis particulier dans cette liste, et vous en trouverez toutes les propriétés à droite. Il faut, en particulier, définir les diamètres des barres et leurs distances d'axe en axe pour les deux directions orthogonales. La section disponible par mètre linéaire est calculée automatiquement. Il vous faut encore définir, en-dessous, les dimensions et le poids du treillis d'armature. Notez toutefois que ces dernières données n'interviennent pas dans le calcul mais ont un caractère purement informatif.

Vous pouvez modifier les caractéristiques géométriques d'un treillis à tout moment. Vous pouvez aussi enrichir la bibliothèque de nouveaux treillis. A l'aide du premier bouton [image], insérez le nouveau treillis juste avant le treillis sélectionné. Si vous utilisez le bouton [image], le treillis sera ajouté à la fin de la liste. Vous pouvez adapter le nom de ce nouveau treillis d'armature dans le champ juste au-dessus de la liste. Par contre, si vous souhaitez supprimer un treillis d'armature, sélectionnez le treillis souhaité et cliquez sur le bouton [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Opérations avec les bibliothèques

Ajouter un nouvel objet

Supprimer un objet

Changer les paramètres du filtre

Importer une bibliothèque

Exporter une bibliothèque

Mettre à jour une bibliothèque

Réinitialiser une bibliothèque aux paramètres par défaut

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Ajouter un nouvel profil/ matériau

La procédure ci-dessous décrit comment ajouter un nouveau profil. Vous pouvez ajouter un nouveau matériau de manière analogue.

  • Cliquez sur [image].
  • Donnez le profil un nom.

  • Cliquez sur le champ “Groupes” pour assigner la section à plusieurs groupes de sections.

  • Cliquez sur [image] et choisissez le type de section et les dimensions souhaités.
  • Cliquez sur [image] pour enregistrer la section de façon permanente dans la bibliothèque. Si vous ne le faites pas, la section ne sera pas disponible après la fermeture de Diamonds

  • Cliquez sur [image] pour enregistrer tous les changements.

    Note: A partir du moment où vous cliquez sur [image], les paramètres du filtre actuels seront appliqués à ce profil! Cela rend possible que le profil ne soit soudainement plus visible! Par exemple:

    • Le filtre est défini pour que seuls les profils IPE soient visibles.

    • L'utilisateur ajoute un profil L à la bibliothèque.

    • Il clique sur [image]. Un avertissement apparaît.

    • L'utilisateur clique sur "OK" et le profil n'est plus visible.

    • Pour rendre le profil visible, vous devez ajuster les paramètres du filtre:

      • Soit vous cliquez [image] pour afficher tous les profils L.
      • Ou vous cochez le groupe concerné.
      • Ou vous cochez 'Utilisateur défini' > 'Oui'.
      • Ou vous cliquez sur [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Supprimer un élément

  • Sélectionnez l'élément à supprimer. Cet élément doit être précédé de l'icône [image]. Les éléments précédés de l'icône [image] sont des éléments standard et ne peuvent pas être supprimés.
  • Cliquer sur [image]. L'élément est définitivement supprimé de la bibliothèque.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Changer les paramètres du filtre

Le filtre de la bibliothèque de sections vous permet de choisir les sections qui doivent être visibles dans la boîte de dialogue de sections [image] . Le critère est ‘OU’. Les sections utilisées (assignées à des barres dans le modèle) sont toujours visibles, indépendamment des paramètres du filtre.

Par exemple, si la section présente une forme de I ou de H OU si elle appartient au groupe ‘L égale’ OU si elle est définie par l’utilisateur, elle apparaît dans la boîte de dialogue de sections. Ainsi, vous pouvez définir un filtre qui affiche uniquement les sections européennes/ américaines ou britanniques.

Cliquez sur [image] pour supprimer tous les filtres et afficher la bibliothèque complète dans la boîte de dialogue de sections.

Note:

  • Les sections utilisées (sections affectées aux membres dans le modèle actuel) seront toujours visibles dans la liste, quels que soient les paramètres du filtre.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Importer une bibliothèque

Si vous importez une bibliothèque de profils et certains profils contiennent des matériaux définis par l'utilisateur, importez d'abord ces matériaux!

  • Cliquez sur [image] et puis sur [image].
  • Allez vers le fichier/la bibliothèque que vous souhaitez importer.
    • * .mdb est l'ancien format des bibliothèques (2015r06 ou plus ancien)
    • * .bsf importe les éléments dans le projet sélectionné
    • * .xml est le format d'une bibliothèque (2017r00 ou plus récent) exportée
    • * .sut est le format d'un profil 'Section Utility'

  • Cliquez sur [image].

  • Sélectionnez les matériaux ou les sections que vous souhaitez importer. Cliquez sur [image] .

  • Choisissez si vous souhaitez sauvegarder les éléments de manière permanente dans la bibliothèque ou si vous souhaitez simplement les utiliser dans cette instance Diamonds.

  • Résoudre les conflits.

    Par exemple, un matériel dans la bibliothèque actuelle a les mêmes propriétés que le matériel que vous importez. Comment Doit Diamonds réagir? Ajouter le matériel importé comme nouveau matériau ou importer le matériel (= changer à existant)? Ensuite, cliquez sur [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exporter une bibliothèque

  • Définissez le filtre (Changer les paramètres du filtre) afin que seulement les éléments que vous souhaitez exporter soient visibles. Il n'est pas recommandé d'exporter la bibliothèque entière car les éléments par défaut ( [image]) seront toujours présents dans n'importe quelle bibliothèque, alors pourquoi les exporter?
  • Cliquez sur [image].
  • Vous pouvez conserver cette bibliothèque en tant que sauvegarde ou l'importer sur un autre ordinateur (Importer une bibliothèque).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Mettre à jour une bibliothèque

Lorsque vous démarrez Diamonds pour la première fois, les bibliothèques inclues par défaut sont chargées.

  • Les matériaux et les sections standard [image] sont tenus à jour par. Après avoir installé la version la plus récente, vous travaillerez avec les bibliothèques les plus récentes.
  • Lorsque vous travaillez avec des bibliothèques centrales (voir Bibliothèques locales ou centrales ) et des modifications sont apportées, vous recevrez une notification. Après le redémarrage Diamonds, vous travaillerez avec les bibliothèques les plus récentes.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Réinitialiser une bibliothèque aux paramètres par défaut

Consultez notre site de support pour plus d'information: http://buildsoftsupport.com/knowledge-base/how-to-reset-the-databases-back-to-their-defaults/

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calculs

Méthode des éléments finis

La subdivision des éléments

L'analyse élastique globale

Onglet 'Structurel'

Onglet 'Sol'

Onglet 'Dynamique'

Calcul élastique

L'analyse modale

Calcul des longueurs de flambement

Analyse au feu

Calcul des radiers par équilibre itératif

Dimensionnement de la fondation

Paramètres de sol

Sondage statique en profondeur

Essai au pressiomètre de Ménard

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Méthode des éléments finis

Diamonds est un programme d'éléments finis basé sur les déplacements. La méthode des éléments finis subdivisera la construction en un nombre limité d'éléments finis qui sont reliés entre eux au moyen de points nodaux. Les déplacements dans ces points nodaux, en particulier les translations et les rotations des angles, seront traités comme des inconnues discrètes. Une fois ces déplacements connus, il sera possible de calculer par interpolation les déplacements en chaque point de la barre ou du plan. Nous trouvons alors les déformations par déduction et les contraintes en chaque point par application de la loi de Hooke.

Les barres seront évidemment subdivisées en éléments. Pour les dalles et les plaques, des éléments de plaque sont requis. Il existe actuellement différents éléments de plaque sur le marché. Nous établissons une distinction, d'une part, entre les éléments triangulaires et les éléments rectangulaires et, d'autre part, entre les éléments de Mindlin et les éléments de Kirchoff. Dans Diamonds, nous utilisons l'élément triangulaire DKT (Discrete Kirchoff Theory).

Il y a déjà un certain temps qu'on découvre que les calculs de plaques à l'aide d'éléments triangulaires produiraient des résultats moins valables. Étant donné l'amélioration de la qualité des éléments triangulaires actuels, ces derniers ne le cèdent pratiquement plus en rien aux éléments rectangulaires. Le choix entre un élément de Mindlin ou de Kirchoff dépend plutôt de l'application. Alors que les éléments de Mindlin sont basés sur la théorie relative au calcul de plaques épaisses et tiennent par conséquent compte de l'incidence des déformations de cisaillement, les éléments de Kirchoff conviennent extrêmement bien pour le calcul des plaques minces. Si nous tenons compte du fait que nous ne parlons de plaque mince que lorsque le rapport entre la portée et l'épaisseur est inférieur à environ 5, nous pouvons justifier notre choix pour un élément de Kirchoff dans Diamonds. Les éléments de Mindlin fournissent aussi des résultats fiables pour les plaques minces, à condition que le maillage soit très affiné localement.

Un programme d'éléments finis est un instrument de calcul particulièrement puissant, mais il faut toujours se prémunir contre les résultats inexacts ou imprécis. Un élément 'plus riche' peut être indiqué dans certains cas, mais il ne fournit pas toujours un résultat plus précis comme nous l'avons déjà suggéré ci-dessus.

Les résultats peuvent dépendre fortement non seulement du type d'élément mais aussi de la finesse du maillage. Un maillage plus fin produira une moindre rigidité théorique totale de la plaque et approchera davantage la rigidité réelle de la plaque. Par ailleurs, un maillage trop fin induira dans certains cas des résultats défavorables. Nous pensons ici, en particulier, aux pics de moment au droit de points d'appui intermédiaires.

Il n'y a pas de règles générales qui puissent garantir l'exactitude des calculs d'éléments finis, puisque c'est souvent la compréhension du processus à modéliser par l'utilisateur qui est déterminante ici. Dans ce contexte, on dira donc que les résultats d'un calcul d'éléments finis sont aussi fiables que la personne qui utilise le logiciel. Mais les options ci-après peuvent apporter un certain soutien.

En premier lieu, il faut récolter les données d'entrée exactes avec le soin voulu. Si ces données ne concordent pas, il est impossible d'obtenir des résultats corrects. Si l'on ne dispose pas de toutes les données, on peut parfois recourir à une estimation, mais il est conseillé, dans ce cas, de répéter le calcul pour plusieurs valeurs du paramètre en question, afin de mettre en évidence leur incidence sur le résultat final. Il faut aussi que la précision des données d'entrée soit acceptable. Ainsi cela n'a-t-il aucun sens d'exprimer la constante de couche avec trois décimales après la virgule, puisqu'il est impossible de prédire le comportement du sol avec autant de précision. Enfin, il faut être attentif à ce que les unités utilisées correspondent toujours pendant l'entrée des données.

Pour éviter les longs temps de calcul, il arrive souvent qu'on ne modélise qu'une partie d'une construction. L'interaction de cette partie avec le reste de la construction est alors prédite à l'aide de conditions préalables appropriées. Il peut parfois s'indiquer de ne modéliser qu'une partie, même dans le cas d'une construction symétrique. Il faut toutefois appliquer alors les conditions de symétrie correctes. La solution doit donc être contrôlée soigneusement quant à la symétrie.

Pour les calculs plus complexes, il est parfois pratique de commencer par composer un modèle aussi simple que possible, qui décrive dans les grandes lignes le comportement de la construction. Une fois que l'on a bien compris ce modèle, on peut passer à un modèle plus détaillé.

Enfin, signalons l'importance de l'interprétation des résultats. En tant qu'ingénieur, vous avez déjà une petite idée des résultats possibles. Les résultats doivent donc correspondre à cette prévision. Pour contrôler si l'ordre de grandeur des résultats est conforme, vous pouvez faire appel à des calculs manuels ou à un référentiel de solutions.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La subdivision des éléments

Une fois que la géométrie de la construction est bouclée, le modèle peut être subdivisé en "éléments finis", opération que l'on appelle aussi 'génération de maillage'.

Cliquez sur le bouton [image] dans la barre d'icônes ou sélectionnez l'option de menu ‘Analyser – Maillages…’ pour définir le maillage de l'élément.

Dalles et plaques

Poutres et poteaux

Les données figurant dans la moitié supérieure de la boîte de dialogue portent sur la subdivision des éléments de plaque.

  • La première dimension vous permet de définir la finesse générale du maillage. De fait, Diamonds va s'efforcer de subdiviser la plaque ou le disque en éléments triangulaires équilatéraux dont le côté est égal à cette dimension maximale.

  • La dimension minimale manipulere la subdivision des éléments autour de lignes plus petites ou de points très rapprochés. En effet, une ligne ou une ligne imaginaire entre deux points proches, de longueur inférieure à la dimension maximale, correspond toujours à un côté d'un tel petit élément triangulaire. On peut ainsi obtenir localement un maillage d'éléments plus fin. Si vous définissez une dimension minimum égale à zéro, le programme s'efforcera ici aussi de créer autant d'éléments triangulaires équilatéraux que possible. De tels éléments vous fournissent de meilleurs résultats du point de vue qualitatif, mais le grand nombre de petits éléments fait vite augmenter le temps de calcul. C'est pourquoi il est parfois déconseillé d'indiquer une dimension minimale de manière à passer plus rapidement à un maillage plus grossier.

    Nous illustrerons notre propos à l'aide de l'exemple ci-dessous.

    Si aucune dimension minimale n'a été définie, il se crée une zone transitoire avant que l'on obtienne des éléments triangulaires de taille acceptable (égale à la dimension maximale). Dans l'autre cas, cette zone transitoire est beaucoup plus petite. Néanmoins, les éléments triangulaires y ont encore l'air très régulier. Nous pouvons donc conclure, dans cet exemple, que l'indication d'une dimension minimale est un bon choix.

  • Paramètres avancés

    • Si vous souhaitez affiner le maillage, vous pouvez diviser par deux la dimension maximale ou simplement cocher l'option 'avec subdivision des triangles'. L'affinage du maillage en question consiste à subdiviser chaque élément en un certain nombre de nouveaux éléments, afin que l'ancien maillage reste incrusté dans le nouveau. Ces éléments triangulaires ont une forme un peu plus irrégulière et ne possèdent donc pas la même qualité que si l'on réalisait l'affinage avec une dimension maximale plus petite. Mais la création du maillage est beaucoup plus rapide.

    • Avec ‘Division minimale de bord’ vous indiquez le nombre de pièces dans lequel chaque bord de la plaque devrait être divisé. Si vous entrez une valeur différente que ‘1’ pour ‘Facteur de raffinement taille minimale élément’, Diamonds recalculera le maillage pour des plaques sans noeuds internes de maillage. Le nouveau maillage à utiliser est alors:

      Ces paramètres prouvent leur utilité dans les modèles où il y a et des petites plaques et des grandes plaques. Si vous choisissez les tailles max et min assez grossiers, vous pouvez obtenir encore un bon maillage pour les petites plaques aussi, en réglant ces 2 paramètres.

    • Avec les deux dernières options, vous déterminez l'algorithme à utiliser.

      (par défaut)

La subdivision des éléments est entièrement automatique, à l'exception de l'introduction d'une dimension maximale et d'une dimension minimale. Vous ferez bien de limiter la géométrie à un minimum absolu et d'attribuer les charges mais aussi les supports à des points et des lignes afin de ne pas créer un nombre inutilement élevé de triangles. Malgré tout, on peut décider d'intégrer des points supplémentaires dans le modèle pour obtenir une subdivision plus fine sur les plaques où on l'estime nécessaire.

Les données situées dans la moitié inférieure de la boîte de dialogue couvrent la subdivision des barres.

  • Ces barres sont subdivisées en plusieurs éléments de barre. Vous noterez ce nombre (n) en bas de la boîte de dialogue. Il est conseillé de diviser la barre en un nombre suffisant d'éléments afin d'approcher le mieux possible le comportement réel. Diamonds attire votre attention sur les limitations qu'implique une subdivision trop petite en affichant en jaune le champ correspondant à n ≤ 3.

    Tenez également compte du fait que le nombre de subdivisions est important quand on effectue par la suite un contrôle normatif sur l'acier ou le bois. Il va sans dire que Diamonds limitera le contrôle aux sections pour lesquelles des efforts tranchants sont disponibles, à savoir les sections au droit des points de maillage.

  • Dans certains cas, il sera peut-être indiqué de définir également une dimension minimum pour les éléments de barre. Il est en tout cas indiqué, dans le cas où votre modèle contient des barres de très petite longueur, de respecter une grandeur minimum pour les éléments (≠ 0), sinon cela peut entraîner des instabilités numériques.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L'analyse élastique globale

Une fois que le modèle est subdivisé en "éléments finis", on peut démarrer le calcul élastique. En particulier, les efforts internes seront calculés selon la théorie d’élasticité, ce que veut dire que seulement les caractéristiques élastiques du matériau (E et ν) interviendront.

Pour démarrer le calcul élastique global de la structure étudiée, choisissez ‘Analyser – Analyse élastique’ dans le menu des commandes. Vous pouvez également utiliser l’icône [image] ou appuyer sur la touche F9.

la fenêtre consacrée à l'analyse élastique contient 3 onglets:

  • Structurel (voir Onglet 'Structurel')
  • Sol (voir Onglet 'Sol')
  • Dynamique (voir Onglet 'Dynamique')

Suivant la géométrie, un ou plusieurs onglets seront actifs. Vous devez passer en revue tous les onglets actifs.

Onglet 'Structurel'

Onglet 'Sol'

Onglet 'Dynamique'

Calcul élastique

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Structurel'

L'onglet 'Structurel' se présente comme suit:

Analyse

Plusieurs méthodes de calcul sont envisageables pour déterminer la répartition des efforts et les déformations. La norme impose telle ou telle méthode en fonction du type de structure (classe) étudiée. Parcourons ensemble les différentes méthodes de calcul.

Vous avez tout d’abord le choix entre un calcul au premier ou au second ordre (du moins si vous disposez d’une licence ‘2nd order Beams & Frames’).

  • Lors d’un calcul au premier ordre, les efforts sont calculés en faisant l’hypothèse que la géométrie de la structure ne se déforme pas.
  • Lors d’un calcul au second ordre, on exprime l’équilibre de la structure déformée. Celle-ci se retrouve alors dans une position a priori inconnue avant calcul. Pour ce faire, on tient compte des phénomènes suivants :
    1. le déplacement de la ligne des efforts normaux, plus couramment appelé l’effet P-Δ;
    2. l’effet rigidifiant ou assouplissant qu’ont les efforts normaux sur la déformée des barres, plus couramment appelé l’effet P-δ.

L’effet P-Δ est d’autant plus important que les charges appliquées sur la structure étudiée font subir aux nœuds de celle-ci des déplacements latéraux considérables.

Une charge externe horizontale peut par exemple engendrer une déformation latérale d’un portique. La déformation angulaire Ψ, observée au niveau des pieds de poteaux, a pour effets que l’effort normal (ici en l’occurrence un effort de compression) ne s’applique plus dans l’alignement de l’axe principal de la barre et que des moments supplémentaires apparaissent au niveau des colonnes alors que ceux-ci n’étaient pas pris en compte dans le calcul du premier ordre.

En plus, un calcul au second ordre tient également compte du fait que les barres ne restent pas parfaitement rectilignes entre leurs extrémités lorsque la structure globale se déforme. La figure ci-dessous illustre que cette déformation implique des moments fléchissants et des courbures complémentaires.

Un effort normal de traction dans une barre en réduit la rigidité alors que la présence d’un effort normal de compression l’augmente. C’est pourquoi les équations exprimant le comportement de la structure seront corrigées en y intégrant les fonctions de Γ et Δ. Celles-ci sont naturellement fonction de la grandeur de l’effort normal N. Ce sont ces fonctions qui rendent la matrice des rigidités singulière lorsque les efforts normaux N deviennent trop importants et qui permettent ainsi d’identifier un danger de flambement global de la structure.

Pour les structures qui disposent d’une rigidité horizontale suffisante (= structures dites ‘non-sway’), un calcul d’ordre 1 suffit. Par contre, lorsque l’influence des déformations latérales (l’effet P-Δ) s’avère non négligeable, un calcul d’ordre deux est souvent souhaitable. Les critères permettant de savoir s’y un calcul au second ordre s’impose ou non ne sont pas si évidents que cela… En général, on considère que les structures souples et sensibles aux déformations latérales (= structures qualifiées de ‘sway-structures’) demandent de prendre en compte l’effet P-Δ. Elles doivent dès lors être calculées au second ordre, à moins que le concepteur prenne, en âme et conscience, les mesures nécessaires pour pouvoir les calculer au premier ordre (par exemple en adaptant la grandeur des efforts horizontaux s’appliquant sur la structure). La décision finale d’appliquer telle ou telle analyse revient finalement toujours à l’utilisateur. Néanmoins, compte-tenu de la puissance de calcul du logiciel Diamonds, celui-ci pourrait, par soucis de facilité, systématiquement calculer ses structures au second ordre, en prenant toutefois la précaution de les calculer préalablement au premier ordre et d’effectuer une première vérification normative afin d’écarter tout risque de sous-dimensionnement.

Lorsque vous optez pour un calcul au second ordre, celui-ci se poursuivra jusqu’au moment où l’effort normal calculé converge dans l’ensemble des barres. Le calcul s’arrête effectivement lorsque la précision souhaitée est atteinte au niveau de la variation d’effort normal (ΔN/N < 1% par exemple) ou lorsque le nombre maximum d’itérations a été atteint. Si au bout de ce nombre d’itérations la précision souhaitée n’est pas atteinte, Diamonds indiquera pour quelles combinaisons l’équilibre n’a pas pu être atteint.

Remarque : N est généralement Petit dans le cas d’éléments principalement sollicités en flexion. Tout effort normal complémentaire suite aux effets liés au second ordre, aussi petit soit-il, engendre un ΔN/N très important. Pour éviter ce genre d’anomalies, le critère décrit ci-dessus (ΔN/N < 1%) ne sera pas appliqué lorsque Δσ = ΔN/A < 1N/mm².

Vous pouvez imposer aussi le nombre maximum d'itérations pour les non-linéarités.

Imperfections

Indépendamment du choix de calculer au premier ou au second ordre, vous pouvez ensuite préciser si vous souhaiter prendre en compte les imperfections globales de la structure.

  • Automatique (par défaut) : Diamonds détermine la direction la plus défavorable. Cette option représente le calcul le plus complet, mais elle implique aussi un temps de calcul très long.
  • Horizontale com. : les imperfections globales sont appliquées dans la direction horizontale dans laquelle la structure fléchit le plus. Si la structure ne subit pas de déplacement horizontal, Diamonds rebasculera en mode automatique pour déterminer la direction. Cette option correspond le plus à l'option pour les imperfections globales de Diamonds 2012 R02 ou de versions antérieures.
  • Globale X et Z : les imperfections globales sont appliquées dans la direction des axes globaux X et Z.
  • Globale X : les imperfections globales sont appliquées dans la direction de l'axe global X.
  • Globale Z : les imperfections globales sont appliquées dans la direction de l'axe global Z.
  • Imposée : au moyen d'un angle de rotation, l'utilisateur imposera la direction dans laquelle les imperfections globales agissent. L'angle de rotation est l'angle entre les axes globaux X et Z.

En réalité, toute structure effective est quelque peu différente de son modèle mathématique. La construction réelle présente en effet des erreurs et des imperfections par rapport au modèle théorique. Dans le cas particulier des constructions souples, dites ‘structures sway’, la norme prévoit qu’il faut tenir compte des imperfections globales pour la répartition des charges. Diamonds le fait en appliquant des efforts horizontaux équivalents. Si vous choisissez de vérifier une structure en position déformée, vous optez en fait pour un calcul itératif pendant lequel, pour chaque cas de chargement et chaque combinaison de charges, les étapes suivantes seront exécutées:

  1. (Optionel) Si vous optez pour 'Automatique', c'est Diamonds qui va déterminer la direction. La première itération permet de déterminer la direction principale de la déformation horizontale.
  2. Un second calcul permet de connaître les réactions aux appuis en appliquant un effort horizontal (= ϕ.N) dans la direction obtenue lors de la première itération, en chaque nœud sur lequel s’applique une charge verticale externe.
  3. Finalement la structure globale est calculée en tenant compte cette fois, des efforts extérieurs, des efforts horizontaux équivalents et des réactions obtenues lors de la seconde itération.

L’utilisateur est invité à limiter la déformation latérale. Par défaut la valeur de celle-ci est fixée à 1/200 et correspond à la position déformée de référence φ0 telle que décrite dans l’Eurocode.

Remarque: Outre la possibilité de définir une imperfection globale (position déformée extrême), la norme prévoit également que l’on puisse définir les flèches initiales (imperfections locales) de certains éléments. Ces imperfections au niveau des barres ne peuvent néanmoins pas être automatiquement prises en compte lors de l’analyse globale de la structure. Normalement, ceci ne devrait pas poser problème puisque l’effet des flèches initiales sont bel et bien pris en compte lors des vérifications individuelles.

Assemblages

Il vous est ensuite possible d’indiquer si vous souhaitez prendre en compte les rigidités réelles des assemblages ou simplement tenir compte de leur classification théorique. Cette option n’est bien entendu utilisable qu’en liaison directe avec PowerConnect permettant de modéliser de manière détaillée, chacun des assembles correspondant aux différents nœuds de la structure et d’en calculer les résistances et rigidités réelles. En fonction de la valeur de la rigidité réelle, l’assemblage sera considéré comme étant parfaitement rigide, semi-rigide ou parfaitement articulé.

Structures non-contreventées

Zone 1 : rigide lorsque Sj,ini≥ 25 EIb/Lb

Zone 2 : semi-rigide

Zone 3 : articulé lorsque Sj,ini≤ 0.5EIb/Lb

Structures contreventées

Zone 1 : rigide lorsque Sj,ini≥ 8 EIb/Lb

Zone 2 : semi-rigide

Zone 3 : articulé lorsque Sj,ini≤ 0.5EIb/Lb

Après avoir calculé la rigidité réelle et après avoir déduit la classe de l’assemblage (liaison rigide, semi-rigide ou articulée), vous pouvez, pour les encastrements et les rotules:

  • soit considérer ceux-ci comme parfaits et vous limiter à cette classification,
  • soit prendre en compte la rigidité calculée, telle qu’elle a été calculée au Conditions limites pour les extrémités des barres et les tirants, peu importe la classification de l’assemblage.

Pour les assemblages qui n'ont pas un comportement linéaire, vous pouvez encore choisir de:

  • Tenir compte de l'ensemble du diagramme de rigidité.
  • Eviter la partie plastique du diagramme de rigidité. En regard de ‘Limite’, indiquez le degré de pente [-] du morceau du graphique à partir duquel vous voulez refaire le calcul élastique. Un degré de pente négatif est toujours considéré comme un comportement plastique.
  • Calculer uniquement avec la rigidité Sj
  • Calculer uniquement avec la rigidité initiale Sj,ini.

Exemple: pour le diagramme de rigidité ci-dessous, le degré de pente a été déterminé pour chaque segment (à l'aide du tableau de données de gauche).

Si nous sélectionnons le comportement de l'assemblage selon une seule des options suivantes, c'est le diagramme de rigidité orange qui sera calculé au lieu du rouge.

Diagramme de rigidité complet | Éviter la plasticité - limite
Rigidité Sj | Rigidité initiale Sj,ini

Fissuration

Finalement, pour peu que vous disposez d’une licence 'Concrete Design' et que vous ayez calculé préalablement les quantités d’acier nécessaires aux différents endroits, vous pouvez également prendre en compte la fissuration des sections réalisées en béton arme. La flèche ainsi obtenue correspondra à l’affaissement total des sections fissurées que vous obtiendrez en cliquant sur le bouton [image] (à condition toutefois d’appliquer la même méthode de calcul: 1er ou 2ième ordre, avec ou sans prise en compte de la position déformée). Notez qu’il reste deux options complémentaires : vous avez également la possibilité de tenir compte ou pas du fluage du béton et de la fissuration dans les voiles suite à la présence de forces axiales dans ceux-ci. Rappelons qu’il est indispensable d’avoir calculé préalablement les quantités de ferraillage dans les différents éléments. Cette analyse vous permettra néanmoins de comprendre l’influence de la fissuration sur la répartition des charges et vous permettra d’obtenir par itération un ferraillage bien plus économique. Voyez Flèche fissurée.

Bois

Cochez cette option si vous souhaitez prendre en compte l’effet de fluage pour le bois. L’effet de fluage est pris en compte par correction du module de Young avec un facteur kdef, conformément à la norme EN 1995-1-1 §2.3.2.2. (1).

Les valeurs du facteur kdef peuvent se situer entre 0,6 et 2,0. Veuillez noter qu’un facteur kdefde 2,0 entraînera des déformations trois fois plus importantes.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Sol'

Si un profil de sol a été défini dans le modèle sur base des caractéristiques des différentes couches de terrain, Diamonds vous demandera également de préciser les informations suivantes. dans l'onglet 'Sol':

Chaque fois que le modèle ou une partie de celui-ci prend appui sur un sol dont le profil est défini par différentes couches, un calcul itératif supplémentaire s’impose. En réalité, Diamonds détermine la capacité portante du sol de manière itérative pour chacune combinaisons de charges. Les tassements globaux ainsi que les efforts de coupe peuvent alors être déduits en superposant les résultats spécifiques à chacun des groupes de charges, à moins qu’on ait choisi d’imposer que le sol en question ne peut reprendre d’efforts de traction. Vous trouvez plus d’information de ce méthode de calcul dans Calcul des radiers par équilibre itératif.

Diamonds connaît déjà le niveau du sol naturel, comme défini dans Niveau du sol.

Vous devez encore définir le niveau avant excavation. Pour plus de clarté, le niveau de la fondation la plus haute (à laquelle un profil de couches est attribué) est donné juste au-dessus. Diamonds connaît ainsi

  • les couches de sol qui se trouvent directement sous les différentes fondations ;
  • la profondeur de fouille pour chaque fondation de sorte qu’on puisse tenir compte d’une charge éventuelle du terrain.
    • Si le niveau indiqué est situé plus bas que l'ébauche de la fondation la plus haute, l'écran affiche un avertissent selon lequel la couche ne peut pas être calculée pour le niveau indiqué.
    • Si le niveau du terrain naturel et la fondation ne correspondent pas, on peut prendre en compte un pourcentage donné de l'effet de la charge du terrain dans la formule de Terzaghi.

Les autres paramètres concernent le processus itératif proprement dit.

  • Comme le calcul itératif de la constante de couche peut être une opération relativement longue, le calcul de la couche n'est réalisé que pour une seule combinaison de charges. Il est recommandé d'utiliser pour cela une combinaison représentative de la charge habituelle sur l'ébauche de fondation. C'est pourquoi on opte généralement pour une combinaison de charges quasi-permanentes.
  • La résolution en profondeur dépend par conséquent étroitement de l'épaisseur des couches successives. Généralement, le calcul de la couche se fait avec une précision identique à celle postulée avec le choix du maillage d'éléments. C'est pourquoi Diamonds assimilera toujours la résolution à la dimension maximale sélectionnée pour les éléments triangulaires. Il est donc peu judicieux d'évaluer l'augmentation de la contrainte sur de petites épaisseurs de couche si on a généré un maillage d'éléments grossier pour la dalle de fondation proprement dite.
  • Notez encore le nombre maximal d'itérations à effectuer. En général, on a en fait déjà obtenu une précision suffisante après deux ou trois itérations. Il est vrai qu'en tant qu'utilisateur, vous ne pouvez pas imposer le nombre de couches de sol qui interviendront dans le calcul. Seules les couches sur lesquelles la contrainte supplémentaire du sol est supérieure à 5% de la charge sur l'ébauche de fondation seront prises en compte. On suppose que la dernière couche de sol définie se prolonge à une profondeur infinie.

  • L’option ‘Tolérance du contraintes’ est ajouté. Cette option vous permet de terminer les calculs du sol à une certaine profondeur z pour laquelle là précision spécifiée pour ∆p/p est atteint:

    • ∆p est l'augmentation de la contrainte verticale effective à la profondeur z résultant de la charge de surfacique.
    • p est la contrainte effective verticale initiale à la profondeur z

    Selon EN 1997-1-1 §6.6.2. (5) et (6) vous pouvez utiliser une tolérance de 20%. Les entreprises de l’examen du sol utilisent généralement une tolérance de 10% pour le calcul des tassements.

  • L'option ‘Appliquer sol enlevé à l’interface’ permet de définir la façon dont l'excavation doit être prise en compte :

    • Lorsque l'option est décochée, Diamonds part du principe que le sol sera retiré en plusieurs étapes, générant une diminution de la contrainte, sous et à côté de l'excavation.
    • Lorsque l'option est cochée, Diamonds part du principe que l'ensemble du sol est retiré en une seule fois. Cela génère une diminution de la contrainte seulement en dessous de l’excavation.

    En plusieurs étapes

    En une seule fois

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Onglet 'Dynamique'

L'onglet 'Dynamique' s'active quand le modèle comporte une contrainte dynamique ou sismique.

Cette fenêtre contient les paramètres suivants:

  • Indiquez le nombre de modes propres (et les fréquences propres correspondantes) que vous souhaitez déterminer.
  • Sélectionnez aussi la combinaison sur laquelle vous souhaitez baser la détermination de la matrice de rigidité. Pour ce faire, il vaut mieux sélectionner le groupe de charges 'Poids propre'.
  • Paramètres avancés:
    • Avec 'Intervalle', vous pouvez indiquer dans quelles limites vous souhaitez déterminer les modes propres (et les fréquences propres correspondantes).
    • Vous avez ensuite le choix entre deux types d'amortissement:
      • L'amortissement de Rayleigh: indiquez le taux d'amortissement ξ du premier et du second modes propres.
      • Ou indiquez les taux d'amortissement mesurés pour chaque mode propre séparément.
    • Si vous disposez du module Diamonds 'Linear Dynamic Analysis', vous pouvez choisir ici d'utiliser soit le solveur interne de Diamonds soit le solveur DDS externe, très performant (recommandé).
    • Matrice de masse: vous avez le choix entre une matrice cohérente ou concentrée (lumped)

Remarque: le solveur interne selon la méthode de Lanczos.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul élastique

Après avoir indiqué les différentes options avec lesquelles vous souhaitez effectuer l’analyse, cliquez sur ‘OK’. Une fenêtre vous montre l'avancement de l'analyse. Cette fenêtre disparaît automatiquement quand l'analyse s'est terminée sans erreurs, sinon elle reste affichée à l'écran. Le bouton 'Détails' vous permet de vérifier où l'erreur s'est produite exactement. Ensuite, vous refermerez la fenêtre en cliquant sur le bouton 'Finir'.

Le bouton [image] permet d’arrêter la procédure de calcul. Si vous la relancez par la suite, celle-ci sera complètement ré-exécutée.

En fonction de la méthode de calcul choisie, la répartition des charges suite aux combinaisons de charges sera déterminée par superposition ou par calcul itératif.

En réalité, le principe de la superposition ne peut être appliqué qu’en cas de calcul au premier ordre d’une structure sans non-linéarités. Dans ce cas précis, il est en effet possible de calculer la structure sous l’effet des différents cas de charges et d’ensuite superposer les résultats obtenus de façon à en déduire la répartition des charges sous l’effet des différentes combinaisons de charges.

Dès que le modèle comprend des non-linéarités, un calcul itératif s’impose. La superposition n’est en effet plus possible et chaque combinaison de charges doit alors être calculée séparément. Il va de soi que ceci nécessite d’avantage de temps de calcul. On parle de ‘non-linéarités’ lorsque le comportement de certains éléments du modèle n’est pas linéaire. Cela peut être le cas lorsque le modèle comprend des tirants, des appuis qui ne fonctionnent que dans une seule direction (ne reprenant que des efforts de traction ou de compression) ou des éléments pour lesquels vous avez défini des rigidités variables aux extrémités. Dans le cas des tirants, chaque fois qu’il s’avère que, sous l’effet d’un groupe de charges ou d’une combinaison de charges, un tirant est soumis à compression ; celui-ci est retiré du modèle et la structure est alors recalculée avec les autres tirants en traction. Ce processus est répété jusqu’au moment où une solution est obtenue pour laquelle tous les tirants sont, soit effectivement en traction, soit retirés du modèle de calcul.

Dans le cas d’imperfections globales de la structure, il est évident qu’on ne peut appliquer le principe de la superposition. Dans le cas de calculs au second ordre, la méthode itérative s’impose systématiquement. Les fonctions de stabilité Γ et Δ ne peuvent d’ailleurs être déterminées que sur base des efforts normaux résultant à chaque fois de l’itération précédente. Dès lors, les analyses au second ordre demandent généralement des temps de calcul très importants, d’autant plus que les instabilités globales de la structure sont également vérifiées. Le temps de calcul sera d’autant plus long que le modèle comprenne en outre un certain nombre de non-linéarités (telles par exemple des tirants ou des appuis ne reprenant que la traction ou la compression), puisque dans ce cas les différents processus itératifs s’imbriquent les uns dans les autres.

Dernièrement, chaque fois que le modèle ou une partie de celui-ci prend appui sur un sol dont le profil est défini par différentes couches, un calcul itératif supplémentaire s’impose. En réalité, Diamonds détermine la capacité portante du sol de manière itérative pour chacune combinaisons de charges. Les tassements globaux ainsi que les efforts de coupe peuvent alors être déduits en superposant les résultats spécifiques à chacun des groupes de charges, à moins qu’on ait choisi d’imposer que le sol en question ne peut reprendre d’efforts de traction. Vous trouvez plus d’information de ce méthode de calcul dans Calcul des radiers par équilibre itératif.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L'Analyse modale

Une analyse modale permet de déterminer les fréquences propres et les modes propres de la structure. Pour lancer ce type d'analyse, cliquez sur [image] . Diamonds affiche alors un écran dans lequel vous pourrez encore paramétrer quelques options de calcul:

Cette fenêtre contient les paramètres suivants:

  • Indiquez le nombre de modes propres (et les fréquences propres correspondantes) que vous souhaitez déterminer.
  • Sélectionnez aussi la combinaison sur laquelle vous souhaitez baser la détermination de la matrice de rigidité. Pour ce faire, il vaut mieux sélectionner le groupe de charges 'Poids propre'.
  • Paramètres avancés:
    • Avec 'Intervalle', vous pouvez indiquer dans quelles limites vous souhaitez déterminer les modes propres (et les fréquences propres correspondantes).
    • Vous avez ensuite le choix entre deux types d'amortissement:
      • L'amortissement de Rayleigh: indiquez le taux d'amortissement ξ du premier et du second modes propres.
      • Ou indiquez les taux d'amortissement mesurés pour chaque mode propre séparément.
    • Si vous disposez du module Diamonds 'Linear Dynamic Analysis', vous pouvez choisir ici d'utiliser soit le solveur interne de Diamonds soit le solveur DDS externe, très performant (recommandé).
    • Matrice de masse: vous avez le choix entre une matrice cohérente ou concentrée (lumped)

Après avoir effectué une analyse modale, vous pouvez examiner, par fréquences propres, les modes propres et les résultats correspondants.

Remarque: le solveur interne selon la méthode de Lanczos.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul des longueurs de flambement

Diamonds intègre une puissante méthode de calcul pour la détermination des longueurs de flambement. La méthode utilisée est relativement simple. Voici l’explication pour la détermination des longueurs de flambement de barres non groupées, d’une part autour de leur axe fort y’- (u) et d’autre part, autour de leur axe faible z’- (v).

Diamonds commence par appliquer une charge uniformément répartie sur la barre, perpendiculairement à l’axe fort dont nous souhaitons déterminer la longueur de flambement.

Il exécute ensuite le calcul et obtient comme résultats les déplacements des deux extrémités u, la déformation angulaire φ, le moment M en l’effort tranchant V. Les rapports (V/u) et (M/φ) déterminent pour chacune des extrémités les raideurs transversales et angulaire des ressorts équivalents.

Pour une barre maintenue en ses deux extrémités par un ressort transversal et un ressort angulaire, on peut appliquer la relation différentielle d’Euler :

Cette expression a comme solution générale :

En exprimant les 4 conditions aux appuis en fonction de la solution globale, on obtient un système de 4 équations à 4 inconnues A, B, C et D.

Ce système comprend une solution non triviale lorsque le déterminant est nul. Le déterminant ne peut être égal à zéro que pour certaines valeurs de α.

La plus petite de ces valeurs α correspond à la charge critique Pk qui fait flamber la barre.

La charge provoquant le flambement Pk permet de déterminer la longueur de flambement correspondante lk à partir de l’équation d’Euler:

Ensuite, Diamonds recommence l’opération une seconde fois en appliquant cette fois une charge uniformément répartie sur la barre, perpendiculairement à l’axe faible dont nous souhaitons déterminer la longueur de flambement.

La méthode de calcul (détaillée ci-dessus pour le cas d’une barre individuelle) s’applique de la même manière pour un groupe de barres pour peu que celles-ci puissent physiquement flamber simultanément. Dans ce cas, la charge uniformément répartie s’appliquera simultanément sur l’ensemble des éléments et les conditions limites à prendre en compte dans l’équation différentielle d’Euler correspondront à celles des appuis correspondant aux extrémités du groupe de barres. En pratique, Diamonds calculera systématiquement les longueurs de flambement au niveau des groupes.

C’est à l’utilisateur de grouper les éléments de façon correcte et réfléchie (voir La palette pour (dé-)grouper des éléments barres). Dans le cas contraire, il se peut qu’une situation critique ou plus défavorable en matière de flambement ne soit pas prise en compte.

Parfois il s’avère indispensable de pouvoir définir des comportements différents en matière de flambement autour des axes fort et faible. La notion de groupe permet cette finesse. L’exemple ci-dessous illustre comment procéder. Il s’agit d’une poutre en treillis simplement appuyée dont les membrures supérieure et inférieure sont considérées comme continues.

Les angles supérieurs de la poutre ne peuvent pas bouger hors du plan. On étudiera plus particulièrement la sensibilité au flambement de la membrure supérieure.

Pour étudier le flambement autour de l’axe fort (dans le plan), chaque élément linéaire doit être considéré séparément et les barres constituant la membrure supérieure ne peuvent être groupées selon l’axe fort.

Les poinçons et diagonales consolideront d’ailleurs suffisamment la poutre en treillis pour éviter le flambement vertical de la membrure supérieure. La longueur de flambement ainsi calculée sera souvent plus petite que la longueur réelle des éléments pris individuellement.

Par contre, le danger de flambement hors du plan (autour de l’axe faible du profil) sera bien plus important. En effet, dans ce cas de figure, les poinçons et diagonales n’apportent que très peu de résistance. Il est dès lors conseillé de considérer la membrure supérieure comme un seul élément pour calculer sa longueur de flambement autour de son axe faible. Pour ce faire, il faut grouper les éléments constituant cette membrure selon l’axe faible.

Cette fois, la longueur de flambement sera déterminée à partir de la longueur du groupe de barres constituant la membrure dans son ensemble. Logiquement, vous obtiendrez ainsi une longueur de flambement autour de l’axe faible équivalent à la portée de la poutre en treillis.

Remarque :Il faut être extrêmement prudent lors de la définition des groupes. Imaginez que nous ayons également groupés les éléments pour étudier le flambement autour de leur axe fort. Nous aurions obtenu une longueur de flambement dénudée de tout sens physique ! Les conditions limites auraient été déterminées avec l’hypothèse que l’ensemble de la membrure supérieure soit chargée (dans le plan) alors que dans le modèle d’Euler équivalent, on ne tiendrait pas compte de l’effet bénéfique des poinçons et diagonales qui interviennent pourtant comme des appuis élastiques intermédiaires.

Le calcul de la longueur de flambement, tel qu'exposé ci-dessus, suppose le maintien de la rigidité de la structure adjacente. Une constante de ressort plus grande ou plus petite du ressort de translation sera déduite sur base de cette rigidité. Or, la norme ne suit pas ce scénario. Elle prévoit, par contre, deux longueurs de flambement: une pour les nœuds déplaçables et une pour les nœuds non déplaçables. Concrètement, cela veut dire que, lorsqu'on calcule la charge de flambement selon Euler, le ressort de translation sera supposé soit très petit soit infiniment rigide.

Pour être complet, Diamonds prévoit trois scénarios possibles:

  • calcul des longueurs de flambement sur base de nœuds non déplaçables – à utiliser en cas de calcul de 2ième ordre ou à utiliser lors d'une analyse de 1er ordre d'un portique sans contreventement. Ce calcul donne toujours des longueurs de flambement plus petites que la longueur du système.
  • calcul des longueurs de flambement sur base de nœuds déplaçables (dans ce cas, on ne tient pas compte de la rigidité du reste de la structure adjacente, mais toutes les barres mises en compression perdent simultanément leur stabilité au flambement) – à utiliser avec un calcul de 1er ordre du portique contreventé. Ce calcul produit une évaluation aussi conservatrice que possible des longueurs de flambement.
  • calcul des longueurs de flambement sur base de nœuds semi-déplaçables (avec maintien de la rigidité de la structure adjacente) – à utiliser en cas d'analyse de 1erordre d'un portique contreventé.

Le critère sur base duquel un portique doit être classé dans la catégorie sans ou avec contreventement ne sera pas abordé ici. Vous trouverez des informations à ce sujet dans les documents sur les Eurocodes.

Pour calculer les longueurs de flambement, utilisez la commande ‘Analyser – Calculer longueurs de flambement’ ou le bouton [image] de la palette d’icônes de la configuration de modélisation (‘Géométrie’). La fenêtre de dialogue ci-dessous apparaît alors à l’écran :

Les longueurs de flambement peuvent se calculer pour le flambement autour de l'axe fort y’(u) et autour de l'axe faible z’(v). Pour chaque sens de flambement (et par conséquent autour de l'axe fort/faible y’(u) - z’(v)), vous pouvez:

  • Indiquer s'il faut ou non calculer les longueurs de flambement autour de cet axe. Si vous cochez la case, les longueurs de flambement autour de l'axe en question ne seront pas calculées.
  • Selon quel type de structure et quel mode de calcul ces longueurs de flambement doivent être déterminées

En outre, vous pouvez aussi cocher ou décocher l'option 'Regrouper des barres illogiquement non groupées'. Si l'option est cochée, les barres

  • qui se situent dans le prolongement l'une de l'autre, sans point d'appui ou sans autre barre qui s'y raccorde
  • et définies comme 'dégroupées'

sont quand même groupées en interne.

Enfin, dans le cas où la structure contient des non-linéarités (tirants, points d'appui actifs dans une seule direction, ...), le programme vous demandera sur base de quelle combinaison ces non-linéarités doivent être déterminées. Concrètement, la structure sera calculée une première fois, de manière à pouvoir établir quels tirants/barres ou points d'appui doivent être supprimés dans le modèle. Ensuite, toutes les longueurs de flambement seront calculées dans l'hypothèse que tous les tirants subsistants et seuls les points d'appui actifs peuvent reprendre un effort de traction comme de compression.

Si vous souhaitez que les longueurs de flambement soient affichées au niveau des barres, sélectionnez la commande ‘Montrer – Fenêtre Configuration…’ ou utilisez l’icône [image]. Indiquez ensuite que vous souhaitez que les longueurs de flambement soient calculées (voir Définition ou modification d’une configuration).

Si vous n’êtes pas d’accord avec la longueur de flambement calculée ou si vous souhaitez imposer une valeur, commencez par sélectionner la/les barre(s) concernée(s). Puis, utilisez le bouton [image] de la palette correspondant à la configuration ‘Géométrie’ (Paramètres de flambement et de déversement).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul de la réponse thermique

Un incendie se traduira par une augmentation de la température de la section. Avec le calcul de la réponse thermique on peut déterminer cette augmentation.

Cliquer sur le bouton [image] pour ouvrir la fenêtre de réponse thermique.

  • En haut, il y a deux onglets: ‘Solveur FÉM’ et ‘Solveur Analytique’.

    • Solveur FÉM

      • Le calcul est basée sur la Méthode Eléments Finis (MEF, EN: FEM)

      • adéquate pour les sections massives (normalement en béton armé)

    • Solveur Analytique

      • Le calcul se base sur les formules de EN 1993-1-2
      • adéquate pour les sections mince (acier)

    Diamonds va déterminer automatiquement si la section a besoin d’un calcul par le solveur FÉM ou le solveur analytique. Pour cela, Diamonds utilise le schéma suivant:

    Vous pouvez, si vous le souhaitez, convertir un cas FEM vers un cas analytique et vice versa. Pour faire cela, vous faites glisser une section vers le solveur désirée.

    Si le projet a plusieurs barres avec le feu défini, tous les cas de feu seront regroupés par section et puis par conditions limites.

    Les bords de la section marquée en jaune/orange sont soumis au feu.

    Remarques:

    • Le solveur analytique n’est pas adapté pour calculer les sections massives!
    • Pas tous les cas FEM peuvent être convertis à un cas analytique et vice versa. Quand il n’est pas possible de convertir, Diamonds affichera un message d'erreur.
  • Un algorithme interne calcule un maillage approprié. Les valeurs proposées sont dans la plupart des cas, très bien, il ne faut pas les modifier. Seulement pour les sections avec beaucoup de différences dans les dimensions des parties, vous pouvez décider de régler le maillage afin d'obtenir un mesh qui est mieux réparti.
  • Appuyez sur [image] pour arrêter les calculs.

Remarques:

  • Pour une analyse de résistance au feu, suivez ces étapes:

    • Faites la géométrie comme d’habitude
    • Ajoutez sur les barres les courbes de feu (voir Protection incendie)

    • Faites le calcul de la réponse

      • Réponse thermique (voyez en haut)

      • Réponse élastique

        • Générations des combinaisons (voir Combinaisons de charges)

        • Analyse globale élastique (voir L'analyse élastique globale)

    • Faites le dimensionnement (à ce moment uniquement pour l’acier)
  • A l’importation d’un fichier PowerFrame dans Diamonds, il est recommandé de redéfinir les paramètres de feu et vice versa.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul des radiers par équilibre itératif

Dimensionnement de la fondation

Paramètres de sol

Sondage statique en profondeur

Essai au pressiomètre de Ménard

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Dimensionnement de la fondation

Les radiers sont très fréquents et pourtant leur calcul constitue encore souvent un problème. Souvent, on en revient au calcul d'une couche élastique selon le modèle de Winkler. On suppose à cette fin que la réaction exercée par le sol est proportionnelle au tassement du sol:

q = k • s

(q = réaction du sol, k = constante de couche, s = tassement).

Dans certains cas, on ‘évalue’ la valeur de la constante de couche en se basant sur le tassement calculé selon Terzaghi et appartenant à un niveau de charge sur une semelle continue ou non; l'entreprise de sondages joint souvent ces calculs au rapport de sondage et il n'y a pour ainsi dire plus qu'à ramasser les résultats. Dans les autres cas, on tire la valeur de la constante de couche k des résultats d'un essai (supplémentaire) sur dalle. Comme l'essai sur dalle s'effectue toujours sur une plaque de taille limitée par rapport aux dimensions réelles de la dalle de fondation, il manque toujours les informations sur les couches plus profondes, lesquelles ne jouent aucun rôle sur la plaque de l'essai, mais bien sur la dalle de fondation beaucoup plus grande. Quelle que soit l'approche retenue parmi les deux ci-dessus, on détermine toujours 1 valeur constante pour la relation réaction du sol – tassement, et cette valeur fait partie d'un effort donné sur une plaque de dimension donnée. Dans la pratique, la charge exercée sur la dalle varie et les dimensions s'écartent des dimensions susmentionnées.

Même si l'on devait quand même réussir à connaître la 'bonne' valeur de la constante de couche, le modèle de Winkler présente quelques lacunes:

  • d'après cette théorie, si une dalle est mise en charge uniformément, elle s'enfonce sans contrainte dans le sol;
  • la charge d'une dalle n'a aucune influence sur le tassement d'une dalle voisine.

Une méthode plus sophistiquée s'impose donc. En fait, Diamonds permet de déterminer l'évolution de la couche résiliente de manière itérative de telle manière que le calcul de la dalle reposant sur une couche résiliente non régulière donne les mêmes tassements que le calcul du tassement du sol mis en charge avec l'effort de réaction des ressorts et calculé avec Boussinesq et Terzaghi. Il est donc possible de déterminer par calcul l'évolution de la couche de la manière itérative suivante:

Au cas où les résultats sont obtenus par un essai au pressiomètre, les tassements sont calculés à l'aide de la relation suivante:

Vous trouverez ci-après la définition des coefficients utilisés dans les formules ci-dessus:

  • z la profondeur de la couche considérée;
  • C constante de compression (voir Sondage statique en profondeur);
  • A constante de remise en charge (voir Sondage statique en profondeur);
  • Δh l'épaisseur de la couche considérée;
  • σ contrainte initiale due au poids du sol;
  • Δσz(i) augmentation de la contrainte due aux charges ajoutées;
  • αk coefficient structurel de la couche de sol k (voir Essai au pressiomètre de Ménard).
  • EMK module de compression de la couche k (voir Essai au pressiomètre de Ménard).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres de sol

Sondage statique en profondeur

Essai au pressiomètre de Ménard

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sondage statique en profondeur

La constante de compressibilité du sol C ou A et la loi des tassements de Terzaghi permettent de déterminer la façon dont les différentes couches de sol se comportent lorsqu’elles sont soumises à compression. La constante de compressibilité du sol peut être déterminée par des essais en laboratoire sur des échantillons non-modifiées. Une valeur approximative peut également être déduite d’essais de sol sur site. De tels sondages nous informent quant à la résistance au frottement le long de la surface du tube ainsi qu’à la pointe du cône enfoncé à travers les différentes couches de sol étudiées. Lorsque le tassement semble instantané, il peut être établi une corrélation entre la résistance conique qc et la constante de compression C . Celle-ci est donnée par l’équation :

Où α=1,5 (valeur par défaut du rapport de sondage), qc la résistance au cône σ'v0 la tension intergranulaire verticale. Si vous souhaitez obtenir des valeurs de C plus précises, vous pouvez néanmoins considérer les bornes figurant dans le tableau ci-dessous pour α. Ces dernières ont été établies en prenant en compte la nature du sol et la résistance au cône observée (qc) :

Type de sol | [MPa] | facteur de correlation α pour la determination de C | acteur de correlation α pour la determination de A
Argile peu plastique | qc≤ 0.7 0.7 < qc< 2 qc< 2 | 3 < α < 8 2 < α < 5 1 < α < 2.5 | 4.5
Terre glaise peu plastique | qc< 2 qc> 2 | 3 < α < 6 1 < α < 2 | 6 < α < 7,5
Argile ou glaise plastique | qc< 2 qc> 2 | 2 < α < 6 1 < α < 2 |
Terre organique | qc< 1.2 | 2 < α < 8 |
Troube très organique | qc< 0.7 50 < w ≤ 100 100 < w ≤ 200 w > 200 | 1.5 < α < 4 1 < α < 1.5 α < 0.4 | 1
Chaux | 2< qc≤ 3 qc> 3 | 2 < α < 4 1,5 < α < 3 |
Sable |  | 1,5 < α < 2 | 15 < α < 20

Valeurs pour α (colonnes 1-3 voir EN 1997-1-2 Tablau D.2)

Le coefficient de consolidation CC [%] indique combien de la consolidation du sol (relaxation) s'est produit entre le moment de l'excavation et du (re)chargement :

  • 0% => L’excavation et la charge de la fondation se succèdent très rapidement. Il n'y a pas de détente ou un gonflement du sol possible. Au niveau de la fondation, la contrainte est égale à contrainte géo-statique initiale.
  • 100% => Il y a longtemps entre l'excavation et la charge causant tous précharge a disparu dans le sol. Le niveau de la fondation a une contrainte égale à 0 kN/m, et se comportera comme le terrain naturel.

Parfois, une détermination plus détaillée de CC nécessaire. CC ne est pas seulement dépendante du temps entre l'excavation et le chargement, mais également sur le type de sol, et plus précisément de la capacité de drainage. Le plus facile qu’un sol peut écouler l’eau interstitielle, le plus rapidement la préconsolidation aura disparu:

  • Un puits de fondation est drainé, le CC sera à peu près égal à 100%
  • Le sable est drainé immédiatement, donc le CC sera approximativement de 100%
  • Les couches d'argile supérieures minces se drainent rapidement, donc le CC se situe entre 50% et 75%
  • Les couches d'argile épaisses situées dans le bas se drainent plus lentement, donc le CC se situe entre 25% et 50%
  • En présence de couches d'argile épaisses profondes, le drainage dure plus longtemps, donc le CC se situe entre 0% et 25%

Le rapport de surconsolidation OCR[-]: il exprime la mesure dans laquelle le sol a déjà été mis en charge antérieurement.

OCR = (tension effective maximale présente dans le passé)/(tension effective actuelle,avant fouilles)

  • Si le sol a déjà été mis en charge antérieurement (p.ex. démolition d'un ancien bâtiment ou enlèvement d'un amas de sable), le rapport de surconsolidation sera supérieur à 1.
  • Si le sol n'a pas été mis en charge antérieurement, le rapport de surconsolidation sera égal à 1.

Le rapport de surconsolidation OCR peut prendre une valeur différente selon la couche de sol. Ainsi un profil de sol peut-il consister en un sol déjà mis en charge antérieurement plus un sol d'apport.

Attention: pour les fouilles, vous n'avez PAS besoin d'adapter l'OCR. Diamonds le prend automatiquement en compte.

Si vous n'avez aucune idée du rapport de surconsolidation OCR, il vaut mieux introduire ‘1’.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Essai au pressiomètre de Ménard

Un essai au pressiomètre fournit également les paramètres de sol indispensable au calcul du tassement par méthode itérative.

Ce test est effectué à l’aide d’un cylindre extensible. Celui-ci est soit directement placé dans un trou pré-foré, soit amené à la bonne profondeur par autoforage, enfoncement, vibration ou tout autre procédé adapté.

Les mesures des déformations du sol en fonction des pressions exercées sur la tête de sondage permettent d’établir un graphique des déformations en fonction des efforts exercés et d’en déduire les caractéristiques mécaniques du sol.

Le module de compression pressiométrique EMK ainsi déterminé à différentes profondeurs est parfaitement analogue à la constante de compression C. Les tassements ne sont néanmoins plus déterminés par la loi de Terzaghi mais à l’aide de l’équation suivante:

Dans cette formule, Δσz(i) correspond à la tension verticale résultant des charges supérieures et observée au point i situé à une profondeur z.

Δh correspond à l’épaisseur de la couche de sol considérée.

Le coefficient αk dépend de la nature du sol et peut être déduit du tableau ci-dessous :

Nature du sol | Tourbe | Argile | Limon | Sable | Gravier
Très compacté | - | 1 | 2/3 | 1/2 | 1/3
Normalement compacté | 1 | 2/3 | 1/2 | 1/3 | 1/4
Non compacté | - | 1/2 | 1/2 | 1/3 | 1/4

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Dimensionnement

Béton armé

Calcul d'armature

Choix de la norme béton

Paramètres pour le béton et l'armature

Calcul de l'armature

Amatures pratiques

Base

Avancé

Calcul de la flèche fissurée

Flèche fissurée

Flèche fissurée dans le temps

Calcul de largeur de fissuration

Contrôle de l'acier et du bois

Définition des renforts au déversement

Renforts au déversement et calcul automatique des longueurs de déversement

Modification ou suppression de renforts au déversement

Vérification de l’acier & bois

Choix de la norme

Paramètres pour l’acier

Paramètres pour le bois

Vérification de la résistance et de la stabilité

Optimisation

Optimisation des peintures résistantes au feu

Déformation acier inoxydable

Assemblages

Modéliser l’assemblage

Sélectionner les combinaisons

Calculer l’assemblage

Sauvegarder l’assemblage dans la bibliothèque

Attribuer les caractéristiques de l’assemblage à un nœud

Assamblages paramétrique

Stiffness

Resistance

Interaction

Bibliothèque d’assemblages

Vérification d’assemblages dans Diamonds

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Béton armé

Calcul d'armature

Choix de la norme béton

Paramètres pour le béton et l'armature

Calcul de l'armature

Calcul des armatures dans les poutres et les poteaux

Calcul de l'armature dans les dalles et les plaques

Calcul des armatures de poinçonnement

Amatures pratiques

Base

Avancé

Calcul de la flèche fissurée

Flèche fissurée

Flèche fissurée dans le temps

Première étape: définition du moment de la charge et de la combinaison pour fissuration

Deuxième étape: préparation des flèches à calculer dans le temps

Troisième étape: le calcul de la flèche dans le temps

Calcul de largeur de fissuration

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul d'armature

Diamonds propose une armature minimum sur la base de la section donnée. Cette armature est indispensable pour résister aux charges en état-limite ultime. Elle peut en outre éventuellement être augmentée afin d'éviter des contraintes excessives dans le béton (ou l'acier) dans des "conditions normales" également. Le calcul d'armature est aussi désigné par le terme 'calcul organique' parce que c'est le comportement réel du béton armé qui y intervient. En effet, en cas de dimensionnement classique, les efforts internes seront toujours calculés selon la théorie de l'élasticité linéaire. C'est uniquement dans le calcul organique que l'on fait intervenir le comportement non linéaire du matériau.

Choix de la norme béton

Paramètres pour le béton et l'armature

Calcul de l'armature

Calcul des armatures dans les poutres et les poteaux

Calcul de l'armature dans les dalles et les plaques

Dalles

Plaques

Calcul des armatures de poinçonnement

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Choix de la norme béton

Diamonds peut vous calculer la quantité d'armature pour les éléments du type béton.

Ici aussi, les résultats peuvent être légèrement différents selon la norme utilisée. Vous sélectionnerez la norme souhaitée sous l'option de menu 'Étude – Norme béton'. Les normes disponibles sont:

La norme EN 1992-1-1 est toujours accompagnée d'une annexe nationale. C'est là que sont établis tous les paramètres déterminés nationalement (AN). Si vous voulez quand même tenir compte des valeurs recommandées par EN 1992-1-1, sélectionnez l'option “--“.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres pour le béton et l'armature

Les propriétés de résistance du béton armé sont reprises dans la bibliothèque des matériaux. Sélectionnez l'option de menu 'Modifier - Bibliothèque des matériaux' pour ouvrir cette bibliothèque puis cliquez sur l'onglet 'Avancé'.

Comme nous l'avons déjà dit, toutes les normes n'appliquent pas les mêmes propriétés du matériau. C'est pourquoi vous devez remplir les caractéristiques requises pour chaque norme. Nous expliquerons ci-dessous les paramètres utilisés dans le calcul organique selon EN 1992-1-1.

Vous trouverez les propriétés matérielles du béton proprement dit dans le premier onglet.

Pour le béton, nous distinguons différentes classes de résistance. Chaque classe (p. ex. C25/30) est désignée par la lettre C (pour ‘concrete’) suivie de deux nombres. Le premier nombre représente la résistance caractéristique à la compression d'un cylindre de béton (cylindre de 150mm x 300mm), le second chiffre représente la résistance caractéristique d'un cube de béton (cube de 150mm de côté). Dans les deux cas, il s'agit d'une résistance en compression à 28 jours. Étant donné que, dans l'Eurocode 2, les autres propriétés de résistance du béton sont déduites de la résistance caractéristique en compression d'un cylindre de béton, vous noterez ici le premier nombre.

En fonction de la qualité de béton que vous aurez choisie, on peut déduire une série de caractéristiques correspondantes du matériau. Chacune d'entre elles est munie d'un bouton [image].

  • La résistance moyenne en traction fctm du béton est donnée par:

    • pour les classes de résistance ≤ C50/60

    • pour les classes de résistance > C50/60

La résistance en traction du béton intervient dans le calcul de la flèche fissurée. Le moment de fissuration, en particulier, est calculé sur la base de la résistance moyenne en traction par flexion fctm,fl.

Ici, h représente respectivement la hauteur totale ou l'épaisseur de la poutre ou de la plaque en mm.

  • Le module E de Young intervient à la fois dans l'analyse de la flèche élastique, l'analyse de la flèche fissurée et le calcul organique de l'armature (lors du contrôle des contraintes en traction du béton). Le module sécant, en particulier, intervient pour les contraintes de longue durée.

Étant donné que Ecm est déduit de fck, ces valeurs se rapporteront également à 28 jours.

  • Le coefficient de fluage φ(∞, t0) pour la limite de contrainte intervient dans le contrôle des contraintes du béton et de l'acier dans l'état limite de service, tout au moins quand le fluage est pris en compte. Diamonds calcule ce facteur de fluage de manière à ce que le rapport entre le module E de l'acier (200.000 N/mm²) et celui du béton après fluage ( [image]) soit égal à 15. On obtient ainsi un facteur de fluage inférieur à celui imposé par la norme (voir point suivant), mais si l'on exécutait le contrôle de contrainte au moment ∞ (et donc quand le fluage est entièrement survenu), on obtiendrait un sous-dimensionnement de l'armature et donc un résultant peu sûr.

  • Le coefficient de fluage φ(∞, t0) pour la flèche intervient dans le calcul de la flèche fissurée. Ce facteur dépend, en principe, de l'humidité de l'environnement, des dimensions de l'élément, de la composition du béton et de l'âge du béton au moment de la mise en charge. Des graphiques permettant d'évaluer ce facteur sont disponibles dans l'Eurocode. Dans Diamonds, ce facteur est toujours assimilé à 2. Mais vous êtes libre de définir un autre coefficient de fluage plus précis, évidemment.

  • En principe, il faut limiter les contraintes du béton dans l'état-limite de service. Ici aussi, vous pouvez introduire vous-même une valeur ou faire calculer la valeur proposée par la nome en appuyant sur un bouton. Comme les contraintes du béton diminuent sous l'effet du fluage et que la sollicitation maximale n'intervient généralement qu'après qu'un effet de fluage a déjà eu lieu pour les charges permanentes, il est d'usage de limiter ces contraintes pour un rapport de 15 des modules E susmentionnés. Pour parvenir à ce rapport, vous devez donc calculer le coefficient de fluage φ pour un rapport de 15 et cocher l'option ‘après fluage’.

Les autres paramètres sont indépendants de la qualité de béton choisie. Tout d'abord, vous trouvez encore le coefficient de sécurité partielle pour le béton, qui est habituellement de 1.50. Ce coefficient est appliqué en même temps que le coefficient de longue durée (αcc) pour estimer la valeur théorique de la résistance en compression fcd.

Enfin, vous pouvez indiquer vous-même l'excentricité additionnelle pour le calcul du flambement. En effet, si vous avez coché cette option, Diamonds augmentera éventuellement l'armature lors du calcul d'armature des poteaux pour résoudre, le cas échéant, les problèmes de flambement. La vérification du flambement s'effectue à l'aide de la méthode de la colonne modèle. Cette méthode requiert une excentricité additionnelle qui tient compte d'une obliquité possible.

Vous retrouverez les propriétés matérielles de l'armature dans le deuxième onglet de cette boîte de dialogue.

On établit une distinction entre l'acier d'armature destiné à l'armature longitudinale et à l'armature transversale (les étriers). Le facteur de sécurité partielle pour l'acier d'armature est de 1.15.

Si vous le désirez, vous pouvez limiter la contrainte de l'acier à une fraction inférieure aux 80% proposés par l'Eurocode 2. Dans les constructions où la largeur de fissuration a son importance, cette réduction peut contribuer à réduire la largeur des fissures.

Les pourcentages minimum et maximum d'armature se rapportent toujours au pourcentage géométrique d'armatureρ = As/bd. As est la quantité d'armature considérée en mm², b et d sont respectivement la largeur et la hauteur utile de la section. La hauteur utile est égale à la différence entre la hauteur totale de la section et l'enrobage brut de l'armature. Lorsqu'il faut une armature donnée (inférieure, supérieure, gauche et droite) pour l'action des forces, cette armature sera au besoin augmentée jusqu'au pourcentage minimum. Le pourcentage maximum d'armature concerne la somme de toutes les armatures longitudinales (inférieure, supérieure, gauche et droite) dans une section donnée.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul de l'armature

Pour qu'un calcul d'armature soit possible, il faut avoir calculé globalement l'ensemble de la structure pour au moins une combinaison dans l'état-limite ultime (ELU) et une combinaison dans chacun des deux états-limites de service (ELS QP en ELS CR). Vous commencez le calcul d'armature en sélectionnant l'option ‘Analyser – Armatures’ dans le menu ou en cliquant sur l'icône [image]. Les armature seront calculées suivant les zones sélectionnées (voir Matériaux, enrobages (béton) et mode de fabrication (acier) des barres). Une boîte de dialogue vous montre l'avancement du calcul.

Une fois le calcul terminé, un bouton supplémentaire s'active dans la palette 'Résultats': . Vous pouvez ensuite choisir dans le menu déroulant l'armature que vous souhaitez représenter. Vous trouverez la signification des symboles dans Affichage des résultats de l'armature.

Si avant de lancer le calcul vous avez sélectionné un ou plusieurs éléments, le logiciel vous demandera de préciser si vous souhaitez calculer les armatures pour tous les éléments ou uniquement pour ceux que vous avez sélectionnés. Lors de la sélection d'éléments de barres (poutres/poteaux), il est également possible d'avoir les résultats intermédiaires du calcul d'armature écrits dans un fichier txt. Le fichier txt peut être ouvert depuis Base via le bouton [image].

Calcul des armatures dans les poutres et les poteaux

Calcul de l'armature dans les dalles et les plaques

Dalles

Plaques

Calcul des armatures de poinçonnement

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul des armatures dans les poutres et les poteaux

Vous voyez ci-dessous un exemple de l'armature inférieure et supérieure pour une poutre simple.

La ligne mince représente la quantité d'armature nécessaire pour satisfaire uniquement à l'état-limite ultime. Dans la ligne plus épaisse, ces quantités ont éventuellement été augmentées pour tenir compte de la limitation des contraintes dans les états-limites de service, du respect de pourcentages minimum d'armature et d'un risque éventuel de flambement.

Le même principe s'applique à la représentation de l'armature de cisaillement. La ligne mince est l'armature théoriquement exigée pour reprendre l'effort tranchant. Dans la ligne plus épaisse, ces quantités ont éventuellement été augmentées pour tenir compte de la torsion et les pourcentages minimum d'armature.

Lorsque la section de béton est insuffisante pour permettre de déterminer une armature qui satisfasse à tous les critères, un avertissement s'affiche à la fin du calcul et mentionne le numéro de tous les éléments pour lesquels il n'a pas été possible de calculer l'armature. Une tête de mort se dessine également au milieu de l'élément si vous avez cliqué sur un seul des symboles d'armature. Dans l'exemple ci-dessous, il n'a pas été possible d'abaisser la contrainte du béton jusqu'à un niveau admissible sans dépasser le pourcentage maximum d'armature. Par contre, il est possible de résister avec succès à l'état-limite ultime, comme vous le voyez à la ligne plus mince qui se poursuit sur toute la longueur.

Pour info, l’état limite auquel on ne peut donner satisfaction est indiqué dans la fenêtre de dialogue permettant de définir les armatures pratiques. Pour rappel, vous pouvez accéder à cette fenêtre de dialogue en double-cliquant sur la poutre concernée.

Remarque :Lorsque vous déterminez une armature pratique, vous ne pouvez plus utiliser la section que vous avez déjà utilisée pour un coté (p. ex. l'armature supérieure) pour un autre côté (p. ex. l'armature gauche ou droite). Vous devez donc toujours veiller à ce que la somme des armatures pratiques (inférieure, supérieure, gauche et droite) soit au moins égale à la somme des armatures calculées. Dans le cas d'une barre d'angle, vous pouvez évidemment utiliser une partie de sa section pour l'armature supérieure, par exemple, et la partie restante pour l'armature gauche, par exemple.

Vous pouvez aussi exporter l'armature calculée théorique vers ConCrete Plus pour y générer automatiquement un plan d'armature (voir Exportation vers ConCrete Plus). Tenez compte du fait que ConCrete Plus ne trace que l'armature supérieure et l'armature inférieure, une armature latérale éventuelle se traduit en armature de renfort.

Remarquons encore qu'un contrôle de flambement s'opère également pour les éléments soumis à compression dès qu'il faut tenir compte d'une éventuelle excentricité additionnelle (voir aussi Paramètres pour le béton et l'armature).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul de l'armature dans les dalles et les plaques

Un élément mis en charge perpendiculairement à sa surface est une dalle (slab). Un élément mis en charge dans sa surface est désigné par le terme 'plaque’ ou 'mur' (plate). La méthode de calcul utilisée pour déterminer l'armature est différente pour les deux éléments. Vous en trouverez les formules dans les annexes de l'Eurocode 2. Nous en reprenons les principes essentiels ci-dessous.

Remarque : Diamonds calcule les armatures longitudinal dans des dalles/ plaques dû à l'effort normal et du moment de flexion. Cependant, Diamonds ne calculera jamais l'armature de cisaillement dans des dalles/ plaques.

Dalles

Plaques

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Dalles

La solution de l'équation des dalles selon la théorie élastique donne, en chaque point de la plaque, les valeurs intervenantes de Mxx, Myy et Mxy. Au départ de ces valeurs, on peut également déterminer les moments principaux M1 et M2 avec le cercle de Mohr ainsi que les directions principales qui y correspondent. Seuls agissent donc sur ces petites surfaces des moments de flexion, et la contrainte par traction y est maximale. La fissuration survient donc à la perpendiculaire de la direction principale de traction: l'armature devrait donc logiquement être posée suivant cette direction principale de traction et sa section devrait être calculée avec le moment principal en question.

Mais ce concept est peu pratique car il donne lieu à des armatures à tracé courbe.

C'est pourquoi, dans Diamonds, le sens de l'armature est toujours établi suivant les axes locaux x’ et y’. Diamonds suppose par conséquent toujours un treillis d'armature orthogonal. Imaginez qu'outre les moments fléchissants Mxx et Myy des moments de torsion Mxy surviennent aussi dans la plaque. La méthode consiste donc à recalculer ces moments de torsion en moments fléchissants. La norme propose la méthode suivante à cette fin:

Eurocode 2 et normes apparentées:

(ENV 1992-1-1 §A2.8)

Sur base de ces moments, on peut maintenant déterminer l'armature dans les deux directions orthogonales. Éventuellement, on augmente cette armature pour tenir compte de la limitation des contraintes dans les états-limites de service.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Plaques

Bien qu'en principe, les plaques soient mis en charge uniquement dans leur surface, nous allons discuter ici de la méthode générale valable pour les éléments soumis à une flexion composée.

Partons d'un point quelconque dans lequel on connaît les efforts Mxx, Myy, Mxy, Nxx, Nyy et Nxy. Pour chaque plan perpendiculaire qui passe par ce point et dont le vecteur normal forme un angle θ avec l'axe x, on va définir l'effort normal Nθ et le moment fléchissant Mθ à l'aide des équations suivantes:

Mθ= Mxxcos2θ + Myysin2θ - 2Mxysinθcosθ [1]

Nθ= Nxxcos2θ + Nyysin2θ - 2Nxysinθcosθ [2]

L'armature équivalente Aθ, parallèle au vecteur normal, s'exprime de manière analogue:

Aθ= Axxcos2θ + Ayysin2θ

Le but est de déterminer l'armature supérieure Axxs, Ayys et l'armature inférieure Axxi, Ayyi de façon à réduire au maximum l'armature totale. La détermination du rapport Aθs/Aθi est un problème bien connu qui revient aussi dans le dimensionnement de l'armature des poutres. Il nous reste encore à trouver un algorithme pour réduire au maximum les sommes Axxs+Ayys et Axxi + Ayyi.

Dans notre exemple, nous nous concentrons sur l'armature supérieure As. Pour chaque valeur q, il faut respecter l'inégalité suivante:

Aθ≤ Axxscos2θ + Ayyssin2θ [3]

où Aθs est déterminée au départ de (Mθ; Nθ) des définitions [1] et [2].

L'équation [3] peut être représentée graphiquement en traçant depuis le point de repère Axxs-Ayy, une ligne droite qui passe par les points ( [image];0) et (0; [image]).

Lorsque cela a été fait pour toutes les valeurs de q, nous obtenons une limite subordonnée à toutes les combinaisons possibles (Axxs; Ayys). L'illustration montre aussi que, pour une solution possible (Axxs; Ayys), la distance jusqu'à l'origine du point projeté sur la première bissectrice est égale à 0.7071(Axxs+Ayys. Après avoir déterminé la courbe, il faut rechercher le point sur la courbe dont la projection sur la première bissectrice est la plus proche de l'origine.

Le calcul de l'acier d'armature optimal pour les murs soumis à une flexion composée peut être résumé comme suit:

  1. Détermination des efforts Mxx, Myy, Mxy, Nxx, Nyy et Nxy dans le sens x’ et y’ de l'armature.

  2. Détermination de Mθ et Nθpour toutes les directions de θ.

  3. Détermination du profil théorique de l'armature supérieure Aθs et inférieure Aθi, compte tenu d'un rapport optimal Aθs/Aθi de manière à ce que la somme (Aθs + Aθi) soit minimale.

  4. Détermination de l'armature supérieure Axxs and Ayys, compte tenu de l'inégalité [3] pour toutes les directions de θ et en veillant à ce que la somme (Axxs+ Ayys) soit minimale.

  5. Détermination de l'armature inférieure Axxiet Ayyi, en tenant également compte de l'inégalité [3] pour toutes les directions de θ et en veillant aussi à ce que la somme (Axxs+ Ayys) soit minimale.

Une fois que l'armature Axxs, Ayys, Axxi, Ayyi a été déterminée pour l'état-limite ultime, on peut éventuellement encore augmenter la quantité d'armature en reprenant le même calcul de manière à satisfaire à l'état-limite de service pour les combinaisons rares et quasi-permanentes.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul des armatures de poinçonnement

Dans le cas de dalles soumises à des charges concentrées, le risque existe de les voir se détériorer voir céder localement sous l’effet du poinçonnement.Une zone conique sera particulièrement critique sous chaque point d’application de ces charges concentrées.

Lorsque la résistance au poinçonnement du béton est insuffisante, c’est comme si l’élément sur lequel s’applique la charge ponctuelle passait à travers la fondation.On peut obtenir de meilleures résistances au poinçonnement en augmentant par exemple localement l’épaisseur de la dalle ou en augmentant la section des colonnes.Des armatures spécifiques (recourbées) peuvent également apporter une solution. Diamonds vérifie si des armatures de poinçonnement sont nécessaires et si oui, en quelles quantités.

Semelles

Pour les semelles de fondations [image] telles que définies au Caractéristiques des semelles, Diamonds exécute automatiquement une vérification au poinçonnement. Vous pouvez modifier les paramètres utilisés lors du contrôle du poinçon de cette manière :

  • Cliquez sur le bouton [image] et puis sur [image].

  • Sélectionnez la semelle et cliquez sur la touche droite de la souris. La fenêtre de dialogue de la page suivante apparaît alors à l’écran:

    Vous pouvez ajuster les propriétés suivantes :

    • La surface de contact correspond à la zone soumise à la charge concentrée.

    • Ensuite, vous pouvez intervenir sur l’épaisseur et les enrobages de la semelle.

    • Pour terminer, Diamonds indique les quantités d’armatures longitudinales susceptibles d’être présentes aux abords immédiats de la charge concentrée.A priori, la résistance au poinçonnement sera toujours calculée sur base des armatures en traction nécessaires là où la vérification est effectuée.Compte-tenu des piques de moment et d’armatures que l’on observe souvent au niveau d’appuis intermédiaires, la quantité d’armatures sera souvent surévaluée. Les semelles ont toujours une armature dans les deux directions orthogonales (Ax et Az). La quantité d’armature, qui est donnée dans cette fenêtre, est égale à [image].

Dalles (de fondations)

Pour les dalles (de fondations) et les radiers, vous devez vous-même choisir d’effectuer cette vérification. Pour ce faire:

  • Cliquez sur le bouton [image] et puis sur [image].
  • Après cela, vous sélectionnez la dalle pour laquelle vous souhaiter vérifier si des armatures de poinçonnement sont requises ainsi que le point où s’applique la charge concentrée critique.

  • Cliquez sur la touche droite de la souris, la fenêtre de dialogue de la page suivante apparaît alors à l’écran:

Dans la partie supérieure de celle-ci, un croquis schématise la dalle sélectionnée ainsi que le point où le poinçonnement doit être vérifié.La zone dans laquelle cette vérification sera effectuée apparaît en couleur.Elle sera constituée de l’ensemble des triangles de maillage dont au moins un des sommets se situe dans un rectangle dont les dimensions(Lx' etLz') ainsi que la position (α, ex' et ez') sont précisés par l’utilisateur.

A l’intérieur de cette zone, tous les contours possibles dans les quels le phénomène de poinçonnement pourrait survenir seront vérifiés. Compte-tenu du fait que la charge concentrée n’est pas forcément centrée sur la zone, un coefficient β, dépendant de la forme de la zone de contrôle intervient au niveau du calcul.

Généralement, on distingue les types de contours suivants :

  • Contours fermés autour de la zone où une charge concentrée est appliquée (voir croquis ci-après). Dans ce cas, β = 1,15.

  • Contours englobant un bord libre de la dalle. Diamonds prend systématiquement en compte ce type de contours pour peu que les bords soient situés dans la zone à vérifier.Dans ce cas,β = 1,4.

  • Contours englobant plusieurs bords libres et successifs de la dalle. Dans ce cas le phénomène de poinçonnement peut provoquer une rupture du coin de la dalle qui se détache alors du reste de la dalle.Dans ce type de situations, β = 1,5.

Dans le cas d’une semelle de fondation, les contours les plus proches à vérifier se situent à une distance entre d et 2d du bord de la colonne. La position exacte est alors calculée par Diamonds en considérant le contour le plus défavorable.

Dans tous les autres cas de dalles, les contours se situent à une distance 2d (cf. la norme EN 1992).

Dans le cas où ceux-ci nécessitent des armatures de poinçonnement, Diamonds s’attaque à une seconde série de contours situés à une distance0,5d. Diamonds poursuit ainsi jusqu’au moment où il n’y a plus besoin d’armatures de poinçonnement.

L’armature ainsi calculée pour un contour de référence doit en théorie être appliquée entre le bord de la colonne et le contour lui-même. C’est pourquoi les quantités d’armatures de poinçonnement sont toujours exprimées en mm²/m².

Dans la partie inférieure droite de la fenêtre de dialogue, vous avez la possibilité de vérifier ou d’imposer certains paramètres influençant la résistance au poinçonnement du béton utilisé :

  • La surface de contact correspond à la zone soumise à la charge concentrée.Lorsqu’une colonne a effectivement été modélisée et dessinée, la forme et les dimensions de la zone soumise à la charge concentrée sont connues. Lorsqu’un simple appui a été modélisé à l’emplacement de la colonne ou lorsqu’on a effectivement appliquée une charge ponctuelle, Diamonds considère l’octogone dont le diamètre circonscrit vaut 20 cm.

  • Ensuite, vous pouvez intervenir sur l’épaisseur et les enrobages de la dalle. Lorsque plusieurs dalles aux épaisseurs différentes sont concernées, Diamonds ne tient compte que de la plus faible épaisseur.

  • Pour terminer, Diamonds indique les quantités d’armatures longitudinales susceptibles d’être présentes aux abords immédiats de la charge concentrée. A priori, la résistance au poinçonnement sera toujours calculée sur base des armatures en traction nécessaires là où la vérification est effectuée. Compte-tenu des piques de moment et d’armatures que l’on observe souvent au niveau d’appuis intermédiaires, la quantité d’armatures sera souvent surévaluée.

Si vous voulez comprendre d’avantage les effets de ces différents paramètres, vous pouvez toujours les modifier manuellement après avoir coché l’option permettant cette possibilité. Vous pouvez de la sorte découvrir quelle épaisseur de dalle ne nécessite absolument pas d’armatures au poinçonnement. Vous pouvez aussi, en imposant la quantité d’armatures longitudinales, obtenir une armature de poinçonnement plus réaliste, surtout dans le cas les armatures pratiques sont trop différentes des armatures théoriques dans ce point. Les dalles ont toujours une armature dans les deux directions orthogonales (Ax et Az). La quantité d’armature, qui est donnée dans cette fenêtre, est égale à [image].

Remarque: lorsque vous utilisez la vérification au poinçonnement de Diamonds, vous devez à tout moment être conscient des limites suivantes :

  • La résistance au poinçonnement du béton est calculée sur base des armatures théoriques. Lorsque les armatures n’ont pas pu être déterminées, Diamonds se base sur les armatures minimales, en ne tenant nullement compte d’éventuelles armatures pratiques. Par contre, la résistance au poinçonnement des semelles est calculée sur base du maximum des armatures théoriques requises ou des armatures pratiques lorsque celles-ci ont été définies.
  • Diamonds ne prend pas en compte les ouvertures dans les dalles sauf s’ils peuvent être considérées comme bords libres.
  • L'armature de poinçonnement est calculée en fonction de la valeur de calcul de la charge qui intervient, en particulier la force de réaction ou la force concentrée perpendiculaire à la plaque ou à la semelle de fondation. Dans le cas d'une dalle de fondation, cette force est diminuée de la pression du sol dans le périmètre considéré. Un coefficient β tient compte de l'excentricité de la charge agissante et escompte, par conséquent, l'effet défavorable d'un moment éventuel. Diamonds applique toujours les valeurs approchées pour β (c.-à-d. 1,15 pour une colonne centrale, 1,4 pour une colonne périphérique et 1,5 pour une colonne d'angle). En principe, ces valeurs approchées ne peuvent s'utiliser que si la stabilité latérale ne dépend pas de l'effet de portique entre plaque et colonne(s) et si les longueurs des différentes portées contiguës ne diffèrent pas de plus de 25%. Dans tous les autres cas, il y a lieu d'exécuter un calcul plus détaillé de β. Vous trouverez des formules générales dans la norme EN 1992-1-1.
  • Dans le cas d’une dalle alvéolée, Diamonds prend en compte l’épaisseur minimale pour l’ensemble de la surface.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Amatures pratique

Base

Avancé

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Base

Une fois le calcul d'armature effectué, vous pouvez définir une armature pratique. On tient compte de cette armature pendant le calcul de la fissurabilité de la section.

Pour attribuer une armature pratique à une poutre ou à une plaque, appuyez dans chacun des cas sur le bouton [image] dans la palette ‘Résultats' et sélectionnez dans le menu déroulant un des résultats d'armature des poutres ou des plaques. Double-cliquez ensuite sur la barre ou la plaque en question.

  • La première boîte de dialogue s'applique aux poutres, et la seconde aux plaques. Pour les poutres, notez la section d'armature (en mm²) pour les 4 armatures longitudinales différentes (supérieure, inférieure, gauche et droite).

    En utilisant le bouton [image], vous pouvez ouvrir un fichier txt contenant les résultats intermédiaires du calcul des armatures pour les poutres/poteaux sélectionnés. De plus d'informations sur l’interprétation de ces résultats intermédiaires peuvent être trouvées sur le site Web de support.

  • Pour les plaques, notez la section d'armature totale par mètre courant (en mm²/m) pour l'armature supérieure et l'armature inférieure. Comme Diamonds est doté d'une bibliothèque des treillis d'armature (voir La bibliothèque des treillis), vous ne devez plus calculer cette section. Vous cliquez simplement sur le bouton [image] et indiquez le treillis en question dans la boîte de dialogue.

    A gauche, vous trouvez tous les treillis d'armature repris dans la bibliothèque. A droite, vous trouvez un croquis du treillis sélectionné avec indication des dimensions, des diamètres des barres et de la largeur des mailles. Si la section d'armature n'est pas identique dans les deux sens, vous pouvez indiquer, en bas à gauche, qu'il faut faire pivoter le treillis à 90°.

    L'armature théorique maximale figure également à côté de chaque armature. Aux endroits où l'armature calculée théoriquement est supérieure à l'armature pratique, Diamonds ne tiendra aucun compte de cette armature pratique pendant le calcul de la flèche fissurée.

    Enfin, indiquez sur combien de barres cette armature doit être répartie. Ce nombre est important pour le calcul de la largeur de fissuration. Si le treillis provient de la bibliothèque des treillis d'armature, cette valeur se remplit automatiquement.

Remarquons encore que vous pouvez attribuer l'armature pratique à plusieurs éléments à la fois. Commencez par sélectionner à cette fin toutes les poutres ou les plaques et puis cliquez sur le bouton droit de la souris. Des boîtes de dialogue identiques à celles ci-dessus vont s'afficher mais l'armature introduite sera maintenant adaptée au groupe d'éléments sélectionnés.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Avancé

Après avoir calculé les armatures, vous pouvez définir les armatures pratiques en détail en sélectionnant une ou plusieurs plaques dans le même plan et en cliquant sur [image] .

Remarque : ce module nécessite d’utiliser une licence distincte ! Ce module n’est pas accessible dans la version démo.

Pour revenir à Diamonds, cliquez sur [image] ou utilisez le raccourci clavier CTRL+ W. Les modifications sont automatiquement enregistrées.

Ajout d'une zone d’armatures
Zone avec barres d’armatures pratiques

  1. Choisissez les Armatures pratiques que vous souhaitez tracer [image] .

    • Les axes ‘x’ et ‘z’ renvoient au système de coordonnées situé sur l’écran en bas à gauche, ET NON AU SYSTÈME LOCAL DE COORDONNÉES DES PLAQUES !
    • La lettre ‘i’ correspond aux armatures inférieures et ‘s’ aux armatures supérieures.

    Dans la figure ci-dessous, les armatures inférieures (i) ont été choisies en parallèle à l'axe z.

  2. Cliquez [image] sur pour activer le mode orthogonal.

    • Lorsque l'option [image] est activée (ou que vous appuyez sur la touche SHIFT. du clavier), vous ne pouvez tracer que des zones d’armatures parallèles aux axes x et z.
    • Lorsque l'option [image] est désactivée, vous pouvez également tracer des zones d’armatures angulaires.

  3. Cliquez sur [image] pour tracer une zone avec des barres d’armatures pratiques

    • Tracez une ligne parallèle à l'axe z (car l'option Azi est sélectionnée).

      Cette action permet de définir le sens et la longueur des barres d’armatures.

    • Tracez une ligne parallèle à l'axe x.

      Cette action permet de définir la largeur de la zone d’armatures.

    • Réglez le diamètre à l’aide des touches ↑ et ↓ du clavier.

      Réglez le pas à l’aide des touches → et ← du clavier.

      Vous pouvez également spécifier le diamètre et le pas de votre choix en cliquant via les champs [image] .

      Vous pouvez également double-cliquer sur la zone pour ajuster le diamètre / la distance.

    • Cliquez une dernière fois pour positionner le nom de la zone d’armatures.

    • Les zones dans lesquelles les armatures pratiques appliquées sont supérieures aux armatures calculées théoriquement sont colorées en blanc.

      Les armatures supplémentaires requises sont affichées dans toutes les autres zones.

Zone avec treillis d’armatures pratiques

  1. Choisissez les Armatures pratiques que vous souhaitez tracer [image].

    • Les axes ‘x’ et ‘z’ renvoient au système de coordonnées situé sur l’écran en bas à gauche, ET NON AU SYSTÈME LOCAL DE COORDONNÉES DES PLAQUES !
    • La lettre ‘i’ correspond aux armatures inférieures et ‘s’ aux armatures supérieures.

  2. Cliquez sur [image] pour tracer une zone avec des treillis d’armatures pratiques

    • Cliquez plusieurs fois sur l’écran pour définir un polygone. Pour arrêter la fonction de dessin, appuyez sur la touche ENTERdu clavier. La zone d'armatures ne doit pas nécessairement se situer dans la plaque ou correspondre parfaitement aux bords de la plaque. Le contour peut être dessiné grossièrement autour.

      Cette action permet de définir les dimensions de la zone d’armatures.

    • Réglez le diamètre à l’aide des touches ↑ et ↓ du clavier.

      Réglez le pas à l’aide des touches → et ← du clavier.

      Vous pouvez également spécifier le diamètre et le pas de votre choix en cliquant via les champs [image] .

      Vous pouvez également double-cliquer sur la zone pour ajuster le diamètre / la distance.

    • Les zones dans lesquelles les armatures pratiques appliquées sont supérieures aux armatures calculées théoriquement sont colorées en blanc.

      Les armatures supplémentaires requises sont affichées dans toutes les autres zones. Déplacez le curseur de la souris sur le dessin. Le volume d’armatures supplémentaires requises est indiqué sur l’écran en bas à droite. Cliquez sur le bouton Total pour afficher les armatures théoriques totales calculées.

Réglage d'une zone d’armatures
Réglage du diamètre/ pas d’une zone d’armatures
  • Activez le mode de sélection [image].

  • Cliquez sur le nom (dans le cas des treillis et barres d’armatures) ou sur le point d’intersection des flèches (dans le cas des barres d’armatures). La zone d’armatures sélectionnée s’affiche alors en surbrillance.

  • Réglez le diamètre à l’aide des touches ↑ et ↓ du clavier.

    Réglez le pas à l’aide des touches → et ← du clavier.

    Vous pouvez également spécifier le diamètre et le pas de votre choix en cliquant via les champs [image] .

    Vous pouvez également double-cliquer sur la zone pour ajuster le diamètre / la distance.

Réglage de la longueur/largeur d’une zone d’armatures
  • Activez le mode de sélection [image].
  • Déplacez le curseur de la souris sur le bord de la zone d’armatures. Le curseur [image] devient alors une double flèche [image].
  • Vous pouvez désormais étirer le bord concerné et ainsi régler la longueur/ largeur de la zone.
Réglage de la position d’une zone d’armatures
  • Activez le mode de sélection [image].

  • Cliquez sur le nom (dans le cas des treillis et barres d’armatures) ou sur le point d’intersection des flèches (dans le cas des barres d’armatures). La zone d’armatures sélectionnée s’affiche alors en surbrillance.

  • Faites glisser la zone d’armatures à l’emplacement de votre choix.

Inclure la longueur d'ancrage

Pour afficher la longueur d'ancrage à l'écran :

  • Ouvrez les paramètres de configuration [image] et accédez à l'onglet « Renforcement ».
  • Cochez l'option 'Afficher la longueur d'ancrage' et définissez la longueur souhaitée (X fois le diamètre des barres).
  • Appuyez sur « OK » pour fermer le dialogue.
  • Résultat :
    Les zones comportant des barres d'armature recevront un décalage dans la direction correspondante. Le décalage ne compte pas dans la déformation fissurée (il n'est donc pas dessiné en blanc). Les zones comportant des filets de renfort n'obtiendront PAS de décalage.

    Si vous choisissez de ne pas afficher les longueurs d'ancrage à l'écran (par exemple parce qu'elles gênent), vous pouvez toujours les inclure facilement dans l'export DXF (voir la procédure ci-dessous).

Pour inclure la longueur d'ancrage dans un export

  • Accédez à Fichier > Exporter au format DXF. Une boîte de dialogue contextuelle vous demandera si vous souhaitez ou non inclure la longueur d'ancrage (pour les zones avec barres d'armature).

    Remarque : un export PDF imprime toujours ce que vous voyez, donc si vous souhaitez inclure la longueur d'ancrage dans un PDF , vous devez le rendre visible à l'aide des paramètres de configuration [image].
Suppression d'une zone d’armatures
  • Activez le mode de sélection [image].

  • Cliquez sur le nom (dans le cas des treillis et barres d’armatures) ou sur le point d’intersection des flèches (dans le cas des barres d’armatures). La zone d’armatures sélectionnée s’affiche alors en surbrillance.

  • Cliquez sur le bouton [image] ou appuyez sur la touche DEL.
Autres fonctions
 | Imprimer L'impression est une image vectorielle que vous pouvez mettre à l’échelle vous-même
 | Annuler/ rétablir
/ | Afficher les armatures supérieures et inférieures / Afficher uniquement la couche active
 | pan
 | Tout afficher aussi grand que possible sur l’écran
 | Inverser le sens d’affichage
 | Régler la taille de police de caractère
 | Zoom avant ou arrière
 | Ouvre les préférences
 | Indique le poids du ferraillage appliqué

Raccourcis clavier généraux
SHIFT | Activer le mode orthogonal
DEL | Supprimer la sélection
ECS | Quitter
↑ et ↓ | Basculer entre les différents paramètres
→ et ← | Basculer entre les différents pas
CTRL + D | Exporter au format DXF
CTRL + E | Exporter au format PDF
CTRL + P | Imprimer
CTRL + W | Fermer le module d’armatures pratiques. Les modifications sont automatiquement enregistrées.
CTRL + Y | Rétablir
CTRL + Z | Annuler
F1 | Ouvrir la rubrique d’aide
F11 | Ouvrir les préférences
F12 | Tout afficher aussi grand que possible sur l’écran
b | Tracer une zone avec des barres d’armatures
i | Définir la couche active sur les armatures inférieures
n | Tracer une zone avec des treillis d’armatures
s | Définir la couche active sur les armatures supérieures
x | Définir la couche active sur les armatures dans le sens x
z | Définir la couche active sur les armatures dans le sens z
Double-clic | Régler le diamètre et le pas dans la zone d’armatures

Préférences
Onglet ‘Apparence’

  • Général

    Vous permet d’afficher, si vous le souhaitez, l'échelle, les axes et les info-bulles à côté des boutons.

  • Géométrie

    Vous permet, si vous le souhaitez, d’afficher les numéros des plaques et le système local de coordonnées des plaques.

  • Résultats
    • Vous permet, si vous le souhaitez, d’afficher les isolignes, et de choisir le dégradé de couleur de l’échelle.

    • Pour régler les valeurs de l’échelle, cliquez dessus et saisissez une valeur de votre choix.

      Si vous saisissez ‘8/150’, l'échelle reconnaîtra la commande comme ‘barres de diamètre Ø8, pas de 150’. L’outil calculera ensuite la superficie correspondante en mm².

5.4.5.2. Onglet ‘Armatures’

  • ‘Barres’
    • Vous permet d’afficher, si vous le souhaitez, la longueur des barres.
    • Choisissez les diamètres et les pas disponibles via les boutons [image] .
      • Cliquez sur le diamètre/ pas concerné pour le supprimer.
      • Cliquez sur le bouton [image] pour ajouter un diamètre/ pas.

  • ‘Treillis’

    Choisissez les diamètres et les pas disponibles via les boutons [image] .

    • Cliquez sur le diamètre/ pas concerné pour le supprimer.
    • Cliquez sur le bouton [image] pour ajouter un diamètre/ pas.

  • ‘Layers’

    Choisissez une couleur et un type de ligne pour les armatures supérieures et inférieures.

  • ‘Options de dessin'

    Si vous le souhaitez, spécifiez ici la tolérance sur les longueurs des barres.

    La tolérance s’appliquera aux zones d’armatures dessinées à partir de ce moment, mais pas sur les zones d’armatures précédemment dessinées.

Onglet ‘Unités et décimales

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul de la flèche fissurée

Une des questions qui se posent le plus lors du calcul du béton armé selon l'Eurocode 2 et similaires est de savoir jusqu'à quelle valeur il faut limiter la flèche. Nous remarquerons qu'avant de pouvoir répondre à cette question, il faut spécifier si l'on parle de la flèche totale ou de la flèche supplémentaire. En effet, les valeurs à respecter sont différentes pour les deux flèches.

En général, la valeur de 1/250 de la portée vaut comme flèche maximale, à calculer sous charge quasi-permanente (poids propre, charges permanentes et environ 30% des surcharges). La longueur de portée/500 est admise comme valeur maximale pour la flèche qui peut provoquer des dommages aux murs de séparation. Cette flèche dommageable ou supplémentaire est égale à la flèche sous combinaison quasi-permanente de charges moins la flèche qui était survenue avant la mise en œuvre de murs non portants.

Si nous voulons contrôler la flèche au moyen du calcul, nous devons de toute manière tenir compte de la fissuration. La mesure dans laquelle le béton se fissure dépendra, à cet égard, de la résistance en traction du béton, mais aussi de l'armature réellement mise en œuvre. C'est pour cette raison que nous commencerons par expliquer comment l'utilisateur peut définir une armature pratique. Ensuite, nous expliquerons brièvement de quelle manière les deux flèches susmentionnées sont calculées dans Diamonds.

Flèche fissurée

Flèche fissurée dans le temps

Première étape: définition du moment de la charge et de la combinaison pour fissuration

Deuxième étape: préparation des flèches à calculer dans le temps

Troisième étape: le calcul de la flèche dans le temps

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Flèche fissurée

Le calcul classique de la flèche des dalles de plancher en béton armé selon l'Eurocode 2 donne une représentation très réaliste de la flèche totale finale, mais ne tient par ailleurs pas compte de l'ordre dans lequel les charges sont appliquées.

Pour lancer le calcul de la flèche fissurée sans recalculer les nouveaux efforts, cliquez soit dans le menu sur l'option ‘Analyser – Déformation fissurée’ soit sur le bouton [image]. Alors la même analyse (1° ou 2° ordre avec ou sans imperfections globales) comme faite pendant l’analyse globale, sera appliquée. Dans l’autre cas, il faut reprendre l’analyse globale (voir L'analyse élastique globale).

La boîte de dialogue suivante s'affiche:

L'option Type d'armature permet de sélectionner avec quelle armature la rigidité des sections doit être déterminée. Vous pouvez choisir entre :

  • uniquement l'armature théorique (y compris l'armature minimale)
  • uniquement l'armature pratique
  • ou l'armature théorique (y compris l'armature minimale) et l'armature pratique (qui est le valeur par défaut).

Le paramètre β tient compte de la nature de la charge. Pour les charges uniques de courte durée, on peut prendre β égal à 1.0. Pour les charges de longue durée et/ou répétées, on calcule avec β=0,5. Toutefois, il est proposé de prendre toujours ce coefficient égal à 0,5 dans la pratique. En effet, ni les charges fixes ni les charges de service n'ont un caractère unique et de courte durée.

Remarque: dans l’ancienne norme ENV 1992-1-1 le facteur β était divisé en deux facteurs β1 et β2 dans lequel β1 tient compte de l'adhérence entre le béton et les barres. Pour les barres à adhérence améliorée, on prend β1 égal à 1.

La dernière option vous permet de tenir compte ou non des effets de fluage du béton. Si vous cochez cette option, le module d'élasticité du béton sera calculé comme:

φ est le facteur de fluage défini dans la boîte de dialogue des paramètres du béton (voir Paramètres pour le béton et l'armature). Si vous ne cochez pas cette option, vous calculerez la flèche fissurée instantanée.

Le calcul de la flèche exposé ci-dessous s'applique aux plaques mises en contrainte en flexion. Si des forces axiales surviennent également dans la plaque, elles influenceront les rigidités réduites en flexion, mais les rigidités en allongement resteront inchangées. Cette méthode ne peut donc pas s'employer pour étudier la flèche des murs (éléments qui sont mis en charge dans leur plan). Pour se faire quand même une idée de la fissurabilité de tels éléments, la théorie relative à la fissuration a été étendue aux forces axiales. Si vous cochez la dernière option, les rigidités sont réduites en flexion mais aussi en allongement, ce qui fait que la déformation dans le plan après fissuration peut, elle aussi, être évaluée de manière approximative.

La méthode de calcul utilisée dans Diamonds pour la détermination de la flèche fissurée est une extension logique des prescriptions normatives relatives aux éléments portants dans une seule direction. Nous rappellerons d'abord le principe du calcul de la flèche fissurée pour les éléments portants dans une seule direction. Nous examinerons ensuite comment nous pouvons étendre la méthode de calcul aux éléments portants dans deux directions.

En ce qui concerne les éléments sujets à flèche, la relation générale suivante s'applique pour la détermination de l'évolution de la flèche y:

La valeur de la courbure 1/r dépend toutefois, pour le béton armé, de la fissuration ou non de la section. Une flèche n'est pas fissurée avant que le moment y dépasse le moment de fissuration Mr. Ce moment de fissuration Mr est déterminé par

où

  • fr une valeur de la résistance en traction du béton, choisie judicieusement;
  • W le moment de résistance de la section de béton fictive non fissurée.

Pour une section située dans des zones non fissurées (M < Mr), la courbure 1/r1est calculée à l'aide de:

où E est le module d'élasticité du béton et I1, le moment d'inertie de la section fictive de béton non fissurée, composée de la section complète du béton augmentée de α fois la section d'armature requise.

Pour une section entièrement fissurée (M > Mr), la courbure 1/r2 est donnée par:

où E est le module d'élasticité du béton et I2, le moment d'inertie de la section fictive de béton entièrement fissurée, composée de la partie comprimée de la section du béton augmentée de α fois la section d'armature requise.

Comme, dans une zone fissurée, toutes les sections sont loin d'être fissurées, la courbure moyenne 1/r pour une section située dans une zone fissurée (M > Mr) est calculée par:

où

au lieu d'appliquer une double intégration des courbures 1/rpour déterminer la courbe de flèche y, nous pourrions en principe subdiviser l'élément en différents éléments, pour lesquels la rigidité EI varie chaque fois, soit en appliquant I1 pour I (dans les zones non fissurées) soit en déterminant I à partir de la relation qui se crée quand les courbures 1/rsont remplacées en (4) par M/EI (la subdivision M/E peut alors être supprimée). Les solutions de ce système d'éléments finis aboutissent à peu près aux mêmes résultats.

Mais la dernière méthode se laisse plus facilement étendre à plusieurs sens porteurs. En effet, il est possible de déterminer les sens principaux pour les moments pour chaque élément fini.

Nous déterminerons le moment M et le moment de fissuration Mr pour chaque sens principal. A l'aide des relations (4) et (5), nous déterminons les rigidités El suivant les deux sens principaux.

Le cœur de calcul de Diamonds est conçu de manière à pouvoir calculer avec des éléments finis ayant chacun un caractère orthotrope (avec une rigidité différente dans les sens perpendiculaires) et dont l'orientation peut être différente pour chaque élément.

Une solution apportée par un tel système aboutit à une bonne approche de la flèche fissurée des dalles portantes dans plusieurs directions. Le système permet aussi de tenir compte de la fissuration dans les éventuelles poutres de renforcement en béton.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Flèche fissurée dans le temps

Afin de limiter les dégâts liés à la fissuration au niveau des parois de séparation, vous pouvez limiter la flèche différentielle à ces endroits. Nous parlons ici de flèche différentielle car au moment où les cloisons légères sont placées dans un bâtiment, celui-ci a très souvent déjà adopté une partie de sa déformation définitive. Les futurs dégâts au niveau de ces parois secondaires ne peuvent dès lors provenir que de flèches supplémentaires survenant après leur mise en place. Ces flèches différentielles sont d’une part l’effet de charges variables ou utiles appliquées plus tard, et d’autre part, l’effet différé dans le temps de charges préexistantes.

Pour pouvoir déterminer la flèche nuisible, l’ordre d’apparition des différentes charges ainsi que leur moment précis d’application réelle sont primordiaux. La fissuration réelle dans le temps reste imprévisible mais Diamonds approche le problème de la façon suivante :

  • Pour chaque cas de chargement isolé, Diamonds détermine d’une part la flèche fissurée instantanée, et d’autre part, la flèche différée en tenant compte du phénomène de fluage
  • La flèche fissurée aux différents instants donnés peut alors être déterminée par simple superposition des résultats précédents. C’est-à-dire que pour déterminer la flèche instantanée à un moment précis, Diamonds prend en compte la totalité de toutes les charges appliquées avant cet instant donné alors que pour déterminer la flèche différée, il considère un pourcentage donné pour chaque charge prévue, en tenant compte du moment de la mise en charge.

Remarque :Compte-tenu que cette méthode de calcul se base sur le principe de superposition, elle ne prend nullement en compte les éventuelles non-linéarités du modèle. Les appuis ne fonctionnant que dans une seule direction (ne pouvant reprendre que de la traction ou que de la compression) ainsi que les éléments barres ne fonctionnant qu’en traction (tirants) perdront cette caractéristique particulière, chaque fois que vous recourrez à l’application de cette méthode pour déterminer la flèche fissurée dans le temps.

Première étape: définition du moment de la charge et de la combinaison pour fissuration

Deuxième étape: préparation des flèches à calculer dans le temps

Troisième étape: le calcul de la flèche dans le temps

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Première étape: définition du moment de la charge et de la combinaison pour fissuration

Si nous voulons déterminer la flèche dommageable, il sera nécessaire non seulement d'introduire les charges dans les différents groupes de charges, mais aussi d'indiquer à quel moment une charge donnée devient active et quelle combinaison de charges est déterminante pour la fissuration, pour chaque groupe de charges.

Maintenant, le moment où chaque charge entre en action est introduit dans la boîte de dialogue réservée aux coefficients de charges (voir Cas de charges). Vous noterez plus particulièrement dans la colonne t0 après combien de jours le groupe de charges agit sur la construction. Ce nombre de jours est à compter à partir du jour de coulée du béton.

En ce qui concerne les charges variables, on suppose que c'est à t0 que la partie quasi-permanente intervient et que la partie restante est alternativement présente et absente. Il n'y a pas d'effet de fluage pour cette dernière partie, mais il y en a un pour la partie quasi-permanente.

Plus le temps progresse et plus les charges augmentent et, par conséquent, plus la fissuration s'amplifie. L'amplification de la fissuration dans le temps ne peut toutefois pas être prise en compte avec exactitude. L'augmentation de la flèche dans le temps (effet de fluage) est calculée, pour chaque groupe de charges, avec un état fissuré unique, causé par une seule combinaison donnée de charges. Vous sélectionnez cette combinaison de charges (souvent ELS CR1) dans la dernière colonne de cette boîte de dialogue. Vous remarquerez que les combinaisons de charges ne peuvent être sélectionnées que si elles ont d'abord été générées à l'aide de [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Deuxième étape: préparation des flèches à calculer dans le temps

La deuxième étape consiste à préparer les flèches à calculer dans le temps. Cliquez à cette fin sur le bouton [image] dans la palette ‘Charges'.

Soit vous définissez vous-même quelques moments où vous voulez connaître la flèche, soit Diamonds génère automatiquement les combinaisons de la flèche à tous les moments marquants. Vous modifierez éventuellement ensuite les coefficients pour la flèche instantanée ou différée (voir Combinaisons dans le temps).

La flèche juste avant l'application d'une nouvelle charge est caractérisée par un signe moins. Une composition affectée d'un signe plus représente la flèche juste après l'application de la charge.

Les coefficients Ci et Cc(t) sont calculés pour chaque groupe de charges:

  • Ci correspond à la flèche instantanée
  • Cc(t) fait référence à la flèche différée (la partie qui provient du fluage)

Pour les charges permanentes, on prend entièrement en compte la flèche instantanée et la flèche après fluage.

Par contre, les charges mobiles sont fractionnées en une partie quasi-permanente ψ2qui agit au moment t0, et une partie résiduelle (1 - ψ2) qui est soit présente soit absente. C'est pourquoi la composition ‘flèche +90 jours' est subdivisée en ‘flèche +90 jours min’ et ‘flèche +90 jours max’. Pour l'effet de fluage, on tient uniquement compte de la partie quasi-permanente de la charge variable.

Les combinaisons 'flèche infini min' et 'flèche infini max' donnent les flèches au moment où le fluage s'est entièrement installé. Ainsi, le coefficient pour Cc(t) relatif aux charges permanentes et variables prend respectivement la valeur 1.00 et 0.30.

Enfin, si nous souhaitons connaître, par exemple, l'augmentation de la flèche entre la flèche minimale finale à l'infini (lorsque le fluage s'est entièrement installé) et la flèche juste après l'application de la partie quasi-permanente de la charge, nous cliquons d’abord sur le bouton [image] et sélectionnons ensuite dans la liste la combinaison ‘flèche +90 min’ et ‘flèche infini min’. Diamonds prépare alors une nouvelle composition dont les coefficients pour Ci et Cc(t) forment le complémentaire des coefficients appartenant à la combinaison ‘flèche -90 jours'.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Troisième étape: le calcul de la flèche dans le temps

Pour lancer le calcul de la déformation dans le temps, cliquez sur l'icône [image] dans la barre de menu ou utilisez l'option 'Analyser – Déformation dans le temps’. La fenêtre suivant apparaît :

Pour plus d’information concernant Type d'armatures, le facteur β et l’option en dessous, veuillez consulter le paragraphe Flèche fissurée.

Une fois le calcul terminé, vous pouvez exprimer les déformations pour chaque combinaison de charges dans le temps. Dans le menu déroulant, dans lequel vous sélectionnez le type de la combinaison, apparaît cette fois-ci la règle ‘Dans le temps’. Le menu au dessous vous donne toutes les combinaisons dans le temps qui sont générées. Notez bien que les autres résultats ne sont pas recalculés pendant ce calcul et qu'ils ne sont donc pas disponibles.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calcul de largeur de fissuration

La norme ouvre deux voies pour calculer la largeur de fissuration. Soit on détermine la valeur théorique de la largeur de fissuration à l'aide d'un calcul (compliqué) soit on s'en tient strictement à quelques règles pratiques qui ont été établies pour une largeur de fissuration maximale de 0.3 mm.

Le calcul direct de la valeur théorique de la largeur de fissuration wk doit toujours se faire sous la combinaison quasi-permanente à l'aide de la formule suivante (selon EN 1992-1-1):

où:

et

Ici,

σs | la contrainte dans l'armature soumise à traction dans la section où une fissuration survient
kt | coefficient qui dépend de la durée de la mise en charge = 0,6 pour une charge de courte durée = 0,4 pour une charge de longue durée
ρp,eff | le rapport effectif de l'armature = As/Ac,eff
Ac,eff | la section effectivement mise en traction ≤ 2,5b(h - d) ≤ b (h - x) / 3
φ | diamètre moyen (mm)
αe | = Es/Ec,eff
k1 | = 0,8 (acier à grande adhérence)
k2 | = 0,5 pour la flexion = 1,0 pour la traction pur
k3 | = 3,4
k4 | = 0,425
c | enrobage de béton sur l'armature longitudinale

Cette largeur de fissuration doit être limitée à 0,3mm pour les classes d'environnement 2 à 4.

Diamonds calcule la largeur des fissures, tant pour les poutres que pour les dalles. Dans le cas des dalles, Diamonds calcule d’abord la largeur des fissures pour les deux directions d’armatures. En fonction de l’angle de la direction d’armatures et de la direction des efforts normaux principaux, la largeur maximale des fissures, sera calculée comme :

Il va de soi que les résultats relatifs à la largeur des fissures ne peuvent être consultés que si l’analyse en état fissuré a été effectivement été exécutée.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Contrôle de l'acier et du bois

Une fois l'analyse globale effectuée, nous connaissons les déformations et les efforts internes de la structure. Nous pouvons déjà déduire des contraintes élastiques dans quelle mesure le matériau est fatigué. Pour les éléments de barre en acier et en bois, nous pouvons aller encore un peu plus loin et contrôler la résistance et le flambement de l'élément.

Pour la vérification de la résistance, les caractéristiques des profilés suffisent. Par contre pour la vérification de la stabilité, il faut préalablement déterminer les longueurs de flambement et de déversement. Les longueurs de flambement sont surtout important pour les éléments soumis à compression alors que les longueurs de déversement sont importantes pour les éléments soumis à flexion (autour de l’axe fort).

Dans Diamonds, vous pouvez soit imposer ces valeurs manuellement, soit demander de les calculer. Les longueurs de flambement sont calculés en fonction de la géométrie et des groupes définis par l’utilisateur. Les longueurs de déversement dépendent directement dus renforts contre le déversement placés par l’utilisateur.

Définition des renforts au déversement

Renforts au déversement et calcul automatique des longueurs de déversement

Modification ou suppression de renforts au déversement

Vérification de l’acier & bois

Choix de la norme

Paramètres pour l’acier

Paramètres pour le bois

Vérification de la résistance et de la stabilité

Vérification de la résistance des sections

Vérification de la stabilité des barres

Optimisation

Optimisation des peintures résistantes au feu

Déformation acier inoxydable

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définition des renforts au déversement

Pour les poutrelles métalliques soumises à flexion autour de leur axe fort, il convient d’évaluer le danger de torsion engendrée par un éventuel phénomène de flambement latéral. En prévoyant des renforts contre le déversement, ce danger peut considérablement être réduit. En entend par ‘renfort contre le déversement’, tout élément empêchant le déplacement latéral. Dans la plupart des structures, un certain nombre d’éléments assurent cette fonction : contreventements, appuis externes, renforts, …

Il est important de connaître les positions exactes de ces renforts contre le déversement car celles-ci influencent directement la vérification conformément à la norme acier choisie. Par exemple, dans le cas de l’Eurocode, on vérifiera la stabilité et la résistance au déversement pour chaque barre située entre deux renforts contre le déversement, peu importe si celle-ci fait partie d’un groupe d’éléments. Diamonds considère la présence par défaut d’un certain nombre de renforts contre le déversement, notamment aux extrémités des barres. Vous pouvez néanmoins à tout moment modifier ces conditions limites en ajoutant ou en supprimant des degrés de liberté.

Renforts au déversement et calcul automatique des longueurs de déversement

Modification ou suppression de renforts au déversement

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Renforts au déversement et calcul automatique des longueurs de déversement

A priori, Diamonds considère toujours la présence d’un certain nombre de renforts de manière telle que vous êtes susceptible de devoir effectuer un minimum de modifications. Pour ce faire, les règles générales suivantes sont toujours appliquées :

Les extrémités de barres pour lesquelles un appui (peu importe le nombre de degrés de liberté) a été défini sont d’office pourvu de renforts au déversement. Il en est de même si l’extrémité de barre sert de jonction avec une autre barre qui n’est pas dans le prolongement de la première. Par contre, les extrémités de barres libres ou assurant une jonction entre deux barres, dans le prolongement l’une de l’autre (et sans qu’une autre barre les rejoigne en ce point), ne sont pas munis de renforts au déversement. Dans le cas d’une barre avec une extrémité libre, on considère une longueur de déversement correspondant au double de la longueur effective de barre.

Les renforts au déversement qui sont automatiquement placés conformément aux règles générales ne sont pas représentés graphiquement dans la fenêtre de modélisation. De plus, on suppose que par défaut ils empêchent le déversement latéral, tant en partie supérieure qu’en partie inférieure des profilés. Si cette définition ne vous satisfait pas, vous pouvez toujours supprimer ou ajouter des renforts au déversement (cf. Modification ou suppression de renforts au déversement). Ce n’est que lorsqu’on déroge aux règles générales que la présence ou non du renfort sera illustrée graphiquement.

  • Des points verts ( [image]) illustrent le fait qu’on a libéré les conditions limites en supprimant les renforts latéraux et qu’il peut dès lors y avoir déversement en ce point.

    Supprimer un renfort n’a de sens que pour les extrémités de barres correspondant à un appui ou à la jonction entre deux barres qui ne sont pas situées dans le prolongement les unes des autres. Dans le cas d’une barre continue, il faudra libérer les conditions de part et d’autre du point de jonction, sans quoi la longueur de déversement sera doublée du côté où le renfort latéral aura été supprimé.

  • Des points rouges ( [image]) illustrent le fait qu’on ait ajouté des renforts latéraux. Ceci n’a de sens qu’au niveau d’extrémités libres de barres ou au niveau d’une jonction entre deux barres situées dans le prolongement l’une de l’autre. Dans tous les autres cas de figure, des renforts latéraux sont prévus par défaut. Lorsque vous ajouter un renfort au niveau d’une extrémité de barre, Diamonds applique par défaut les mêmes conditions limites aux deux extrémités de la barre.

Illustrons le calcul automatique des longueurs de déversement à l’aide de quelques exemples ci-dessous dans lesquels chaque barre a une longueur effective de 4m.

Nous indiquons en gras l’élément dont les conditions limites ont été modifiées.

Définition automatique des renforts au déversement

Suppression de renforts au déversement

Ajout de renforts au déversement

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Modification ou suppression de renforts au déversement

Les renforts au déversement sont assignés aux extrémités des barres. Vous pouvez à tout moment modifier ces conditions limites en ajoutant ou en supprimant des degrés de liberté. Ces opérations sont possibles à partir de la fenêtre de dialogue pour le flambement et déversement [image].

A l’aide d’un menu flottant (via bouton gauche de votre souris), vous pouvez pour chacune des extrémités de barre, tant au niveau de leur fibre supérieure qu’au niveau de leur fibre inférieure, préciser que vous souhaitez …

  • appliquer la règle générale (option “Auto”) telle que définie au Renforts au déversement et calcul automatique des longueurs de déversement. Notez toutefois que les renforts ainsi définis ne seront pas visualisés dans la fenêtre de modélisation.
  • supprimer un renfort au déversement qui a été défini par défaut (option “Libre”). Le symbole [image] apparaît alors dans la fenêtre de modélisation.
  • ajouter un renfort au déversement (option “Fixe”). Le symbole [image] apparaît alors dans la fenêtre de modélisation.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de l’acier & bois

Choix de la norme

Paramètres pour l’acier

Paramètres pour le bois

Vérification de la résistance et de la stabilité

Vérification de la résistance des sections

Vérification de la résistance selon la norme EN 1993-1-1

Vérification de la résistance selon la norme EN 1993-1-3

Vérification de la résistance selon la norme EN 1993-1-4

Vérification de la résistance selon la norme EN 1995-1-1

Vérification de la stabilité des barres

Vérification de la stabilité selon la norme EN 1993-1-1

Vérification de la stabilité selon la norme EN 1993-1-3

Vérification de la stabilité selon la norme EN 1993-1-4

Vérification de la stabilité selon la norme EN 1995-1-1

Optimisation

Optimisation des peintures résistantes au feu

Déformation acier inoxydable

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Choix de la norme

La commande ‘Analyser – Norme Acier’/ ‘Analyser – Norme Bois’ permet de choisir entre:

Norme bois | Norme acier

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres pour l’acier

Examinons tout d'abord les paramètres qui interviennent pour les éléments en acier. Ces paramètres sont repris dans la bibliothèque des matériaux de Diamonds, que vous ouvrez via l'option de menu 'Edition - Bibliothèque matériaux…'. Sélectionnez un matériau du type acier et cliquez ensuite sur l'onglet 'Avancé'.

Il faut définir la qualité d'acier de chaque matériau acier. Vous remarquerez que la limite élastique (fy) et la limite de rupture (fu) à appliquer dépendent de l'épaisseur du matériau.

Outre ces propriétés de résistance, notez aussi les facteurs de sécurité partiels. Seuls les deux premiers coefficients sont utilisés dans le contrôle de la résistance et du flambement.

  • γM0 pour la résistance des sections, indépendamment de la classe
  • γM1pour le contrôle de la stabilité des barres

La qualité de l'acier ne dépend en théorie pas de la norme utilisée. Par contre, les coefficients de sécurité peuvent varier d'une norme à l'autre. C'est pourquoi vous pouvez aussi choisir ici d'autres propriétés du matériau pour chaque norme.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres pour le bois

Tout comme pour l'acier, vous retrouvez les caractéristiques de résistance du bois dans la bibliothèque des matériaux de Diamonds. Vous ouvrez cette bibliothèque via l'instruction du menu 'Modifier – Bibliothèque matériaux …'. Sélectionnez ensuite un matériau du type bois et cliquez sur l'onglet 'Avancé'.

Depuis l'introduction de l'Eurocode, le bois est subdivisé en "classes de résistance". Une classe de résistance est désignée par la lettre C pour les résineux et la lettre D pour les feuillus, suivie d'un nombre (par exemple C22). Ce nombre correspond à la valeur représentative pour la résistance en flexion parallèlement aux fibres. Le bois stratifié est également subdivisé en classes de résistance. On utilise pour cela la combinaison de lettres GL.

Vous trouvez dans cette boîte de dialogue toutes les propriétés représentatives qui interviennent dans le calcul de contrôle des éléments en bois. Outre la résistance en traction et en compression dans le sens des fibres, vous y trouvez la résistance du bois en flexion et sa résistance au cisaillement. Ces propriétés du matériau sont ensuite divisées par un facteur matériel (γM) et multipliées par un facteur de modification (kmod) qui prend en compte le degré d'humidité, caractérisé par une classe de climat, et la durée de la charge.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la résistance et de la stabilité

Les contraintes une fois déterminées, la commande ‘Analyser – Vérification Acier et bois’, également disponible par le bouton [image], permet d’effectuer une vérification de la résistance et de la stabilité (flambement et déversement) pour chaque section conformément à la norme choisie (cf. Choix de la norme). En principe, il faudrait effectuer ces vérifications pour toutes les sections. En pratique, Diamonds effectue ces contrôles pour les sections pour lesquelles des valeurs de contraintes sont disponibles, en l’occurrence aux points du maillage. Vous pouvez dès lors augmenter le nombre de contrôles en demandant de mailler les éléments barres en un nombre plus important d’éléments finis.

Avant de lancer le calcul, Diamonds vous montrera l'écran suivant:

  • Dans le cadre ‘Action’, indiquez (comme dans les versions précédentes de Diamonds) si vous voulez effectuer le contrôle de l'acier et du bois pour les barres sélectionnées ou pour toutes les barres.
  • Dans le cadre ‘Critère de sélection', vous pouvez indiquer si Diamonds doit effectuer ce contrôle pour toutes les combinaisons ou uniquement pour les combinaisons déterminantes. Une vérification limitée à la sélection de combinaisons réduira fortement le temps de calcul. La sélection peut s'opérer de deux manières:
    • Au moyen d'une valeur globale, c.-à-d. que le même pourcentage est appliqué pour chaque effort interne et contrainte;
    • Au moyen d'une valeur spécifique à chaque effort interne ou contrainte.
  • Choisissez également entre "méthode 1" et "méthode 2" (si l’annexe nationale le permet), pour effectuer la vérification de l’interaction (flambement + déversement).

En fonction des pourcentages introduits, Diamonds sélectionnera les combinaisons correspondantes.

Si vous ouvrez à nouveau cette fenêtre après le calcul, vous verrez les contrôles épargnés et le temps écoulé s'afficher en gris clair.

Remarque: Si vous placez les limites trop haut, il se peut que la combinaison de M, N et V soit déterminante mais qu'elle tombe juste en-dehors de la plage du filtre et ne soit donc pas vérifiée. L'effet combiné de M, N et V peut être plus dangereux qu'une combinaison avec, par exemple, seulement M élevé. Une certaine prudence est donc de mise.

Une boîte de dialogue vous montre l'avancement du calcul. A l’aide du bouton [image] de la palette ‘Résultats’, vous pouvez consulter les résultats de cette vérification normative. Un menu déroulant permet de choisir de voir les résultats de la vérification de la résistance ou ceux de la stabilité. Ces résultats sont toujours exprimés en pourcents. Un élément satisfait à la norme si les deux vérifications aboutissent à un résultat inférieur à 100%.

N’oubliez pas que les résultats pour la résistance ont été calculés aux points de maillage et fluctuent dès lors tout au long de la barre. Par contre, les résultats pour la stabilité sont considérés comme constants tout au long de la barre compte-tenu du fait que c’est bien tout l’élément qui risque de succomber et non pas une section précise.

Vérification de la résistance des sections

Vérification de la résistance selon la norme EN 1993-1-1

Vérification de la résistance selon la norme EN 1993-1-3

Vérification de la résistance selon la norme EN 1993-1-4

Vérification de la résistance selon la norme EN 1995-1-1

Vérification de la stabilité des barres

Vérification de la stabilité selon la norme EN 1993-1-1

Vérification de la stabilité selon la norme EN 1993-1-3

Vérification de la stabilité selon la norme EN 1993-1-4

Vérification de la stabilité selon la norme EN 1995-1-1

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la résistance des sections

La vérification de la résistance des sections consiste à contrôler que les efforts présents ne sont pas supérieurs aux limites imposées par la norme. On tient bien entendu compte de facteurs de sécurité tant sur les caractéristiques des matériaux que sur les charges appliquées. Pour la plupart des normes, la vérification se fait aux états limites et concernent tant les efforts et moments pris séparément que les combinaisons de ceux-ci. Les critères varient néanmoins d’une norme à l’autre. Pour les normes EN 1993-1-1 (Acier) et EN 1995-1-1 (Bois), la vérification de la résistance est expliquée dans les paragraphes suivants.

Pour observer les résultats détaillés des vérifications en matière de résistance effectuées par Diamonds, cliquez sur le bouton [image] de la palette ‘Résultats’. Dans le menu déroulant, optez pour la première option: . Outre les résultats globaux pour l’ensemble de la structure (Pour chaque point du maillage, un pourcentage de la valeur correspondant au contrôle le plus défavorable est affiché), il est également possible de consulter les résultats détaillés pour chaque barre de la structure. En double-cliquant sur un d’elles, vous ouvrez la fenêtre de dialogue ci-après:

La partie supérieure de la fenêtre de dialogue reprend les informations générales concernant l’élément sélectionné : le numéro de barre, le nom du profil, le matériau et la longueur de l’élément. Un schéma en haut à droite de cette fenêtre illustre la barre en mentionnant son numéro ainsi que ceux des nœuds correspondant aux extrémités.

La partie inférieure comprend également deux volets. La partie gauche affiche une liste des vérifications effectuées avec le pourcentage de sollicitation maximale observé pour chacune d’elles. Un élément satisfait au critère de résistance si aucune des vérifications n’aboutit à un résultat supérieur à 100%. La partie droite affiche le calcul détaillé et les résultats intermédiaires pour le critère sélectionné dans la liste de gauche.

Tous les symboles et notations utilisés sont ceux prescrits par la norme EN 1993-1-1. Pour de plus amples renseignements concernant ceux-ci, veuillez consulter la norme mentionnée.

Une touche en bas de la fenêtre de dialogue permet finalement d’imprimer ou de sauvegarder toutes ces informations au format RTF.

Vérification de la résistance selon la norme EN 1993-1-1

Vérification de la résistance selon la norme EN 1993-1-3

Vérification de la résistance selon la norme EN 1993-1-4

Vérification de la résistance selon la norme EN 1995-1-1

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la résistance selon la norme EN 1993-1-1

Conformément la norme EN 1993-1-1 on doit vérifier les vérifications suivantes:

  • Traction axiale
 §6.2.3
  • Compression axiale
 §6.2.4
  • Moment My'
 §6.2.5
  • Moment Mz'
 §6.2.5
  • Effort tranchant Vz'
 §6.2.6
  • Effort tranchant Vy'
 §6.2.6
  • Torsion
 §6.2.7
  • Moment My' et effort tranchant Vz'
 §6.2.8
  • Moment Mz' et effort tranchant Vy'
 §6.2.8
  • Double moment avec effort normal
 §6.2.9
  • Double moment avec effort normal et effort tranchant
 §6.2.10

Si vous effectuez un contrôle de résistance conformément à la norme EN 1993-1-1, veuillez prendre en compte les remarques suivantes:

  • Pour une combinaison d’efforts, la règle générale (plutôt conservative) ci-dessous est le plus souvent appliquée :

    Néanmoins, certaines sections, telles les sections doublement symétriques de type I ou H et de classe 1 ou 2, nécessitent des inéquations plus rigoureuses que celle-ci.

  • La résistance de la section à la torsion dépend normalement et de sa rigidité rotative et de la rigidité de son âme. Les deux caractéristiques contribuent en effet à la résistance globale à la torsion : la première concerne la torsion pure (Saint-Venant) alors que la seconde concerne les effets d’efforts normaux dans l’âme du profilé. La version actuelle de Diamonds ne tient compte que du premier phénomène.

  • Les profilés tubulaires disposant généralement d’une très grande rigidité rotative, Diamonds ne sous-estime que très peu leurs résistance à la torsion. Par contre, dans le cas des profilés en I ou H, il ne faudra pas perdre de vue que la contribution des efforts normaux au niveau de l’âme des profilés est loin d’être négligeable (et que les résultats obtenus dans Diamonds sont légèrement trop favorables).

  • Les sections massives, essentiellement rectangulaires ou circulaires, seront toujours considérées comme étant de classe 3. Dans le cas de profilés tubulaires, on ne calculera pas de section effective, mêmes s’ils sont de classe 4. Dans ce cas, on se contentera des caractéristiques élastiques de la section.

  • Pour les profilés dont les axes d’inertie principaux ne correspondent pas aux axes locaux y’ et z’, les critères de vérification seront exprimés en fonction des axes u et v. Cette remarque n’est pas valable pour des sections formées à froid.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la résistance selon la norme EN 1993-1-3

Conformément la norme EN 1993-1-3 on doit vérifier les vérifications suivantes:

  • Traction axiale
 §6.1.2
  • Compression axiale
 §6.1.3
  • Moment My'
 §6.1.4
  • Moment Mz'
 §6.1.4
  • Effort tranchant Vz'
 §6.1.5
  • Effort tranchant Vy'
 §6.1.5
  • Torsion
 §6.1.6
  • Double moment avec effort normal
§6.1.8 and § 6.1.9

Remarque: Le contrôle relatif à l'effort tranchant s'exécute uniquement si les caractéristiques moyennes Vy,Rd, Vz,Rdet fya sont connues (voir Propriétés des sections de barres).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la résistance selon la norme EN 1993-1-4

Conformément à la norme EN 1993-1-4, les mêmes contrôles sont effectués pour l'acier inoxydable que pour l'acier au carbone (voir EN 1993-1-1).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la résistance selon la norme EN 1995-1-1

Conformément la norme EN 1995-1-1 on doit vérifier les vérifications suivantes:

  • Traction // au fil
 §6.1.2
  • Compression // au fil
 §6.1.4
  • Flexion double
 §6.1.6
  • Cisaillement Vz'
 §6.1.7
  • Cisaillement Vy'’
 §6.1.7
  • Torsion
 §6.1.8
  • Flexion et traction axiale combinées
 §6.2.3
  • Flexion et compression axiale combinées
 §6.2.4

Pour les barres avec une section variable, on tient également compte du §6.4.2 de EN 1995-1-1.

Contrairement à l'acier et au béton (considérés comme des matériaux isotropes), le bois se caractérise par plusieurs propriétés de résistance. Il faudra donc prendre en compte la résistance correspondant à chaque règle de contrôle. Ces caractéristiques de résistance dépendront, en outre, dans une large mesure du taux d'humidité et de la durée des contraintes qui interviennent sur la construction. Le facteur de modification kmod (qui doit être considéré comme un facteur de réduction sur la résistance) joue ici un rôle important. Ainsi, dans les combinaisons de charges où interviennent aussi des charges variables, faudra-t-il calculer avec une résistance plus élevée que dans les combinaisons de charges permanentes uniquement. Diamonds détermine automatiquement le kmod à prendre en compte (pour chaque combinaison) sur base de la classe de climat et de la durée de la contrainte pour chaque groupe de charges que vous avez introduit vous-même dans la fenêtre des groupes de charges. (voir Définir ou supprimer des cas de charges). Etant donné l'impact de ce facteur, vous avez tout intérêt à introduire ces valeurs avec soin.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la stabilité des barres

Pour consulter les résultats relatifs à la vérification de la stabilité, vous devez cliquer sur le bouton [image] de la palette ‘Résultats’ et opter pour la seconde possibilité du menu déroulant ( [image]). Comme pour la résistance, plusieurs vérifications sont effectuées. Celles-ci peuvent varier en fonction de la norme conformément à laquelle on souhaite effectuer la vérification. Pour les normes EN 1993-1-1 (Acier) et EN 1995-1-1 (Bois), la vérification de la stabilité est expliquée dans les paragraphes suivants.

Les diagrammes des résultats globaux affichent en pourcents les résultats de la vérification aux flambement-déversement la plus contraignante pour chacun des points du maillage. Une note de calcul détaillée est également disponible pour chacune des barres. Il suffit de double-cliquer sur une de celles-ci pour consulter la fenêtre de dialogue ci-après:

Vous remarquerez que cette fenêtre de dialogue est similaire à celle utilisée pour les résultats détaillés de la vérification de la résistance (voir Vérification de la résistance et de la stabilité), sauf que cette fois c’est la page attachée au second onglet et concernant la stabilité des éléments qui s’affiche automatiquement.

Dans la partie gauche, vous trouvez à nouveau une énumération de toutes les vérifications effectuées avec mention des pourcentages correspondants. La stabilité d’une barre sera jugée satisfaisante lorsque le seuil des 100% n’est atteint pour aucune des vérifications effectuées.

Dans la partie droite, vous pouvez consulter les détails de chacune des vérifications. Les symboles et notations utilisées sont celles de la norme EN 1993-1-1. Vous pouvez dès lors consulter celle-ci si vous en ignorez les définitions ou significations.

Les calculs détaillés peuvent être directement imprimés ou sauvegardés au format RTF à l’aide du bouton [image].

L’icône [image] permet de consulter et/ou modifier les longueurs de flambement et de déversement ainsi qu’un certain nombre de paramètres intervenant dans le calcul du moment de déversement critique Mcr. Dès que vous avez modifié la valeur d’un de ceux-ci, vous pouvez revérifier la stabilité de la barre en cliquant sur le bouton [image].

Vérification de la stabilité selon la norme EN 1993-1-1

Vérification de la stabilité selon la norme EN 1993-1-3

Vérification de la stabilité selon la norme EN 1993-1-4

Vérification de la stabilité selon la norme EN 1995-1-1

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la stabilité selon la norme EN 1993-1-1

Dans le cas de la norme EN 1993-1-1, on doit vérifier les critères suivants:

  • Flambement par flexion autour de l’axe fort
 §6.3.1
  • Flambement par flexion autour de l’axe faible
 §6.3.1
  • Flambement par torsion
 §6.3.1
  • Flambement par torsion latérale
 §6.3.2
  • Flambement autour de l’axe fort par rapport à My', Mz' et N
 §6.3.3
  • Flambement autour de l’axe faible par rapport à My', Mz' et N
 §6.3.3

Les trois premiers critères concernent les barres soumises à de la compression axiale. Nous distinguons 3 formes de flambement : celui lié à de la flexion autour de l’axe fort, celui lié à de la flexion autour de l’axe faible et finalement, celui suite aux phénomènes de torsion.

  • Pour les sections pour lesquelles le centre de gravité coïncide avec le centre de cisaillement, les trois formes de flambement pourront en théorie se manifester indépendamment les uns des autres. Néanmoins, en pratique, seul le flambement provoqué par le plus faible chargement se produira et provoquera la rupture avant même que les autres surviennent.
  • Lorsqu’une barre subit un flambement provenant uniquement d’un phénomène de torsion et en rien de celui de flexion, on parle de flambement suite au phénomène de torsion. Ce phénomène d’instabilité ne se produit que dans le cas de barres relativement courtes avec des ailes relativement larges.
  • Pour les sections pour lesquelles le centre de gravité ne coïncide pas avec le centre de cisaillement, les phénomènes de flambement et de torsion coexistent toujours. On parle alors de flambement spatial.

La vérification du flambement suite à un phénomène de torsion latérale a pour but de chiffrer le risque de flambement d’une poutre soumise à flexion. La présence éventuelle de renforts latéraux doit bien entendu être prise en compte. Il va de soi que la coexistence de compression et de flexion augmenteront le danger de flambement. C’est pourquoi la norme prévoit également des formules d’interaction. Celles-ci sont d’ailleurs bien plus complexes que celles qui figuraient autrefois dans la norme ENV 1993 et le concepteur doit aujourd’hui avoir pas mal de connaissances et de savoir-faire pour comprendre pleinement les critères de vérifications et interpréter correctement les résultats.

Remarques: Si vous effectuez un contrôle de stabilité conformément à la norme EN 1993-1-1, veuillez prendre en compte les remarques suivantes:

  • Les formules d’interactions ne peuvent être appliquées que lorsque l’effort normal n’excède pas le chargement de flambement critique. Lorsque la vérification ne peut être effectuée en aucun point de la barre, un point d’interrogation apparaît au niveau de la note de calcul pour signifier à l’utilisateur que le résultat de la vérification demeure inconnu. Lorsque la vérification ne peut être effectuée qu’en un certain nombre de points de la barre mais pas en tous, le résultat partiel est affiché mais un message indique en rouge que la vérification n’a pu être effectuée pour l’ensemble des points et des combinaisons.
  • Nous souhaitons attirer l’attention sur le fait que l’expression générale du moment de déversement élastique théorique a été conçue pour des sections doublement symétriques. De plus, le charges sont supposées être appliquées au centre de cisaillement de la section. Concrètement, cela signifie que les termes zgC2 et C3zi sont négligés dans la formule générale de Mcr.
  • Les facteurs de moment Cmy et Cmz intervenant dans le calcul des facteurs d’interaction kij pour le calcul du moment critique dépendent de la définition des groupes compte-tenu du flambement, respectivement autour des axes forts et faibles.
  • Lorsqu’une barre est soumise à compression, il y a risque de flambement par torsion. Celui-ci dépend directement de la longueur de torsion ou de la longueur de la barre si les extrémités de celle-ci ne peuvent pivoter autour de l’axe principal. Diamonds considère qu’une barre ne peut pivoter sur elle-même à partir du moment que les deux ailes en compression sont soutenues latéralement. La longueur de torsion dépend dès lors directement de l’emplacement des renforts au déversement. La longueur de torsion correspondra toujours à la plus grande des longueurs de déversement observées au niveau des fibres supérieure et inférieure de la barre.
  • Les sections rectangulaires ou circulaires massives seront toujours considérées être de classe 3. D’autre part, il ne sera pas possible de calculer les sections effectives pour des profilés tubulaires, même lorsqu’il s’agit de profilés de classe 4. Dans ce cas, la suite du calcul sera effectuée en prenant en compte les caractéristiques élastiques de ces sections.
  • Pour les profils dont les axes principaux d’inertie ne coïncident pas avec les axes locaux y’ et z’, les critères de vérification seront exprimés en fonction des axes u et v. Cette remarque n’est pas valable pour des sections formées à froid.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la stabilité selon la norme EN 1993-1-3

Conformément la norme EN 1993-1-3 on doit vérifier les vérifications suivantes:

  • Flambement par flexion autour de l’axe fort
 §6.2.2
  • Flambement par flexion autour de l’axe faible
 §6.2.2
  • Flambement par torsion
 §6.2.3
  • Flambement par torsion latérale
 §6.2.4
  • Flambement autour de l’axe fort par rapport à My', Mz' et N
 §6.2.5
  • Flambement autour de l’axe faible par rapport à My', Mz' et N
 §6.2.5

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la stabilité selon la norme EN 1993-1-4

Dans le cas de la norme EN 1993-1-4, on doit vérifier les critères suivants:

  • Flambement par flexion autour de l’axe fort N
 §5.4.2
  • Flambement par flexion autour de l’axe faible N
 §5.4.2
  • Flambement par torsion
 §5.4.2
  • Flambement par torsion latérale
§5.4.3
  • N + My' (Flambement par flexion autour de l’axe y)
 §5.5
  • N + Mz' (Flambement par flexion autour de l’axe z)
 §5.5
  • N + My' (Flambement par flexion autour de l’axe z)
 §5.5
  • N +My'+ My'
 §5.5
  • N +My'+ My' (Flambement par torsion latérale)
 §5.5

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification de la stabilité selon la norme EN 1995-1-1

Conformément la norme EN 1995-1-1 on doit vérifier les vérifications suivantes :

  • Flambement par flexion dans et hors le plan
 §6.3.2
  • Flambement par torsion latérale
 §6.3.3

La première règle de contrôle s'applique aux colonnes mises en charge en compression, ou en compression et en flexion. La deuxième règle de contrôle vaut pour les poutrelles mises en charge en flexion, ou en flexion et en compression. Dans le premier cas, on considère le flambement en flexion aussi bien autour de l'axe faible qu'autour de l'axe fort étant donné l'intervention simultanée de la compression et de la double flexion. Dans le second cas, le moment autour de l'axe fort est éventuellement combiné avec la force normale de compression.

Il y a lieu de remarquer que, lors du contrôle sur le flambement par torsion latérale, Diamonds suppose que la longueur collaborante lef est égale à 1/C1. La raison en est que lef n'est donnée que pour quelques cas dans la norme. Le coefficient C1 est appliqué dans le contrôle normatif de l'acier et prend en compte la répartition des moments entre les renforts au déversement.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Optimisation

Lorsque Diamonds a effectuée une vérification des sections en acier et bois, il obtient une valeur en pourcentage de la capacité des barres à résister aux efforts auxquels elles sont soumises.

Toutefois, le premier choix des sections s’est fait relativement aléatoirement. Il se peut donc qu’une section soit trop grande ou trop petite en fonction des sollicitations.

Afin d’éviter un travail fastidieux à l’utilisateur, Diamonds propose des routines d’optimisation des sections pour assurer la meilleure adéquation entre la résistance d’une part et le coût d’autre part.

Il existe deux principes d’optimisation dans Diamonds :

  • la section de base provient d’une bibliothèque (aussi sections type SADEF). Diamonds va donc chercher dans la bibliothèque la section la mieux adaptée.
  • La section est construise sur base d’une forme caractéristique. Diamonds va optimiser en modifiant soit la hauteur, soit la largeur d’un pas à définir par l’utilisateur.

Après avoir exécuté une vérification de la résistance et la stabilité des sections en acier (§6.2.2.4), vous pouvez cliquer sur [image] pour démarrer l’optimisation.

L'optimisation peut être effectuée pour

  • les éléments sélectionnés;
  • tout les éléments;

Dans la fenêtre de dialogue qui apparaît, vous pouvez avoir soit 2 ou 3 feuillets en fonction du type de section présente dans le projet.

Le premier feuillet contient un éditeur avec une valeur en pourcent. Il s’agit de la valeur qu’il faut approcher lors de l’optimisation.

Etant donné que l’optimisation se fait toujours à partir des résultats des anciennes sections et non des sections optimisées, il se peut qu’il soit nécessaire de faire plusieurs optimisations successives. Cependant, afin de diminuer ce nombre lorsque l’on se trouve loin des résultats optimaux, on peut faire varier la valeur à viser judicieusement. Lorsque vos sections sont nettement surdimensionnées, il peut être préférable de viser un pourcentage légèrement supérieur à 100% et vis versa dans le cas contraire.

L’optimisation peut se faire soit à partir

  • à partir des résultats de résistance,
  • à partir des résultats de stabilité,
  • à partir des deux.

Le deuxième feuillet est présent lorsque le projet contient une section provenant de la bibliothèque de section.

Si vous souhaitez faire apparaître une fenêtre de dialogue avec la liste des sections avec la proposition faite par Diamonds, cochez ‘Rapporter l’optimisation à l’écran’. Cela vous permettra également d’accepter certaines sections et d’en refuser d’autres:

En cochant la case ‘Sections identiques restent identiques après l’optimisation’, vous indiquez à Diamonds que les barres ayant la même section avant l’optimisation seront tous avec une section identique après l’optimisation.

La deuxième option ‘Barre d’un même type restent égalent’ permet de les barres faisant partie d’un type de design (Types de design) défini dans le projet gardent toujours une section identique. Par exemple, vous pourriez avoir une série de poteau classé dans un type. Lors de l’optimisation, Diamonds va déterminer la plus petite section qui convient à tous les poteaux du type.

Le troisième feuillet permet de paramétrer l’optimisation des sections construite sur base des formes types.

Un premier cadre contient le nom de toutes les formes de sections présentes dans le projet. Sélectionnez-les un à un pour compléter la partie inférieure propre à chaque nom.

C’est dans cette partie inférieure que vous pouvez indiquer que est la dimension qui peut varier pour effectuer l’optimisation. Entrez également le pas dans l’éditeur qui suit ‘Adapter les dimensions par’.

Dans certains, cas, il est possible d’optimiser en faisant varier deux valeurs de façon proportionnelle.

Pour finir, sur la dernière ligne, il est possible d’indiquer à Diamonds s’il doit toujours se limiter à un maximum et à un minimum. Deux éditeurs permettent d’introduire la valeur des bornes à ne pas dépasser.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Optimisation des peintures résistantes au feu

Pour effectuer une analyse de la résistance incendie en s’appuyant sur les peintures ignifuges, procédez comme suit :

  1. Dessinez la structure.
  2. Si nécessaire, appliquez une peinture ignifuge sur les barres de votre choix [image].
  3. Ajoutez les groupes de charges pour la résistance incendie [image].
  4. Attribuez la courbe incendie de votre choix aux barres [image].
  5. Calculez la réponse thermique [image] .
  6. Générez les combinaisons incendie ELU IN [image] ..
  7. Procédez à une analyse élastique [image].
  8. Procédez à la vérification de l'acier [image] .

  9. Optimisez l’épaisseur de la peinture pour les barres protégées et non protégées [image]. Le contenu des deux onglets est décrit dans les prochains paragraphes.

Paramètres d’optimisation
  • Optimisez toutes les barres ou uniquement les barres sélectionnées.

  • Par défaut, l'optimisation s’appliquera sur les barres protégées.

    Si vous le souhaitez, vous pouvez également appliquer un revêtement thermique sur les barres non protégées. Dans ce cas, choisissez le revêtement thermique adapté (peinture thermique Euroquímica ou Hempel, plaques de plâtre, etc.)

  • Indiquez si l’épaisseur du revêtement thermique doit être optimisée en fonction de la température critique ou d’une valeur définie par l’utilisateur (spécifiez la valeur).

    La température critique correspond à la température à laquelle la vérification de l'acier pour une barre donnée atteint 100 %.

  • Indiquez l'épaisseur minimale du revêtement thermique.

    L'épaisseur minimale des peintures Euroquímica et Hempel est de 0,2 mm (épaisseur minimale pouvant être pulvérisée en pratique). En dessous de cette épaisseur, une extrapolation sera utilisée.

  • Indiquez l'épaisseur maximale du revêtement thermique.

    L’épaisseur maximale est de 3,1 mm pour les peintures Euroquímica et de 5,4 mm pour les peintures Hempel. Au-dessus de cette épaisseur, une extrapolation sera utilis.

  • Vous pouvez modifier l'épaisseur de la couche via une étape spécifique.
Paramètres d’adaptation
  • Choisissez si Diamonds peut adapter les profils automatiquement après optimisation, ou afficher un récapitulatif dans lequel vous pouvez sélectionner les profils à adapter.
  • Spécifiez les règles d’adaptation des sections.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Déformation acier inoxydable

Étant donné que l’acier inoxydable est un matériau non linéaire, le module d’élasticité dépend du niveau de contrainte dans la section transversale. Par conséquent, la norme EN 1993-1-4 §4.2 (5) stipule que les déformations doivent être calculées à l’aide du module sécant d’élasticité en tenant compte des contraintes (état ELS).

La norme EN 1993-1-4 utilise le modèle de Ramberg-Osgood pour calculer le module sécant d’élasticité, comme Diamonds le fait.

  • Diamonds calcule le module sécant d’élasticité dans chaque noeud de maillage comme la valeur minimale du module sécant d’élasticité pour les axes principaux (fort et fable) de la section
  • Il en résultera différents modules sécants d’élasticité sur toute la longueur de la barre. La déformation est obtenue en résolvant une intégrale sur la longueur de l’élément.

Ainsi, les étapes pour calculer les déformations dans l’acier inoxydable dans Diamonds sont:

  1. Exécutez une analyse élastique [image] .

    Cela résulte en une déformation calculée avec le module d’élasticité défini dans EN 1993-1-4 §2.1.3 (inclus dans la bibliothèque de matériaux de Diamonds).

    Comme dit précédemment, cette déformation n’est pas toujours précise.

  2. Soit

    1. Calculez la déformation en tenant compte des modules sécants [image] .

      Choisissez une combinaison. Diamonds calcule les modules sécants d’élasticité à partir des contraintes sous la combinaison sélectionnée. Choisissez la même combinaison que celle pour laquelle vous souhaitez vérifier les déformations.

    2. Calculez la déformation et les efforts internes en tenant compte des modules sécants d’élasticité [image] .

      Cette option fait la même chose que l’option 'a', mais elle redistribuera également les forces internes en utilisant les modules sécants d’élasticité.

Notes:

  • Les modules sécants d’élasticité sont calculés en fonction des contraintes élastiques, quelle que soit la classe de section de l’élément.
  • La déformation calculée pour l’acier inoxydable en Diamonds n’est valable que lorsque les contraintes dans les sections (dans l’état ELS sélectionné) sont inférieures à la limite d’élasticité de la qualité de l’acier inoxydable utilisé. Diamonds ne vérifie pas littéralement cette condition, car il est supposé que lorsque la vérification de l’acier est inférieure à 100%, l’exigence de contrainte est également satisfaite.
  • Comme simplification, la norme EN 1993-1-4 §4.2 (9) accepte de calculer la variation de Es,ser le long de l’élément et d’utiliser la valeur minimale sur toute sa longueur. Mais pour des niveaux de contrainte supérieurs à 65% de la limite d’élasticité, il en résulte des déformatons très élevées ; pour cette raison, cette simplification n’est pas appliquée.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Assemblages

Si vous disposez d’une licence Connection Design, vous pouvez, en plus de l’analyse globale de vos structures filaires, effectuer une vérification normative détaillée de la plupart des assemblages métalliques. Pour ce faire, Diamonds fait directement appel aux algorithmes de calcul de PowerConnect.

Assemblages du type

‘Poteau-Poutre’, ‘Poutre-Poutre’ ou ‘Poutre-Poteau-Poutre’ entre profilés en H ou en I

Pieds de colonnes en H ou I

Liaison ‘Poutre-Poutre’

à l’aide de platines boulonnées au niveau des ailes ou des âmes de profilés en H ou I

Assemblages articulés entre éléments en H ou I

Assemblages tubulaires circulaires ou rectangulaires

Le fait de pouvoir utiliser PowerConnect de manière intégrée dans Diamonds apporte un certain nombre d’avantages :

  • Grâce à l’intégration dans un environnement de travail unique de l’analyse globale de la structure et du dimensionnement détaillé de ses assemblages, vous évite de devoir appliquer manuellement dans PowerConnect, les efforts obtenus dans Diamonds.
  • Les rigidités réelles des assemblages peuvent elles aussi aisément être prises en compte dans l’analyse globale de la structure.

Ci-après, nous vous décrivons en détails les fonctionnalités se rapportant à la modélisation et à la vérification des assemblages dans Diamonds.

Modéliser l’assemblage

Sélectionner les combinaisons

Calculer l’assemblage

Sauvegarder l’assemblage dans la bibliothèque

Attribuer les caractéristiques de l’assemblage à un nœud

Assamblages paramétrique

Stiffness

Resistance

Interaction

Bibliothèque d’assemblages

Vérification d’assemblages dans Diamonds

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Modéliser l’assemblage

Avant de modéliser un assemblage, il est conseillé d’effectuer préalablement une vérification de la résistance et de la stabilité (flambement et déversement) des profilés en présence. Ceci afin de s’assurer que les dimensions des éléments à assembler sont bien réalistes. Dans tous les cas, vous devez commencer par effectuer une analyse élastique globale de la structure. Sans quoi le lien avec le module permettant de modéliser les assemblages n’a pas de sens puisqu’on ne sait pas quels efforts sont à prendre en considération au niveau de chaque nœud.

Après une première vérification normative, vous pouvez sélectionner les éléments entre lesquels vous souhaitez créer une attache. Selon la configuration physique rencontrée, Diamonds propose différentes attaches possibles et imaginables. De plus, les configurations similaires peuvent être regroupées au sein d’un groupe ou famille d’attaches. De cette façon, il est possible de calculer et vérifier simultanément et rapidement plusieurs assemblages similaires. Illustrons nos propos à l’aide de l’exemple ci-dessous:

Imaginez une structure composée de trois portiques successifs où les jonctions entre les arbalétriers et les poteaux sont chaque fois renforcées par des jarrets. Si vous souhaitez savoir comment définir ceux-ci directement dans Diamonds, nous vous référons au Jarrets du présent document.

Après avoir sélectionnés les profils à assembler, cliquez sur le bouton [image] de la barre d’icônes ou utilisez la commande ‘Analyser – Dimensionnement d’assemblages’. Lorsque Diamonds reconnait une configuration d’assemblage, il ouvre automatiquement la fenêtre de dialogue illustrée à la page suivante proposant différentes interprétations. S’il n’arrive pas à faire la corrélation avec des assemblages connus, il indique que la connexion ne peut être vérifiée à l’aide de PowerConnect.

Dans le cas de notre exemple d’illustration, Diamonds reconnaît automatiquement trois types d’assemblages. Il indique notamment que des pieds de poteaux peuvent être définis aux extrémités inférieures des barres 1, 4, 29, 30, 35 et 36. Sachant que celles-ci ont tous la même section, il propose de regrouper ces 6 pieds de poteaux au sein d’une seule et même famille. Il suffit alors de modéliser et de vérifier un seul de ceux-ci avant d’appliquer les mêmes détails d’assemblage à l’ensemble des nœuds de la famille.

Le second groupe d’assemblages reconnus concerne les liaisons ‘Poutre-Colonne’. Observez que les jarrets ont automatiquement été interprétés comme tels. Il reste néanmoins à indiquer quel profilé doit être considéré comme élément porteur par rapport à l’autre. Les numéros des barres sont indiqués de façon à guider l’utilisateur dans ce choix.

Une dernière famille d’attaches concerne les liaisons entre arbalétriers au niveau du faitage.

Une fois que vous avez validé les différentes familles d’assemblages, vous pouvez les modéliser en détails. La prochaine étape consiste à indiquer ou valider les combinaisons de charges considérées comme dimensionnantes. Sur base de celles-ci, PowerConnect vérifie la résistance et la rigidité de l’assemblage. Notez que vous pouvez ajouter jarrets et éléments rigidifiants mais que vous ne pouvez modifier les dimensions et le matériau des sections à assembler.

Après avoir défini une configuration d’assemblage satisfaisante, vous pouvez retourner dans Diamonds et sauvegardé celle-ci dans la bibliothèque des assemblages afin de pouvoir l’attribuer à d’autres nœuds.

Les différentes étapes pour ce faire sont décrites ci-après.

Sélectionner les combinaisons

Calculer l’assemblage

Sauvegarder l’assemblage dans la bibliothèque

Attribuer les caractéristiques de l’assemblage à un nœud

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sélectionner les combinaisons

Vous devez commencer par indiquer pour quelles combinaisons vous souhaitez vérifier l’assemblage. Il va de soi que toutes les combinaisons ne sont pas dimensionnantes. En filtrant celles-ci sur base de pourcentages par rapport aux valeurs extrêmes, vous pouvez ne prendre en compte que les combinaisons aux moments fléchissants, efforts normaux ou efforts tranchants les plus contraignants. Notez que si vous fixez un seuil trop élevé, vous courez le risque de mal évaluer les choses: si vous imposez par exemple une limite de 95%, les combinaisons pour lesquelles les 3 valeurs de M, N et V, prises individuellement atteignent chacune 90% ne seront pas vérifiées alors qu’elles présentent un risque potentiel non négligeable alors qu’une combinaison avec une valeur de M à 95% et des valeurs de N et V négligeables peut très bien ne représenter aucun danger. Toutes les précautions en la matière sont des lors de mise!

Illustrons dans le cas des pieds de poteaux. Commencez par cliquer sur le bouton [image] de façon à faire apparaître la fenêtre de dialogue suivante:

Observez que vous pouvez imposer des seuils de pourcentages différents selon le signe de M, N et V. Diamonds indique en permanence en haut à gauche le nombre de combinaisons à prendre en compte en fonction des critères que vous avez définis. Une autre façon de travailler consiste à cocher/décocher directement dans la liste des combinaisons, celles que vous souhaitez prendre en compte.

Remarque: Compte-tenu du fait que la vérification des assemblages se fait toujours à l’état limite ultime, seules les combinaisons ELU figurent dans la liste.

Après avoir sélectionné les combinaisons souhaitées, validez par ‘OK’. Vous revenez ainsi dans la fenêtre initiale et un petit ‘v’ indique que la première étape a été effectuée correctement. Rien ne vous empêche néanmoins de revenir en arrière si vous le souhaitez.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Calculer l’assemblage

Poursuivons avec le calcul des pieds de poteaux. En cliquant sur le bouton [image] vous activez le module PowerConnect permettant de dimensionner et de vérifier les assemblages de charpentes métalliques.

Remarque :Si vous ne disposez pas personnellement du module permettant de dimensionner les assemblages et que vous souhaitez sauvegarder les données nécessaires pour qu’un collègue ou confrère disposant bien de cette licence puisse définir les attaches à votre place, vous pouvez utilisez l’icône [image], en bas à gauche de chaque configuration d’assemblage.

Au sein de PowerConnect vous pouvez modéliser vos assemblages de façon très détaillée. Dans le cas des pieds de poteaux vous pouvez par exemple définir la position, la longueur et le type d’ancrage. Vous pouvez également ajouter plusieurs sortes de raidisseurs de façon à augmenter le moment résistant, voir obtenir un assemblage parfaitement rigide. Lorsque cela s’avère nécessaire, vous pouvez modifier les dimensions du massif en béton. Si vous ne l’avez pas encore fait dans Diamonds (cf. Conditions limites pour les extrémités des barres et les tirants), vous pouvez ajouter des jarrets et des goussets dans PowerConnect, plus particulièrement dans les cas de liaisons ‘Poutre-Colonne’ ou ‘Poutre-Poutre’.

A tout moment, vous pouvez effectivement calculer l’assemblage de façon à vérifier s’il satisfait aux spécifications. Lors de ce calcul, la rigidité réelle est elle aussi calculée afin de pouvoir attribuer une classe à l’attache (rigide, semi-rigide ou articulée). Lorsqu’un assemblage ne donne pas satisfaction, vous pouvez facilement détecter les composants qui posent problème grâce à un code de couleurs qui indique le taux de sollicitation de chacun de ceux-ci.

Le but de ce manuel n’est en aucun cas de se substituer au manuel détaillé PowerConnect. Si vous souhaitez connaître toutes les finesses de ce logiciel en version autonome (dite ‘stand-alone’), nous vous invitons à consulter celui-ci.

Après avoir modélisé l’assemblage dans les moindres détails, vous pouvez retournez vers Diamonds. Dans la fenêtre de dialogue apparaît alors un second signe ‘v’ à côté de l’étape ‘calculer l’assemblage’ pour indiquer que celle-ci a également été effectuée correctement. Les résultats sont systématiquement sauvegardés, même si vous passer au dimensionnement d’un autre type d’assemblage.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sauvegarder l’assemblage dans la bibliothèque

Une fois que l’assemblage a entièrement été défini, vous pouvez le sauvegarder dans la bibliothèque externe des assemblages, à condition de le nommer préalablement. Un petit ‘v’ apparaît alors devant le nœud pour indiquer que l’assemblage qui lui est affecté a bien été sauvegardé dans la bibliothèque des assemblages. Cette étape est inutile si un assemblage a déjà été affecté au nœud. Dans ce cas, la sauvegarde et l’attribution des caractéristiques détaillées se fait en une seule opération (voir Attribuer les caractéristiques de l’assemblage à un nœud).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Attribuer les caractéristiques de l’assemblage à un nœud

La dernière étape consiste à attribuer les caractéristiques d’un assemblage à l’ensemble des nœuds du même type repris dans la liste associée à l’attache étudiée.

Plusieurs scénarios sont envisageables:

  • Aucune définition d’assemblage n’a jamais été associée aux nœuds de la liste
  • Des détails d’assemblage ont déjà été associés à un ou plusieurs nœuds et vous souhaitez également les appliquer aux autres nœuds de la liste.
    • Soit, vous remplacez l’ancienne définition d’assemblage dans la bibliothèque par la nouvelle en utilisant le même nom
    • Soit, vous sauvegardez la définition actuelle sous un nouveau nom

Dans les deux cas, la nouvelle définition d’assemblage sera appliquée aux nœuds sélectionnés.

  • Des détails d’assemblage ont déjà été associés à un ou plusieurs nœuds mais il existe d’autres nœuds, non sélectionnés pour le moment, auxquels les mêmes détails d’assemblage ont également été attribués.
    • Soit vous remplacez l’assemblage précédemment attribué aux nœuds sélectionnés par le nouveau. Le logiciel demande alors de nommer ce dernier.
    • Soit vous remplacez tous les assemblages répondant au même nom (donc également pour les nœuds non sélectionnés) par l’assemblage actuel en le sauvegardant sous le même nom.
    • Soit vous sauvegardez la définition actuelle de l’assemblage sous un autre nom avant de l’appliquer à l’ensemble des nœuds répondant aux anciens paramètres. Ceci a l’avantage que l’ancienne configuration continue a exister au niveau de la bibliothèque des assemblages.

En plus de la configuration géométrique, une rigidité angulaire est également attribuée comme condition limite (cf. Définir un diagramme de rigidité et peut influencer considérablement la répartition des moments et la déformation du reste de la structure.

Si le nom de l’assemblage était coché dans la fenêtre des paramètres de configuration, ce même nom apparait à présent auprès des nœuds auxquels vous venez d’attribuez les détails d’assemblages.

Compte-tenu du fait que ceci modifie les conditions limites aux extrémités des barres, il est vivement conseillé de ré-effectuer une nouvelle analyse globale. Vous pouvez néanmoins poursuivre avec les autres familles d’assemblages de la liste sans avoir a relancer celle-ci à chaque fois, pour peu que vous ne fermez pas la fenêtre de dialogue. En effet, lorsque vous fermez celle-ci, les résultats sont définitivement perdus. Pour les consulter à nouveau et revérifier un ou plusieurs assemblages, il vous faudra alors relancer l’analyse globale de la structure.

Nous avons ainsi parcouru les différentes étapes de la modélisation et de la vérification de pieds de poteaux. La même démarche peut être effectuée pour calculer les autres types d’assemblages de la liste.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Assemblage paramétrique

Chaque assemblage peut recevoir un nom, qui ne doit pas nécessairement être unique. Définissez ensuite les limites générales :

  • Pour deux barres, vous pouvez limiter l'angle entre les barres en définissant un angle minimum et un angle maximum.
  • Pour les éléments principal et secondaire, vous pouvez autoriser
    • Pour la section transversale
      • N'importe quelle forme
      • Un type de forme spécifique {liste}
      • Une section transversale spécifique à partir de la bibliothèque de sections
    • Pour le matériau
      • N'importe quel matériau
      • Un type de matériau spécifique (acier, béton, bois, etc.)
      • Un matériau spécifique à partir de la bibliothèque de matériaux

Chaque assemblage peut avoir une image – l'image par défaut est celle présentée ci-dessous.

Six composants peuvent être pris en compte dans le calcul, si la case correspondante est cochée :

  • Torsion Tx’
  • Moment de flexion My’
  • Moment de flexion Mz’
  • Cisaillement Vy’
  • Cisaillement Vz’
  • Force normale N’

Le symbole prime (‘) correspond au système d'axe local de l'élément principal. Il est visualisable dans la fenêtre Configuration [image]. Par défaut les axes locaux sont les suivants, mais:

La rigidité est importante pour l'analyse globale. La vérification de l'assemblage tient compte des formules de résistance et d'interaction.

Stiffness

Resistance

Interaction

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Rigidité

La rigidité par défaut de chaque composant est fixe. Pour la modifier, cliquez sur le bouton de fonction [image] situé à la fin.

Ici, vous pouvez définir le comportement de rigidité du composant, négatif (< 0, haut) et positif (> 0, bas). Sélectionnez l'un des états prédéfinis – fixe, libre ou valeur (valeur requise) ou ajoutez un schéma défini par l'utilisateur en saisissant plusieurs ensembles de valeurs pour

  • (φ, M) pour les composants de moment
  • (u, F) pour les composants de cisaillement ou de force normale

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Résistance

Pour la vérification de l'assemblage, vous pouvez saisir une résistance négative (< 0, première valeur) et positive (> 0, deuxième valeur).

Diamonds vérifie la résistance de chaque composant individuellement, en comparant la force active FEd à la force résistante FRd. Le résultat doit être inférieur à 1 :

FEd/FRd <1

FRd correspond à la valeur saisie dans l'image ci-dessus.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Interaction

Pour la vérification de l'assemblage, vous pouvez saisir une ou plusieurs formules d'interaction pour la résistance du composant. Les formules déjà saisies sont accessibles dans le menu déroulant. Diamonds vérifie automatiquement les résistances des composants de façon individuelle, il n'est donc pas nécessaire de les ajouter ici.

Vous pouvez ajouter, modifier et supprimer des formules. Lorsque vous cliquez sur le bouton ‘Ajouter’, la boîte de dialogue suivante s'affiche :

Vous pouvez saisir un nom pour la formule d'interaction.

Dans la fenêtre précédente, les composants cochés s'affichent en noir et sont utilisables dans les formules d'interaction. Les composants non cochés sont grisés et indisponibles.

Pour inclure un composant à la formule, cochez la case correspondante. Les composants sont ajoutés en tant que force active divisée par la force résistante FEd/FRd. Ce rapport peut être multiplié par un facteur et mis en puissance – dans la section ‘Paramètres’. Il est possible d'assigner le composant à un groupe. Un groupe comporte un ou plusieurs composants entre crochets. Ce groupe peut également comporter un facteur de multiplication et une puissance. Notez que la puissance n'est pas limitée aux nombres entiers : vous pouvez saisir par exemple une racine carrée avec une valeur de 0,5.

La formule apparaît immédiatement en bas de la fenêtre, pour simplifier le contrôle visuel et la modification. L'ensemble de la formule doit donner un résultat inférieur à 1, pour permettre une vérification acceptable de l'assemblage.

Cliquez sur ‘OK’ pour enregistrer la formule d'interaction ou la modifier.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Bibliothèque d’assemblages

Il est possible de consulter la bibliothèque des assemblages en cliquant sur l’icône [image]. Il convient toutefois de distinguer la bibliothèque interne liée au projet en cours de la bibliothèque générale et externe, indépendante du projet ouvert. Une règle est toutefois systématique : chaque fois qu’une configuration détaillée est appliquée à un nœud de la structure, cet assemblage est automatiquement intégré à la bibliothèque interne liée au projet de telle sorte que les caractéristiques de l’attache restent associées au fichier du projet. Un autre utilisateur peut ainsi également consulter vos choix de modélisation d’attaches. Pour info, la bibliothèque externe des assemblages (‘ConfigurationLibrary.xml’) se situe par défaut sous C:\documents and Settings\Nom login\Mes documents\Diamonds.

Lorsque vous démarrez un nouveau projet, la bibliothèque interne associée ne contient aucun assemblage. C’est à l’utilisateur à peupler celle-ci au fur et à mesure de l’état d’avancement de son étude.

L’icône [image] permet à Diamonds de vérifier si des barres ont été sélectionnées au niveau de la fenêtre de modélisation. Les trois cas de figure ci-dessous sont envisageables:

  • Premier cas de figure: Une configuration détaillée d’assemblage a déjà été affectée à l’ensemble des nœuds sélectionnés.
  • Second cas de figure: Aucune configuration détaillée d’assemblage n’a été affectée aux nœuds sélectionnés mais un certain nombre d’assemblages ont déjà été définis.
  • Troisième cas de figure: Aucune configuration détaillée d’assemblage ne correspond à la sélection ou aucune barre n’a été sélectionné dans la fenêtre de modélisation.

Remarque :Les cas de figure 1 et 2 ne peuvent se produire que lorsque un seul nœud a été sélectionné ou que tous les nœuds sélectionnés sont du même type.

Dans le premier cas, la fenêtre de dialogue n’affiche que les assemblages déjà affectés au(x) nœud(s) sélectionné(s). Le bouton [image] permet éventuellement d’annuler les paramètres appliqués. Attention, ceci ne signifie pas que la configuration est supprimée pour autant. L’assemblage reste bien présent dans les bibliothèques interne et/ ou externes. Seulement, ces caractéristiques ne sont attribuées au(x) nœud(s) sélectionné(s). De même, la rigidité angulaire qui a été préalablement calculée n’est pas effacée.

Dans le second cas de figure, Diamonds propose une liste d’assemblages pouvant être affectés à l’ensemble des nœuds sélectionnés. Ceux-ci proviennent et de la bibliothèque interne, et de la bibliothèque externe.

Le bouton [image] permet d’appliquer la configuration choisie parmi les propositions. Si celle-ci est issue de la bibliothèque externe, elle est automatiquement ajouté à la bibliothèque interne afin de respecter la règle de base décrite en début de paragraphe.

Le dernier cas de figure permet de consulter et de gérer la bibliothèque des assemblages.

Observons plus attentivement cette fenêtre de dialogue.

Vous observez tout d’abord une liste de toutes les attaches que vous avez définies. Pour chacun d’eux, le logiciel affiche un croquis de l’assemblage avec les éléments à relier, leurs sections respectives ainsi que leurs caractéristiques en matière de rigidité. Notez que les rigidités Sj,ini et Sj ainsi que la classification de l’assemblage sont conservées.

Vous pouvez consulter les caractéristiques de rigidité en cliquant sur le bouton [image].

Vous remarquerez que les caractéristiques en matière de résistance sont également affichées, à savoir les efforts maximum que l’assemblage peut encaisser avant rupture plastique.

Dans le cas spécifique des pieds de poteaux, on peut également consulter le domaine de validité des combinaisons de M et N.

Si par soucis d’exactitude, vous souhaitez en savoir plus sur le comportement de l’assemblage étudié, vous pouvez consulter le diagramme de rigidité en cliquant sur le bouton [image]. Ce diagramme illustre la déformation angulaire en fonction du moment appliqué.

Aussi longtemps que le moment agissant (MEd) est inférieur à 2/3 du moment résistant (MRd), la norme permet d'effectuer les calculs d'après la rigidité initiale Sj,ini (premier segment de la courbe). Si le moment augmente, la rigidité diminue progressivement jusque quand MEd = MRd. La rigidité de rotation plastique Sj correspond à cette valeur. Passé ce point (MEd > MRd), la déformation angulaire devient particulièrement élevée (segment horizontal de la courbe) et aucun moment supplémentaire ne peut plus être repris.

Si nous revenons à la toute première fenêtre, vous trouvez encore, dans le bas, des fonctions qui concernent toujours la connexion sélectionnée dans la liste.

Vous pouvez notamment modifier le nom de l’attache et préciser dans quelle bibliothèque des assemblages vous souhaitez la sauvegarder. Si vous avez fait la modélisation de l’attache dans le projet-même, vous pouvez toujours sauvegarder les données dans la bibliothèque générale (externe) afin de pouvoir réutiliser les détails d’assemblage dans d’autres projets. Pour ce faire, il suffit de cocher la seconde option de sauvegarde en bas à gauche. D’autre part, pour récupérer les détails d’un assemblage que vous avez déjà sauvegardé dans la bibliothèque externe à l’occasion d’un projet précédent, afin de les sauvegarder cette fois au niveau de la bibliothèque (interne) du projet, vous devez cocher la première option de sauvegarde. Pour peu que vous ayez déjà affecté cette configuration à un nœud du projet en cours, celle-ci est disponible dans les deux bibliothèques.

A l’inverse, en décochant une option, vous supprimez la configuration de la bibliothèque correspondante. Un assemblage ne peut toutefois pas être supprimé à partir du moment où il est encore affecté à au moins un nœud du projet. Le bouton [image] devant les cases à cocher permet d’afficher ou non les assemblages d’une ou des deux bibliothèques. Cette possibilité est indépendante de l’assemblage sélectionné.

En plus d’échanger les paramètres d’assemblages entre les deux bibliothèques, il est également possible d’en importer ou d’en exporter les détails à partir de la version autonome (dite ‘stand-alone’) de PowerConnect, par le biais d’un fichier ‘.ebc’. Ce type de fichier vous permet notamment d’échanger les infos avec des collègues ou confrères qui possèdent PowerConnect seul. En outre, c’est une façon judicieuse de sauvegarder vos assemblages sans recourir aux bibliothèques. Notons que chaque fois qu’un assemblage est importé, Diamonds l’ajoute automatiquement à sa bibliothèque externe des assemblages. En cochant l’option décrite précédemment, vous pouvez choisir de l’ajouter également à la bibliothèque des assemblages spécifiques au projet en cours.

Pour terminer, le bouton [image] affiche la liste des nœuds et barres auxquels l’assemblage a déjà été affecté. Un cadre à droite vous permet d’ajouter vos propres commentaires.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vérification d’assemblages dans Diamonds

Après avoir modélisé en détails tous les assemblages, vous devez effectuer une nouvelle analyse globale en tenant compte des rigidités réelles calculées. Puisque celle-ci modifiera à son tour la répartition des charges, il est conseillé de revérifier ensuite que chacun des assemblages convient toujours.

Diamonds offre néanmoins la possibilité de vérifier ceux-ci à la nouvelle répartition des charges en recourant à une formule de combinaisons simplifiée qui ne nécessite pas de retourner dans PowerConnect. Ainsi le nombre de manipulations et le temps de calcul sont fortement réduits.

Pour ce faire, il vous suffit d’utiliser le bouton [image] de la barre des icônes.

La vérification est alors effectuée pour chaque groupe de charges et pour chacun des nœuds. Lorsque le résultat n’est pas satisfaisant, celui-ci apparaît en rouge.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Gérer et imprimer les notes de calcul

Diamonds vous permet de composer et imprimer plusieurs notes de calcul dans un même projet de calcul. Pour définir une note de calcul, cliquez sur l’icône [image] dans la barre de menu ou sélectionnez l'option de menu 'Fichier – Gestionnaire pour notes de calcul…'.

La boîte de dialogue suivante s'affiche:

La fenêtre reste bien évidemment vide aussi longtemps qu'aucune note de calcul n'a été définie dans le projet de calcul. Vous trouverez ci-après l'explication de la manière de composer une nouvelle note de calcul, puis de la modifier, de la copier, de la supprimer ou de l'imprimer. Les paragraphes suivants expliquent également de manière circonstanciée la signification des autres boutons. Nous commencerons toutefois par mentionner comment vous pouvez introduire des données générales d'un dossier dans le projet.

Les deux boutons [image] et [image] permettent d’enregistrer (exporter) et de réutiliser (importer) des configurations de notes de calcul. A l’aide de cette fonctionnalité, vous pouvez rapidement générer des notes de calcul pour des projets similaires ou des variantes de projets (hauteurs différentes par exemple). Vous pouvez également, très aisément, générer des notes selon le même canevas pour des étages différents d’un même immeuble.

Données de dossier

Composer une nouvelle note de calcul

L'onglet 'Généralités'

Orientation du modèle et sélection des éléments

Titre et table des matières

L'onglet 'Géométrie'

L'onglet 'Charges'

L'onglet 'Résultats globaux'

L'onglet 'Résultats détaillés'

Déplacer une note de calcul

Modifier, copier ou supprimer une note de calcul

Imprimer une note de calcul

Définir une imprimante

La mise en page

Imprimer une note de calcul

Aperçu avant impression

Enregistrer une note de calcul dans un fichier RTF

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Données de dossier

Il est souvent pratique d'ajouter les principales données du dossier dans la note de calcul. Sélectionnez l'option de menu 'Fichier – Référence projet' si vous voulez imputer ces données au projet de calcul.

Chaque bouton vous permet d'ouvrir une nouvelle boîte de dialogue dans laquelle vous pourrez noter les coordonnées (nom, adresse...) du projet, de l'ingénieur, de l'architecte, du maître de l'ouvrage et de l'entrepreneur.

Il y a 3 boutons dans le bas de chaque fenêtre. Avec le bouton [image], vous enregistrez les données de référence introduites afin de pouvoir les rappeler ultérieurement dans un nouveau projet, avec le bouton [image]. Cliquez sur le bouton [image] si vous voulez effacer toutes les informations.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Composer une nouvelle note de calcul

Pour composer une nouvelle note de calcul, cliquez sur le bouton [image].

Les deux boutons en haut de la fenêtre de dialogue permettent d’enregistrer (exporter) et de réutiliser (importer) des configurations de notes de calcul. A l’aide de cette fonctionnalité, vous pouvez rapidement générer des notes de calcul pour des projets similaires ou des variantes de projets (hauteurs différentes par exemple). Vous pouvez également, très aisément, générer des notes selon le même canevas pour des étages différents d’un même immeuble.

Ensuite, vous notez le nom de la nouvelle note de calcul. Parcourez ensuite les différents onglets. Le premier onglet contient quelques paramètres généraux. Le deuxième et le troisième onglet portent sur le rendu de la géométrie de la structure et des charges définies. Les deux derniers onglets ne sont visibles que quand la structure a été calculée.

L'onglet 'Généralités'

Orientation du modèle et sélection des éléments

Titre et table des matières

L'onglet 'Géométrie'

L'onglet 'Charges'

L'onglet 'Résultats globaux'

L'onglet 'Résultats détaillés'

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L'onglet 'Généralités'

Orientation du modèle et sélection des éléments

Titre et table des matières

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Orientation du modèle et sélection des éléments

Commencez par choisir l’orientation avec laquelle vous voulez illustrer le modèle étudié (vue du haut, de face, de derrière, latérale ou vue en perspective) et afficher la partie ou les éléments pour lesquels vous souhaitez imprimer une note de calcul.

Le mode de représentation (filaire, semi-transparent ou volumique) dépendra de la configuration que vous choisirez dans les différents onglets.

Vous pouvez manipuler l'orientation et la visibilité:

  • d'une part via le bouton [image].

    Vous revenez alors à la fenêtre modèle de la configuration active, où vous pouvez modifier la représentation (vue) à votre guise.

    Une fois déterminées l'orientation, la visibilité et la sélection, vous revenez en arrière via le bouton [image] en haut à gauche de la fenêtre modèle. A titre de contrôle, une illustration miniature de la représentation que vous avez choisie s'affiche au milieu de cette boîte de dialogue;

  • d'autre part via le bouton [image].

    Si vous cliquez sur le bouton [image], une liste des vues standard contenues dans Diamonds va s'afficher. Dans le même temps, Diamonds centrera et maximisera le modèle dans la fenêtre.

C'est ici aussi que vous sélectionnerez éventuellement les éléments pour lesquels vous voulez imprimer les résultats détaillés. Pour ceci, deux possibilités :

  • Soit vous cachez la partie de la construction dont vous ne souhaitez pas de résultats dans la note de calcul (partielle) que vous êtes en train de paramétrer. Vous indiquez alors au gestionnaire des notes de calcul que vous souhaitez les résultats uniquement pour les éléments visibles. La géométrie des éléments invisibles apparaîtra néanmoins de façon grisée dans votre note de calcul.
  • Soit vous sélectionnez dans la fenêtre de conception, les éléments dont vous souhaitez voir la géométrie, les charges et les résultats dans la note de calcul. Vous indiquez alors au gestionnaire des notes de calcul que vous souhaitez les résultats uniquement pour les éléments sélectionnés. Dans ce cas, la géométrie des éléments non sélectionnés n’apparaîtra pas du tout dans votre note de calcul.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Titre et table des matières

Vous pouvez choisir un titre en haut de votre rapport. Le texte qui sera utilisé comme titre est le nom de votre rapport; dans le cas standard, ce sera donc 'nouveau rapport'. Vous pouvez évidemment modifier ce titre en renommant votre rapport. Vous avez aussi l'option d'ajouter une table des matières pour chaque rapport séparément. Cochez pour ce faire le champ 'Table des matières'.

Si vous avez plusieurs rapports qui forment un tout, vous souhaiterez sans doute créer une seule table des matières pour l'ensemble. Vous utiliserez alors les réglages suivants:

1er rapport

2ème rapport et rapports suivants que vous voulez reprendre dans la table des matières

La table des matières de chaque rapport pour lequel vous avez sélectionné les options ‘Table des matières' et ‘Reprendre dans table des matières précédente, avec numérotation continue' est jointe à la table des matières du rapport précédent. La pagination et la section de numérotation du rapport poursuit le rapport précédent.

Si un rapport a pour seul réglage 'Table des matières', c'est là qu'est regroupée la table des matières globale, composée de la table des matières:

  • du rapport en cours
  • de tous les rapports suivants ayant le réglage supplémentaire 'Reprendre dans table des matières précédente, avec numérotation continue'

Exemple de table des matières composée:

Notez bien qu'il est parfaitement possible de créer plusieurs tables des matières composées dans un même dossier Diamonds. Au moment où vous cochez 'Table des matières' sans l'option supplémentaire, une nouvelle table des matières est créée à partir de ce rapport. Cette dernière peut être composée d'autres rapports suivants éventuels, mais à condition d'activer le réglage supplémentaire.

L'option 'Reprendre dans table des matières précédente, avec numérotation continue' n'est disponible qu'à partir du deuxième rapport.

Si vous ne cochez pas cette option, vous pouvez indiquer vous-même à quel numéro le paragraphe doit commencer:

Vous cocherez encore les données du dossier (voir Données de dossier) du projet qui doivent être reprises dans la note de calcul. Indiquez aussi si la note de calcul doit mentionner la version dans laquelle la structure a été dessinée, calculée et imprimée et sur base de quels options de calcul l’analyse globale est exécutée.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L'onglet 'Géométrie'

Tout d'abord, vous pouvez indiquer si vous souhaitez imprimer la géométrie du modèle. Sélectionnez ensuite, via le menu déroulant, l'environnement dans lequel la géométrie doit être exprimée. Il se peut, en effet, que le fichier 'Diamonds' contienne plusieurs configurations 'Géométrie'. Le bouton [image] vous permet de vérifier une nouvelle fois les paramètres de la configuration. Si vous modifiez un de ces paramètres, un nouvel environnement se crée sous le nom 'Autre configuration'. Pour plus d'informations concernant le paramétrage d'une configuration, on consultera Paramètres de configuration.

Vous vous rappelez que vous avec pu consulter les données du modèle sous forme de tableau (voir Tableau ‘Données’). Vous pouvez aussi décider ici de reprendre les données géométriques du modèle dans la note de calcul. Vous définirez quelles informations doivent exactement être reprises dans le tableau via le bouton [image].

Vous indiquerez éventuellement aussi si les propriétés de la section, les données du matériau, les données des connexions et lest données des fonctions doivent être imprimées. Seules les propriétés qui font partie du projet seront reprises dans la note de calcul.

L'option avant dernière vous permet de reprendre les profils de couches de sol dans la note de calcul.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L'onglet 'Charges'

Tout d'abord, vous pouvez indiquer si vous souhaitez imprimer les charges agissant sur la structure. Sélectionnez ensuite, via le menu déroulant, l'environnement dans lequel les charges doivent être exprimées. Il se peut, en effet, que le fichier 'Diamonds' contienne plusieurs configurations 'Charges'. Le bouton [image] vous permet de vérifier une nouvelle fois les paramètres de configuration. Si vous modifiez un de ces paramètres, un nouvel environnement se crée soue le nom 'Autre configuration'. Pour plus d'informations concernant le paramétrage d'une configuration, on consultera Paramètres de configuration.

Indiquez ensuite quels cas et/ou combinaisons de charges vous voulez imprimer. Si vous cochez l'option [image], toutes les combinaisons seront désélectionnées de ce groupe de charges. Si vous souhaitez sélectionner toutes les combinaisons dans un groupe de charges, décochez l'option [image].

Chaque cas ou chaque combinaison sera alors repris dans un dessin séparé.

Vous vous rappelez que vous avez pu consulter les données du modèle sous forme de tableau (voir Tableau ‘Données’). Vous pouvez aussi décider ici de reprendre ce tableau de charges dans la note de calcul. Attention: vous ne pouvez sélectionner ici que les cas de charges particuliers.

L'option 'Montrer charges générées' dans la gestion des rapports affichera:

  • pour les charges de vent: les paramètres de terrain
  • pour les charges de neige: les paramètres de terrain
  • pour les charges dynamiques: les paramètres de l'onde, la forme, la période,...,
  • pour le charge sismique: les paramètres: le spectre, l'accélération, ...
  • les paramètres d'une charge mobile

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L'onglet 'Résultats globaux'

  • Tout d'abord, vous pouvez indiquer si vous souhaitez imprimer les résultats globaux. Les résultats globaux sont toujours imprimés sous forme de graphique. Vous devez définir les informations qui doivent être reprises sur le graphique.

    • Soit vous sélectionnez une configuration prédéfinie via le menu déroulant.

    • Ou bien vous cliquez sur le bouton [image] pour définir un nouvel environnement. Si vous modifiez un des paramètres proposés, un nouvel environnement se crée soue le nom 'Autre configuration'. Pour plus d'informations concernant le paramétrage d'une configuration, on consultera Paramètres de configuration.

  • Sélectionnez un des boutons qui représentent les résultats partiels

  • Une fois que l'un des boutons ci-dessus est pressé, vous pouvez récupérer les résultats détaillés correspondant en cliquant sur l'une des boutons sous-jacentes:

  • Ensuite spécifiez pour quelle combinaison vous voulez afficher les résultats.

    Si vous cochez l'option [image], toutes les combinaisons seront désélectionnées de ce groupe de charges. Si vous souhaitez sélectionner toutes les combinaisons dans un groupe de charges, décochez l'option [image].

    Indiquez ensuite quels résultats doivent être imprimés pour quels cas et/ ou combinaisons de charges. Un dessin est alors ajouté pour chaque résultat et chaque cas de charge. Notez bien que vous pouvez indiquer un jeu de combinaisons différent pour chaque résultat (partiel).

  • Vous pouvez obtenir une liste des résultats qui sont déjà été récupérées en déplaçant la souris sur le bouton avec des résultats partiels correspondant.

  • Vous vous rappelez que vous avez pu consulter les résultats globaux sous forme de tableau (voir Tableau ‘Résultats’). Vous pouvez aussi décider ici de reprendre ce tableau de résultats dans la note de calcul.

    En cliquant sur le bouton [image], vous pouvez afficher ou masquer les coordonnées de l'étiquette/ du maillage. Spécifiez également pour les barres pour quelle position (valeurs extrêmes, tous les points de maillage, points d'extrémité de la barre) les résultats doivent être imprimés.

  • Enfin, vous pouvez choisir de reprendre un contrôle d'équilibre dans le rapport. Ce contrôle d'équilibre comporte, pour chaque combinaison de contraintes, un récapitulatif de la contrainte intervenant à la verticale/ à l'horizontale et des efforts de réaction qui en résultent (voir Tableau ‘Vérification d'équilibre’).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


L'onglet 'Résultats détaillés'

Après avoir effectué l'analyse pour chacune des barres ou des plaques, vous pouvez consulter un résultat détaillé sous forme de graphique (voir Résultats détaillés). Le dernier onglet vous permet de reprendre aussi ces graphiques détaillés dans la note de calcul.

  • Indiquez si vous souhaitez imprimer les résultats globaux.

  • Sélectionnez un des boutons qui représentent les résultats partiels

  • Une fois que l'un des boutons ci-dessus est pressé, vous pouvez récupérer les résultats détaillés correspondant en cliquant sur l'une des boutons sous-jacentes:

  • Indiquez ensuite quels résultats doivent être imprimés pour quels cas et/ou combinaisons de charges. Un dessin est alors ajouté pour chaque résultat et chaque cas de charge. Notez bien que vous pouvez indiquer un jeu de combinaisons différent pour chaque résultat (partiel)..

    Si vous cochez l'option [image], toutes les combinaisons seront désélectionnées de ce groupe de charges. Si vous souhaitez sélectionner toutes les combinaisons dans un groupe de charges, décochez l'option [image].

    Outre les graphiques détaillés d’élément par élément, il est aussi possible de reprendre la suite dans la note de calcul :

    • les résultats détaillés de la vérification normative;
      • dans un diagramme

      • uniquement le contrôle le plus prudent pour la résistance /stabilité

        Sélectionnez judicieusement les barres pour lesquelles vous voulez afficher le contrôle normatif complet! Le contrôle de résistance prend 3 pages pour une seule barre, et le contrôle de stabilité en prend 2.

      • tous les contrôles effectués pour la résistance/ stabilité

    • les résultats détaillés sous forme de tableau. Les résultats de chaque point du maillage, en particulier, sont imprimés ici.

      En cliquant sur le bouton [image], vous pouvez afficher ou masquer les coordonnées de l'étiquette/ du maillage.

  • Vous pouvez obtenir une liste des résultats qui sont déjà été récupérées en déplaçant la souris sur le bouton avec des résultats partiels correspondant.

Si aucun élément n'a été sélectionné dans la fenêtre modèle, les résultats détaillés s'impriment pour tous les éléments. Dans l'autre cas, seuls les résultats détaillés pour les éléments sélectionnés s'affichent. Ce qui précède vaut pour la représentation graphique des résultats détaillés comme pour la représentation sous forme de tableau.

Enfin, vous spécifiez en bas de cette fenêtre si vous souhaitez imprimer la vérification des assemblages.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Déplacer une note de calcul

Lorsque vous générer une nouvelle note de calcul, celle-ci sera toujours ajoutée en fin de liste. Si vous souhaitez modifier l’ordre de vos rapports, vous pouvez le faire simplement en les glissant à l’aide de la souris. Diamonds indique alors à l’aide d’un très rouge où vous apprêtez à déposer le rapport sélectionné dès que vous lâcherez le bouton gauche de la souris. Notez que l’ordre des rapports sera également respecté en cas d’impression de plusieurs documents simultanément.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Modifier, copier ou supprimer une note de calcul

Pour modifier, copier ou supprimer une note de calcul, sélectionnez la note de calcul en question et cliquez ensuite respectivement sur le bouton [image], [image] ou [image]. Une note de calcul est sélectionnée quand la ligne correspondante se colore en bleu. Par contre, si vous souhaitez supprimer toutes les notes de calcul, utilisez le bouton [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Imprimer une note de calcul

Définir une imprimante

La mise en page

Imprimer une note de calcul

Aperçu avant impression

Enregistrer une note de calcul dans un fichier RTF

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Définir une imprimante

Lorsque vous cliquez sur le bouton [image], la fenêtre ‘Print Setup’ de MS Windows s'affiche. Cette fenêtre peut varier selon la version de MS Windows. Vous pouvez y sélectionner l'imprimante sur laquelle vous voulez imprimer et en modifier les paramètres en cliquant sur le bouton 'Propriétés…'.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


La mise en page

Pour configurer votre mise en page, cliquez sur le bouton [image]. La boîte de dialogue suivante s'affiche:

Tout d'abord, vous pouvez définir les espaces blancs qui ne peuvent pas imprimés en indiquant des marges à gauche, à droite, en haut et en bas, ainsi que l’orientation de la page : Portrait ou Paysage.

En-dessous, vous sélectionnez la police souhaitée dans le menu déroulant. Vous pouvez également définir ici la taille de la police du texte normal, de l'en-tête et du bas de page ainsi que des différents titres.

En outre, [image] vous permet de sélectionner un logo que vous désirez placer dans l'en-tête ou le pied de page. Au besoin, vous pouvez modifier la taille du logo. Si vous cochez l'option 'Conserver les proportions', Diamonds gardera le même pourcentage pour la largeur et la hauteur.

Vous pouvez en outre indiquer quel texte vous voulez voir imprimé en haut ou en bas de chaque page. Ces textes d'en-tête et de bas de page sont subdivisés en 3 zones: gauche, milieu et droite. Pour chaque zone, un menu déroulant vous permet de sélectionner:

  • rien
  • la date (le jour où a lieu l'impression)
  • le nom du projet
  • le nom du projet avec mention du chemin d'accès
  • le numéro de page à partir du numéro 1
  • le numéro de page à partir d'un numéro à introduire par l'utilisateur (la première page imprimée reçoit ce numéro).
  • un logo

Pour utiliser un texte d'en-tête ou de bas de page plus sophistiqué, cliquez à droite dans le cadre ‘Avancé’ sur le bouton [image]. Une boîte de dialogue s'affiche alors; elle contient 3 colonnes correspondant aux 3 zones mentionnées plus haut.

Pour introduire les informations souhaitées dans une des zones, cliquez tout d'abord avec la souris dans cette zone. Vous pouvez maintenant, par exemple, introduire vous-même un texte personnel, éventuellement réparti sur plusieurs lignes. Si vous souhaitez introduire la date d'impression, cliquez sur le bouton [image]; la date est alors ajoutée à l'endroit où le curseur est positionné dans la zone. Vous pouvez aussi ajouter le numéro de page et le nom du fichier avec ou sans mention du chemin d'accès en suivant le même processus avec les autres boutons.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Imprimer une note de calcul

Une fois que les notes de calcul ont été composées et que leur mise en page est terminée, vous pouvez les imprimer via le bouton [image]. Uniquement les notes de calcul sélectionnées seront imprimées. A l’aide du bouton [image] vous pouvez sélectionner ou désélectionner toutes les notes de calcul. Le bouton [image] vous permet de inverser la sélection.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Aperçu avant impression

Si vous souhaitez visualiser la note de calcul avant de l'imprimer, cliquez sur le bouton [image]. Seules les notes de calcul sélectionnées seront imprimées.

La fenêtre 'Aperçu avant impression' vous permet d'abord de vérifier ce que vous allez imprimer exactement.

  • Le bouton [image] envoie l’aperçu à l’imprimante.
  • Le bouton [image] ouvrira la configuration de la page.

  • Avec [image] , vous pouvez faire défiler les pages.

    • va à la première page
    • va à la page précédente
    • va à la page suivante
    • va à la dernière page
  • Le bouton [image] permet de zoomer ou de dézoomer selon un pourcentage.
  • Avec les boutons [image] , vous pouvez afficher une ou deux pages simultanément.
  • Cliquez [image] sur pour fermer l’aperçu avant impression.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Enregistrer une note de calcul dans un fichier RTF

Une fois que les paramètres de la note de calcul sont définis, vous pouvez imprimer la note de calcul ou l'enregistrer dans un fichier RTF. L'acronyme RTF veut dire ‘Rich Text Format’; c'est un format de fichier qui peut être lu et modifié par la plupart des traitements de texte (comme MS Word).

Pour enregistrer la note de calcul dans un fichier RTF, cliquez sur l'icône [image] dans le bas de la boite de dialogue. Lorsque vous cliquez sur la flèche [image], vous pouvez indiquer si les informations de cap doivent également être exportées. Dans ce cas, par ex. Microsoft Office Word reconnaît les titres utilisés comme style.

Uniquement les notes de calcul sélectionnées seront imprimées. A l’aide du bouton [image] vous pouvez sélectionner ou désélectionner toutes les notes de calcul. Le bouton [image] vous permet de inverser la sélection.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres définis par l'utilisateur

Paramètres de préférence

Paramètres de sauvegarde des projets

Paramétrage des tolérances géométriques du modèle

Tolérance pour la vérification du modèle

Tolérance pour la définition des groupes

Option de la déplacement des éléments

Paramètres de dessin

Unités et décimales

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres de préférence

En tant qu’utilisateur, vous pouvez définir un certain nombre de paramètres de préférences. Ceux-ci seront d’application chaque fois que vous utiliserez Diamonds. Nous distinguons trois types de paramètres de préférences:

  • Paramètres pour la sauvegarde et l’archivage des fichiers;
  • Paramètres se rapportant à la géométrie pure du modèle,
  • Paramètres se rapportant au dessin.

Tous les paramètres sont décrits dans les paragraphes qui suivent. Si après avoir modifié l’un ou l’autre paramètre, vous souhaitez retrouver les paramètres initiaux, il vous suffit de cliquer, en bas de l’écran, sur [image]. Tous les paramètres sont alors remplacés par les paramètres par défaut, et ceux indépendamment de l’onglet actif.

Paramètres de sauvegarde des projets

Paramétrage des tolérances géométriques du modèle

Tolérance pour la vérification du modèle

Tolérance pour la définition des groupes

Option de la déplacement des éléments

Paramètres de dessin

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres de sauvegarde des projets

La sauvegarde régulière du projet constitue une bonne mesure préventive contre la perte de données causée par une panne ou d'autres raisons. Dans Diamonds, cet enregistrement peut même être automatique. Sélectionnez pour cela l'option 'Préférences…' dans le menu 'Options'. La boîte de dialogue suivante s'affiche alors:

Notez tout d'abord la fréquence à laquelle Diamonds doit sauvegarder le projet de calcul. Le projet est alors enregistré sous le même nom et la version précédemment sauvegardée est modifiée en fichier "backup" (.bs!). Un backup temporaire peut en outre être effectué à intervalles réguliers dans le dossier ‘Mes Documents’ du disque dur. Si le programme est brusquement interrompu, ce fichier temporaire sera, au redémarrage de Diamonds, restauré dans le dossier "OldBackUpFile" du dossier ‘Mes Documents’, où il pourra être à nouveau ouvert.

Indiquez, en outre, si le maillage, les notes de calcul et les résultats doivent aussi être enregistrés lors de la sauvegarde. Les notes de calcul sont enregistrées dans le fichier proprement dit. En revanche, le maillage et les résultats seront sauvegardés dans un fichier distinct comportant l'extension '.bsr' dans le même répertoire que le fichier proprement dit.

Notez que vous ne pouvez ouvrir ce fichier seul. Il est par contre ouvert et lu automatiquement au moment où l’utilisateur demande à consulter les résultats.

Vous pouvez entrer le nombre maximal d’opérations Undo (Annuler) / Redo (Refaire). Le maximum est 20 opérations.

Pendant l'enregistrement d'un fichier, les paramètres d'affichage sont toujours sauvegardés en même temps. Si vous cochez la dernière option, ces paramètres seront activés pendant l'ouverture du fichier. En principe, il vaut mieux que vous ne cochiez pas cette option.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramétrage des tolérances géométriques

Tolérance pour la vérification du modèle

Tolérance pour la définition des groupes

Option de la déplacement des éléments

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tolérance pour la vérification du modèle

Après chaque utilisation d’une fonction de dessin (tracer une ligne, générer une dalle à partir de son contour, supprimer un ou des éléments, opération de rotation ou de translation, …), Diamonds effectue bon nombre de vérifications et d’opérations automatiques pour s’assurer que le modèle reste cohérent et logique.

En particulier, Diamonds …

  • divise chaque ligne rejointe par un nouveau segment;
  • entrecoupe les lignes qui se croisent pour peu qu’elles appartiennent à une même dalle ou paroi;
  • génère de nouvelles dalles chaque fois qu’une dalle existante est coupée par une nouvelle ligne ou qu’un contour fermé est repéré au sein d’une dalle existante;
  • divise chaque dalle entrecoupée par une autre.

De plus, un modèle n’est considéré comme ‘exploitable’ qu’à partir du moment où une certaine tolérance est acceptée au niveau des coordonnées des nœuds. Sans celle-ci, l’utilisateur serait systématiquement confronté à des inexactitudes et des imperfections empêchant le bon déroulement du calcul et des vérifications.

Depuis la Révision 6 de Diamonds2008, le logiciel prend en compte une telle tolérance afin que …

  • les nœuds trop proches les uns des autres soient fusionnés ;
  • les nœuds trop proches des lignes soient associés à celles-ci et les lignes dès lors divisées compte-tenu de la présence de ces nœuds;
  • des dalles ou parois soient générées même lorsque les lignes qui constituent leurs contours ne sont pas parfaitement situées dans un même plan.

Diamonds permet de définir vous-même cette tolérance en utilisant la commande ‘Options - Préférences’, puis le second onglet de la fenêtre de dialogue, intitulé ‘Modèle’.

Cette vérification est effectuée automatiquement …

  • chaque fois que vous importez un fichier DXF ou un fichier PowerPlate ou PowerFrame
  • chaque fois que vous ajouter, supprimer ou modifier des éléments du modèle

Étant donné que ces vérifications géométriques nécessitent pas mal de temps de calcul, elles ne sont effectuées que dans la zone immédiatement adjacente à l’endroit où un élément vient d’être modifié, ajouté ou supprimé.

Si à un moment donné, vous souhaitez exécuter la vérification avec une tolérance plus grande, cliquez sur le [image] de la palette ‘Géométrie’ après avoir sélectionné l’ensemble ou une partie de votre modèle (voir Vérification du modèle). Lorsque Diamonds n’est pas en mesure de redéfinir des dalles ou voiles en fonction de la tolérance fixée par l’utilisateur, il supprime tout simplement ces éléments du modèle.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Tolérance pour la définition des groupes

Un certain nombre de fonctions de Diamonds concernent des barres dans le prolongement les unes des autres. Par exemple, pour grouper des éléments physiquement, il est indispensable que ceux-ci soient parfaitement alignés. (voir La palette pour (dé-)grouper des éléments barres). L’alignement a également une incidence sur les longueurs de flambement (voir Renforts au déversement et calcul automatique des longueurs de déversement).

Une tolérance angulaire permet de s’assurer que des éléments provenant d’un logiciel de CAO ou dessiner à l’aide de fonctions différentes de Diamonds soient parfaitement alignés.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Option de la déplacement des éléments physiques

Les transformations dans Physiques ont été créées en appliquant une fonction ( [image] ou [image]).

Mais vous pouvez aussi déformer une structure en changeant les coordonnées des points. Si vous souhaitez que Diamonds n'applique pas cette transformation aux groupes physiques, vous devez décocher l'option 'Déplacer les éléments comme un ensemble physique par défaut' dans l'onglet 'Modèle' (et vice versa).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Paramètres de dessin

Sous l’onglet ‘Dessiner’ 2 options sont disponibles au niveau des outils permettant la modélisation graphique. Une première permet l’affichage ou nom des longueurs projetées lorsqu’on dessine des lignes, des murs, des poutres ou des colonnes.

Une seconde permet de bénéficier pleinement des possibilités offertes par la technologie OpenGL. En cas de problèmes graphiques récurrents, il peut être judicieux de décocher cette option.

La troisième option ‘Rendu rapide’ permet une gestion plus rapide du modèle. En cas de problèmes graphiques récurrents, il peut être judicieux de décocher cette option.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Unités et décimales

Vous êtes entièrement libre de choisir les unités et le nombre de décimales que vous souhaitez utiliser pour introduire vos données du modèle, et pour exprimer les données du modèle et les résultats du calcul. Ces paramètres sont accessibles via l'option de menu 'Options – Unités et décimales…'.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Importation et exportation vers d'autres programmes

Pour importer les données depuis d'autres programmes ou les exporter vers d'autres programmes, sélectionnez dans le menu 'Fichier' l'option 'Importer' ou 'Exporter'. Indiquez ensuite le nom du programme ou du format que vous souhaitez importer ou exporter.

Importation de fichiers DXF

Importation de fichiers BIM Expert

Importation de fichiers PowerPlate/ PowerFrame

Importation de fichiers Diamonds

Exportation de fichiers DXF

Exportation vers BIM Expert

Exportation de fichiers bitmap

Exportation vers ConCrete Plus

Exportation vers Strakon

Exportation vers fichiers DSTV

Exportation de tableaux de valeurs

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Importation de fichiers DXF

Les fichiers DXF contiennent des informations sur les dessins qui sont comprises par la plupart des programmes de CAO. Il peut être très utile de transférer celles-ci en même temps que le dessin de façon à réduire le côté conception au strict minimum dans le logiciel de calcul. Diamonds permet également d’importer des fichiers DXF. Néanmoins, celui-ci se limitera à la lecture de points, lignes et arcs. Il est donc conseillé d’éclater vos objets avant de les importer dans Diamonds.

Pour importer un fichier DXF, sélectionnez dans le menu 'Fichier' l'option 'Importer - Importer d’un DXF'. La fenêtre suivante apparaît :

La plupart des logiciels de CAO fonctionnent avec des couches (également appelées ‘calques’).

Lorsqu’on importe des fichiers DXF dans Diamonds, celles-ci sont automatiquement converties en ‘Types’ (cf. Types de design). Ceci permet par exemple de prévoir une couche par profil au niveau du logiciel de CAO et de ne pas perdre les informations relatives à ces profils lors du transfert du DXF.

A gauche, vous pouvez indiquer quelles couches vous voulez importer dans Diamonds.

A droite, vous indiquez par combien de segments rectilignes vous souhaitez modéliser les éléments courbes. Les arcs et les cercles seront impérativement remplacés par des éléments rectilignes.

Veillez également à ce que les unités de longueur dans Diamonds correspondent à celles du fichier DXF importé. Sur la figure illustrée à la page précédente, l’unité de longueur dans le fichier DXF est de 1 mètre.

Compte-tenu que tous les programmes de CAO n’utilisent pas le même référentiel au niveau des axes, vous avez également la possibilité de fixer celui-ci lors de l’import. Vous pouvez également définir un point d’insertion. Ceci revient à indiquer les coordonnées d’un point de référence qui servira de nouvelles coordonnées d’origine pour le fichier DXF importé. Si ce dernier comprend différentes couches, vous pouvez fixer la coordonnée Y du plan importé de façon à retrouver directement le dessin au niveau souhaité (dans le gestionnaire des étages).

Vous précisez comment vous souhaitez arrondir les décimales des coordonnées. Attention, ceci peut avoir comme conséquences qu’après import, certains points ne soient plus alignés ou n’appartiennent plus à un même plan si la tolérance (cf. Paramétrage des tolérances géométriques) est plus petite que la précision que vous imposez ici.

Remarque: soyez conscient que des erreurs au niveau de la modélisation en CAO entraînent inévitablement des erreurs au niveau du calcul.

Enfin, si le modèle contient des polylignes, vous pouvez générer des plaques entre ces dernières, grâce à l’option ci-dessous. Cette option est intéressante pour générer des surfaces incurvées. Une démonstration de cette option est disponible sur YouTube :

  • Via Rhino
  • Via Grasshopper

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Importation de fichiers BIM Expert

Pour envoyer un modèle de BIM Expert vers Diamonds, consultez le manuel de BIM Expert.

Une fois le modèle reçu par Diamonds, vous obtenez une notification avec [image]. Vous pouvez choisir de charger le modèle ou de le supprimer.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Importation de fichiers PowerPlate/ PowerFrame

Jusqu'à Diamonds 2015r06, il était possible d'importer d'anciens fichiers PowerPlate / PowerFrame.

À partir de Diamonds 2017, cette fonctionnalité n'est plus disponible.

Alternative:

  • Importez le modèle PowerPlate / PowerFrame dans Diamonds 2015r06.
  • Enregistrez le fichier Diamonds 2015r06.
  • Ouvrez le fichier Diamonds 2015r06 en Diamonds 2017 (ou plus récent).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Importation de fichiers Diamonds

Sélectionnez dans le menu l'instruction 'Fichier – Importer – Importer Diamonds' pour importer un fichier Diamonds.

Si vous importez un modèle Diamonds préexistant, Diamonds 2012 vous demandera ce qu'il doit faire des groupes de charges de ce fichier. Vous avez le choix entre:

  • Importer un groupe de charges dans un groupe de charges préexistant
  • Importer un groupe de charges sous le même nom
  • Importer un groupe de charges sous un autre nom
  • Ne pas importer un groupe de charges

Illustrons notre propos: supposons qu'un projet existant contienne les groupes de charges suivants:

  • 'Poids propre'
  • 'Charges fixes’
  • 'Charges d'exploitation E'
  • 'Vent' avec quatre sous-groupes de charges: 'vent gd asc’, 'vent gd desc’, 'vent dg asc’, 'vent dg desc'

Le projet actuel contient les groupes de charges 'Poids propre', 'Charges permanentes' et 'Vent', avec 4 sous-groupes de charges (Cas 1 à 4).

Lorsque vous importez le modèle existant, Diamonds affiche la boîte de dialogue ci-dessous:

  • Le groupe de charges 'Poids propre' sera importé dans le groupe de charges 'Poids propre' préexistant;
  • Le groupe de charges 'Charges permanentes' sera importé dans le groupe de charges préexistant appelé 'Charges fixes’;
  • Le groupe de charges 'Charges d'exploitation E' sera importé en tant que nouveau groupe de charges appelé 'Charges d'exploitation E'; Tous les coefficients de sécurité et facteurs de combinaison sont repris dans le fichier à importer;
  • Le groupe de charges 'Vent' sera importé avec ses quatre sous-groupes dans un groupe de charges existant appelé 'Vent', y compris les sous-groupes de charges.

Confirmez votre choix par 'OK'. Si vous souhaitez ne pas importer un groupe de charges donné, décochez-le.

Par rapport à l'ouverture de fichiers Diamonds, cette fonction offre l'avantage qu'il ne faut pas commencer par fermer le modèle existant. Il est ainsi possible d'importer, un par un, différents projets Diamonds et de les regrouper en un nouveau modèle Diamonds global. Mais vous devez veiller à ce que les modèles ne se recouvrent pas. Notez éventuellement les nouvelles coordonnées du point qui a servi d'origine dans le fichier importé.

Remarque: Il est recommandé d'exécuter un contrôle de modèle à la fin (une fois que tous les modèles ont été introduits) afin de corriger les éventuelles erreurs de modèle qui se seraient produites pendant la fusion des fichiers.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exportation de fichiers DXF

Si vous souhaitez exporter le modèle géométrique vers un logiciel de CAO, vous devez sélectionner la commande ‘Exporter en DXF’ du menu ‘Fichier’. La fenêtre de dialogue suivante apparaît alors à l’écran :

Commencez par indiquer ce que vous souhaitez exporter. Cinq sortes d’éléments sont exportables. Diamonds permet d’exporter aussi bien des éléments filaires (axes des barres) que surfaciques. Il est également possible d’exporter les contours des profilés et des dalles ainsi que les isolignes des quantités d’armatures. A chacun de ces 5 catégories peut être attribué un nom spécifique. Si vous utilisez cette possibilité, ces éléments seront exportés dans des couches distinctes.

Indiquez ensuite si vous souhaitez exporter tous les éléments ou uniquement les éléments visibles ou sélectionnés. Il est en effet possible d’exporter toute la structure ou seulement une partie de celle-ci.

En dessous, vous indiquez l’unité de longueur du fichier DXF

Compte-tenu que tous les logiciels de CAO n’utilisent pas la même convention pour les axes, vous pouvez également indiquer quel référentiel vous souhaitez utiliser.

Afin de contribuer à une meilleure lisibilité de vos modèles exportés, Diamonds sauvegarde chacun des types définis dans Diamonds dans des couches (layers) différentes.

N’oubliez pas que vos modèles initiaux ne comprennent non seulement les axes des barres mais également leurs arêtes. Compte-tenu de cette réalité, Diamonds vous permet d’attribuer des noms spécifiques aux couches exportées dans votre outil de CAO. Vous pouvez ainsi faire correspondre jusqu’à 4 couches de dessin à un seul type d’éléments définis dans Diamonds. Dans ce cas, le nom du type sera précédé du nom que vous donnerez à la couche.

Si vous souhaitez à tout prix générer un seul layer dans votre logiciel de CAO et que vous voulez que celui-ci corresponde à un seul type défini dans Diamonds, laissez tous les champs vierges (blanco).

Si votre modèle initial comprend en outre plusieurs étages, vous pouvez en plus subdivisez chaque type (ou chaque layer si vous en avez déjà généré plusieurs à partir d’un seul et même type d’élément) par niveau. Dans ce cas, le nom de l’étage sera également ajouté au nom de la couche afin que vous puissiez vous y retrouver facilement dans votre logiciel de dessin. Il va de soi que si vous choisissez d’utiliser toutes ces possibilités, vous aller générer un fichier DXF composé de bon nombre de layers.

Lorsque vous choisissez d’exporter les courbes de niveau illustrant les quantités d’armatures requises aux différents endroits, chaque courbe est exportée dans un layer différent. Des couleurs spécifiques sont toutefois attribuées aux isolignes correspondant au même type de résultats: Axs, Axi, Azs ou Azi.

D’autre part, vous devez préciser si vous souhaitez exporter tous les éléments ou uniquement les éléments visibles ou sélectionnés. Il est dès lors possible d’exporter soit une partie soit la totalité de la structure.

Finalement, vous devez préciser l’unité de longueur du fichier DXF (dans le cas de l’exemple ci-dessus, il s’agit d’un mètre) et l’orientation des axes afin de permettre l’éventuelle conversion des axes entre Diamonds le votre programme de CAO (puisque tous les logiciels ne fonctionnent pas forcément avec les mêmes repères).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exportation vers BIM Expert

Pour exporter un modèle de Diamonds vers BIM Expert, procédez comme suit :

  • Démarrez Diamonds et connectez-vous (si vous ne l'avez pas déjà fait). Ouvrez le projet à exporter.
  • Démarrez BIM Expert.
  • Dans Diamonds, allez dans ‘Fichier’ " ‘Exporter vers’ " ‘Exporter vers BIM Expert’ ou appuyez sur F8.

Vous devez disposer des licences ‘BIM Expert Basic’ et ‘BIM Expert Diamonds plug-in’.

Dans BIM Expert, vous pouvez :

  • Envoyer ce modèle à un collègue. Vous devez tous deux disposer de la licence ‘BIM Expert Server’. Le destinataire du modèle peut choisir d'ouvrir le modèle dans Diamonds ou de l'envoyer vers Tekla Structures.
  • Envoyer ce modèle vers Tekla Structures sur votre appareil. Vous devez posséder la licence ‘BIM Expert Tekla Structures Plug-in’.

Consultez le manuel de BIM Expert pour plus d'informations.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exportation de fichiers bitmap

Vous pouvez exporter n'importe quelle illustration dans la fenêtre modèle sous forme d'image bitmap. Une image construite de lignes et de points, ou bitmap, est une image de forme numérique, où la couleur de chaque pixel est définie. Vous pouvez ouvrir le dessin par la suite et le retravailler dans des programmes de dessin simples (Paint, Microsoft Office Picture Manager…).

Sélectionnez la commande ‘Fichier – Exporter – Exporter en Bitmap’ pour créer une image de la configuration active à l’écran.

En haut à gauche s’affiche la taille de la fenêtre de modélisation (exprimée en pixels). Juste en dessous, vous pouvez vous-mêmes fixer la taille du bitmap à créer.

A l’aide des boutons [image] vous pouvez corriger le rapport base/ hauteur de façon à obtenir le même rapport que la fenêtre active. Le premier bouton corrige la longueur par rapport à la largeur. Le second, la largeur par rapport à la longueur.

Lorsque vous créer un bitmap illustrant des résultats obtenus, vous pouvez en outre choisir d’y faire figurer l’échelle d’application en cochant la case prévue à cet effet, en bas à gauche de la fenêtre de dialogue.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exportation vers ConCrete Plus

BuildSoftpropose un programme, ConCrete Plus, qui assure la conversion d'une armature théorique en armature pratique pour les poutres (continues) sujettes à flexion simple.

Procédez comme suit pour envoyer des éléments à ConCrete Plus. Sélectionnez indépendamment de la configuration active un ou plusieurs éléments dont vous voulez transmettre l'armature. Sélectionnez ensuite dans le menu 'Fichier' l’option 'Exporter – Exporter vers ConCrete Plus'. Un fichier ConCrete Plus avec extension *.pcp est maintenant créé.

Le terme 'élément' utilisé au paragraphe précédent peut aussi désigner une série de barres successives, alignées dans le prolongement l'une de l'autre. Ces barres seront ensuite importées dans ConCrete Plus sous la forme d'une seule poutre (continue).

Remarques :

  • ConCrete Plus permet de convertir les armatures théoriques (longitudinales Ay et transversales Awz) en armatures pratiques. Notez toutefois que les armatures de flanc (Az) déterminées en fonction des moments Mz et/ou Mx ne sont pas lues et converties par ConCrete Plus!

    Il en est de même pour les armatures horizontales nécessaires en cas d’efforts tranchants extrêmement importants…

    (Diamonds assimile ces armatures à des armatures de flanc.)

  • Pour les éléments soumis à torsion, l’utilisateur doit lui-même vérifier la résistance des jambes horizontales des étriers.

  • ConCrete Plus déplace les sections théoriques d’une distance al (appelée ‘longueur de déplacement’) avant d’effectivement les convertir en armatures pratiques.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exportation vers Strakon

Strakon vous permet de définir et de détailler des structures en béton armé. En particulier, vous pouvez recourir à Strakon pour établir des schémas d'armature pratiques, pour dessiner des coffrages et pour générer des bordereaux d'armature.

Évidemment, il faut connaître d'avance les quantités théoriques d'armature. Les programmes qui supportent le calcul d'armature des structures en béton peuvent donc être interconnectés avec Strakon.

Ainsi, Diamonds offre-t-il aussi la possibilité d'exporter les sections théoriques d'armature de dalles et de murs sous format texte. Ces sections peuvent ensuite être lues par Strakon et converties en treillis d'armature pratique. La condition en est, bien sûr, que la structure soit également modélisée en Strakon.

Une fois l'armature calculée dans Diamonds, sélectionnez dans le menu 'Fichier' l'option 'Exporter - Exporter vers Strakon'. La boîte de dialogue suivante s'affiche:

Soit vous exportez toutes les dalles et tous les murs visibles, soit vous exportez uniquement les éléments sélectionnés dans la fenêtre modèle. Si, malgré tout, vous ne voulez pas exporter toutes les dalles visibles ou sélectionnées, désélectionnez les dalles en question dans la fenêtre du bas. Diamonds groupera alors toutes les dalles ou tous les murs qui se situent dans le même plan et qui, en outre, se touchent.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exportation vers fichiers DSTV

Le fichier DSTV, principalement utilisé par des logiciels de conception et dessin détaillé des structures métalliques pour l’envoi direct vers les machines-outils de fabrication, est un fichier plus complet car il permet de conserver les sections des profils. Diamonds préférera donc utiliser ce fichier en guise de lien avec les différents logiciels de dessin de construction métallique.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Exportation de tableaux de valeurs

Tous les tableaux de valeurs des fenêtres ‘Données’ et ‘Résultats’ peuvent être exportés et lus par la majorité des logiciels de traitement de texte et les tableurs, dont Microsoft Excel.

Le transfert de données se fait de la façon suivante:

Ouvrez une des deux fenêtres. Sélectionnez les données et appuyez sur la combinaison de touches ‘Ctrl+C’. Ouvrez ensuite Microsoft Excel. Vous pouvez récupérer les données à l’aide de la commande ‘Edition – Coller’ ou en utilisant la combinaison de touches ‘Ctrl+V’. Le tableau de valeurs apparaît alors instantanément sur le bureau et l’utilisateur peut manier celles-ci comme bon lui semble.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Table des matières

Titre
Disclaimer
1 Introduction
En quoi consiste le présent manuel ?
Connaissances préalables
Aperçu des raccourcis clavier dans Diamonds (shortcuts)
Convention relative aux axes des barres
2 Environnement de travail
Principes généraux
Sélection d'éléments
Sélection à l'aide de la souris
Sélection via le menu
Général
Barres les plus chargées
Surfaces les plus chargées
Utilisation des touches CTRL et ALT
Sélection d'éléments supplémentaires
Le curseur intelligent
La barre d'outils
Gestion de projets
Ouvrir un nouveau projet
Sauvegarder un projet
Ouvrir un projet
Utiliser des fichiers templates
Imprimer la fenêtre modèle et gérer des notes de calcul
Imprimer la fenêtre modèle
Copier et coller la fenêtre modèle
Gérer des notes de calcul
Annuler et rétablir une opération
Masquer partiellement
La trame
Types de design
Fonctions d’analyse
Orientation du modèle
Plan de dessin
Zoom et déplacement
Mesurage
Gestion des fenêtres modèles
Paramètres de configuration
Qu’est-ce qu’une configuration?
Définition ou modification d’une configuration
L’onglet ‘Général’
L’onglet ‘Géométrie’
L’onglet ‘Charges’
L’onglet ‘Maillage’
L’onglet ‘Résultats’
Tableau de données et résultats
Tableau ‘Données’
Tableau ‘Résultats’
Tableau ‘Vérification d'équilibre’
Tableau ‘Information modale’
Fenêtre ‘Réponse Modale’
Résultats détaillés sur une section
Les contraintes
Résultats thermiques
Résultats détaillés
Les assemblages
Log in et notifications
La palette d’icônes
La palette 'Géométrie'
Le pointeur de sélection
Label et commentaire
Tracer des points
Tracer des lignes
Effacer des points, des lignes et des plans
Tracer des éléments structurels
Chercher des dalles ou plaques
Diviser des lignes
Extruder
Formes paramétrées
Structures paramétrées
Déplacer et copier
Pivoter
Projection
Miroiter
Intersection
Vérification du modèle
Redimensionner de la géométrie
Modifier les propriétés communes à plusieurs éléments
Propriétés des barres
Dimensions
Propriétés des sections de barres
Onglet 'Général'
Onglet 'Elastique'
Onglet 'Plastique'
Onglet 'Effective'
Onglet 'Dimensionnement'
Matériaux, enrobages (béton) et mode de fabrication (Fe) des barres
Axes locaux des barres
Propriétés des dalles et plaques
Propriétés des sections de dalles
Matrice de rigidité
Matériaux et enrobages des dalles
Axes locaux des dalles
Caractéristiques des semelles
Choix d’une section dans la bibliothèque des profilés
Excentricité des barres
Excentricité d’une poutre par rapport à une dalle
Excentricité entre différentes barres
Modèle physique
Rotation de sections
Attribuer des points d'appui
Points d'appui et lignes d'appui
Support surfacique
Conditions limites pour les extrémités des barres et les tirants
Tirants
Rigidités de rotation et de translation aux extrémités des barres
Définir un diagramme de rigidité
Jarrets
Lignes articulées
Choix de matériau
Liens rigides
Paramètres de flambement et de déversement
La longueur de flambement d’une barre individuelle
Longueur de torsion latérale ou de déversement d’une barre
Paramètres pour la vérification au déversement
Protection incendie
Modification de lignes et de nœuds
Copier et coller des points d'appui et des sections
La palette 'Charges'
Cas de charges
Choix de la norme
Choix de la classe de service
Définir ou supprimer des cas de charges
Définir des incompatibilités
Définir des groupes de charges liés
Définir des sous-groupes de charges
Combinaisons de charges
Combinaisons dans le temps
Les charges
Redimensionner les charges
Charges ponctuelles sur nœuds
Moments sur nœuds
Charges ponctuelles sur barres
Moments sur barres
Charges linéaires uniformément réparties et charges trapézoïdales
Torsion répartie
Charge surfacique
Générateur de charges surfaciques sur barres
Charge de température
Charge de température sur barres
Charge de température sur barres
Générateur de vent
Norme de vent et données du terrain
Vent sur une ossature
Vent sur un plan
Vent sur un groupe de barres
Générateur de neige
Norme de neige et données du terrain
Neige sur une ossature
Neige sur un plan
Neige sur un groupe de barres
Charge sismique
Charge dynamique
Données généraux: période et synchronisation
Données de l'onde
Charge mobile
Bibliothèque des charges mobiles
Attribuer une charge mobile à un modèle
Aperçu des charges mobiles appliquées
Animation
Courbes de feu
Supprimer ou modifier des charges
Copier et coller des charges
Bouton droite souris
Translation
La palette 'Résultats'
Affichage des déformations
Affichage des efforts internes dans les poutres et les poteaux
Affichage des efforts internes dans les dalles et les plaques
Affichage des réactions dans les points d'appui
Affichage des contraintes élastiques dans les poutres et les poteaux
Affichage des contraintes élastiques dans les dalles et les plaques
Affichage des résultats de l'armature
Affichage de la largeur de fissuration
Affichage des résultats thermiques
Résultats le long d’un ligne de coupe
La palette de création et de gestion des plans de dessin ou des étages
Gestion des étages
Niveau du sol
Un plan de dessin
La palette de sélection du mode d'affichage
La palette pour (dé-)grouper des éléments barres
Qu’est-ce qu’un groupe?
Comment créer un groupe?
Que faire avec un groupe?
Pour flambement
Physiques
Pour des charges
Pour des sections
La palette de définition de la grandeur des lettres, des symboles, des charges et des résultats
3 Bibliothèques
Bibliothèques locales ou centrales
La bibliothèque des matériaux
Les propriétés élastiques
Les propriétés thermiques
Les propriétés élastiques
La bibliothèque des profilés
La bibliothèque des treillis
Opérations avec les bibliothèques
Ajouter un nouvel objet
Supprimer un objet
Changer les paramètres du filtre
Importer une bibliothèque
Exporter une bibliothèque
Mettre à jour une bibliothèque
Réinitialiser une bibliothèque aux paramètres par défaut
4 Calculs
Méthode des éléments finis
La subdivision des éléments
L'analyse élastique globale
Onglet 'Structurel'
Onglet 'Sol'
Onglet 'Dynamique'
Calcul élastique
L'analyse modale
Calcul des longueurs de flambement
Analyse au feu
Calcul des radiers par équilibre itératif
Dimensionnement de la fondation
Paramètres de sol
Sondage statique en profondeur
Essai au pressiomètre de Ménard
5 Dimensionnement
Béton armé
Calcul d'armature
Choix de la norme béton
Paramètres pour le béton et l'armature
Calcul de l'armature
Calcul des armatures dans les poutres et les poteaux
Calcul de l'armature dans les dalles et les plaques
Dalles
Plaques
Calcul des armatures de poinçonnement
Amatures pratiques
Base
Avancé
Calcul de la flèche fissurée
Flèche fissurée
Flèche fissurée dans le temps
Première étape: définition du moment de la charge et de la combinaison pour fissuration
Deuxième étape: préparation des flèches à calculer dans le temps
Troisième étape: le calcul de la flèche dans le temps
Calcul de largeur de fissuration
Contrôle de l'acier et du bois
Définition des renforts au déversement
Renforts au déversement et calcul automatique des longueurs de déversement
Modification ou suppression de renforts au déversement
Vérification de l’acier & bois
Choix de la norme
Paramètres pour l’acier
Paramètres pour le bois
Vérification de la résistance et de la stabilité
Vérification de la résistance des sections
Vérification de la résistance selon la norme EN 1993-1-1
Vérification de la résistance selon la norme EN 1993-1-3
Vérification de la résistance selon la norme EN 1993-1-4
Vérification de la résistance selon la norme EN 1995-1-1
Vérification de la stabilité des barres
Vérification de la stabilité selon la norme EN 1993-1-1
Vérification de la stabilité selon la norme EN 1993-1-3
Vérification de la stabilité selon la norme EN 1993-1-4
Vérification de la stabilité selon la norme EN 1995-1-1
Optimisation
Optimisation des peintures résistantes au feu
Déformation acier inoxydable
Assemblages
Modéliser l’assemblage
Sélectionner les combinaisons
Calculer l’assemblage
Sauvegarder l’assemblage dans la bibliothèque
Attribuer les caractéristiques de l’assemblage à un nœud
Assamblages paramétrique
Stiffness
Resistance
Interaction
Bibliothèque d’assemblages
Vérification d’assemblages dans Diamonds
6 Notes de calcul
Données de dossier
Composer une nouvelle note de calcul
L'onglet 'Généralités'
Orientation du modèle et sélection des éléments
Titre et table des matières
L'onglet 'Géométrie'
L'onglet 'Charges'
L'onglet 'Résultats globaux'
L'onglet 'Résultats détaillés'
Déplacer une note de calcul
Modifier, copier ou supprimer une note de calcul
Imprimer une note de calcul
Définir une imprimante
La mise en page
Imprimer une note de calcul
Aperçu avant impression
Enregistrer une note de calcul dans un fichier RTF
7 Parametres utilisateur
Paramètres de préférence
Paramètres de sauvegarde des projets
Paramétrage des tolérances géométriques du modèle
Tolérance pour la vérification du modèle
Tolérance pour la définition des groupes
Option de la déplacement des éléments
Paramètres de dessin
Unités et décimales
8 Importation et exportation
Importation de fichiers DXF
Importation de fichiers BIM Expert
Importation de fichiers PowerPlate/ PowerFrame
Importation de fichiers Diamonds
Exportation de fichiers DXF
Exportation vers BIM Expert
Exportation de fichiers bitmap
Exportation vers ConCrete Plus
Exportation vers Strakon
Exportation vers fichiers DSTV
Exportation de tableaux de valeurs

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Configuration requise

Diamonds a été conçu pour MS Windows. Il est recommandé de posséder MS Windows 7, 8, 8.1 ou 10, et de disposer d'au moins 2GB de mémoire RAM.

La vitesse à laquelle Diamonds effectuera vos calculs de stabilité est proportionnelle à la vitesse d'horloge de votre processeur. Nous préconisons un processeur Intel Pentium 4 ou AMD Athlon d'une vitesse d'horloge de 3 GHz ou supérieure. Notre préférence va néanmoins au processeur Intel, le cœur de calcul de Diamonds ayant été optimisé pour ce type de processeur.

Grâce à l'intégration de la technologie OpenGL®, Diamonds utilise votre matériel graphique de manière optimale. Votre carte graphique sera de préférence du type ATI RADEON ou nVidia avec prise en charge de OpenGL® version 2.0. Votre carte graphique nécessite une mémoire embarquée d’au moins 128 MB.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Logiciels requis

Avant d’installer le logiciel Diamonds, il est préférable d’installer le .NET Framework 4.0 de Microsoft ®.

Votre licence Diamonds est incluse dans une clé USB qui vous est livrée conjointement à ce manuel. BuildSoftutilise la protection développée et livrée par Wibu Systems, nommée CodeMeter. Pour bien faire fonctionner la gestion des licences, il est nécessaire que vous installiez le module CodeMeter à partir du CD-ROM, tant sur le(s) station(s) de travail que sur le serveur (si vous utilisez les logiciels en réseau).

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Physiques

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Résultats globaux

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Résultats 'modales'

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Sections dérivées

Dans cette fenêtre [image], vous définissez les propriétés d'un profil (= profil source). Cependant, vous pouvez étendre ce profil en ajoutant des protecteurs de feu [image]. C'est ainsi que vous obtenez une section dérivée.

Si vous faites ensuite des ajustements au profil source (par exemple en augmentant le profil), ces ajustements ne sont pas automatiquement implémentés sur les sections dérivées! Vous verrez le message suivant:

Cliquez sur le message et ajustez les sections dérivées dans [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Vent sur une toiture isolée

Sélectionnez la toiture isolée sur laquelle vous désirez générer du vent, et le bouton [image] ou [image] s'activera. Notez bien que l'ossature sélectionnée doit se situer dans un plan 2D.

Cliquez sur le bouton [image] pour le vent sur une ossature. L'écran ci-dessous s'affiche alors (selon EN 1991-1-4):

  • Un premier cadre vous donne le dessin de la structure avec, encadré en rouge, les points d’extrémités considérés. Par défaut, Diamonds va rechercher le point libre le plus en bas à gauche et le point le plus en bas à droite comme point respectivement de début et de fin. Toutefois, si un appui a été défini en un point, ce point sera prioritaire au niveau recherche des extrémités du contour défini.

    Le point de départ, c'est-à-dire celui numéroté ‘1’, peut être modifié manuellement en cliquant avec le bouton gauche sur une extrémité possible (avec un petit carré blanc). De même, le deuxième extrémité peut être modifiée de la même manière mais en utilisant le bouton droit de la souris. Toutefois, il faut respecter le fait que le point ‘1’ est toujours à gauche du point ‘2’.

    Dans le cadre 'Géométrie', notez la profondeur totale de la construction ainsi que la position de l'ossature sélectionnée par rapport à la façade principale (FRONT) et la distance jusqu'à l'ossature précédente et l'ossature suivante. La figure de droite vous montre en plan terrier la position de cette ossature par rapport à l'avant et à l'arrière du bâtiment. L'ossature précédente et l'ossature suivante sont également représentées (en pointillé). Le repère d'axes en haut à gauche définit clairement l'orientation du bâtiment. La charge de vent qui pèse sur la toiture sélectionné tient donc compte des distances entre les toitures successives ainsi que de leur distance par rapport à la façade frontale. De la sorte, on calcule aussi correctement le coefficient de pression nette cf,net qui varie en fonction de la profondeur de la construction.

  • Dans les 4 onglets indiquez quelles charges de vent doivent être générées et dans quel cas ces charges doivent être classées.

    Vous pouvez calculer les charges de vent sur une toiture isolée en utilisant des coefficients de force globale ou avec des coefficients de pression nette (= un coefficient local). Le coefficient globale est utilisée pour estimer la résistance / stabilité de la structure, le coefficient de pression nette pour la conception et le calcul des matériaux de toiture et les fixations.

    Tant le coefficient global et le coefficient de pression nette peut avoir une valeur positif (maximum) et une valeur négative (minimum) (voir l'EN 1991-1-4 Tableau 7.7). Il y a donc quatre onglets visibles:

    • Locale max
    • Locale min
    • Globale max
    • Globale min

    Tant le coefficient global et le coefficient de pression nette sont fonction de l'obstruction φ. φ=0 représente une toiture isolée sans rien en dessous, et φ=1 représente la toiture isolée entièrement. Parce que l'obstruction φ peut prendre deux valeurs (0 et 1), vous pouvez choisir d'entrer une obstruction alternative en Diamonds.

    Enfin, EN 1991-1-4 Figure 7.17 donne des combinaisons différentes des coefficients qu’on doit prendre en considération. Cettes combinaisons résultent dans des différents cas de charge. Un aperçu peut être trouvé à la fin de ce document.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Échelle

Diamondsinclut une série de ratios largeur – hauteur que vous pouvez sélectionner en cliquant sur le bouton . Le ratio sélectionné s'affiche toujours à côté de l'icône.

Vous pouvez aussi définir une échelle spécifique en sélectionnant Manuel et en saisissant un chiffre. Un ratio de 2,0 signifiera que la largeur est égale au double de la hauteur.

Les figures ont toujours la largeur d'une page.

Lorsque vous cliquez sur le bouton Modifier la sélection sur la vue, la fenêtre de ratio sélectionnée est conservée et vous pouvez définir la taille (en mode agrandissement) avec la molette de la souris.

Echelle 5:3 | Echelle 3:1

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Trame

Activez ou désactivez/définissez facilement la trame avec [image].

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique


Importation de fichiers PowerFrame

Diamonds vous permet d’ouvrir les anciens fichiers PowerFrame. De la sorte, vous pouvez toujours construire et analyser votre modèle dans PowerFrame et après l’importer vers Diamonds pour refaire le calcul avec des autres hypothèses.

BuildSoft
Hundelgemsesteenweg 244-1
9820 Merelbeke
Belgique